Gerenciar intervalos de dados externos e suas propriedades

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

As propriedades de um intervalo de dados externos podem ser alteradas para controlar dados que tenham sido importados para uma planilha através de uma conexão com uma fonte de dados externa.

O que você deseja fazer?

Saiba mais sobre as propriedades e intervalos de dados externos

Localizar um intervalo de dados externos

Alterar o nome de um intervalo de dados externos

Alterar a consulta subjacente para um intervalo de dados externos

Copiar um intervalo de dados externos e sua consulta subjacente

Especificar como novos dados serão adicionados a um intervalo de dados externos

Especificar o layout e a formatação de dados

Copiar fórmulas quando um intervalo de dados externos se expandir

Congelar dados em um intervalo de dados externos

Personalizar nomes de campo em um intervalo de dados externos

Excluir um intervalo de dados externos

Aprender mais sobre intervalos de dados externos e suas propriedades

Um intervalo de dados externos (também denominado tabela de consulta) é um nome definido ou nome de tabela que determina a localização dos dados trazidos para uma planilha. Quando você se conecta a dados externos, o Excel cria automaticamente um intervalo de dados externos. A única exceção é um relatório de tabela dinâmica (que não usa intervalos de dados externos) conectado a uma fonte de dados. No Excel, é possível definir o formato e o layout de um intervalo de dados externos ou usá-lo em cálculos, como quaisquer outros dados.

Propriedades do intervalo de dados externos

Um intervalo de dados externos possui propriedades adicionais (não confunda com as propriedades da conexão) que podem ser usadas para controlar os dados, como a preservação da formatação da célula e da largura da coluna. Você pode alterar essas propriedades clicando em Propriedades, no grupo Conexões da guia Dados. Em seguida, faça suas alterações da seguinte forma:

  • Para intervalos de dados externos criados pelo Microsoft Query e pelo Assistente para Conexão de Dados, use a caixa de diálogo Propriedades dos Dados Externos.

  • Para intervalos de dados externos criados por um arquivo de texto importado ou uma consulta à Web que recupera dados HTML, use a caixa de diálogo Propriedades do Intervalo de Dados Externos.

  • Para intervalos de dados externos criados por uma consulta à Web que recupera dados HTML, use a caixa de diálogo Propriedades do Mapa XML.

Uso de modelos com intervalos de dados externos

Se você quiser compartilhar um resumo ou relatório baseado em dados externos, forneça aos outros usuários uma pasta de trabalho contendo um intervalo de dados externos ou crie um modelo de relatório. Esse tipo de modelo permite que você salve o resumo ou relatório sem salvar os dados externos, para que o arquivo fique menor. Os dados externos são recuperados quando um usuário abre o modelo de relatório.

Início da Página

Localizar um intervalo de dados externos

  1. Selecione a planilha na qual deseja pesquisar um intervalo de dados externos.

  2. Na barra de fórmulas, clique na seta ao lado da Caixa de nome e no nome do intervalo de dados externos desejado.

Início da Página

Alterar o nome de um intervalo de dados externos

  1. Na guia Fórmulas, no grupo Nomes Definidos, clique no Gerenciador de Nomes.

    Imagem da Faixa de Opções do Excel

  2. Na caixa de diálogo Gerenciador de Nomes, clique no nome do intervalo de dados externos e em Editar. Também é possível clicar duas vezes no nome.

  3. Na caixa de diálogo Editar Nome, digite o novo nome para a referência na caixa Nome.

Observação : O botão Fechar apenas fecha a caixa de diálogo Gerenciador de Nomes. Não é preciso clicar nele para confirmar alterações já feitas.

Início da Página

Alterar a consulta subjacente para um intervalo de dados externos

É possível alterar a consulta subjacente para um intervalo de dados externos criado pelo Microsoft Query, por um arquivo de texto importado, por uma consulta à Web ou pelo Assistente para Conexão de Dados.

Alterar a consulta subjacente para um intervalo de dados externos criado pelo Microsoft Query

  1. Clique em uma célula no intervalo de dados externos para o qual deseja alterar a consulta subjacente.

  2. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  3. Na caixa de diálogo Propriedades dos Dados Externos, clique em Propriedades da Conexão Propriedades .

  4. Na caixa de diálogo Propriedades da Conexão, clique na guia Definição e clique em Editar Consulta.

Para obter mais informações sobre como construir e editar consultas no Microsoft Query, consulte a Ajuda do Microsoft Query.

Alterar a consulta subjacente para um intervalo de dados externos criado por um arquivo de texto importado

  1. Clique em uma célula no intervalo de dados externos para o qual deseja alterar a consulta subjacente.

  2. Na guia Dados, no grupo Conexões, clique em Conexões.

    Imagem da Faixa de Opções do Excel

  3. Na caixa de diálogo Conexões da Pasta de Trabalho, clique em Propriedades.

  4. Na caixa de diálogo Propriedades da Conexão, clique na guia Definição e clique em Editar Consulta.

  5. Na caixa de diálogo Importar Arquivo de Texto, clique em Importar.

  6. Faça alterações no arquivo de texto importado no Assistente de Importação de Texto e clique em Concluir.

    Para obter mais informações sobre a importação de arquivos de texto, consulte Importar ou exportar arquivos de texto.

Alterar a consulta subjacente para um intervalo de dados externos criado por uma consulta à Web

  1. Clique em uma célula no intervalo de dados externos para o qual deseja alterar a consulta subjacente.

  2. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  3. Na caixa de diálogo Conexões da Pasta de Trabalho, clique em Propriedades.

  4. Na caixa de diálogo Propriedades da Conexão, clique na guia Definição e clique em Editar Consulta.

  5. Faça as alterações na consulta à Web na caixa de diálogo Editar Consulta da Web e clique em Concluir.

Para obter mais informações sobre como criar e editar consultas à Web, consulte Obter dados externos de uma página da Web.

Alterar a consulta subjacente para um intervalo de dados externos criado com uso do Assistente para Conexão de Dados

  1. Clique em uma célula no intervalo de dados externos para o qual deseja alterar a consulta subjacente.

  2. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  3. Na caixa de diálogo Propriedades dos Dados Externos, clique em Propriedades da Conexão Propriedades .

  4. Na caixa de diálogo Propriedades da Conexão, clique em Definição.

  5. Siga um destes procedimentos:

    • Na caixa Tipo de comando, clique em Tabela e, na caixa Texto de comando, altere o valor para o nome de uma tabela, exibição ou consulta apropriada.

    • Na caixa Tipo de comando, clique em SQL ou Padrão e, na caixa Texto de comando, edite a instrução SQL.

      Observação : Dependendo de como a conexão foi definida, a caixa Tipo de comando poderá ficar indisponível (aparecerá esmaecida).

Início da Página

Copiar um intervalo de dados externos e sua consulta subjacente

  1. Na barra de fórmulas, clique na seta ao lado da Caixa de nome e selecione o nome do intervalo de dados externos que deseja copiar.

    Para uma tabela do Excel, selecione o nome do intervalo e pressione CTRL+A para selecionar os cabeçalhos da tabela.

    Se quiser incluir rótulos de coluna ou fórmulas que não fazem parte do intervalo de dados externos, selecione as células que contêm os rótulos de coluna ou fórmulas que deseja copiar. Clique na seta ao lado da Caixa de nome na barra de fórmulas e selecione o nome do intervalo de dados externos que deseja copiar.

  2. Na guia Início, no grupo Área de Transferência, clique em Copiar.

    imagem da faixa de opções do excel

  3. Alterne para a pasta de trabalho na qual deseja colar o intervalo de dados externos.

  4. Clique na célula superior esquerda da área de colar.

    Para garantir que os dados externos não substituam dados existentes, verifique se a planilha não têm dados abaixo ou à direita da célula em que você clicar.

  5. Na guia Início, no grupo Área de Transferência, clique em Colar.

Observação : Se você copiar somente parte de um intervalo de dados externos, o subjacente consulta não é copiada e os dados copiados não podem ser atualizados.

Início da Página

Especificar como novos dados serão adicionados a um intervalo de dados externos

É possível controlar o modo de lidar com um conjunto de dados maior ou menor que volte para o Excel quando os dados forem atualizados.

  1. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  2. Na caixa de diálogo Propriedades do Intervalo de Dados Externos, em Se o número de linhas no intervalo de dados for alterado após atualização, clique em uma destas opções:

    • Insira células para novos dados, exclua células não utilizadas

      Observações : 

      • Quando uma ou mais linhas são adicionadas na fonte de dados, as células diretamente abaixo do intervalo de dados externos são movidas para baixo, mas as células à direita dele não são movidas.

      • Quando uma ou mais linhas são excluídas na fonte de dados, as células diretamente abaixo do intervalo de dados externos são movidas para cima, mas as células à direita dele não são movidas.

    • Insira linhas inteiras para novos dados, limpe as células não utilizadas

      Observações : 

      • Quando uma ou mais linhas são adicionadas na fonte de dados, as células diretamente abaixo e à direita do intervalo de dados externos são movidas para baixo.

      • Quando uma ou mais linhas são excluídas na fonte de dados, as células diretamente abaixo e à direita do intervalo de dados externos não são movidas.

    • Sobrescreva células existentes com novos dados, limpe as não utilizadas

      Observações : 

      • Quando uma ou mais linhas são adicionadas na fonte de dados, as células diretamente abaixo do intervalo de dados externos são substituídas, mas as células à direita dele não são movidas.

      • Quando uma ou mais linhas são excluídas na fonte de dados, as células diretamente abaixo e à direita do intervalo de dados externos não são movidas.

Início da Página

Especificar o layout e a formatação de dados

  1. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  2. Em Layout e formatação de dados, siga um ou mais destes procedimentos:

    • Para incluir nomes de campo como primeira linha, marque a caixa de seleção Incluir nomes de campo.

      Observação : Essa caixa de seleção só está disponível para intervalos de dados externos que sejam convertidos a partir de um programa do Microsoft Office 2003 ou que sejam criados programaticamente.

    • Para adicionar uma coluna de números de linha, marque a caixa de seleção Incluir números de linha.

      Observação : Essa caixa de seleção não está disponível para arquivos de texto importados, arquivos XML ou consultas à Web.

    • Para preservar a formatação de célula que você aplicar, marque a caixa de seleção Preservar formatação de célula.

      Observação : No caso de consultas à Web, essa opção é desmarcada automaticamente quando você seleciona Formatação HTML Completa na caixa de diálogo Opções, que pode ser acessada na caixa de diálogo Editar Consulta.

    • Para preservar as larguras da coluna que você definir, marque a caixa de seleção Ajustar largura da coluna.

    • Para preservar a classificação, a filtragem e o layout da coluna que você aplicar, marque a caixa de seleção Preservar classificação/filtro/layout de coluna.

      Observação : Essa caixa de seleção não está disponível para consultas à Web.

    • Para preservar a filtragem de coluna que você aplicar, marque a caixa de seleção Preservar filtro de coluna.

      Observação : Essa caixa de seleção só está disponível para consultas à Web baseadas em dados XML.

Início da Página

Copiar fórmulas quando um intervalo de dados externos se expandir

Observação : O procedimento a seguir se aplica somente a intervalos de dados externos que sejam convertidos a partir de um programa do Microsoft Office 2003 ou que sejam criados programaticamente. No Office Excel 2007, todos os intervalos de dados externos criados com o uso da interface do usuário são criados como tabelas do Excel. Essas tabelas se expandem automaticamente quando novas linhas são adicionadas e preenchem colunas calculadas.

  1. Insira uma fórmula em uma célula que seja adjacente à primeira linha de dados no intervalo de dados externos.

    Observação : A primeira linha de dados pode ser a primeira ou a segunda linha no intervalo de dados externos, dependendo se a primeira linha contém ou não cabeçalhos.

  2. Selecione a célula e clique duas vezes na alça de preenchimento para copiar a fórmula para todas as linhas no intervalo de dados externos.

  3. Clique em uma célula no intervalo de dados externos.

  4. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  5. Na caixa de diálogo Propriedades do Intervalo de Dados Externos, marque a caixa de seleção Preencher fórmulas em colunas adjacentes aos dados.

    Observação : Se o intervalo de dados externos se expandir quando você atualizar, o Excel copiará somente as fórmulas imediatamente adjacentes ou dentro do intervalo de dados externos.

Início da Página

Congelar dados em um intervalo de dados externos

O congelamento de um intervalo de dados externos retém os dados, mas não sua consulta adjacente, por isso um intervalo de dados externos não pode ser atualizado.

Congelar dados em uma tabela do Excel

  1. Clique na planilha que contém a tabela do Excel da qual você deseja remover a conexão de dados.

  2. Na barra de fórmulas, clique na seta ao lado da Caixa Nome e clique no nome do intervalo de dados externo do qual você deseja remover a conexão de dados. O intervalo de dados é selecionado.

  3. Na guia Ferramentas, no grupo Dados externos de tabela, clique em Desvincular. O intervalo de dados permanece e ainda tem o mesmo nome, mas a conexão é excluída.

Congelar dados em um intervalo

Observação : O procedimento a seguir se aplica somente a intervalos de dados externos que sejam convertidos a partir de um programa do Microsoft Office 2003 ou que sejam criados programaticamente. No Office Excel 2007, todos os intervalos de dados externos criados com o uso da interface do usuário são criados como tabelas do Excel. Essas tabelas se expandem automaticamente quando novas linhas são adicionadas e preenchem colunas calculadas.

  1. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  2. Em Definição de consulta, desmarque a caixa de seleção Salvar definição de consulta.

Observação : Quando você salva sua pasta de trabalho, a consulta adjacente é excluída. Entretanto, os arquivos de consulta a banco de dados salvos (arquivos .dqy ou .odc) não são excluídos. Se você salvou a consulta quando a criou no Assistente de Consulta ou no Microsoft Query, o arquivo de consulta foi salvo no seu computador e você pode usar a consulta novamente para recuperar dados externos. Para obter mais informações, consulte a Ajuda do Microsoft Query.

Início da Página

Personalizar nomes de campo em um intervalo de dados externos

Observação : O procedimento a seguir se aplica somente a intervalos de dados externos que sejam criados com o uso do Assistente para Conexão de Dados ou do Microsoft Query (e não por um arquivo de texto importado ou uma consulta à Web), convertidos de um programa do Microsoft Office 2003 ou criados programaticamente. No Office Excel 2007, todos os intervalos de dados externos criados com o uso da interface do usuário são criados como tabelas do Excel.

  1. Insira uma linha em branco acima do intervalo de dados externos.

    Como inserir uma linha em branco

    1. Siga um destes procedimentos:

      • Inserir novas células em branco    Selecione um intervalo de células no qual deseje inserir as novas células em branco. Selecione um número de células equivalente ao que deseja inserir.

      • Inserir uma única linha    Clique em uma célula na linha imediatamente acima de onde deseja a nova linha. Por exemplo, para inserir uma nova linha acima da linha 5, clique em uma célula na linha 5.

      • Inserir várias linhas    Selecione linhas imediatamente acima de onde deseja as novas linhas. Selecione um número de linhas equivalente ao que deseja inserir.

      • Inserir uma única coluna    Clique em uma célula na coluna imediatamente à direita de onde deseja inserir a nova coluna. Por exemplo, para inserir uma nova coluna à esquerda da coluna B, clique em uma célula na coluna B.

      • Inserir várias colunas    Selecione colunas imediatamente à direita de onde deseja inserir as novas colunas. Selecione um número de colunas equivalente ao que deseja inserir.

    2. Na guia Início, no grupo Células, clique na seta ao lado de Inserir e clique em uma destas opções: Inserir Células, Inserir Linhas na Planilha ou Inserir Colunas na Planilha.

      Se estiver inserindo células em branco, clique em Deslocar células para a direita ou Deslocar células para baixo para definir para onde deseja que as células existentes sejam movidas.

      Se houver formatação, você poderá usar o Pincel Imagem do botão , no grupo Área de Transferência, na guia Início, para escolher como definir a formatação das células, linhas ou colunas inseridas.

  2. Na linha em branco, digite os rótulos que deseja usar nas células.

  3. Clique em uma célula no intervalo de dados externos.

  4. Na guia dados, no grupo conexões, clique em Propriedades.

    Imagem da Faixa de Opções do Excel

  5. Na caixa de diálogo Propriedades do Intervalo de Dados Externos, em Layout e formatação de dados, desmarque a caixa de seleção Incluir nomes de campo e clique em OK.

  6. Para remover os nomes de campo existentes e atualizar o intervalo de dados externos, clique em uma célula no intervalo e depois em Atualizar Dados Imagem do botão .

Observação : Quando você recupera dados de um banco de dados, quaisquer alterações em nomes de coluna no Microsoft Query são retidas no intervalo de dados externos. Para obter informações sobre como alterar nomes de coluna na consulta, consulte a Ajuda do Microsoft Query.

Início da Página

Excluir um intervalo de dados externos

  1. Clique na planilha que contém o intervalo de dados externos que deseja excluir.

  2. Na barra de fórmulas, clique na seta ao lado da Caixa de nome e selecione o nome do intervalo de dados externos que deseja excluir.

    Se o intervalo de dados externos for uma tabela do Excel, pressione CTRL+A para selecionar a tabela inteira.

  3. Para excluir o intervalo de dados externos, pressione DELETE.

  4. Para excluir a consulta subjacente, clique em Sim quando o Excel perguntar.

Início da Página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×