Função SE

Use a função SE, uma das funções lógicas, para retornar um valor se uma condição for verdadeira e um outro valor se for falsa.

Sintaxe

SE(teste_lógico, valor_se_verdadeiro, [valor_se_falso])

Por exemplo:

  • =SE(A2>B2,"Acima do orçamento","OK")

  • =SE(A4=500,B4-A4,""

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que você deseja testar.

valor_se_verdadeiro    (obrigatório)

O valor que você deseja retornar se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que você deseja retornar se o resultado do teste_lógico for FALSO.

Exemplos

Copie os dados de exemplo na tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para ver a fórmula na célula da fórmula, selecione a célula e pressione F2.

Despesas reais

Despesas previstas

R$ 1.500

R$ 900

R$ 500

R$ 900

R$ 500

R$ 925

=SE(A2>B2,"Acima do orçamento","OK")

Como as despesas reais de R$ 1.500 (A2) excederam as despesas previstas de R$ 900 (B2), o resultado é Acima do orçamento

=SE(A2<B2,VERDADEIRO, SE(A3>B3,"Acima do orçamento","OK"))

A primeira função SE é falsa. Portanto, a segunda instrução SE é calculada e, por também ser falsa, o resultado é OK.

=SE(A4=500,B4-A4,"")

Como A4 é igual a 500, a Despesa real de R$ 500 é subtraída da Despesa prevista de R$ 925 para informá-lo sobre o quanto você está acima do orçamento. O resultado é 425. Se A4 não fosse igual a 500, o texto vazio ("") seria exibido.

=SE(A2<B2,VERDADEIRO, SE(A3>B3,"Acima do orçamento","OK"))

A primeira função SE é falsa. Portanto, a segunda instrução SE é calculada e, por também ser falsa, o resultado é OK.

Problemas comuns

Problema

O que aconteceu de errado

0 (zero) na célula

Não havia um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso. Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Isso geralmente significa que a fórmula está incorreta.

Práticas recomendadas

Faça isto

Por que

Usar uma função SE dentro de outra função SE.

Até 64 funções SE podem ser aninhadas dentro de outras para que os argumentos valor_se_verdadeiro e valor_se_falso gerem testes mais elaborados.

Usar SE com matrizes

Se qualquer um dos argumentos para a função SE for uma matriz, cada elemento da matriz será avaliado quando a instrução SE for executada. Saiba como criar uma fórmula de matriz.

Relacionado

Aplicável a: Excel for Mac 2011, Excel 2010, Excel 2016 for Mac, Excel Online, Excel Starter, Excel 2013, Excel 2016 Preview, Excel 2007



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma