Função SOMASE

Use a função SOMASE para somar os valores em um intervalo que atendem aos critérios que você especificar. Por exemplo, suponha que em uma coluna que contém números, você deseja somar apenas os valores maiores que 5. É possível usar a seguinte fórmula: =SOMASE(B2:B25;">5")

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Este vídeo faz parte de um curso de treinamento chamado Adicionar números no Excel 2013.

Dicas : 

  • Se quiser, você pode aplicar o critério a um intervalo e somar os valores correspondentes em um intervalo diferente. Por exemplo, a fórmula =SOMASE(B2:B5;"Pedro";C2:C5) soma apenas os valores do intervalo C2:C5, em que as células correspondentes no intervalo B2:B5 sejam iguais a "Pedro".

  • Para somar células com base em vários critérios, consulte a função SOMASES.

Sintaxe

SOMASE(intervalo; critérios; [intervalo_soma])

A sintaxe da função SOMASE tem os seguintes argumentos:

  • intervalo   Obrigatório. O intervalo de células que se deseja calcular por critérios. As células em cada intervalo devem ser números ou nomes, matrizes ou referências que contêm números. Espaços em branco e valores de texto são ignorados. O intervalo selecionado deve conter datas no formato padrão do Excel (exemplos abaixo).

  • critérios   Obrigatório. Os critérios na forma de um número, expressão, referência de célula, texto ou função que define quais células serão adicionadas. Por exemplo, os critérios podem ser expressos como 32, ">32", B5, "32", "maçãs" ou HOJE().

    Importante : Qualquer critério de texto ou qualquer critério que inclua símbolos lógicos ou matemáticos deve estar entre aspas duplas ("). Se os critérios forem numéricos, as aspas duplas não serão necessárias.

  • intervalo_soma   Opcional. As células reais a serem adicionadas, se você quiser adicionar células diferentes das especificadas no argumento intervalo. Se o argumento intervalo_soma for omitido, o Excel adicionará as células especificadas no argumento intervalo (as mesmas células às quais os critérios são aplicados).

  • Você pode usar os caracteres curinga – o ponto de interrogação (?) e o asterisco (*) – como o argumento critérios. O ponto de interrogação corresponde a qualquer caractere único; o asterisco corresponde a qualquer sequência de caracteres. Para localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Comentários

  • A função SOMASE retorna valores incorretos quando você a utiliza para corresponder cadeias de caracteres com mais de 255 caracteres ou para a cadeia de caracteres #VALOR!.

  • O argumento intervalo_soma não precisa ter o mesmo tamanho e forma que o argumento intervalo. As células reais adicionadas são determinadas pelo uso da célula na extremidade superior esquerda do argumento intervalo_soma como a célula inicial e, em seguida, pela inclusão das células correspondentes em termos de tamanho e forma no argumento intervalo. Por exemplo:

Se o intervalo for

e intervalo_soma for

Então, as células reais serão

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Porém, quando os argumentos intervalo e intervalo_soma na função SOMASE não contêm o mesmo número de células, o recálculo da planilha pode levar mais tempo do que o esperado.

Exemplos

Exemplo 1

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Valor de propriedade

Comissão

Dados

$ 100.000,00

$ 7.000,00

$ 250.000,00

$ 200.000,00

$ 14.000,00

$ 300.000,00

$ 21.000,00

$ 400.000,00

$ 28.000,00

Fórmula

Descrição

Resultado

=SOMASE(A2:A5;">160000";B2:B5)

Soma das comissões para valores de propriedades acima de 160.000.

$ 63.000,00

=SOMASE(A2:A5;">160000")

Soma dos valores de propriedades acima de 160.000.

$ 900.000,00

=SOMASE(A2:A5;300000;B2:B5)

Soma das comissões para valores de propriedades iguais a 300.000.

$ 21.000,00

=SOMASE(A2:A5;">" & C2;B2:B5)

Soma das comissões para valores de propriedades maiores que o valor em C2.

$ 49.000,00

Exemplo 2

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Categoria

Alimentos

Vendas

Vegetais

Tomates

$ 2.300,00

Vegetais

Nabo

$ 5.500,00

Frutas

Laranjas

$ 800,00

Manteiga

$ 400,00

Vegetais

Cenouras

$ 4.200,00

Frutas

Maçãs

$ 1.200,00

Fórmula

Descrição

Resultado

=SOMASE(A2:A7;"Frutas";C2:C7)

Soma das vendas de todos os alimentos na categoria "Frutas".

$ 2.000,00

=SOMASE(A2:A7;"Vegetais";C2:C7)

Soma das vendas de todos os alimentos na categoria "Vegetais".

$ 12.000,00

=SOMASE(B2:B7;"*s";C2:C7)

Soma das vendas de todos os alimentos que terminam com "s" (Tomates, Laranjas e Maçãs).

$ 4.300,00

=SOMASE(A2:A7;"";C2:C7)

Soma das vendas de todos os alimentos que não têm uma categoria especificada.

$ 400,00

Início da Página

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site UserVoice do Excel.

Consulte Também

A função SOMASES adiciona todos os argumentos que atendem a vários critérios

A função SOMAQUAD soma vários valores depois de executar uma operação matemática de raiz quadrada em cada um deles

A função CONT.SE calcula apenas os valores que atendem a um único critério

A função CONT.SES calcula apenas os valores que atendem a vários critérios

A função SES (Office 365, Excel 2016 e posterior)

Visão geral de fórmulas do Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções de matemática e trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Usando as funções SOMASE, CONT.SE e outras funções relacionadas para analisar dados rapidamente (visualização gratuita)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×