Função SOMA

A função SOMA, uma das funções de matemática e trigonometria, adiciona valores. É possível adicionar valores individuais, referências de célula ou intervalos, ou uma mistura dos três.

Por exemplo:

  • =SOMA(A2:A10)

  • =SOMA(A2:A10;C2:C10)

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Este vídeo faz parte de um curso de treinamento chamado Adicionar números no Excel 2013.

SOMA(número1,[número2],...)

Nome do argumento

Descrição

número1    (Obrigatório)

O primeiro número que você deseja somar. O número pode ser como “4”, uma referência de célula, como B6, ou um intervalo de células, como B2:B8.

número2-255    (opcional)

Este é o segundo número que você deseja somar. Você pode especificar até 255 números adicionais dessa maneira.

Se você deseja obter rapidamente a soma de um intervalo de células, basta selecionar o intervalo e olhar na parte inferior direita da janela do Excel.

Captura de tela da seleção de um intervalo de células e da procura na Barra de Status
Barra de Status


Esta é a Barra de status e ela exibe as informações referentes ao que você selecionou, seja uma única célula ou várias células. Se você clicar com o botão direito do mouse na Barra de status, uma caixa de diálogo destacada será exibida com todas as opções que podem ser selecionadas. Observe que ela também exibe os valores do intervalo selecionado, caso tenha esses atributos marcados. Saiba mais sobre a Barra de status.

A maneira mais fácil de adicionar uma fórmula de SOMA à planilha é usar o Assistente de AutoSoma. Selecione uma célula vazia diretamente acima ou abaixo do intervalo que você deseja somar e, nas guias Página Inicial ou Fórmula da Faixa de Opções, pressione AutoSoma > Soma. O Assistente de AutoSoma detectará automaticamente o intervalo a ser somado e criará a fórmula para você. Ele também pode trabalhar horizontalmente se você selecionar uma célula à esquerda ou à direita do intervalo a ser somado. Observe que isso não funcionará em intervalos não contíguos, mas abordaremos o tema na próxima seção.

Você pode usar o Assistente de AutoSoma para criar uma fórmula de soma automaticamente.  Selecione um intervalo acima/abaixo ou à esquerda/à direita do intervalo a ser somado e vá para a guia Fórmula na Faixa de Opções, selecione AutoSoma e SOMA.
Use o Assistente de AutoSoma para somar intervalos contíguos rapidamente


O diálogo AutoSoma também permite que você selecione outras funções comuns, como:

AutoSoma verticalmente

A célula B6 mostra a fórmula Soma AutoSoma: =SOMA(B2:B5)

O Assistente de AutoSoma detectou automaticamente as células B2:B5 como o intervalo a ser somado. Tudo o que você precisa fazer é pressionar Enter para confirmá-lo. Se você precisar adicionar/excluir mais células, poderá manter a tecla Shift > Tecla de direção de sua escolha até que a seleção corresponda ao que deseja e pressionar Enter quando terminar.

Guia de função do Intellisense: a marca flutuante SOMA(número1;[número2];...) embaixo da função é sua guia Intellisense. Se você clicar no nome de função ou em SOMA, ela se transformará em um hiperlink azul que o levará ao tópico da Ajuda para essa função. Se você clicar em elementos de função individuais, suas partes representativas na fórmula serão realçadas. Nesse caso, somente B2: B5 seriam realçados pois há apenas uma referência numérica nessa fórmula. A marca Intellisense será exibida para qualquer função.

AutoSoma horizontalmente

A célula D2 mostra a fórmula de Soma AutoSoma: =SOMA(B2:C2)

Usando SOMA com intervalos não contíguos.  A fórmula da célula C8 é =SOMA(C2:C3;C5:C6). Você também poderia usar Intervalos Nomeados, e a fórmula seria =SOMA(Semana1;Semana2).

O Assistente de AutoSoma geralmente só funciona com intervalos contíguos. Portanto, se você tem linhas ou colunas vazias no intervalo de soma, o Excel pára no primeiro espaço. Nesse caso, você precisa fazer a SOMA por seleção, adicionando intervalos individuais um de cada vez. Neste exemplo, se houvesse dados na célula B4, o Excel geraria =SOMA(C2:C6), já que ele reconheceria um intervalo contíguo.

É possível selecionar vários intervalos não contíguos rapidamente clicando com o botão esquerdo do mouse enquanto mantém pressionada a tecla Ctrl. Primeiro, insira "=SOMA(", selecione intervalos diferentes e o Excel adicionará automaticamente a vírgula entre os intervalos para você. Pressione Enter quando terminar.

Dica: você pode usar ALT+= para adicionar a função SOMA a uma célula rapidamente. Depois é só selecionar os intervalos.

Observação: você notará que o Excel realçou os intervalos de funções diferentes por cor, e que as cores correspondem à fórmula em si. Portanto, C2:C3 é uma cor e C5:C6 é outra cor. O Excel fará isso para todas as funções, a menos que o intervalo referenciado esteja em outra planilha ou em outra pasta de trabalho. Para obter acessibilidade aprimorada com tecnologia assistiva, use Intervalos nomeados, como "Semana1", "Semana2" e assim por diante. Depois, faça referência a eles na fórmula:

=SOMA(Semana1;Semana2)

Você pode realizar operações matemáticas com facilidade usando somente o Excel ou em conjunto com funções do Excel como SOMA. A tabela a seguir lista os operadores que você pode usar, além de algumas funções reacionadas. Você pode introduzir os operadores da linha de números do seu teclado ou do teclado numérico, caso tenha um. Por exemplo, se você pressionar Shift+8, o asterisco (*) será exibido para multiplicação.

Operador

Operação

Exemplos

+

Adição

=1+1

=A1+B1

=SOMA(A1:A10)+10

=SOMA(A1:A10)+B1

-

Subtração

=1-1

=A1-B1

=SOMA(A1:A10)-10

=SOMA(A1:A10)-B1

*

Multiplicação

=1*1

=A1*B1

=SOMA(A1:A10)*10

=SOMA(A1:A10)*B1

=PRODUTO(1;1) – Função PRODUTO

/

Divisão

=1/1

=A1/B1

=SOMA(A1:A10)/10

=SOMA(A1:A10)/B1

=QUOCIENTE (1;1) – Função QUOCIENTE

^

Exponenciação

=1^1

=A1^B1

=SOMA(A1:A10)^10

=SOMA(A1:A10)^B1

=POTÊNCIA(1;1) – Função POTÊNCIA

Para saber mais, confira Use o Excel como sua calculadora.

Outros exemplos
  1. Digamos que você queira aplicar um desconto de porcentagem em um intervalo de células que você somou.

    Usando operadores com SOMA.  A fórmula na célula B16 é =SOMA(A2:A14)*-25%.  A fórmula seria construída corretamente se, em vez disso, -25% fosse uma referência de célula, como =SOMA(A2:A14)*E2
    • =SOMA(A2:A14)*-25%

    Daria 25% do intervalo somado. No entanto, isso embute os 25% na fórmula, e isso poderá ser difícil de encontrar mais tarde se desejar alterá-la. Em vez disso, é muito melhor colocar os 25% em uma célula e referenciá-la, onde estará individualizada e poderá ser alterada facilmente, por exemplo:

    • =SOMA(A2:A14)*E2

    Para dividir em vez de multiplicar, basta substituir "*" por "/": =SOMA(A2:A14)/E2

  2. Adicionando ou subtraindo de uma SOMA

    i. Você pode facilmente adicionar ou subtrair de uma Soma usando + ou -, por exemplo:

    • =SOMA(A1:A10)+E2

    • =SOMA(A1:A10)-E2

Esta seção discutirá algumas práticas recomendadas para trabalhar com a função SOMA. Grande parte delas pode ser aplicada ao trabalho com outras funções também.

Método =1+2 ou =A+B – Embora seja possível inserir =1+2+3 ou =A1+B1+C2 e obter resultados totalmente precisos, esses métodos estão sujeitos a erros por vários motivos:
  1. Erros de digitação – Imagine tentar inserir mais valores e/ou valores maiores, desta forma:

    • =14598,93+65437,90+78496,23

    Tente validar se suas entradas estão corretas. É muito mais fácil colocar esses valores em células individuais e usar uma fórmula de SOMA. Além disso, é possível formatar os valores quando eles estão nas células, tornando-os muito mais legíveis quando estiverem em uma fórmula.

    Use a função SOMA em vez de embutir valores em fórmulas.  A fórmula na célula D5 é =SOMA(D2:D4)
  2. Erros #VALOR! de referência de texto em vez de números

    Se você usar uma fórmula como:

    • =A1+B1+C1 ou =A1+A2+A3

    Exemplo de uma construção de fórmula ruim.  A fórmula na célula D2 é =A2+B2+C2

    Sua fórmula pode ser interrompida se houver valores não numéricos (texto) nas células referenciadas, que retornarão um erro #VALUE!. A função SOMA ignora valores de texto e fornece somente a soma dos valores numéricos.

    Construção de fórmula adequada.  Em vez de =A2+B2+C2, a fórmula da célula D2 fórmula é =SOMA(A2:C2)
  3. Erro #REF! de exclusão de linhas ou colunas

    Erro #REF! causado pela exclusão de uma coluna  A fórmula mudou para =A2+#REF!+B2

    Se você excluir uma linha ou coluna, a fórmula não será atualizada para excluir a linha excluída e retornará um erro #REF!, em que uma função SOMA será atualizada automaticamente.

    A função SOMA se ajusta automaticamente a colunas e linhas inseridas ou excluídas
  4. As fórmulas não atualizarão referências ao inserir linhas ou colunas

    As fórmulas =A+B+C não serão atualizadas se você adicionar linhas

    Se inserir uma linha ou coluna, a fórmula não será atualizada para incluir a linha adicionada, em que uma função soma será atualizada automaticamente (desde que você não esteja fora do intervalo referenciado na fórmula). Isso é especialmente importante se você espera que a fórmula atualize, pois ela não será atualizada e dará resultados incompletos que você poderá não perceber.

    O exemplo retrata uma fórmula de SOMA expandindo automaticamente de =SOMA(A2:C2) para =SOMA(A2:D2) quando uma coluna foi inserida
  5. SOMA com Referências de célula individuais versus Intervalos

    Usando uma fórmula como:

    • =SOMA(A1;A2;A3;B1;B2;B3)

    Também está bastante sujeito a erros durante a inserção ou exclusão de linhas dentro do intervalo referenciado pelas mesmas razões. É muito melhor usar intervalos individuais, como:

    • =SOMA(A1:A3;B1:B3)

    Que serão atualizados ao adicionar ou excluir linhas.

  1. Você pode usar SOMA com outras funções. Aqui está um exemplo que cria um cálculo da média mensal:

    Usando SOMA com outras funções.  A fórmula na célula M2 é =SOMA(A2:L2)/CONT.VALORES(A2:L2).  Observação: as colunas de maio a novembro estão ocultas para maior clareza.
    • =SOMA(A2:L2)/CONT.VALORES(A2:L2)

  2. Que usa a SOMA de A2:L2 dividida pela contagem de células não vazias em A2:L2 (maio a dezembro estão em branco).

  1. Às vezes, você precisa somar determinada célula em várias planilhas. Pode ser tentador clicar nas planilhas e células desejadas e usar o "+" para adicionar os valores da célula, mas é entediante e pode causar erros.

    • =Plan1!A1+Plan2!A1+Plan3!A1

    Você pode fazer isso muito mais facilmente com uma SOMA 3D ou tridimensional:

    Soma 3D - a fórmula na célula D2 é =SOMA(Plan1:Plan3!A2)
    • =SOMA(Plan1:Plan3!A1)

    Que somará a célula A1 em todas as planilhas, da Planilha 1 à Planilha 3.

    Isso será particularmente útil quando você tiver uma única folha para cada mês (janeiro a dezembro) e precisar totalizá-las em uma planilha de resumo.

    SOMA 3D entre Planilhas Nomeadas.  A fórmula em D2 é =SOMA(Janeiro:Dezembro!A2)
    • =SOMA(Janeiro:Dezembro!A2)

    Que somará a célula A2 em cada planilha de janeiro a dezembro.

    Observações : Caso as planilhas incluam espaços nos nomes, como "Vendas Janeiro", será necessário usar um apóstrofo quando fizer referência aos nomes das planilhas em uma fórmula. Observe o apóstrofo ANTES do primeiro nome e APÓS o último nome da planilha.

    • =SOMA(‘Vendas Janeiro:Vendas dezembro’!A2)

    O método 3D também funciona com outras funções, como MÉDIA, MÍN, MÁX etc.:

    • =MÉDIA(Plan1:Plan3!A1)

    • =MÍNIMO(Plan1:Plan3!A1)

    • =MÁXIMO(Plan1:Plan3!A1)

Problema

O que deu errado

Minha função SOMA mostra #####, mas não o resultado.

Verifique a largura das colunas. ##### geralmente significa que a coluna está muito estreita para exibir o resultado da fórmula.

Minha função SOMA mostra a fórmula em si como texto, mas não o resultado.

Verifique se formatou a célula como texto. Escolha a célula ou o intervalo em questão e use o comando Ctrl+1 para exibir a caixa de diálogo Formatar Células. Em seguida, clique na guia Número e escolha o formato desejado. Se a célula estiver formatada como texto e não mudar,depois que você alterar a formatação, pode ser necessário usar o comando F2 > Enter para forçar a alteração.

Minha função SOMA não atualiza.

Verifique se a opção de Cálculo está definida como Automática. Na guia Fórmulas, vá para Opções de Cálculo. Também é possível usar o botão F9 para forçar o cálculo da planilha.

Verifique se definiu o cálculo como Automático.  Na guia Fórmulas, vá para Opções de Cálculo.

Alguns valores não são adicionados.

Somente os valores numéricos no intervalo ou na referência são adicionados. Células vazias e valores lógicos, como VERDADEIRO, ou texto são ignorados.

O erro #NOME? em vez do resultado previsto.

Normalmente, isso significa que a fórmula foi digitada incorretamente, como =soma(A1:A10), em vez de =SOMA(A1:A10).

Minha função SOMA mostra um número inteiro, mas deveria mostrar decimais

Verifique a formatação da célula para garantir que está exibindo decimais. Escolha a célula ou o intervalo em questão e use o comando Ctrl+1 para exibir a caixa de diálogo Formatar Células. Em seguida, clique na guia Número, escolha o formato desejado e lembre-se de indicar o número de casas decimais que deseja.

  1. Eu quero somar/subtrair/multiplicar/dividir números. Assista a esta série de vídeos sobre Matemática básica no Excel ou Usar o Excel como calculadora.

  2. Como faço para exibir mais ou menos casas decimais? Você pode mudar a formatação do número. Escolha a célula ou o intervalo em questão e use o comando Ctrl+1 para exibir a caixa de diálogo Formatar Células. Em seguida, clique na guia Número, escolha o formato desejado e lembre-se de indicar o número de casas decimais que deseja.

  3. Como faço para adicionar ou subtrair horas? Você pode adicionar e subtrair horas de modos diferentes. Por exemplo, para obter a diferença entre 8:00 e 12:00 para motivos de pagamentos, você usaria: =("12:00 PM"-"8:00 AM")*24, fazendo a subtração da hora de início da hora de término. Observe que o Excel calcula as horas como uma fração do dia, portanto, é preciso multiplicar por 24 para obter o total de horas. No primeiro exemplo, usamos =((B2-A2)+(D2-C2))*24 para obter a soma das horas do início ao fim, menos uma pausa para o almoço (8h50 no total).

    Se você está somente adicionando horas e minutos e gostaria de exibi-los dessa forma, pode somar e não precisa multiplicar por 24. Assim, no segundo exemplo, usamos =SUM(A6:C6), já que precisamos apenas do número total de horas e minutos para tarefas atribuídas (5:36 ou 5 horas e 36 minutos).

    Calculando horas

    Para obter mais informações, consulte: Adicionar ou subtrair horários.

  4. Como faço para obter a diferença entre datas? Assim como nas horas, você pode somar e subtrair datas. Veja um exemplo comum de contagem do número de dias entre duas datas. É simples como =B2-A2. A dica para trabalhar com datas e horas é começar com a data/hora de término e subtrair a data/hora de início.

    Calculando as diferenças entre datas

    Para ver outras maneiras de trabalhar com datas, confira: Calcular o número de dias entre duas datas.

  5. Como faço para somar somente células visíveis? Às vezes, quando você oculta linhas manualmente ou usa o Filtro Automático para exibir somente determinados dados, também recomendamos somar as células visíveis. Você pode usar a função SUBTOTAL Se você está usando uma linha de totais na tabela do Excel, qualquer função que selecionar da lista suspensa Total será inserida automaticamente como um subtotal. Veja mais sobre como obter o Total dos dados de uma tabela do Excel.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Assista a um vídeo sobre como usar a função SOMA

A função SOMASE calcula apenas os valores que atendem a um único critério

A função SOMASES calcula apenas os valores que atendem a vários critérios

A função CONT.SE calcula apenas os valores que atendem a um único critério

A função CONT.SES calcula apenas os valores que atendem a vários critérios

Visão geral de fórmulas do Excel

Como evitar fórmulas quebradas

Localizar e corrigir erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Funções de matemática e trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Compartilhar Facebook Facebook Twitter Twitter Email Email

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×