Função SE

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

A função se é uma das funções mais populares no Excel e ela permite fazer comparações lógicas entre um valor e o que você espera. Em sua forma mais simples, a função se diz:

  • SE(Algo for Verdadeiro, faça tal coisa, caso contrário, faça outra coisa)

Para que uma instrução IF possa ter dois resultados. O primeiro resultado é se sua comparação for verdadeiro, a segunda se sua comparação for falso.

Se você quiser saltar para trabalhar com várias instruções IF, consulte: funções se avançadas - trabalhar com fórmulas aninhadas e evitando armadilhas.

Use a função SE, uma das funções lógicas, para retornar um valor se uma condição for verdadeira e um outro valor se for falsa.

Sintaxe

SE(teste_lógico, valor_se_verdadeiro, [valor_se_falso])

Por exemplo:

  • =SE(A2>B2,"Acima do orçamento","OK")

  • =SE(A2=B2;B4-A4;"")

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que você deseja testar.

valor_se_verdadeiro    (obrigatório)

O valor que você deseja retornar se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que você deseja retornar se o resultado do teste_lógico for FALSO.

Exemplos de SE simples

A célula D2 contém a fórmula =SE(C2="Sim";1;2)
  • =SE(C2="Sim";1,2)

No exemplo acima, a célula D2 diz: SE(C2 = Sim, a fórmula retorna um 1 ou um 2)

A célula D2 contém a fórmula =SE(C2=1;"SIM";"NÃO")
  • =SE(C2=1;"Sim";"Não")

Neste exemplo, a fórmula na célula D2 diz: SE(C2 = 1, a fórmula retorna Sim e, caso contrário, retorna Não)

Como você pode ver, a função se pode ser usada para avaliar valores e o texto. Ele também pode ser usado para avaliar erros. Você não está limitado a verificação somente se algo é igual a outro e retornar um único resultado, você pode também usar operadores matemáticos e executar cálculos adicionais dependendo de seus critérios. Você também pode aninhar várias funções se juntos para realizar várias comparações.

Observação : Se você for usar texto em fórmulas, você precisa quebrar o texto entre aspas (por exemplo, "texto"). A única exceção que está usando verdadeiro ou falso, que o Excel automaticamente entende.

Introdução

A melhor maneira de começar a escrever uma instrução IF é pensar sobre o que você está tentando realizar. Comparação de que você está tentando fazer? Muitas vezes, escrever uma instrução IF pode ser tão simple quanto pensando a lógica de cabeça: "o que acontece se essa condição é atendida versus o que acontece se não estiver?" Sempre que você desejará certificar-se de que seu etapas siga uma progressão lógica ou então a fórmula não é o que você acha que deveria. Isso é especialmente importante quando você cria complexas instruções IF (aninhadas).

Mais exemplos de SE

A fórmula na célula D2 é =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")
  • =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")

No exemplo acima, a função SE em D2 está dizendo SE(C2 é maior que B2, retorne "Acima do orçamento", caso contrário, retorne "Dentro do orçamento")

A fórmula na célula E2 é =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Na ilustração acima, em vez de retornar um resultado de texto, vamos para retornar um cálculo matemático. Para que a fórmula na E2 está dizendo se (real é maior que orçados, depois de subtrair o valor de orçados em relação à quantidade real, caso contrário retorna nada).

A fórmula na célula F7 é SE(E7="Sim";F5*0,0825;0)
  • =SE(E7="Sim";F5*0,0825;0)

Neste exemplo, a fórmula em F7 está dizendo SE(E7="Sim", calcule o Valor Total em F5 * 8,25%, caso contrário, nenhum Imposto sobre Vendas é cobrado, retorne 0)

Práticas Recomendadas – Constantes

No último exemplo, você pode ver "Sim", tanto a taxa de imposto sobre vendas (0.0825) inseridos diretamente na fórmula. Não geralmente é uma boa prática colocar constantes literais (valores que talvez precise alterar do tempo) diretamente em fórmulas, pois elas pode ser difícil de localizar e alterar no futuro. É muito melhor colocar constantes em suas próprias células, onde elas são check-out na caixa Abrir e facilmente encontrado e alterado. Nesse caso, é Okey, porque não há apenas uma função se e a taxa de imposto sobre vendas raramente será alterada. Mesmo se for, será fácil alterá-lo na fórmula.

Operadores de cálculo

Se você quiser saber mais sobre os operadores de cálculo diferentes que você pode usar em fórmulas, (< menor do que, > maior que, = , <> não igual, etc), consulte este artigo: operadores de cálculo e precedência.

Usar SE para verificar se uma célula está em branco

Às vezes, é preciso verificar se uma célula está em branco, geralmente porque você pode não querer uma fórmula exiba um resultado sem entrada.

A fórmula na célula E2 é =SE(D2=1;"Sim",SE(D2=2;"Não";"Talvez"))

Nesse caso, usamos SE com a função ÉCÉL.VAZIA:

  • =SE(ÉCÉL.VAZIA(D2);"Em branco";"Não está em branco")

Que diz IF(D2 is blank, then return "Blank", otherwise return "Not Blank"). Você poderia facilmente usar sua própria fórmula para a condição "Não em branco" também. No próximo exemplo estamos usando "" em vez de ÉCÉL. A "" basicamente significa "nada".

Verificar se uma célula está em branco – A fórmula na célula E2 é =SE(ÉCÉL.VAZIA(D2),"Em branco","Não está em branco")
  • =SE(D3="";"Em branco";"Não está em branco")

Essa fórmula diz se (D3 nada, depois, retornar "Em branco", caso contrário, "não em branco"). Aqui está um exemplo de um método muito comum de uso "" para impedir que uma fórmula de cálculo se uma célula dependente estiver em branco:

  • =SE(D3="";"";SuaFórmula())

    SE(D3 é nada, retorne nada, caso contrário, calcule sua fórmula).

Exemplo de SE aninhada

Em casos onde uma simples função SE tem apenas dois resultados (Verdadeiro ou Falso), as funções se aninhadas SE podem ter de 3 a 64 resultados.

Usar "" para verificar se há uma célula em branco – A fórmula na célula E3 é =SE(D3="","Em branco","Não está em branco")
  • =SE(D2=1;"SIM";SE(D2=2;"Não";"Talvez"))

Na ilustração acima, a fórmula em E2 diz: SE(D2 é igual a 1, retornar "Sim", caso contrário, SE(D2 é igual a 2, retornar "Não", caso contrário, retornar "Talvez")). Observe que existem dois parênteses de fechamento no final da fórmula. Eles são necessários para concluir as duas funções SE e, se você tentar inserir a fórmula sem os dois, o Excel tentará corrigi-la para você.

Cuidado

Enquanto o Excel permitirá que você aninhar até 64 funções se diferente, não é recomendável fazer isso. Por quê?

  • Várias instruções se exigem uma grande quantidade de pensamento criá-los corretamente e certifique-se de que sua lógica pode calcular corretamente por meio de cada condição totalmente até o final. Se você não aninhe suas instruções se 100% com precisão, em seguida, uma fórmula pode trabalhar 75% do tempo, mas retornar resultados inesperados 25% do tempo. Infelizmente, as chances de você captura a 25% é fino.

  • Vários declarações SE podem se tornar muito difíceis de serem mantidas, especialmente quando você retoma a declaração algum tempo depois e tenta descobrir o que você, ou pior, outra pessoa, estava tentando fazer.

  • Várias instruções SE exigem vários parênteses de abertura e fechamento (), o que pode ser difícil de gerenciar dependendo da complexidade da sua fórmula.

Problemas comuns

Problema

O que aconteceu de errado

0 (zero) na célula

Não havia um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso. Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Isso geralmente significa que a fórmula está incorreta.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Vídeo: Se avançadas

Função SES (Office 365, Excel 2016 e posterior)

Funções se avançadas - trabalhar com fórmulas aninhadas e evitando armadilhas

Vídeos de treinamento: funções se avançadas

A função CONT.se contará valores com base em um único critério

A função CONT será contar valores com base em vários critérios

A função SOMASE será somar valores com base em um único critério

A função SOMASES será somar valores com base em vários critérios

Função E

Função ou

Função PROCV

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções lógicas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×