Função SE

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

A função SE é uma das funções mais populares do Excel e permite que você faça comparações lógicas entre um valor e aquilo que você espera. Em sua forma mais simples, a função SE diz:

  • SE(Algo for Verdadeiro, faça tal coisa, caso contrário, faça outra coisa)

Portanto, uma instrução SE pode ter dois resultados. O primeiro resultado é se a comparação for Verdadeira, o segundo se a comparação for Falsa.

Se você quiser começar a trabalhar diretamente com várias instruções SE, consulte: Funções SE avançadas – Trabalhando com fórmulas aninhadas e evitando as armadilhas.

Use a função SE, uma das funções lógicas, para retornar um valor se uma condição for verdadeira e um outro valor se for falsa.

Sintaxe

SE(teste_lógico, valor_se_verdadeiro, [valor_se_falso])

Por exemplo:

  • =SE(A2>B2,"Acima do orçamento","OK")

  • =SE(A2=B2;B4-A4;"")

Nome do argumento

Descrição

teste_lógico    (obrigatório)

A condição que você deseja testar.

valor_se_verdadeiro    (obrigatório)

O valor que você deseja retornar se o resultado do teste_lógico for VERDADEIRO.

valor_se_falso    (opcional)

O valor que você deseja retornar se o resultado do teste_lógico for FALSO.

Exemplos de SE simples

A célula D2 contém a fórmula =SE(C2="Sim";1;2)
  • =SE(C2="Sim";1,2)

No exemplo acima, a célula D2 diz: SE(C2 = Sim, a fórmula retorna um 1 ou um 2)

A célula D2 contém a fórmula =SE(C2=1;"SIM";"NÃO")
  • =SE(C2=1;"Sim";"Não")

Neste exemplo, a fórmula na célula D2 diz: SE(C2 = 1, a fórmula retorna Sim e, caso contrário, retorna Não)

Como você pode ver, a função SE pode ser usada para avaliar texto e valores. Ela também pode ser usada para avaliar erros. Você não está limitado a verificar apenas se um valor é igual a outro e retornar um único resultado; você também pode usar operadores matemáticos e executar cálculos adicionais dependendo de seus critérios. Também é possível aninhar várias funções SE juntas para realizar várias comparações.

Observação : Se você for usar texto em fórmulas, será preciso quebrar o texto entre aspas (por exemplo, "Texto"). A única exceção é usar VERDADEIRO ou FALSO que o Excel reconhece automaticamente.

Introdução

A melhor maneira de começar a escrever uma instrução SE é pensar sobre o que você está tentando realizar. Que comparação você está tentando fazer? Muitas vezes, escrever uma instrução SE pode ser tão simples quanto pensar na lógica em sua cabeça: "o que aconteceria se essa condição fosse atendida vs. o que aconteceria se não fosse?" Você sempre deve se certificar de que suas etapas sigam uma progressão lógica; caso contrário, sua fórmula não executará aquilo que você acha que ela deveria executar. Isso é especialmente importante quando você cria instruções SE complexas (aninhadas).

Mais exemplos de SE

A fórmula na célula D2 é =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")
  • =SE(C2>B2;"Acima do orçamento";"Dentro do orçamento")

No exemplo acima, a função SE em D2 está dizendo SE(C2 é maior que B2, retorne "Acima do orçamento", caso contrário, retorne "Dentro do orçamento")

A fórmula na célula E2 é =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Na ilustração acima, em vez de retornar um resultado de texto, vamos retornar um cálculo matemático. A fórmula em E2 está dizendo SE(Valor real for maior que o Valor orçado, subtraia o Valor orçado do Valor real, caso contrário, não retorne nada).

A fórmula na célula F7 é SE(E7="Sim";F5*0,0825;0)
  • =SE(E7="Sim";F5*0,0825;0)

Neste exemplo, a fórmula em F7 está dizendo SE(E7="Sim", calcule o Valor Total em F5 * 8,25%, caso contrário, nenhum Imposto sobre Vendas é cobrado, retorne 0)

Práticas Recomendadas – Constantes

No último exemplo, você vê dois "Sim" e a Taxa de Imposto sobre Vendas (0,0825) inseridos diretamente na fórmula. Geralmente, não é recomendável colocar constantes literais (valores que talvez precisem ser alterados ocasionalmente) diretamente nas fórmulas, pois elas podem ser difíceis de localizar e alterar no futuro. É muito melhor colocar constantes em suas próprias células, onde elas ficam fora das constantes abertas e podem ser facilmente encontradas e alteradas. Nesse caso, tudo bem, pois há apenas uma função SE e a Taxa de Imposto sobre Vendas raramente será alterada. Mesmo se isso acontecer, será fácil alterá-la na fórmula.

Operadores de cálculo

Se você quiser saber mais sobre os operadores de cálculo diferentes que você pode usar em fórmulas, (< menor do que, > maior que, = , <> não igual, etc), consulte este artigo: operadores de cálculo e precedência.

Usar SE para verificar se uma célula está em branco

Às vezes, é preciso verificar se uma célula está em branco, geralmente porque você pode não querer uma fórmula exiba um resultado sem entrada.

A fórmula na célula E2 é =SE(D2=1;"Sim",SE(D2=2;"Não";"Talvez"))

Nesse caso estamos usando se com a função ÉCÉL :

  • =SE(ÉCÉL.VAZIA(D2);"Em branco";"Não está em branco")

Que diz SE(D2 está em branco, retorne "Em branco", caso contrário, retorne "Não está em branco"). Você também poderia facilmente usar sua própria fórmula para a condição "Não está em branco". No próximo exemplo usamos "" em vez de ÉCÉL.VAZIA. "" basicamente significa "nada".

Verificar se uma célula está em branco – A fórmula na célula E2 é =SE(ÉCÉL.VAZIA(D2),"Em branco","Não está em branco")
  • =SE(D3="";"Em branco";"Não está em branco")

Essa fórmula diz SE(D3 é nada, retorne "Em branco", caso contrário, retorne "Não está em branco"). Veja um exemplo de um método muito comum de usar "" para impedir que uma fórmula calcule se uma célula dependente está em branco:

  • =SE(D3="";"";SuaFórmula())

    SE(D3 é nada, retorne nada, caso contrário, calcule sua fórmula).

Exemplo de SE aninhada

Em casos onde uma simples função SE tem apenas dois resultados (Verdadeiro ou Falso), as funções se aninhadas SE podem ter de 3 a 64 resultados.

Usar "" para verificar se há uma célula em branco – A fórmula na célula E3 é =SE(D3="","Em branco","Não está em branco")
  • =SE(D2=1;"SIM";SE(D2=2;"Não";"Talvez"))

Na ilustração acima, a fórmula na E2 diz: se (D2 é igual a 1, em seguida, retorno "Sim", caso contrário, se (D2 é igual a 2 e retorno "não", caso contrário retornar "Talvez")). Observe que há dois parênteses de fechamento no final da fórmula. Esses são necessários para concluir ambas as funções se e se você tentar inserir a fórmula sem ambos os parênteses de fechamento, o Excel irá tentar corrigi-lo para você.

Cuidado

O Excel permite aninhar até 64 funções SE diferentes, mas não é nada aconselhável fazê-lo. Por quê?

  • Várias instruções SE exigem uma grande quantidade de raciocínio para serem criadas corretamente e para certificar-se de que sua lógica pode calcular corretamente cada condição, do início ao fim. Se você não aninhar suas instruções SE de forma totalmente precisa, em seguida, uma fórmula poderá funcionar 75% das vezes, mas retornar resultados inesperados 25% das vezes. Infelizmente, são grandes as chances de cair nos 25%.

  • Vários declarações SE podem se tornar muito difíceis de serem mantidas, especialmente quando você retoma a declaração algum tempo depois e tenta descobrir o que você, ou pior, outra pessoa, estava tentando fazer.

  • Várias instruções se exigem vários (de parênteses de abertura e de fechamento), que pode ser difícil gerenciar dependendo fica como complexos de sua fórmula.

Problemas comuns

Problema

O que aconteceu de errado

0 (zero) na célula

Não havia um argumento para os argumentos valor_se_verdadeiro ou valor_se_falso. Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.

#NOME? na célula

Isso geralmente significa que a fórmula está incorreta.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no Fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Consulte Também

Veja um vídeo sobre como usar a função SE

Função SES (Office 365, Excel 2016 e posterior)

Funções SE avançadas – Trabalhando com fórmulas aninhadas e evitando armadilhas

Vídeos de treinamento: Funções SE avançadas

A função CONT.SE calcula valores com base em um único critério

A função CONT SES calcula valores com base em vários critérios

A função SOMASE soma valores com base em um único critério

A função SOMASES soma valores com base em vários critérios

Função E

Função OU

Função PROCV

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a Verificação de erros para detectar erros em fórmulas

Funções lógicas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Compartilhar Facebook Facebook Twitter Twitter Email Email

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×