Função OU

Use a função OU, uma da funções lógicas, para determinar se alguma condição em um teste é verdadeira.

Exemplo

Exemplos de como usar a função OU.

A função OU retornará VERDADEIRO se qualquer um dos argumentos for avaliado como VERDADEIRO e retornará FALSO se todos os argumentos forem avaliados como FALSO.

Um uso comum para a função OU é expandir a utilidade de outras funções que realizam testes lógicos. Por exemplo, a função SE realiza um teste lógico e retornará um valor se o teste for avaliado como VERDADEIRO e outro valor se o teste for avaliado como FALSO. Usando a função OU como argumento teste_lógico da função SE, você pode testar várias condições diferentes em vez de apenas uma.

Sintaxe

OU(lógico1; [lógico2], ...)

A sintaxe da função OU tem os seguintes argumentos:

Argumento

Descrição

Lógico1

Obrigatório. A primeira condição que você deseja testar que pode ser avaliada como VERDADEIRO ou FALSO.

Lógico2; ...

Opcional. Condições adicionais que você deseja testar que podem ser avaliadas como VERDADEIRO ou FALSO, até um máximo de 255 condições.

Comentários

  • Os argumentos devem ser avaliados como valores lógicos, como VERDADEIRO ou FALSO, ou em matrizes ou referências que contenham valores lógicos.

  • Se um argumento de uma matriz ou referência contiver texto ou células vazias, esses valores serão ignorados.

  • Se o intervalo especificado não contiver valores lógicos, OU retornará o valor de erro #VALOR!.

  • Você pode usar uma fórmula de matriz OU para verificar se um valor ocorre em uma matriz. Para inserir uma fórmula de matriz, pressione Ctrl+Shift+Enter.

Exemplos

Aqui estão alguns exemplos gerais do uso de OU por si só e em conjunto com SE.

Exemplos de como usar a função OU com a função SE.

Fórmula

Descrição

=OU(A2>1;A2<100)

Exibirá VERDADEIRO se A2 for maior que 1 OU menor que 100, caso contrário, exibirá FALSO.

=SE(OU(A2>1;A2<100);A3;"O valor está fora do intervalo")

Exibirá o valor na célula A3 se for maior que 1 OU menor que 100, caso contrário, exibirá a mensagem "O valor está fora do intervalo".

=SE(OU(A2<0;A2>50);A2;"O valor está fora do intervalo")

Exibirá o valor na célula A2 se for menor que 0 OU maior que 50, caso contrário, exibirá uma mensagem.

Cálculo de comissão de vendas

Aqui está um cenário bastante comum em que precisamos calcular se os vendedores se qualificam para uma comissão usando SE e OU.

Exemplo de como usar SE e OU para calcular uma comissão de vendas.
  • =SE(OU(B14>=$B$4;C14>=$B$5);B14*$B$6;0) - SE Total de Vendas for maior ou igual a (>=) a Meta de Vendas OU Contas forem maiores ou igual a (>=) a Meta de Contas, multiplicar Vendas Totais por % de Comissão, caso contrário, retornar 0.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Tópicos Relacionados

Vídeo Funções SE avançadas
Saiba como usar funções aninhadas em uma fórmula
Função SE
Função E
Função NÃO
Visão geral de fórmulas no Excel
Como evitar fórmulas quebradas
Usar a verificação de erros para detectar erros em fórmulas
Atalhos de teclado no Excel 2016 para Windows
Atalhos de teclado no Excel 2016 para Mac
Funções lógicas (referência)
Funções do Excel (ordem alfabética)
Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×