Função DESLOC

Este artigo descreve a sintaxe da fórmula e o uso da função DESLOC no Microsoft Excel.

Descrição

Retorna uma referência para um intervalo, que é um número especificado de linhas e colunas de uma célula ou intervalo de células. A referência retornada pode ser uma única célula ou um intervalo de células. Você pode especificar o número de linhas e de colunas a serem retornadas.

Sintaxe

DESLOC(ref, lins, cols, [altura], [largura])

A sintaxe da função DESLOC tem os seguintes argumentos:

  • ref    Obrigatório. A referência na qual você deseja basear o deslocamento. Ref deve ser uma referência a uma célula ou intervalo de células adjacentes; caso contrário, DESLOC retornará o valor de erro #VALOR!.

  • lins    Obrigatório. O número de linhas, acima ou abaixo, a que se deseja que a célula superior esquerda se refira. Usar 5 como o argumento de linhas, especifica que a célula superior esquerda na referência está cinco linhas abaixo da referência. Lins podem ser positivas (que significa abaixo da referência inicial) ou negativas (acima da referência inicial).

  • cols    Obrigatório. O número de colunas, à esquerda ou à direita, a que se deseja que a célula superior esquerda do resultado se refira. Usar 5 como o argumento de colunas, especifica que a célula superior esquerda na referência está cinco colunas à direita da referência. Cols pode ser positivo (que significa à direita da referência inicial) ou negativo (à esquerda da referência inicial).

  • altura    Opcional. A altura, em número de linhas, que se deseja para a referência fornecida. Altura deve ser um número positivo.

  • largura    Opcional. A largura, em número de colunas, que se deseja para a referência fornecida. Largura deve ser um número positivo.

Comentários

  • Se lins e cols deslocarem a referência sobre a borda da planilha, DESLOC retornará o valor de erro #REF!.

  • Se altura ou largura forem omitidos, serão equivalentes a altura ou largura de ref.

  • Na verdade, DESLOC não desloca quaisquer células nem modifica a seleção; apenas fornece uma referência. DESLOC pode ser usada com qualquer função que pressuponha um argumento de referência. Por exemplo, a fórmula SOMA(DESLOC(C2;1;2;3;1)) calcula o valor total de um intervalo formado por 3 linhas e 1 coluna que está 1 linha abaixo e 2 colunas à direita da célula C2.

Exemplo

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Fórmula

Descrição

Resultado

=DESLOC(D3,3,-2,1,1)

Exibe o valor da célula B6 (4)

4

=SOMA(DESLOC(D3:F5,3,-2, 3, 3))

Soma o intervalo B6:C8

34

=DESLOC(D3, -3, -3)

Retorna um erro porque a referência é feita a um intervalo inexistente na planilha.

#REF!

Dados

Dados

4

10

8

3

3

6

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×