Fazer check-in ou check-out de um arquivo de uma biblioteca do SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando você faz o check-out de um arquivo de uma biblioteca em um site do Microsoft Windows SharePoint Services, você garante que outras pessoas não possam fazer alterações no arquivo enquanto você o edita. Enquanto o check-out do arquivo é feito, você pode editar o arquivo, fechá-lo, reabri-lo e até mesmo trabalhar com o arquivo no seu disco rígido. Outros usuários não podem alterar o arquivo ou ver as alterações até que você faça o check-in do arquivo.

Neste artigo

Visão geral

Fazer check-out de um arquivo em uma biblioteca do SharePoint

Check-in de um arquivo para uma biblioteca do SharePoint

Alterar o local onde você trabalhar em arquivos de check-out

Visão geral

Fazer check-out de arquivos antes de trabalhar neles ajuda a evitar conflitos e confusão quando várias pessoas estão trabalhando no mesmo conjunto de arquivos. Quando é feito check-out de um arquivo por você, apenas você pode fazer alterações nele. É possível fazer o check-out de qualquer arquivo em um site do SharePoint para o qual tenha permissão, e é possível fazê-lo diretamente dos seguintes programas do 2007 Microsoft Office system: Word, Excel, PowerPoint e Visio.

Quando você faz o check-in de um arquivo, pode digitar comentários sobre as alterações feitas nele. Isso ajuda as pessoas a entender o que foi alterado no arquivo em cada versão. Isso é especialmente útil se várias pessoas trabalham em um arquivo ou se o arquivo provavelmente passará por diferentes revisões. Se a biblioteca controla versões de arquivos, seus comentários se tornam parte do histórico de versões do arquivo, o que pode ser útil se as pessoas precisam visualizar ou restaurar uma versão anterior.

Sua organização pode exigir que você faça check-out de um arquivo antes de editá-lo. Quando o check-out é exigido, você deve fazer o check-in de um novo arquivo ao criá-lo em uma biblioteca ou atualizá-lo em uma biblioteca.

Enquanto você faz check-out de um arquivo, as alterações que você faz não ficam visíveis às outras pessoas até que você faça o check-in desse arquivo. Pode haver casos em que você deseja fazer o check-in do arquivo para que outras pessoas possam ver as alterações, mas deseja manter o check-out do arquivo para poder continuar trabalhando nele. Quando faz o check-in de um arquivo, você pode optar por continuar trabalhando nele, a menos que a biblioteca controle as versões principal e a secundária e que você esteja fazendo o check-in de uma versão principal. Uma versão principal geralmente sofreu alterações significativas desde a versão principal anterior, enquanto uma versão secundária geralmente sofreu poucas alterações desde a versão anterior. Por exemplo, uma versão principal pode incluir uma grande parte do novo conteúdo, enquanto uma versão secundária pode incluir apenas correções a erros de ortografia.

Quando você usa um programa do Office para fazer check-out de um arquivo em um site do Windows SharePoint Services 3.0, o arquivo é armazenado, por padrão, no disco rígido em uma pasta de rascunho da pasta Meus Documentos. Você pode alterar esse local para outro no disco rígido ou na rede ou pode especificar que os arquivos com check-out sejam armazenados no servidor da Web quando você trabalha neles. Seu administrador deve especificar um local personalizado ou impedir que o local seja alterado, dependendo das necessidades da sua organização.

Quando você faz o check-out de um arquivo em um site do Microsoft Windows SharePoint Services 2.0, o arquivo é armazenado no servidor enquanto você trabalha nele, mas ainda assim você deve fazer o check-in do arquivo para que outras pessoas possam ver suas alterações. Na maioria dos casos, quando você faz o check-out de um arquivo em um site do Windows SharePoint Services 3.0, você recebe uma mensagem informando onde o arquivo será armazenado enquanto você faz o seu check-out. Você não receberá essa mensagem enquanto faz o check-out de um arquivo em um site do Windows SharePoint Services 2.0.

Quando o check-out de um arquivo é feito, o painel de tarefas Gerenciamento de Documentos no programa do Office fornece um comando para fazer o check-in do arquivo novamente.

Se tanto a versão principal quanto a secundária de um arquivo estão sendo controlados, você pode ser solicitado a escolher se deseja fazer o check-in de uma versão principal ou secundária.

Início da página

Check-out de um arquivo de uma biblioteca do SharePoint

Use este procedimento para fazer o check-out de um arquivo que já esteja aberto em um programa do Office. Você também pode fazer check-out de um arquivo na biblioteca de um site do SharePoint.

Faça o seguinte nestes programas do 2007 Office release:

Word, Excel ou PowerPoint

  1. Clique o Botão Microsoft Office Imagem do botão Office , clique em servidor e clique em Fazer Check-Out.

    Os documentos do Word são geralmente abertos no modo de exibição Leitura em Tela Inteira, por padrão. Se esse for o caso, você pode ter que clicar em Layout de Impressão para passar para o modo Layout de Impressão antes de concluir esta etapa.

  2. Se aparecer uma mensagem descrevendo onde o arquivo é armazenado durante o check-out, clique em OK.

    Na maioria dos casos, essa mensagem aparece se você está fazendo o check-out de um arquivo de um site do Windows SharePoint Services 3.0.

    Dica : Na mensagem que descreve onde o arquivo está sendo armazenado durante o check-out, você pode alterar as opções para trabalhar com arquivos com check-out.

Visio

  1. No menu Arquivo, clique em Check-out.

  2. Se aparecer uma mensagem descrevendo onde o arquivo é armazenado durante o check-out, clique em OK.

    Na maioria dos casos, essa mensagem aparece se você está fazendo o check-out de um arquivo de um site do Windows SharePoint Services 3.0.

    Dica : Na mensagem que descreve onde o arquivo está sendo armazenado durante o check-out, você pode alterar as opções para trabalhar com arquivos com check-out.

Início da página

Check-in de um arquivo para uma biblioteca do SharePoint

Use este procedimento para fazer o check-in de um arquivo enquanto ele está aberto em um programa do Office. Você também pode fazer check-in de um arquivo na biblioteca de um site do SharePoint.

Faça o seguinte nestes programas do 2007 Office release:

Word, Excel ou PowerPoint

  1. Clique o Botão Microsoft Office Imagem do botão Office , clique em servidor e clique em Fazer Check-In.

    Os documentos do Word são geralmente abertos no modo de exibição Leitura em Tela Inteira, por padrão. Se esse for o caso, você pode ter que clicar em Layout de Impressão para passar para o modo Layout de Impressão antes de concluir esta etapa.

  2. Se for perguntado se você deseja fazer o check-in de uma versão principal ou secundária, clique em Versão secundária se você fez uma alteração secundária ou em Versão principal se você fez uma alteração principal.

  3. Na caixa Comentários da Versão, digite comentários para suas alterações.

    Esses comentários são exibidos como parte do histórico das versões do arquivo na biblioteca do SharePoint, o que poderá ser útil se você ou outra pessoa precisar exibir informações sobre versões anteriores.

  4. Se a caixa de seleção Manter check-out do documento após fazer check-in desta versão estiver disponível, você poderá marcá-la se desejar continuar trabalhando no arquivo.

    Esta opção está disponível se a biblioteca não controla versões, se ela controla todas as versões do mesmo jeito ou se você está fazendo check-in de uma versão secundária. Essa opção não está disponível se você está fazendo check-in em uma versão principal ou publicando um arquivo.

Visio

  1. No menu Arquivo, clique em Check-in.

  2. Se for perguntado se você deseja fazer o check-in de uma versão principal ou secundária, clique em Versão secundária se você fez uma alteração secundária ou em Versão principal se você fez uma alteração principal.

  3. Na caixa Comentários da Versão, digite comentários para suas alterações.

    Esses comentários são exibidos como parte do histórico das versões do arquivo na biblioteca do SharePoint, o que poderá ser útil se você ou outra pessoa precisar exibir informações sobre versões anteriores.

  4. Se a caixa de seleção Manter check-out do documento após fazer check-in desta versão estiver disponível, você poderá marcá-la se desejar continuar trabalhando no arquivo.

    Esta opção está disponível se a biblioteca não controla versões, se ela controla todas as versões do mesmo jeito ou se você está fazendo check-in de uma versão secundária. Essa opção não está disponível se você está fazendo check-in em uma versão principal ou publicando um arquivo.

Início da página

Alterar o local onde você trabalha em arquivos com check-out

Essa configuração altera o local onde você trabalha no próximo arquivo com check-out. Se você está trabalhando no momento em um arquivo com check-out, esse procedimento não altera seu local.

Faça o seguinte nestes programas do 2007 Office release:

Word, Excel ou PowerPoint

  1. Clique no Botão Microsoft Office Imagem do botão Office e clique nas opções do programa: Opções do Word, as Opções do Excel ou Opções do PowerPoint.

  2. Na caixa de diálogo que é exibida, clique em Salvar.

  3. Na seção Opções de edição offline para arquivos de servidor de gerenciamento de documentos, faça o seguinte:

    • Use o procedimento a seguir para trabalhar com arquivos com check-out no disco rígido ou em um local da rede:

      1. Em Salvar arquivos submetidos com check-out, clique em No local dos rascunhos de servidor deste computador.

      2. Na caixa Local dos rascunhos do servidor, digite o local do disco rígido em que você deseja trabalhar com arquivos submetidos a check-out ou clique em Procurar para encontrar esse local.

    • Para trabalhar com arquivos com check-out em um servidor Web, em Salvar arquivos submetidos a check-out, clique em No servidor Web.

      Quando você escolhe essa opção, trabalha com os arquivos com check-out no servidor Web ou no site onde os arquivos são armazenados. Você não pode personalizar o local específico.

  4. Clique em OK.

Visio

  1. No menu Ferramentas, clique em Opções.

  2. Na caixa de diálogo Opções, clique na guia Geral e, em seguida, clique em Opções de Serviço.

  3. Na caixa de diálogo que é exibida, clique em Opções de Edição Offline.

  4. Na seção Opções de edição offline para arquivos de servidor de gerenciamento de documentos, faça o seguinte:

    • Use o procedimento a seguir para trabalhar com arquivos com check-out no disco rígido ou em um local da rede:

      1. Para trabalhar com arquivos com check-out no disco rígido, em Salvar arquivos submetidos a check-out, clique em No local dos rascunhos de servidor deste computador.

      2. Em Local dos rascunhos do servidor, digite o local do disco rígido em que você deseja trabalhar com arquivos com check-out ou clique em Procurar para procurar o local.

    • Para trabalhar com arquivos com check-out em um local do servidor, em Salvar arquivos submetidos a check-out, clique em No servidor Web.

      Quando você escolhe essa opção, trabalha com os arquivos com check-out no servidor Web ou no site onde os arquivos são armazenados. Você não pode personalizar o local específico.

  5. Clique em OK.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×