Exibir ou ocultar valores nulos

Talvez você tenha uma preferência pessoal por exibir valores zero em uma célula ou pode estar usando uma planilha sujeita a um conjunto de padrões de formato que requerem ocultar os valores zero. Há várias maneiras de exibir ou de ocultar valores zero.

O que deseja fazer?

Exibir ou ocultar todos os valores zero em uma planilha

Usar um formato de número para ocultar valores zero em células selecionadas

Usar um formato condicional para ocultar valores zero retornados por uma fórmula

Usar uma fórmula para exibir valores zero como espaços em branco ou traços

Ocultar valores zero em um relatório de tabela dinâmica

Exibir ou ocultar todos os valores zero em uma planilha

  1. Clique no botão Microsoft Office Imagem do botão do Office, clique em Opções do Excel e, em seguida, clique na categoria Avançado.

  2. Em Opçoes de exibição para esta planilha, selecione uma planilha e siga um destes procedimentos:

    • Para exibir valores zero (0) nas células, marque a caixa de seleção Mostrar um zero nas células cujo valor é zero.

    • Para exibir valores zero como células em branco, desmarque a caixa de seleção Mostrar um zero nas células cujo valor é zero.

Início da Página

Usar um formato de número para ocultar valores zero em células selecionadas

Siga este procedimento para ocultar valores zero nas células selecionadas. Se o valor em uma dessas células for alterado para um valor diferente de zero, o formato do valor será semelhante ao formato de número geral.

  1. Selecione as células que contêm os valores zero (0) que você deseja ocultar.

  2. Na guia Página Inicial, no grupo Células, clique em Formatar e em Formatar Células.

  3. Na lista Categoria, clique em Personalizado.

  4. Na caixa Tipo, digite 0;-0;;@

Observação   

  • Os valores ocultos são exibidos apenas na barra de fórmulas barra de fórmulas ou na célula, caso faça edições dentro dela, e não são impressos.

  • Na guia Página Inicial, no grupo Células, clique em Formatar e em Formatar Células.

  • Para exibir novamente os valores ocultos, selecione as células e, na guia Página Inicial, vá ate o grupo Células, aponte para Formatar e clique em Formatar Células. Na lista Categoria, clique em Geral para aplicar o formato de número padrão. Para exibir novamente a data e a hora, selecione os formatos de data e hora apropriados na guia Número.

Início da Página

Usar um formato condicional para ocultar valores zero retornados por uma fórmula

  1. Selecione a célula que contém o valor zero (0).

  2. Na guia Página Inicial, vá até o grupo Estilos, clique na seta ao lado de Formatação Condicional, aponte para Realçar Regras das Células e clique em É Igual a.

  3. Na caixa à esquerda, digite 0.

  4. Na caixa à direita, selecione Formato Personalizado.

  5. Na caixa de diálogo Formatar Células, clique na guia Fonte.

  6. Na caixa Cor, selecione branco.

Início da Página

Usar uma fórmula para exibir valores zero como espaços em branco ou traços

Para executar essa tarefa, utilize a função SE.

Exemplo

O exemplo pode ser mais fácil de compreender se você copiá-lo para uma planilha vazia.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo.

Importante   Não selecione os cabeçalhos de linha ou de coluna.

selecionando um exemplo na Ajuda do Excel 2013 para Windows

Selecionando um exemplo da Ajuda

  1. Pressione CTRL+C.

  2. Crie uma planilha ou pasta de trabalho em branco no Excel.

  3. Na planilha, selecione a célula A1 e pressione CTRL+V.

Importante   Para que o exemplo funcione corretamente, você deve colá-lo na célula A1 da planilha.

  1. Para alternar entre visualizar os resultados e as fórmulas que retornam os resultados, pressione CTRL+` (acento grave), ou na guia Fórmulas no grupo Auditoria de Fórmula, clique no botão Exibir Fórmulas.

Após copiar o exemplo em uma planilha em branco, você poderá adaptá-lo conforme as suas necessidades.

1

2

3

4

5


6

7

A

B

Dados

10

10

Fórmula

Descrição (Resultado)

=A2-A3

Segundo número subtraído do primeiro (0)

=SE(A2-A3=0,””,A2-A3)

Retorna uma célula em branco quando o valor é zero (célula vazia)

=SE(A2-A3=0,”-”,A2-A3)

Retorna um traço quando o valor é zero (-)

Para saber mais sobre como usar essa função, confira Função SE.

Início da Página

Ocultar valores zero em um relatório de tabela dinâmica

  1. Clique no relatório de tabela dinâmica.

  2. Na guia Opções, no grupo Opções da Tabela Dinâmica, clique na seta ao lado de Opções e depois clique em Opções.

  3. Clique na guia Layout e Formato e, em seguida, siga um destes procedimentos:

    Mudar a exibição de erros    – Marque a caixa de seleção Para valores de erro, mostrar em Formatar. Na caixa, digite o valor que deseja exibir no lugar dos erros. Para exibir erros como células em branco, exclua os caracteres da caixa.

    Mudar a exibição de células vazias    – Marque a caixa de seleção Para células vazias, mostrar. Na caixa, digite o valor que deseja exibir nas células vazias. Para exibir células em branco, exclua os caracteres da caixa. Para exibir zeros, desmarque a caixa de seleção.

Início da Página

Aplicável a: Excel 2007



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma