Exemplos de fórmulas comuns em Listas do SharePoint

Exemplos de fórmulas comuns em Listas do SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Usando fórmulas em colunas calculadas de uma biblioteca de lista ou SharePointSharePoint pode ajudar a adicionar a colunas existentes, como calcular o imposto em um preço. Elas podem ser combinadas para validar programaticamente os dados.

Ao inserir fórmulas, a menos que especificado em contrário, não há nenhum espaços entre palavras-chave e operadores. A seguir não é uma lista completa. Para exibir todas as fórmulas em SharePoint, consulte a lista em ordem alfabética no final deste artigo.

Observação : Campos calculados só podem operar em sua próprias linha, para que você não pode fazer referência a um valor em outra linha ou colunas contidas em outra lista ou biblioteca. Campos de pesquisa não são suportados em uma fórmula, e a ID da linha recém-inserida não pode ser usada como a ID não existe quando a fórmula é processada.

Você pode usar as fórmulas a seguir para testar a condição de uma instrução e retornar um valor Sim ou Não para testar um valor alternativo, como OK ou Não OK, ou para retornar um espaço em branco ou um traço para representar um valor nulo.

Verificar se um número é maior ou menor do que outro número

Use a função se para executar essa comparação.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

15000

9000

=[Coluna1] > [Coluna2]

A Coluna1 é maior do que a Coluna2? (Sim)

15000

9000

=SE([Coluna1]<=[Coluna2], "OK", "Não OK")

A Coluna1 é menor ou igual à Coluna2? (Não OK)

Retornar um valor lógico após a comparação do conteúdo das colunas

Para um resultado que é um uso de valor lógico (Sim ou não), as funções e, oue não .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=E([Coluna1]>[Coluna2], [Coluna1]<[Coluna3])

15 é maior do que 9 e menor do que 8? (Não)

15

9

8

=OU([Coluna1]>[Coluna2], [Coluna1]<[Coluna3])

15 é maior do que 9 ou menor do que 8? (Sim)

15

9

8

=NÃO([Coluna1]+[Coluna2]=24)

15 mais 9 não é igual a 24? (Não)

Para obter um resultado que seja outro cálculo ou qualquer outro valor diferente de Sim ou não, use as funções se, ee ou .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=SE([Coluna1]=15, "OK", "Não OK")

Se o valor na Coluna1 for igual a 15, retorne "OK". (OK)

15

9

8

=SE(E([Coluna1]>[Coluna2], [Coluna1]<[Coluna3]), "OK", "Não OK")

Se 15 for maior do que 9 e menor do que 8, retorne "OK". (Não OK)

15

9

8

=SE(OU([Coluna1]>[Coluna2], [Coluna1]<[Coluna3]), "OK", "Não OK")

Se 15 for maior do que 9 ou menor do que 8, retorne "OK". (OK)

Exibir zeros como espaços em branco ou como traços

Para exibir um zero, execute um cálculo simples. Para exibir um espaço em branco ou um traço, use a função se.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

10

= [Coluna1]-[Coluna2]

Segundo número subtraído do primeiro (0)

15

9

=SE([Coluna1]-[Coluna2],"-",[Coluna1]-[Coluna2])

Retorna um traço quando o valor é zero (-)

Ocultar valores de erro em colunas

Para exibir um traço, # n/d ou ND no lugar de um valor de erro, use a função ISERROR .

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

0

=[Coluna1]/[Coluna2]

Resulta em um erro (#DIV/0)

10

0

=SE(ÉERROS([Coluna1]/[Coluna2]),"NÃO.DISP",[Coluna1]/[Coluna2])

Retorna ND quando o valor é um erro

10

0

=SE(ÉERROS([Coluna1]/[Coluna2]),"-",[Coluna1]/[Coluna2])

Retorna um traço quando o valor é um erro

Verificar se há campos em branco

Você pode usar a fórmula ÉCÉL para localizar campos em branco.

Coluna1

Fórmula

Descrição (resultado possível)

"Jelly beans"

= ISBLANK([Column1]

Retorna se Sim ou não em branco ou não

"Aço"

= IF(ISBLANK([Column1]), "Não Okey", "Okey")

Preencha suas próprias opções, primeiro é se estiver vazio, segundo se não

Para funções é mais, consulte funções é.

Você pode usar as fórmulas a seguir para efetuar cálculos com base em datas e horas, como adicionar um número de dias, de meses ou de anos a uma data, calcular a diferença entre duas datas e conversão de tempo em um valor decimal.

Adicionar datas

Para adicionar um número de dias a uma data, use o operador de adição (+).

Observação : Quando você manipula datas, o tipo de retorno da coluna calculada deve ser definido como Data e Hora.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=[Coluna1]+[Coluna2]

Adiciona 3 dias a 9/6/2007 (12/6/2007)

10/12/2008

54

=[Coluna1]+[Coluna2]

Adiciona 54 dias a 10/12/2008 (2/2/2009)

Para adicionar um número de meses a uma data, use a Data, ano, mêse dia funções.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Adiciona 3 meses a 9/6/2007 (9/9/2007)

10/12/2008

25

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Adiciona 25 meses a 10/12/2008 (10/1/2011)

Para adicionar um número de anos a uma data, use a Data, ano, mêse dia funções.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

9/6/2007

3

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Adiciona 3 anos a 9/6/2007 (9/6/2010)

10/12/2008

25

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Adiciona 25 anos a 10/12/2008 (10/12/2033)

Para adicionar uma combinação de dias, meses e anos a uma data, use a Data, ano, mêse dia funções.

Coluna1

Fórmula

Descrição (resultado)

9/6/2007

=DATA(ANO([Coluna1])+3,MÊS([Coluna1])+1,DIA([Coluna1])+5)

Adiciona 3 anos, 1 mês e 5 dias a 9/6/2007 (14/7/2010)

10/12/2008

=DATA(ANO([Coluna1])+1,MÊS([Coluna1])+7,DIA([Coluna1])+5)

Adiciona 1 ano, 7 meses e 5 dias a 10/12/2008 (15/7/2010)

Calcular a diferença entre duas datas

Use a função DATADIF para executar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

01-Jan-1995

15-Jun-1999

=DATADIF([Coluna1], [Coluna2],"d")

Retorna o número de dias entre as duas datas (1626)

01-Jan-1995

15-Jun-1999

=DATADIF([Coluna1], [Coluna2],"am")

Retorna o número de meses entre as datas, ignorando a parte do ano (5)

01-Jan-1995

15-Jun-1999

=DATADIF([Coluna1], [Coluna2],"ad")

Retorna o número de dias entre as datas, ignorando a parte do ano (165)

Calcular a diferença entre dois horários

Para apresentar o resultado no formato de hora padrão (horas: minutos: segundos), use o operador de subtração (-) e a função texto . Para este método funcionar, horas não devem exceder 24 e minutos e segundos não devem exceder 60.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h")

Horas entre dois horários (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h:mm")

Horas e minutos entre dois horários (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTO([Coluna2]-[Coluna1],"h:mm:ss")

Horas, minutos e segundos entre dois horários (4:55:00)

Para apresentar o resultado em um total baseado em uma unidade de tempo, use a função INT ou hora, minutoou função segundo .

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*24)

Total de horas entre dois horários (28)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*1440)

Total de minutos entre dois horários (1735)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Coluna2]-[Coluna1])*86400)

Total de segundos entre dois horários (104100)

09/06/2007 10:35

10/06/2007 15:30

=HORA([Coluna2]-[Coluna1])

Horas entre dois horários, quando a diferença não exceder 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTO([Coluna2]-[Coluna1])

Minutos entre dois horários, quando a diferença não exceder 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SEGUNDO([Coluna2]-[Coluna1])

Segundos entre dois horários, quando a diferença não exceder 60 (0)

Converter horas

Para converter horas do formato de hora padrão para um número decimal, use a função INT .

Coluna1

Fórmula

Descrição (resultado)

10:35

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde 00:00 (10,583333)

12:15

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde 00:00 (12,25)

Para converter horas de número decimal para o formato de hora padrão (horas: minutos: segundos), use o operador de divisão e a função texto .

Coluna1

Fórmula

Descrição (resultado)

23:58

=TEXTO(Coluna1/24, "hh:mm:ss")

Horas, minutos e segundos desde 00:00 (00:59:55)

2:06

=TEXTO(Coluna1/24, "h:mm")

Horas e minutos desde 00:00 (0:05)

Inserir datas Julianas

Uma data Juliana se refere a um formato de data que é uma combinação do ano atual e o número de dias desde o início do ano. Por exemplo, 1º de janeiro de 2007 é representado como 2007001 e 31 de dezembro de 2007 é representado como 2007365. Esse formato não se baseia no calendário Juliano.

Para converter uma data em uma data do calendário juliano, use as funções texto e Data .

Coluna1

Fórmula

Descrição (resultado)

23/6/2007

=TEXTO([Coluna1],"yy")&TEXTO(([Coluna1]-VALORDATA("1/1/"& TEXTO([Coluna1],"yy"))+1),"000")

Data no formato Juliano, com um ano de dois dígitos (07174)

23/6/2007

=TEXTO([Coluna1],"yyyy")&TEXTO(([Coluna1]-VALORDATA("1/1/"&TEXT([Coluna1],"yy"))+1),"000")

Data no formato Juliano, com um ano de quatro dígitos (2007174)

Para converter uma data em uma data Juliana usada em astronomia, use a constante 2415018,50. Essa fórmula só funcionará para as datas depois de 1/3/1901 e se você estiver usando o sistema de datas de 1900.

Coluna1

Fórmula

Descrição (resultado)

23/6/2007

=[Coluna1]+2415018,50

Data no formato Juliano usado em astronomia (2454274,50)

Mostrar datas como o dia da semana

Para converter datas para o texto para o dia da semana, use as funções texto e dia .

Coluna1

Fórmula

Descrição (resultado possível)

19-Fev-2007

=TEXTO(DIA.DA.SEMANA([Coluna1]), "dddd")

Calcula o dia da semana da data e retorna o nome completo do dia (Segunda-feira)

3-Jan-2008

=TEXTO(DIA.DA.SEMANA([Coluna1]), "ddd")

Calcula o dia da semana da data e retorna o nome abreviado do dia (Qui)

Você pode usar as seguintes fórmulas para executar uma variedade de cálculos matemáticos, como a adição, a subtração, a multiplicação e a divisão de números, o cálculo da média ou da mediana dos números, o arredondamento de um número e a contagem de valores.

Adicionar números

Para adicionar números em duas ou mais colunas em uma linha, use o operador de adição (+) ou a função soma .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=[Coluna1]+[Coluna2]+[Coluna3]

Soma os valores das três primeiras colunas (15)

6

5

4

=SOMA([Coluna1],[Coluna2],[Coluna3])

Soma os valores das três primeiras colunas (15)

6

5

4

=SOMA(SE([Coluna1]>[Coluna2], [Coluna1]-[Coluna2], 10), [Coluna3])

Se a Coluna1 for maior do que a Coluna2, adiciona a diferença e a Coluna3. Caso contrário, adiciona 10 e a Coluna3 (5)

Subtrair números

Para subtrair números em duas ou mais colunas em uma linha, use o operador de subtração (-) ou a função soma com números negativos.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

15000

9000

-8000

= [Coluna1]-[Coluna2]

Subtrai 9.000 de 15.000 (6.000)

15000

9000

-8000

=SOMA([Coluna1], [Coluna2], [Coluna3])

Soma números das três primeiras colunas, incluindo os valores negativos (16000)

Calcular a diferença entre dois números como uma porcentagem

Use a subtração (-) e operadores de divisão (/) e a função ABS .

Coluna1

Coluna2

Fórmula

Descrição (resultado)

2342

2500

=([Coluna2]-[Coluna1])/ABS([Coluna1])

Alteração percentual (6,75% ou 0,06746)

Multiplicar números

Para multiplicar números em duas ou mais colunas em uma linha, use o operador de multiplicação (*) ou a função MULT .

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]*[Coluna2]

Multiplica os números nas duas primeiras colunas (10)

5

2

=PRODUTO([Coluna1], [Coluna2])

Multiplica os números nas duas primeiras colunas (10)

5

2

=PRODUTO([Coluna1], [Coluna2],2)

Multiplica os números nas duas primeiras colunas e o número 2 (20)

Dividir números

Para dividir os números de duas ou mais colunas em uma linha, use o operador de divisão (/).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

15000

12

=[Coluna1]/[Coluna2]

Divide 15000 por 12 (1250)

15000

12

=([Coluna1]+10000)/[Coluna2]

Soma 15000 e 10000 e então divide o total por 12 (2083)

Calcular a média de números

A média também é chamada a média. Para calcular a média dos números em duas ou mais colunas em uma linha, use a função média .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=MÉDIA([Coluna1], [Coluna2],[Coluna3])

Média dos números das três primeiras colunas (5)

6

5

4

=MÉDIA(SE([Coluna1]>[Coluna2], [Coluna1]-[Coluna2], 10), [Coluna3])

Se a Coluna1 for maior do que a Coluna2, calcula a média da diferença e a Coluna3. Caso contrário, calcula a média do valor 10 e a Coluna3 (2,5)

Calcular a mediana de números

A mediana é o valor no Centro de um intervalo ordenado de números. Use a função MED para calcular a mediana de um grupo de números.

A

B

C

D

E

F

Fórmula

Descrição (resultado)

10

7

9

27

0

4

=MED(A, B, C, D, E, F)

Mediana dos números das 6 primeiras colunas (8)

Calcular o menor ou o maior número em um intervalo

Para calcular o menor ou maior número em duas ou mais colunas em uma linha, use as funções mínimo e máximo .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

10

7

9

=MIN([Coluna1], [Coluna2], [Coluna3])

Menor número (7)

10

7

9

=MAX([Coluna1], [Coluna2], [Coluna3])

Maior número (10)

Contar valores

Para contar valores numéricos, use a função Cont .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Maçã

12/12/2007

=CONT.NÚM([Coluna1], [Coluna2], [Coluna3])

Conta o número de colunas que contêm valores numéricos. Exclui os valores de data e hora, de texto e nulos (0)

US$ 12

#DIV/0!

1,01

=CONT.NÚM([Coluna1], [Coluna2], [Coluna3])

Conta o número de colunas que contêm valores numéricos, mas exclui os valores de erro e lógicos (2)

Aumentar ou diminuir um número por uma porcentagem

Use o operador de porcentagem (%) para executar esse cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

23

3%

=[Coluna1]*(1+5%)

Aumenta o número na Coluna1 em 5% (24,15)

23

3%

=[Coluna1]*(1+[Coluna2])

Aumenta o número da Coluna1 pelo valor da porcentagem na Coluna2: 3% (23,69)

23

3%

=[Coluna1]*(1-[Coluna2])

Reduz o número da Coluna1 pelo valor da porcentagem na Coluna2: 3% (22,31)

Elevar um número a uma potência

Use o operador exponencial (^) ou a função potência para executar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]^[Coluna2]

Calcula cinco ao quadrado (25)

5

3

=POTÊNCIA([Coluna1], [Coluna2])

Calcula cinco ao cubo (125)

Arredondar um número

Para arredondar um número, use a função Arredondar, ímparou par .

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARREDONDAR.PARA.CIMA([Coluna1],0)

Arredonda 20,3 para cima até o número inteiro mais próximo (21)

-5,9

=ARREDONDAR.PARA.CIMA([Coluna1],0)

Arredonda -5,9 para cima até o número inteiro mais próximo (-5)

12,5493

=ARREDONDAR.PARA.CIMA([Coluna1],2)

Arredonda12,5493 para cima até o para o centésimo mais próximo, duas casas decimais (12,55)

20,3

=PAR([Coluna1])

Arredonda 20,3 para cima até o número par mais próximo (22)

20,3

=ÍMPAR([Coluna1])

Arredonda 20.3 para cima até o número ímpar mais próximo (21)

Para arredondar um número, use a função Arredondar .

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARREDONDAR.PARA.BAIXO([Coluna1],0)

Arredonda 20,3 para baixo até o número inteiro mais próximo (20)

-5,9

=ARREDONDAR.PARA.BAIXO([Coluna1],0)

Arredonda -5,9 para baixo até o número inteiro mais próximo (-6)

12,5493

=ARREDONDAR.PARA.BAIXO([Coluna1],2)

Arredonda 12,5493 para baixo até o para o centésimo mais próximo, duas casas decimais (12,54)

Para arredondar um número para o número ou fração mais próxima, use a função Arredondar .

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARRED([Coluna1],0)

Arredonda 20,3 para baixo, porque a parte fracionária é menor do que 0,5 (20)

5,9

=ARRED([Coluna1],0)

Arredonda 5,9 para cima, porque a parte fracionária é maior do que 0,5 (6)

-5,9

=ARRED([Coluna1],0)

Arredonda -5,9 para baixo, porque a parte fracionária é menor do que 0,5 (-6)

1,25

=ARRED([Coluna1], 1)

Arredonda o número para o décimo mais próximo (uma casa decimal). Como a parte a ser arredondada é 0,05 ou maior, o número é arredondado para cima (resultado: 1,3)

30,452

=ARRED([Coluna1], 2)

Arredonda o número para o centésimo mais próximo (duas casas decimais). Como a parte a ser arredondada, 0,002, é menor do que 0,005, o número é arredondado para baixo (resultado: 30,45)

Para arredondar um número para o dígito significativo acima de 0, use o Arredondar, arredondar.para.cima, arredondar.para.baixo, INTe funções NÚM. caract .

Coluna1

Fórmula

Descrição (resultado)

5492820

=ARRED([Coluna1],3-NÚM.CARACT(INT([Coluna1])))

Arredonda o número para 3 dígitos significativos (5490000)

22230

=ARREDONDAR.PARA.BAIXO([Coluna1],3-NÚM.CARACT(INT([Coluna1])))

Arredonda o número inferior para baixo em até 3 dígitos significativos (22200)

5492820

=ARREDONDAR.PARA.CIMA([Coluna1], 5-NÚM.CARACT(INT([Coluna1])))

Arredonda o número superior até 5 dígitos significativos (5492900)

Você pode usar as seguintes fórmulas para manipular o texto, como combinar ou concatenar os valores de várias colunas, comparar o conteúdo das colunas, remover caracteres ou espaços e repetir caracteres.

Alterar as maiúsculas e minúsculas do texto

Para alterar as maiusculas e minúsculas do texto, use a função de maiusculas, minúsculaou PRI .

Coluna1

Fórmula

Descrição (resultado)

clara Barbosa

=MAIÚSCULA([Coluna1])

Altera o texto para letras maiúsculas (CLARA BARBOSA)

clara Barbosa

=MINÚSCULA([Coluna1])

Altera o texto para letras minúsculas (clara barbosa)

clara Barbosa

=PRI.MAIÚSCULA([Coluna1])

Altera o texto para capitalização de título (Clara Barbosa)

Combinar nomes e sobrenomes

Para combinar nomes e sobrenomes, use o operador e comercial (&) ou a função concatenar .

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Carlos

Lima

=[Coluna1]&[Coluna2]

Combina as duas cadeias de caracteres (CarlosLima)

Carlos

Lima

=[Coluna1]&" "&[Coluna2]

Combina as duas cadeias de caracteres, separadas por um espaço (Carlos Lima)

Carlos

Lima

=[Coluna2]&", "&[Coluna1]

Combina as duas cadeias de caracteres, separadas por um espaço (Lima, Carlos)

Carlos

Lima

=CONCATENAR([Coluna2], ",", [Coluna1])

Combina as duas cadeias de caracteres, separadas por uma vírgula (Lima, Carlos)

Combinar texto e números de colunas diferentes

Para combinar texto e números, use a função concatenar , o operador e comercial (&), ou a função texto e o operador e comercial.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Davi

28

=[Coluna1]&" vendeu "&[Coluna2]&" unidades."

Combina o conteúdo acima em uma frase (Davi vendeu 28 unidades).

Barros

40%

=[Coluna1]&" vendeu "&TEXTO([Coluna2],"0%")&" do total de vendas."

Combina o conteúdo acima em uma frase (Barros vendeu 40% do total de vendas.)

Observação : A função TEXTO anexa o valor formatado da Coluna2 em vez do valor subjacente, que é 0,4.

Davi

28

=CONCATENAR([Coluna1]," vendeu ",[Coluna2]," unidades.")

Combina o conteúdo acima em uma frase (Davi vendeu 28 unidades).

Combinar texto com uma data ou hora

Para combinar texto com uma data ou hora, use a função texto e o operador e comercial (&).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Data da Cobrança

5-Jun-2007

="Data do demonstrativo: "&TEXTO([Coluna2], "d-mmm-aaaa")

Combina texto com uma data (Data do demonstrativo: 5-Jun-2007)

Data da Cobrança

5-Jun-2007

=[Coluna1]&" "&TEXTO([Coluna2], "mmm-dd-aaaa")

Combina texto e data de colunas diferentes em uma coluna (Data da Cobrança 05-Jun-2007)

Comparar o conteúdo das colunas

Para comparar uma coluna para outra coluna ou uma lista de valores, use as funções exato e ou .

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

BD122

BD123

=EXATO([Coluna1],[Coluna2])

Compara o conteúdo das duas primeiras colunas (Não)

BD122

BD123

=EXATO([Coluna1], "BD122")

Compara o conteúdo da Coluna1 e da cadeia de caracteres "BD122" (Sim)

Verificar se um valor da coluna ou se uma parte dela corresponde a um texto específico

Para verificar se um valor de coluna ou parte dela corresponde a um texto específico, use as funções se, Localizar, pesquisae ÉNÚM .

Coluna1

Fórmula

Descrição (resultado possível)

Barbosa

=SE([Coluna1]="Barbosa", "OK", "Não OK")

Verifica se a Coluna1 é Barbosa (OK)

Barbosa

=SE(ÉNÚM(PROCURAR("v",[Coluna1])), "OK", "Não OK")

Verifica se a Coluna1 contém a letra v (OK)

BD123

=ÉNÚM(PROCURAR("BD",[Coluna1]))

Verifica se a Coluna1 contém BD (Sim)

Contar as colunas não vazias

Para contar colunas vazias, use a função Cont .

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Vendas

19

=CONT.VALORES([Coluna1], [Coluna2])

Conta o número de colunas não vazias (2)

Vendas

19

=CONT.VALORES([Coluna1], [Coluna2], [Coluna3])

Conta o número de colunas não vazias (2)

Remover caracteres de texto

Para remover caracteres de texto, use as funções Núm. caract, esquerdae direita .

Coluna1

Fórmula

Descrição (resultado)

Vitamina A

=ESQUERDA([Coluna1],NÚM.CARACT([Coluna1])-2)

Retorna 7 (9-2) caracteres, iniciando da esquerda (Vitamina)

Vitamina B1

=DIREITA([Coluna1], NÚM.CARACT([Coluna1])-8)

Retorna 2 (10-8) caracteres, iniciando da direita (B1)

Remover espaços à esquerda do início e do final de uma coluna

Para remover espaços de uma coluna, use a função ARRUMAR .

Coluna1

Fórmula

Descrição (resultado)

 Olá!

=ARRUMAR([Column1])

Remove os espaços do início e do final (Olá!)

Repetir um caractere em uma coluna

Para repetir um caractere em uma coluna, use a função REPT .

Fórmula

Descrição (resultado)

=REPT(".",3)

Repete um ponto 3 vezes (…)

=REPT("-";10)

Repete um traço 10 vezes (---------)

Lista em ordem alfabética de funções

A seguir está uma lista de links para as funções disponíveis para usuários SharePoint. Ele inclui trigonomic, estatística e funções financeiras, bem como condicional, fórmulas de data, matemática e texto.

Função ABS

Função ACOS

Função ACOSH

Função ACOSH

Função e

Função ASEN

Função ASENH

Função ATAN

Função ATAN2

Função média

Função MÉDIAA

Função DISTBETA

Função beta.ACUM.Inv

Função DISTRBINOM

Função teto

Função CARACT

Função DIST.

Função escolher

Função código

Função concatenar

Função INT.

Função COS

Função CONT.

Função CONT.

Função CRIT.

Função data

Função DATADIF

Função DATEVALUE

Função dia

Função DIAS360

Função BDD

Função graus

Função moeda

Função par

Função exato

Função DISTEXPON

Função fatorial

Função DISTF

Função FIND

Função INVF

Função FISHER

Função fixo

Função DISTGAMA

Função INVGAMA

Função LNGAMA

Função média.

Função média.

Função HOUR

Função DIST.

Função se

Função INT

Função IPGTO

Funções é

Função LEFT

Função LEN

Função LN

Função log

Função LOG10

Função INVLOG

Função DIST.

Função minúscula

Função máximo

Função eu

Função MED

Função MID

Função mínimo

Função MÍNIMOA

Função minuto

Função MOD

Função mês

Função DIST.

Função DIST.

Função DIST.

Função INV.

Função não

Função NPER

Função VPL

Função VPL

Função ímpar

Função ou

Função PGTO

Função potência

Função PPGTO

Função MULT

Função PRI.

Função VP

Função radianos

Função REPLACE

Função REPT

Função RIGHT

Função ARRED

Função arredondar.para.baixo

Função arredondar.para.cima

Função de pesquisa

Função segundo

Função sinal

Função SEN

Função SENH

Função raiz

Função padronizar

Função DESVPADA

Função DESVPADP

Função DESVPADPA

Função soma

Função SOMAQUAD

Função SDA

Função TANH

Função DISTT

Função texto

Função TIME

Função INVT

Função hoje

Função ARRUMAR

Função VERDADEIRO

Função VERDADEIRO

Função maiuscula

Função moeda

Função valor

Função VAR

Função VARA

Função VARP

Função VARPA

Função Weekday

Função WEIBULL

Função ano

Outros recursos

Se você não vir o que você está tentando fazer aqui, veja se você pode fazê-lo no Excel ou examinar os filtros da Web Part. Aqui estão algumas fontes adicionais. Alguns desses podem cobrir versões mais antigas, portanto pode haver diferenças na interface do usuário mostrado. Por exemplo, itens no menu Ações do Site no SharePoint 2010 agora estão no menu de botão de configuração do office 365 - se parece com uma engrenagem, próximo ao seu nome configurações.

Há muitos outros recursos na web que você pode pesquisar, como como campos calculados do código de cor.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×