Exemplos de fórmulas comuns

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode utilizar os seguintes exemplos nas colunas calculadas de uma lista ou biblioteca. Exemplos que não incluam referências de coluna podem ser usados para especificar o valor padrão de uma coluna.

Neste artigo

Fórmulas condicionais

Fórmulas de data e hora

Fórmulas matemáticas

Fórmulas de texto

Fórmulas condicionais

Você pode utilizar as seguintes fórmulas para testar a condição de uma declaração e retornar um valor de Sim ou Não, a fim de testar um valor alternativo, tal como OK ou Não OK ou para retornar um espaço em branco ou traço para representar um valor nulo.

Verificar se um número é maior ou menor do que outro número

Use a função SE para realizar essa comparação.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

15000

9000

=[Coluna1]>[Coluna2]

A Coluna1 é maior que a Coluna2? (Sim)

15000

9000

=SE([Coluna1]<=[Coluna2], "OK", "Não OK")

A Coluna1 é menor que ou igual à Coluna2? (Não OK)

Retornar um valor lógico após a comparação do conteúdo das colunas

Para um resultado que seja um valor lógico (Sim ou Não), use as funções E, OU e NÃO.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=E([Coluna1]>[Coluna2], [Coluna1]<[Coluna3])

15 é maior que 9 e menor que 8? (Não)

15

9

8

=OU([Coluna1]>[Coluna2], [Coluna1]<[Coluna3])

15 é maior que 9 ou menor que 8? (Sim)

15

9

8

=NÃO([Coluna1]+[Coluna2]=24)

15 mais 9 não é igual a 24? (Não)

Para um resultado que seja outro cálculo ou qualquer outro valor diferente de Sim ou Não, use as funções SE, E e OU.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado possível)

15

9

8

=SE[Coluna1]=15, "OK", "Não OK")

Se o valor na Coluna1 for igual a 15, então retorna "OK". (OK)

15

9

8

=SE(E([Coluna1]>[Coluna2], [Coluna1]<[Coluna3]), "OK", "Não OK")

Se 15 for maior que 9 e menor que 8, então retorna "OK". (Não OK)

15

9

8

=SE(OU([Coluna1]>[Coluna2], [Coluna1]<[Coluna3]), "OK", "Não OK")

Se 15 for maior que 9 ou menor que 8, então retorna "OK". (OK)

Exibir zeros como espaços em branco ou como traços

Para exibir um zero, execute um cálculo simples. Para exibir um espaço em branco ou traço, use a função SE.

C oluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

10

=[Coluna1]-[Coluna2]

Segundo número subtraído do primeiro (0)

15

9

=SE([Coluna1]-[Coluna2],"-",[Coluna1]-[Coluna2])

Retorna um traço quando o valor for zero (-)

Ocultar valores de erro em colunas

Para exibir um traço, #N/D ou ND no lugar de um erro de valor, use a função ÉERROS.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

10

0

=[Coluna1]/[Coluna2]

Resulta em um erro (#DIV/0)

10

0

=SE(ÉERROS([Coluna1]/[Coluna2]),"ND",[Coluna1]/[Coluna2])

Retorna ND quando o valor for um erro

10

0

=SE(ÉERROS([Coluna1]/[Coluna2]),"-",[Coluna1]/[Coluna2])

Retorna um traço quando o valor for um erro

Início da página

Fórmulas de data e hora

Você pode utilizar as seguintes fórmulas para realizar cálculos que estejam baseados em datas e hors, calculando a diferença entre duas datas e convertendo a hora em um valor decimal.

Adicionar datas

Para adicionar um número de dias a uma data, use o operador de soma (+).

Observação : Ao manipular datas, o tipo de retorno da coluna calculada deve ser definido para Data e Hora.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007

3

=[Coluna1]+[Coluna2]

Adiciona 3 dias a 09.06.07 (12.06.07)

10.12.08

54

=[Coluna1]+[Coluna2]

Adiciona 54 dias a 10.12.08 (02.02.09)

Para adicionar um número de meses a uma data, use as funções DATA, ANO, MÊS e DIA.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007

3

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Adiciona 3 meses a 09.06.07 (09.09.07)

10.12.08

25

=DATA(ANO([Coluna1]),MÊS([Coluna1])+[Coluna2],DIA([Coluna1]))

Adiciona 25 meses a 10.12.08 (10.01.11)

Para adicionar um número de anos a uma data, use as funções DATA, ANO, MÊS e DIA.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09/06/2007

3

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Adiciona 3 anos a 09.06.07 (09.06.10)

10.12.08

25

=DATA(ANO([Coluna1])+[Coluna2],MÊS([Coluna1]),DIA([Coluna1]))

Adiciona 25 anos a 10.12.08 (10.12.33)

Para adicionar uma combinação de dias, meses e anos a uma data, use as funções DATA, ANO, MÊS e DIA.

Coluna1

Fórmula

Descrição (resultado)

09.06.07

=DATA(ANO([Coluna1])+3,MÊS([Coluna1])+1,DIA([Coluna1])+5)

Adiciona 3 anos, 1 mês e 5 dias a 09.06.07 (14.07.2010)

10.12.08

=DATA(ANO([Coluna1])+1,MÊS([Coluna1])+7,DIA([Coluna1])+5)

Adiciona 1 ano, 7 meses e 5 dias a 10.12.2008 (15.07.2010)

Calcular a diferença entre duas datas

Use a função DATADIF para realizar esse cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

01.01.95

15.06.99

=DATADIF([Coluna1], [Coluna2],"d")

Retorna o número de dias entre duas datas (1626)

01.01.95

15.06.99

=DATADIF([Coluna1], [Coluna2],"am")

Retorna o número de meses entre as datas, ignorando a parte do ano (5)

01.01.95

15.06.99

=DATADIF([Coluna1], [Coluna2],"ad")

Retorna o número de dias entre as datas, ignorando a parte do ano (165)

Calcular a diferença entre dois horários

Para apresentar o resultado em um formato de hora padrão (horas:minutos:segundos), use o operação de subtração (-) e a função TEXTO. Para que esse método funcione, as horas não devem exceder 24 e os minutos e segundos não devem exceder 60.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09.06.07 10:35

09.06.07 15:30:00

=TEXTO([Coluna2]-[Coluna1],"h")

Horas entre duas linhas (4)

09.06.07 10:35

09.06.07 15:30:00

=TEXTO([Coluna2]-[Coluna1],"mm")

Horas e minutos entre duas linhas (4:55)

09.06.07 10:35

09.06.07 15:30:00

=TEXTO([Coluna2]-[Coluna1],"ss")

Horas, minutos e segundos entre duas linhas (4:55:00)

Para apresentar o resultado em um total que seja baseado em uma unidade de hora, use a função INT ou HORA, MINUTO ou SEGUNDO.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

09.06.07 10:35

10.06.07 15:30:00

=INT(([Coluna2]-[Coluna1])*24)

Total de horas entre duas linhas (28)

09.06.07 10:35

10.06.07 15:30:00

=INT(([Coluna2]-[Coluna1])*1440)

Total de minutos entre duas linhas (1735)

09.06.07 10:35

10.06.07 15:30:00

=INT(([Coluna2]-[Coluna1])*86400)

Total de segundos entre duas linhas (104100)

09.06.07 10:35

10.06.07 15:30:00

=HORA(([Coluna2]-[Coluna1])*24)

Horas entre dois horários, quando a diferença não exceder 24 (4)

09.06.07 10:35

10.06.07 15:30:00

=MINUTO(([Coluna2]-[Coluna1])*24)

Minutos entre dois horários, quando a diferença não exceder 60 (55)

09.06.07 10:35

10.06.07 15:30:00

=SEGUNDO(([Coluna2]-[Coluna1])*24)

Segundos entre dois horários, quando a diferença não exceder 60 (0)

Converter horas

Para converter horas a partir do formato padrão de horário para um número decimal, utilize a função INT.

Coluna1

Fórmula

Descrição (resultado)

10:35

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde 12:00 (10.583333)

24:15

=([Coluna1]-INT([Coluna1]))*24

Número de horas desde 12:00 (12,25)

Para converter horas a partir de um número decimal para o formato padrão de hora (horas:minutos:segundos), use o operador de divisão e a função TEXTO.

Coluna1

Fórmula

Descrição (resultado)

23:58

=TEXTO(Coluna1/24, "hh:mm:ss")

Horas, minutos e segundos desde 24:00 (00:59:55)

2:06

=TEXTO(Coluna1/24, "h:mm")

Horas e minutos desde 12:00 (0:05)

Inserir datas Julianas

Uma data juliana refere-se a um formato de data que é uma combinação do ano atual e o número de dias desde o início do ano. Por exemplo, 1º de janeiro de 2007 é representado como 2007001 e 31 de dezembro de 2007 é representado como 2007356. Esse formato não é baseado no calendário juliano.

Para converter uma data em uma data Juliana, use as funções TEXTO e DATA.VALOR.

Coluna1

Fórmula

Descrição (resultado)

23.06.07

=TEXTO([Coluna1],"aa")&TEXTO(([Coluna1]-DATA.VALOR("1/1/"& TEXTO([Coluna1],"aa"))+1),"000")

Data no formato Juliano, com ano em dois dígitos (07174)

23.06.07

=TEXTO([Coluna1],"aaaa")&TEXTO(([Coluna1]-DATA.VALOR("1/1/"&TEXT([Coluna1],"aa"))+1),"000")

Data no formato Juliano, com ano em quatro dígitos (2007174)

Para converter uma data para uma data Juliana utilizada em astronomia, use a constante 2415018.50. Essa fórmula somente funciona para datas após 01.03.1901 e se você estiver utilizando o sistema de data de 1900.

Coluna1

Fórmula

Descrição (resultado)

23.06.07

=[Coluna1]+2415018.50

Data no formato Juliano, usado em astronomia (2454274.50)

Mostrar datas como o dia da semana

Para converter datas ao texto do dia da semana, utilize as funções TEXTO e DIA.DA.SEMANA.

Coluna1

Fórmula

Descrição (resultado possível)

19.02.07

=TEXTO(DIA.DA.SEMANA([Coluna1]), "dddd")

Calcula o dia da semana para a data e retorna o nome completo do dia (Segunda)

03.01.08

=TEXTO(DIA.DA.SEMANA([Coluna1]), "ddd")

Calcula o dia da semana para a data e retorna o nome abreviado do dia (Qui)

Início da página

Fórmulas matemáticas

Você pode utilizar as seguintes fórmulas para executar uma variedade de cálculos matemáticos, tais como números de adição, subtração, multiplicação e divisão, calcular a média ou mediana de números, arredondar números e contar valores.

Adicionar números

Para adicionar números em duas ou mais colunas em uma linha, use o operador de adição (+) ou a função SOMA.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=[Coluna1]+[Coluna2]+[Column3]

Adiciona os valores nas primeiras três colunas (15)

6

5

4

=SOMA([Coluna1],[Coluna2],[Coluna3])

Adiciona os valores nas primeiras três colunas (15)

6

5

4

=SOMA(SE([Coluna1]>[Coluna2], [Coluna1]-[Coluna2], 10), [Coluna3])

Se a Coluna1 for maior que a Coluna2, adiciona a diferença e a Coluna3. Caso contrário, adicione 10 e a Coluna3 (5)

Subtrair números

Para subtrair números em duas ou mais colunas em uma linha, use o operador de subtração (-) ou a função SOMA com números negativos.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

15000

9000

-8.000

=[Coluna1]-[Coluna2]

Subtrai 9.000 de 15.000 (6.000)

15000

9000

-8.000

=SOMA([Coluna1],[Coluna2],[Coluna3])

Adiciona números nas três primeiras colunas, incluindo valores negativos (16.000)

Calcular a diferença entre dois números como uma porcentagem

Use os operadores de subtração (-) e divisão (/) e a função ABS.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

2342

2500

=([Coluna2]-[Coluna1])/ABS([Coluna1])

Alteração de percentual (6,75% ou 0,06746)

Multiplicar números

Para multiplicar números em duas ou mais colunas em uma linha, use o operador de multiplicação (*) ou a função MULT.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]*[Coluna2]

Multiplica os números nas primeiras duas colunas (10)

5

2

=MULT([Coluna1], [Coluna2])

Multiplica os números nas primeiras duas colunas (10)

5

2

=MULT([Coluna1], [Coluna2],2)

Multiplica os números nas primeiras duas colunas e o número 2 (20)

Dividir números

Para dividir números em duas ou mais colunas em uma linha, use o operador de divisão (/).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

15000

12

=[Coluna1]/[Coluna2]

Divide 15.000 por 12 (1250)

15000

12

=([Coluna1]+10.000)/[Coluna2]

Adiciona 15.000 e 10.000, e em seguida divide o total por 12 (2083)

Calcular a média de números

A média é também conhecida como mediana. Para calcular a média dos números em duas ou mais colunas em uma linha, use a função MÉDIA.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

6

5

4

=MÉDIA([Coluna1],[Coluna2],[Coluna3])

Média dos números nas primeiras três colunas (5)

6

5

4

=MÉDIA(SE([Coluna1]>[Coluna2], [Coluna1]-[Coluna2], 10), [Coluna3])

Se a Coluna1 for maior que a Coluna2, calcular a médida da diferença e a Coluna3. Caso contrário, calcule a média do valor 10 e a Coluna3 (2,5)

Calcular a mediana de números

A mediana é o valor no centro de um intervalo ordenado de números. Use a função MEDIANA para calcular a mediana de um grupo de números.

A

B

C

D

E

F

Fórmula

Descrição (resultado)

10

7

9

27

0

4

=MEDIANA(A, B, C, D, E, F)

Median of numbers in the first 6 columns (8)

Calcular o menor ou o maior número em um intervalo

Para calcular o menor ou maior número em duas ou mais colunas em uma linha, use as funções MÍN. e MÁX..

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

10

7

9

=MÍN.([Coluna1],[Coluna2],[Coluna3])

Menor número (7)

10

7

9

=MÁX.([Coluna1],[Coluna2],[Coluna3])

Maior número (10)

Contar valores

Para contar valores numéricos, use a função CONT.NÚM.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Maçã

12.12.07

=CONT.NÚM([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas que contêm valores numéricos. Exclui datas e horas, texto e valores nulos (0)

R$ 12

#DIV/0!

1,01

=CONT.NÚM([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas que contêm valores numéricos, mas exclui valores de erro e lógicos (2)

Aumentar ou diminuir um número por uma porcentagem

Use o operador de percentual % para realizar esse cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

23

3%

=[Coluna1]*(1+5%)

Aumenta o número na Coluna1 por 5% (24,15)

23

3%

=[Coluna1]*(1+[Coluna2])

Aumenta o número na Coluna1 pelo valor de percentual na Coluna2: 3% (23,69)

23

3%

=[Coluna1]*(1-[Coluna2])

Diminui o número na Coluna1 pelo valor de percentual na Coluna2: 3% (22,31)

Elevar um número a uma potência

Use o operador de exponenciação (^) ou a função POTÊNCIA para executar este cálculo.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

5

2

=[Coluna1]^[Coluna2]

Calcula cinco ao quadradro (25)

5

3

=POTÊNCIA([Coluna1], [Coluna2])

Calcula cinco ao cubo (125)

Arredondar um número

Para arredondar um número para mais, use a função round up a number, use the ARREDONDAR.PARA.CIMA, ÍMPAR ou PAR.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARREDONDAR.PARA.CIMA([Coluna1],0)

Arredonda 20,3 para cima até o próximo número inteiro (21)

-5,9

=ARREDONDAR.PARA.CIMA([Coluna1],0)

Arredonda -5,9 para cima até o próximo número inteiro (-5)

12,5493

=ARREDONDAR.PARA.CIMA([Coluna1],2)

Arredonda 12,5493 para cima até o próximo centésimo, duas casas decimais (12,55)

20,3

=PAR([Coluna1])

Arredonda 20,3 para cima até o próximo número par (22)

20,3

=ÍMPAR([Coluna1])

Arredonda 20,3 para cima até o próximo número ímpar (21)

Para arredondar um número para abixo, use a função ARREDONDAR.PARA.BAIXO.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARREDONDAR.PARA.BAIXO([Coluna1],0)

Arredonda 20,3 para baixo até o próximo número inteiro (20)

-5,9

=ARREDONDAR.PARA.BAIXO([Coluna1],0)

Arredonda -5,9 para baixo até o próximo número inteiro (-6)

12,5493

=ARREDONDAR.PARA.BAIXO([Coluna1],2)

Arredonda 12,5493 para cima até o próximo centésimo, duas casas decimais (12,54)

Para arredondar um número para o próximo número ou fração, use a função ARRED.

Coluna1

Fórmula

Descrição (resultado)

20,3

=ARRED([Coluna1],0)

Arredonda 20,3 para baixo, pois a parte de fração é inferior a 0,5 (20)

5,9

=ARRED([Coluna1],0)

Arredonda 5,9 para cima, pois a parte de fração é maior que 0,5 (6)

-5,9

=ARRED([Coluna1],0)

Arredonda -5,9 para baixo, pois a parte de fração é inferior a -0,5 (-6)

1,25

=ARRED([Coluna1], 1)

Arredonda o número ao próximo décimo (uma casa decimal), pois a porção a ser arredondada é 0,05 ou maior, o número é arredondado para cima (resultado: 1,3)

30,452

=ARRED([Coluna1], 2)

Arredonda o número ao próximo centésimo (duas casas decimais), pois a porção a ser arredondada é 0,002 ou menor que 0,005, o número é arredondado para baixo (resultado: 30,45)

Para arredondar um número para o dígito significativo acima de 0, use as funções ARRED, round a number to the significant digit above 0, use the ROUND, ARREDONDAR.PARA.CIMA, ARREDONDAR.PARA.BAIXO, INT e NÚM.CARACT.

Coluna1

Fórmula

Descrição (resultado)

5492820

=ARRED([Coluna1],3-NÚM.CARACT(INT([Coluna1])))

Arredonda o número para 3 dígitos significativos (5490000)

22230

=ARREDONDAR.PARA.BAIXO,([Coluna1],3-NÚM.CARACT(INT([Coluna1])))

Arredonda o número inferior para baixo até 3 dígitos significativos (22200)

5492820

=ARREDONDAR.PARA.CIMA([Coluna1]5-NÚM.CARACT(INT([Coluna1])))

Arredonda o número superior para cima até 5 dígitos significativos (5492900)

Início da página

Fórmulas de texto

Você pode utilizar as seguintes fórmulas par manipular texto, como combinar ou concatenar os valores de várias colunas, comparando o conteúdo das colunas, removendo caracteres ou espaços e repetindo caracteres.

Alterar as maiúsculas e minúsculas do texto

Para alterar o texto de maiúscula para minúscula ou vice-versa, use a função MAIÚSCULA, MINÚSCULA ou PRI.MAIÚSCULA.

Coluna1

Fórmula

Descrição (resultado)

joana Silva

=MAIÚSCULA([Coluna1])

Altera o texto para maiúscula (JOANA SILVA)

joana Silva

=MINÚSCULA([Coluna1])

Altera o texto para minúscula (joana silva)

joana Silva

=PRI.MAIÚSCULA([Coluna1])

Altera o texto para primeira letra de cada palavra em maiúscula (Joana Silva)

Combinar nomes e sobrenomes

Para combinar nomes e sobrenomes, use o operador ampersand (&) ou a função CONCATENAR.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Carlos

Carvalho

=[Coluna1]&[Coluna2]

Combina as duas seqüências de texto (CarlosCarvalho)

Carlos

Carvalho

=[Coluna1]&" "&[Coluna2]

Combina as duas seqüências, separadas por um espaço (Carlos Carvalho)

Carlos

Carvalho

=[Coluna2]&", "&[Coluna1]

Combina as duas seqüências, separadas por uma vírgula e um espaço (Carvalho, Carlos)

Carlos

Carvalho

=CONCATENAR([Coluna2], ",", [Coluna1])

Combina as duas seqüências separadas por uma vírgula (Carvalho, Carlos

Combinar texto e números de colunas diferentes

Para combinar texto e números, use a função CONCATENAR, o operador ampersand (&) ou a função TEXTO e o operador ampersand.

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Jorge

28

=[Coluna1]&" vendeu "&[Coluna2]&" unidades."

Combina o conteúdo acima em uma frase (Jorge vendeu 28 unidades.)

Santos

40%

=[Coluna1]&" vendeu "&TEXTO([Coluna2],"0%")&" do total de vendas."

Combina o conteúdo acima em uma frase (Santos vendeu 40% do total de vendas.)

Observação : A função TEXTO anexa o valor formatado da Coluna2 em vez de o valor subjacente, que é 0,4.

Jorge

28

=CONCATENAR([Coluna1]," vendeu ",[Coluna2]," unidades.")

Combina o conteúdo acima em uma frase (Jorge vendeu 28 unidades.)

Combinar texto com uma data ou hora

Para combinar texto com uma data ou hora, use a função TEXTO e o operador ampersand (&).

Coluna1

Coluna2

Fórmula

Descrição (resultado)

Data de cobrança

05.06.07

="Data de declaração: "&TEXTO([Coluna2], "d-mmm-aaaa")

Combina texto com uma data (Data de declaração: 05.06.07)

Data de faturamento

05.06.07

=[Coluna1]&" "&TEXTO([Coluna2], "mmm-dd-aaaa")

Combinar texto e data de diferentes colunas em uma coluna (Data de faturamento 05.06.07)

Comparar o conteúdo das colunas

Para comparar uma coluna com outra ou uma lista de valores, use as funções EXATO e OU.

Coluna1

Coluna2

Fórmula

Descrição (resultado possível)

BD122

BD123

=EXATO([Coluna1], [Coluna2])

Compara o conteúdo das duas primeiras colunas (Não)

BD122

BD123

=EXATO([Coluna1], "BD122")

Compara o conteúdo da Coluna1 e a seqüência "BD122" (Sim)

Verificar se um valor da coluna ou se uma parte dela corresponde a um texto específico

Para verificar se um valor de coluna ou uma parte dela corresponde a texto específico, use as funções SE, PROCURAR, LOCALIZAR e ÉNÚM.

Coluna1

Fórmula

Descrição (resultado possível)

Silva

=SE[Coluna1]="Silva", "OK", "Não OK")

Verifica se a Coluna1 é Silva (OK)

Silva

=SE(ÉNÚM(PROCURAR("s",[Coluna1])), "OK", "Não OK")

Verifica se a Coluna1 cntém a letra s (OK)

BD123

=ÉNÚM(PROCURAR("BD",[Coluna1]))

Verifica se a Coluna1 contém BD (Sim)

Contar as colunas não vazias

Para contar colunas que não estejam em branco, use a função CONTA.

Coluna1

Coluna2

Coluna3

Fórmula

Descrição (resultado)

Vendas

19

=CONTA([Coluna1], [Coluna2])

Conta o número de colunas que não estejam em branco (2)

Vendas

19

=CONTA([Coluna1],[Coluna2],[Coluna3])

Conta o número de colunas que não estejam em branco (2)

Remover caracteres de texto

Para remover caracteres do texto, use as funções NÚM.CARACT, ESQUERDA e DIREITA.

Coluna1

Fórmula

Descrição (resultado)

Vitamina A

=ESQUERDA([Coluna1],NÚM.CARACT([Coluna1])-2)

Retorna 7 (9-2) caracteres, iniciando da esquerda (Vitamina)

Vitamina B1

=DIREITA([Coluna1],NÚM.CARACT([Coluna1])-8)

Retorna 2 (10-8) caracteres, iniciando da direita (B1)

Remover espaços à esquerda do início e do final de uma coluna

Para remover espaços de uma coluna, use a função ARRUMAR.

Coluna1

Fórmula

Descrição (resultado)

Olá a todos!

=ARRUMAR([Coluna1])

Remove os espaços do início e do fim (Olá a todos!)

Repetir um caractere em uma coluna

Para repetir um caractere em uma coluna, use a função REPT.

Fórmula

Descrição (resultado)

=REPT(".".3)

Repete um ponto 3 vezes (...)

=REPT("-";10)

Repete um traço 10 vezes (----------)

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×