Executar uma animação do Adobe Macromedia Flash em uma apresentação

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Se você tiver um gráfico animado que foi criado usando o Adobe Macromedia Flash e salvo como um arquivo Shockwave com uma extensão. SWF, você pode reproduzir o arquivo em uma apresentação do PowerPoint.

Você pode adicionar um arquivo Flash a uma apresentação no PowerPoint 2010 e posteriores pela incorporação ou vinculando o arquivo em um slide.

Observações : 

  • Pode haver algumas limitações ao usar o Flash no PowerPoint, incluindo a impossibilidade de usar efeitos especiais (como sombras, reflexos, efeitos de brilho, bordas suaves, biséis e rotação 3D), o esmaecimento e arrumar recursos e a capacidade para compactar esses arquivos para facilitar o compartilhamento e de distribuição.

  • A versão do PowerPoint 2010 64 bits não é compatível com as versões de 32 bits do QuickTime ou Flash. Você deve instalar uma versão de 64 bits do QuickTime ou Flash ou uma versão de 32 bits do PowerPoint 2010.

Inserir um arquivo Flash

  1. No modo de exibição Normal, clique no slide no qual você deseja inserir um vídeo.

  2. Na guia Inserir, no grupo mídia, clique na seta sob vídeo e clique em vídeo em meu PC ou vídeo de arquivo.

  3. Na caixa de diálogo Inserir vídeo, localize e clique no vídeo que você deseja inserir e, em seguida, clique em Inserir.

  4. Para visualizar a animação Flash, clique em Executar na guia Formatar de ferramentas de vídeo.

Link para um arquivo Flash

  1. Na guia Slides no modo de exibição Normal, clique no slide ao qual você deseja adicionar um arquivo de vídeo ou de GIF animado.

  2. Na guia Inserir, no grupo Mídia, clique na seta abaixo de Vídeo.

  3. Clique em vídeo em meu PC ou vídeo de arquivo, localize e clique no arquivo que você deseja vincular.

  4. No botão Inserir, clique na seta para baixo e depois clique em Vincular ao arquivo.

    Importante : Para evitar possíveis problemas com links desfeitos, é uma boa ideia copiar os vídeos na mesma pasta da sua apresentação e fazer a vinculação com eles lá.

  5. Para visualizar a animação Flash, clique em Executar na guia Formatar de ferramentas de vídeo.

Para adicionar um arquivo. SWF no PowerPoint 2007, você usar o controle ActiveX chamado Shockwave Flash Object e Adobe Macromedia Flash Player. Para reproduzir o arquivo Flash, adicione um controle ActiveX ao slide e criar um link dele para o arquivo Flash.

As configurações de segurança do controle ActiveX estão localizadas na Central de Confiabilidade, onde você pode encontrar configurações de segurança e privacidade para os programas do 2007 Microsoft Office system. Talvez seja preciso ajustar suas configurações de segurança para permitir que os controles ActiveX sejam executados. As configurações do ActiveX na Central de Confiabilidade se aplicam a todos os produtos da versão do Office 2007. Por exemplo, se você alterar uma configuração no PowerPoint, essa configuração também será alterada em outros programas do Office que usam a Central de Confiabilidade. Para obter mais informações sobre os controles ActiveX e sobre como alterar as configurações, consulte Habilitar ou desabilitar os controles ActiveX em documentos do Office.

Importante : 

  • O Shockwave Flash Object deve ser registrado no seu computador para poder reproduzir o arquivo Flash dentro de uma apresentação. Para ver se está registrado Shockwave Flash Object, na guia desenvolvedor, no grupo controles, clique em Mais controles Imagem do botão . Se o Shockwave Flash Object aparecer na lista de controles, ele é registrado no seu computador. Se não estiver registrado, Baixe a versão mais recente do Flash Player da Web Adobe sites para registrar o Shockwave Flash Object em seu computador.

  • Para garantir que animações complexas sejam executadas corretamente, instale a versão mais recente do Flash Player, mesmo que versões mais antigas do Shockwave Flash Object estejam registradas no seu computador.

Adicionar um arquivo Flash a uma apresentação

  1. Instale o Flash Player no seu computador.

  2. No PowerPoint, no modo de exibição Normal, exiba o slide no qual você deseja reproduzir a animação.

  3. Clique no Botão do Microsoft Office imagem do botão office e em Opções do PowerPoint.

  4. Clique em Popular, e em Principais opções de trabalho com o PowerPoint, marque a caixa de seleção Mostrar guia do Desenvolvedor na Faixa de Opções e, em seguida, clique em OK.

  5. Na guia Desenvolvedor, no grupo Controles, clique em Mais Controles Imagem do botão .

  6. Na lista de controles, clique em Shockwave Flash Object, em OK, e, em seguida, arraste o cursor no slide para desenhar o controle.

    Redimensione o controle arrastando as alças de dimensionamento.

  7. Clique com botão direito do mouse em Shockwave Flash Object e selecione Propriedades.

  8. Na guia Alfabético, clique na propriedade Filme.

  9. Na coluna de valor (a célula em branco ao lado de Filme), digite o caminho da unidade completo, incluindo o nome do arquivo (por exemplo, C\:MeuArquivo.swf) ou a URL do arquivo Flash que você deseja reproduzir.

  10. Para definir opções específicas de reprodução da animação, siga as instruções a seguir e, quando concluído, feche a caixa de diálogo Propriedades:

    • Para reproduzir o arquivo automaticamente quando o slide for exibido, defina a propriedade Reprodução como Verdadeira. Se o arquivo Flash tiver um controle Iniciar/Retroceder integrado, você pode definir a propriedade Reprodução como Falsa.

    • Se você não quiser que a animação seja reproduzida repetidamente, defina a propriedade Loop como Falsa.

Visualizar uma animação no modo de exibição de Apresentação de Slides

  • Na guia Exibição, no grupo Modos de Exibição de Apresentação, clique em Apresentação de Slides ou pressione F5.

    Para sair da apresentação de slides e retornar ao modo de exibição Normal, pressione ESC.

Observações : 

  • Ao contrário de imagens ou desenhos, arquivos Flash são sempre vinculados à sua apresentação no PowerPoint 2007, em vez de inserido nela. Quando você insere um arquivo vinculado, o PowerPoint cria um link para o local do arquivo atual. Se posteriormente você mover o arquivo para um local diferente, o PowerPoint não é possível localizá-lo quando você desejar executar o arquivo. É uma boa prática para copiar os arquivos Flash na mesma pasta da sua apresentação antes de inserir os arquivos Flash. PowerPoint cria um link para o arquivo Flash e pode encontrar o arquivo Flash como mantê-lo na pasta apresentação, mesmo se você mover ou copiar a pasta para outro computador. Outra maneira para certificar-se de que os arquivos vinculados estejam na mesma pasta da sua apresentação é usar o recurso pacote para CD. Este recurso copia todos os arquivos para um local (um CD ou uma pasta) com a sua apresentação e atualiza automaticamente todos os links para os arquivos. Quando sua apresentação contiver arquivos vinculados, você deve copiar os arquivos vinculados, bem como a apresentação, se você planeja realizar a apresentação em outro computador ou enviá-lo para alguém em email.

  • Os produtos de terceiros abordados neste artigo são fabricados por fornecedores independentes da Microsoft. Não oferecemos garantias, implícitas ou de qualquer outro tipo, em relação ao desempenho ou à confiabilidade desses produtos.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×