Etapa 4: compartilhar sua macro com outras pessoas

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

É importante entender ao compartilhar macros que elas estão armazenados no arquivo do Office, portanto, será necessário compartilhar esses arquivos com outras pessoas. Se você criou uma macro no Word, será necessário compartilhar o arquivo como um Modelo habilitado para macro do Word (.dotm) ou como um Documento habilitado para macro do Word (.docm). Se você criou uma macro no Excel, será necessário compartilhar o arquivo como uma Pasta de trabalho habilitada para macro do Excel (.xlsm) ou como um Modelo habilitado para macro do Excel (.xltm).

Se você criou uma macro do Word, outras etapas deverão ser executadas para compartilhar a macro:

Criar o modelo em branco do Word

  1. Abrir um novo documento do Word.

  2. No menu Arquivo, clique em Salvar como.

  3. Nomeie seu arquivo como global_macros.dotm.

  4. Na lista suspensa Formatar, selecione o Modelo habilitado para macro do Word (*.dotm) como o Formato.

  5. Escolha onde você deseja armazenar o arquivo na sua rede.

  6. Clique em Salvar e feche o modelo.

Exportar a macro do Word do seu documento

Com a macro registrada na Etapa 1, execute as próximas etapas para exportar a macro:

  1. Abra o documento ou modelo contendo a macro que você quer exportar.

  2. No menu Ferramentas aponte para Macro e, em seguida, clique em Macros.

  3. Selecione a macro que você deseja exportar e clique em Editar. Selecione a Macro a ser exportada

  4. No Editor do Visual Basic, clique em Arquivo > Exportar Arquivo.

  5. Salve a macro na mesma pasta que o modelo habilitado para macro, global_macros.dotm.

Importar macro do Word para seu novo modelo em branco

  1. Abra global_macros.dotm e clique em Ferramentas > Macro > Editor do Visual Basic.

  2. Para importar a macro, clique em Arquivo > Importar Arquivo, vá até a pasta para a qual você exportou sua macro, selecione o arquivo e clique em Abrir.

  3. Salve o módulo, feche o Editor do Visual Basic e encerre o Word.

Agora você pode compartilhar sua macro com outras pessoas e pedir que elas sigam as etapas abaixo a fim de instalar a macro nos seus computadores.

Instalação do modelo: configurar o Word para usar sua macro

  1. Coloque o arquivo global_macro.dotm neste local:

    • Word para Mac 2011: HD do Macintosh: Usuários: Nome de usuário: Biblioteca: Suporte do Aplicativo: Microsoft: Office: Modelos do Usuário: Meus Modelos

    • Word 2003 no Windows ou posterior: C:\Documents and Settings \Nome_de_usuário \Dados de Aplicativos\Microsoft\Word\INICIALIZAÇÃO.

      Observação :  Nome de usuário é o nome de logon do usuário.

  2. No Word, clique Word > Preferências....

Preferências do Word

  1. Na seção Configurações Pessoais, clique em Locais de Arquivos

  2. Selecione Inicialização na lista Locais de arquivos e clique em Modificar....

Local do Arquivo

  1. Verifique se o Word está usando a mesma pasta na qual você colocou o arquivo global_macro.dotm como a pasta de Inicialização.

  2. Clique em Escolher para fechar a caixa de diálogo Escolher uma pasta e, em seguida, OK para fechar a caixa de diálogo Locais de Arquivos.

A última etapa é instruir o Word para usar o arquivo global_macros.dotm na inicialização.

  1. No Word, clique Ferramentas > Modelos e Suplementos....

  2. Marque o arquivo global_macros.dotm na lista e clique em OK.

    Dica :  Se você não vir seu modelo na lista, o arquivo global_macros.dotm não estará na pasta de inicialização do Word. Volte para a etapa 1 desta seção e verifique se a pasta Inicialização é a mesma pasta na qual você copiou o arquivo global_macros.dotm.

Modelo de configuração Global no Word

 Etapa 1 - começar com o gravador de macros

Etapa 2 - ler e entender o código

Etapa 3 - aprender os conceitos básicos da programação

Etapa 4 - compartilhar sua macro com outros

Etapa 5 - exemplos da vida real

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×