Enviar dados de formulário para diversos locais

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode criar seu modelo de formulário de modo que esses usuários possam enviar seus dados de formulário para diversos locais ao clicar no botão Enviar.

Neste artigo

Visão geral

Etapa 1: Adicionar as conexões de dados de envio

Etapa 2: Configurar o modelo de formulário para permitir o envio

Visão geral

Para permitir que os usuários enviem seus dados de formulário para diversos locais, você precisa adicionar uma conexão de dados secundária para o seu modelo de formulário que envie os dados para cada um dos locais para os quais deseja que os usuários enviem seus formulários. Após adicionar todas as conexões de dados de envio, você configura o modelo de formulário para permitir que os usuários enviem seus dados de formulário para diversos locais usando uma regra. Como resultado, o Microsoft Office InfoPath adiciona um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo quando os usuários preenchem o formulário. O InfoPath envia os dados do formulário às conexões de dados secundárias na ordem que estão listadas na regra. Não é possível configurar a regra para usar todas as conexões de dados de envio ao mesmo tempo.

Ao configurar o modelo de formulário para permitir que os usuários enviem seus dados de formulário, você também pode personalizar as opções de envio das seguintes maneiras:

  • Alterar o texto que aparece no botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Alterar o atalho de teclado do botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechá-lo ou abrir outro formulário em branco após o formulário ser enviado.

Início da página

Etapa 1: Adicionar as conexões de dados de envio

Para configurar o modelo de formulário para permitir que os usuários enviem seus formulários preenchidos para diversos locais, adicione as conexões de dados de envio necessárias ao modelo de formulário. Você pode adicionar conexões de dados aos seguintes locais:

  • Um serviço da Web

  • Uma biblioteca de documentos em um servidor executando o Microsoft Windows SharePoint Services

  • Em um email.

    Observação : Os usuários precisam ter o Microsoft Office Outlook instalado em seus computadores para enviar os dados de formulário em um email.

Os seguintes procedimentos explicam como adicionar conexões de dados de envio a esses locais.

Adicionar uma conexão de dados que envia dados para um Serviço da Web

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, em Enviar dados e, em seguida, clique em Avançar.

  4. Na próxima página do assistente, clique em Serviço da Web e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, digite o local do serviço da Web onde seus usuários enviarão seus formulários e, em seguida, clique em Avançar.

    Se você quiser pesquisar um servidor UUDI (Universal Description, Discovery and Integration) para um serviço da Web, clique em Pesquisar UDDI, digite o servidor UDDI que deseja pesquisar, especifique se deseja pesquisar por provedor ou por serviços fornecidos, digite uma palavra-chave de pesquisa e, em seguida, clique em Pesquisar. Os serviços da Web que correspondem com sua palavra-chave de pesquisa aparecerão na lista Resultado da pesquisa.

  6. Na próxima página do assistente, na lista Selecione uma operação, clique na operação do serviço da Web que receberá os dados do formulário e, em seguida, clique em Avançar.

  7. Na próxima página do assistente, siga um destes procedimentos:

    Enviar os dados em um campo ou grupo

    1. Na lista Parâmetros, clique em parâmetro de serviço da Web que receberá os dados do formulário.

    2. Em Opções de parâmetro, clique em Campo ou grupo.

    3. Clique em Modificar imagem do botão .

    4. Na caixa de diálogo Selecionar Campo ou Grupo, clique no campo ou no grupo do qual os dados você deseja enviar e, em seguida, clique em OK.

    5. Na caixa Incluir, clique em Somente texto e elementos filho para enviar apenas o conteúdo de quaisquer elementos filho do campo ou do grupo, ou clique em Subárvores XML, incluindo o elemento selecionado para enviar o conteúdo e o grupo ou campo selecionado.

    Enviar todos os dados do formulário

    1. Clique em Formulário inteiro (documento XML, incluindo instruções de processamento).

    Enviar os dados como uma cadeia de caracteres

    1. Marque a caixa de seleção Enviar dados como uma seqüência de caracteres.

      Normalmente, você marca essa caixa de seleção para enviar dados assinados digitalmente. Na maioria dos casos, desmarque essa caixa de seleção.

  8. Clique em Avançar.

  9. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

  10. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

Adicionar uma conexão de dados que envie dados a uma biblioteca de documentos

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, em Enviar dados e, em seguida, clique em Avançar.

  4. Na próxima página do assistente, clique em Para uma biblioteca de documentos em um site SharePoint e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, na caixa Biblioteca de documentos, digite o local da biblioteca de documentos SharePoint.

  6. Na caixa Nome do arquivo, digite um nome que será usado para identificar o formulário na biblioteca de documentos. Você também pode usar uma fórmula para garantir que cada nome de formulário seja exclusivo.

    Como?

    1. Clique em Inserir Fórmula imagem do botão .

    2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

      • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

      • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

      • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

    • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

  7. Para substituir quaisquer formulários existentes pelo mesmo nome na biblioteca de documento, marque a caixa de seleção Permitir que o arquivo seja substituído caso já exista.

  8. Clique em Avançar.

  9. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

  10. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

Adicionar uma conexão de dados que envie dados em um email

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, em Enviar dados e, em seguida, clique em Avançar.

  4. Na próxima página do assistente, clique em Como um email e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, digite os endereços de email dos destinatários da mensagem, o assunto que deseja exibir na mensagem e qualquer texto de introdução que deseja nas caixas apropriadas e, em seguida, clique em Avançar. Você também pode usar uma fórmula em cada caixa exceto para a caixa Introdução .

    Como?

    1. Clique em Inserir Fórmula imagem do botão .

    2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

      • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

      • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

      • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

    • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

  6. Na próxima página do assistente, siga um destes procedimentos:

    1. Para exibir o formulário no corpo da mensagem de email, clique em Enviar apenas o modo ativo do formulário sem anexo.

    2. Para enviar os dados do formulário como um anexo à mensagem de email, clique em enviar os dados do formulário como um anexo, marque a caixa de seleção anexar o modelo de formulário para garantir que os usuários podem abrir o formulário e, em seguida, digite um nome para o formulário na caixa Nome do anexo. Você também pode especificar um campo ou usar uma fórmula para garantir que cada nome de formulário seja exclusivo. Essa opção estará disponível somente se o modelo de formulário está configurado para determinar o nível de segurança automaticamente ou estiver configurado para o nível de segurança restrito ou confiança total.

      Como?

      1. Clique em Inserir Fórmula imagem do botão .

      2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

        • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

        • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

          Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

        • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

      Operação

      Símbolo

      Adicionar

      +

      Subtrair

      -

      Multiplicar

      *

      Dividir

      /

      • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

      • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

        Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

      Os destinatários do email com os dados do formulário enviados como um anexo precisarão do InfoPath instalado em seus computadores para abrir o anexo.

  7. Clique em Avançar.

  8. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

  9. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

Início da página

Etapa 2: Configurar o modelo de formulário para permitir o envio

Após adicionar as conexões de dados secundárias necessárias ao seu modelo de formulário, é necessário configurar o modelo de formulário para permitir que os usuários enviem seus dados de formulário. Isto faz com que o InfoPath adicione um botão Enviar ao menu Arquivo e um botão Enviar à barra de ferramentas Padrão quando os usuários preencherem o formulário. Você pode, em seguida, configurar a ação que ocorrerá quando o usuário clicar no botão Enviar. Nesse caso, você adicionará uma regra que envia os dados do formulário para cada conexão de envio de dados quando o usuário clicar no comando Enviar do menu Arquivo ou no botão Enviar da barra de ferramentas Padrão.

Na mesma caixa de diálogo, você pode configurar as opções de envio.

  1. No menu Ferramentas, clique em Opções de envio.

  2. Na caixa de diálogo Opções de envio, marque a caixa de seleção Permitir que os usuários enviarem este formulário.

    Quando você marca essa caixa de seleção, o InfoPath adiciona um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo quando os usuários preenchem o formulário.

  3. Clique em Executar uma ação personalizada usando Regras e, em seguida, clique em Regras.

  4. Na caixa de diálogo Regras para Enviar Formulários, clique em Adicionar.

  5. Clique em Adicionar Ação.

  6. Na caixa Ação, clique em Enviar usando uma conexão de dados, clique na conexão de dados que deseja usar para essa ação de envio na lista Conexão de dados e, em seguida, clique em OK.

  7. Repita as etapas 5 e 6 para cada conexão de envio de dados que adicionou ao seu modelo de formulário.

  8. Após adicionar as condições para todas as conexões de dados de envio no seu modelo de formulário, clique em OK duas vezes.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  9. Para impedir que os usuários usem o comando Enviar ou o botão Enviar na barra de ferramentas Padrão quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão de barra de ferramenta Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      • Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      • Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×