Enviar dados de formulário par uma biblioteca de documentos

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode armazenar e organizar todos os formulários de seus usuários em uma biblioteca de documentos em um servidor que está executando o Microsoft Windows SharePoint Services. Na biblioteca de documentos, os usuários podem preencher formulários que tem base no seu modelo de formulário, exportar dados de formulários preenchidos para o Microsoft Office Excel 2003 ou para o Microsoft Office Excel 2007, ou mesclar os dados de diversos formulários em um formulário.

Para permitir aos usuários o envio de formulários que têm base no seu modelo de formulário para uma biblioteca de documentos, você pode adicionar uma conexão de dados secundária ao seu modelo de formulários que envia os dados. Após adicionar a conexão de envio de dados, você pode configurar o modelo de formulário para permitir que os seus usuários enviem seus dados de formulário para a biblioteca de documentos. Ao fazer isso, o Microsoft Office InfoPath adiciona um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo no formulário. Você também pode personalizar as opções de envio para o seu modelo de formulário das seguintes maneiras:

  • Alterar o texto que aparece no botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Alterar o atalho de teclado do botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechá-lo ou abrir outro formulário em branco após o formulário ser enviado.

Adicione uma conexão de envio de dados

  1. No menu Ferramentas, clique em Opções de envio.

  2. Na caixa de diálogo Opções de envio, marque a caixa de seleção Permitir que os usuários enviarem este formulário.

  3. Clique em Enviar os dados de formulário para um único destino e, em seguida, clique em Biblioteca de documentos do SharePoint na lista.

  4. Clique em Adicionar.

  5. No Assistente para Conexão de Dados, na caixa Biblioteca de documentos, digite o local da biblioteca de documentos do SharePoint.

  6. Na caixa Nome do arquivo, digite um nome que será usado para identificar o formulário na biblioteca de documentos.

    Dica : Você também pode usar uma fórmula para garantir que cada nome de formulário seja exclusivo.

    Como?

    1. Clique em Inserir Fórmula imagem do botão .

    2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

      • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

      • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Dica : Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

      • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

    • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

  7. Para substituir quaisquer formulários existentes pelo mesmo nome na biblioteca de documento, marque a caixa de seleção Permitir que o arquivo seja substituído caso já exista.

  8. Clique em Avançar.

  9. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

  10. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Dica : Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  11. Se não quiser que as pessoas para usar um comando Enviar ou no botão Enviar na barra de ferramentas padrão, quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      1. Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      2. Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Dica : Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      3. Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×