Enviar dados de formulário em um email

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode adicionar uma conexão de envio de dados secundária ao seu modelo de formulário para permitir que os usuários enviem seus dados de formulário em um email. É possível usar valores estáticos, valores com base nos dados no formulário, ou uma fórmula para especificar os endereços de email para os quais o formulário é enviado, a linha de assunto do email e o nome do formulário. Você também pode especificar se deseja que o formulário apareça no corpo do email ou seja enviado como um anexo da mensagem.

Se você configurar seu modelo de formulário para incluir o formulário como um anexo do email, poderá anexar também o modelo de formulário ao email. Ao incluir o formulário e o modelo de formulário como anexos do email, você pode ajudar a garantir que os destinatários do email possa abrir o formulário no Microsoft Office InfoPath, mesmo se eles não tiverem o modelo de formulário armazenado em cache em seus computadores. Para que ps destinatários abram os anexos, eles devem ter o InfoPath instalado em seus computadores.

Quando os usuários enviam seus dados de formulário em um email, o InfoPath cria uma mensagem de email com os dados do formulário e envia a mensagem aos destinatários do email, especificada quando você criou a conexão de dados. Se as pessoas que receberem os formulários preenchidos usarem o Microsoft Office Outlook 2007, eles poderão adicionar uma pasta às suas Caixas de entrada para conter todos os formulários do InfoPath que receberam e configurar essa pasta para exibir os dados dos formulários em colunas no Outlook.

Após você adicionar a conexão de envio de dados, configure seu modelo de formulário para permitir que os usuários enviem seus dados de formulário. Como resultado, quando os usuários abrirem o formulário, o InfoPath adicionará automaticamente um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo. Você também pode personalizar as opções de envio para o seu modelo de formulário das seguintes maneiras:

  • Alterar o texto que aparece no botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Alterar o atalho de teclado do botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechar o formulário ou abrir outro formulário em branco após o usuário enviá-lo.

Início da página

Adicione uma conexão de envio de dados

  1. No menu Ferramentas, clique em Opções de envio.

  2. Na caixa de diálogo Opções de envio, marque a caixa de seleção Permitir que os usuários enviarem este formulário.

  3. Clique em Enviar dados de formulário para um único destino e, em seguida, na lista, clique em Email.

  4. Clique em Adicionar.

  5. No Assistente para Conexão de Dados, nas caixas apropriadas, digite os endereços de email dos destinatários, o assunto que deseja exibir no email e qualquer texto de introdução que deseja e, em seguida, clique em Avançar.

    Dica : Você também pode especificar um campo ou usar uma fórmula para criar o valor para cada caixa, exceto para a caixa Introdução.

    Como?

    1. Clique em Inserir Fórmula imagem do botão .

    2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

      • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

      • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Dica : Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

      • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

    • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

  6. Na próxima página do assistente, siga um destes procedimentos:

    1. Para exibir o formulário no corpo da mensagem de email, clique em Enviar apenas o modo ativo do formulário sem anexo.

    2. Para enviar os dados do formulário como um anexo da mensagem de email, clique em Enviar os dados do formulário como um anexo, marque a caixa de seleção Anexar o modelo de formulário para garantir que os usuários possam abrir o formulário e, em seguida, digite um nome para o formulário na caixa Nome do Anexo. Você também pode especificar um campo ou usar uma fórmula para garantir que cada nome de formulário seja exclusivo.

      Como?

      1. Clique em Inserir Fórmula imagem do botão .

      2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

        • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

        • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

          Dica : Se a função exigir parâmetros, selecione a função na caixa de diálogo Inserir Função, clique em OK e, em seguida, na caixa Fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que adicionou e clique em um campo ou em um grupo. Encontre links para informações adicionais sobre funções na seção Consulte Também.

        • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

      Operação

      Símbolo

      Adicionar

      +

      Subtrair

      -

      Multiplicar

      *

      Dividir

      /

      • Observação : Se a sua formula usar o operador de divisão (/), verifique se existe espaço antes e depois do operador. Se o operador de divisão não tiver um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para etapas de localização do XPath em vez de um operador de divisão.

      • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

        Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

      Observação : As pessoas que receberem os dados de formulário como um anexo em um email precisam ter o InfoPath instalado em seus computadores para abrir o anexo.

  7. Clique em Avançar.

  8. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

  9. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Dica : Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  10. Se não quiser que as pessoas para usar um comando Enviar ou no botão Enviar na barra de ferramentas padrão, quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      • Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Dica : Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      • Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×