Enviar dados de formulário a um banco de dados do Microsoft SQL Server

Importante:  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Neste artigo

Visão geral

Etapa 1: Habilitar a conexão de dados de envio

Etapa 2: Configurar as opções de envio

Visão geral

Quando você cria um modelo de formulário que tem base em um banco de dados do Microsoft SQL Server, o Assistente para Conexão de Dados ativa uma conexão de envio de dados com o banco de dados se as seguintes condições forem atendidas:

  • Os formulários que têm base nesse modelo de formulário devem ser preenchidos usando o Microsoft Office InfoPath. Se o formulário for preenchido usando uma navegador da Web, ele não poderá enviar dados para um banco de dados diretamente. Para configurar um modelo de formulário compatível com o navegador de modo a enviar dados para um banco de dados, use uma conexão de dados que envia dados para um serviço da Web que funciona com o banco de dados.

  • A tabela de banco de dados primária usada na principal conexão de dados contém uma chave primária, uma restrição exclusiva ou um índice exclusivo.

  • Quaisquer outras tabelas de banco de dados usadas com essa conexão de dados principal têm uma relação simples com a tabela de banco de dados primária.

Se o banco de dados atender a esses requisitos, o InfoPath ativará a conexão de envio de dados e adicionará um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo no formulário.

Você pode escolher desativar a conexão de envio de dados no assistente ao criar um modelo de formulário que tem base em um banco de dados. Se você desativar a conexão de envio de dados no assistente e, posteriormente, decidir que deseja usar essa conexão de envio de dados, poderá ativar a conexão modificando a conexão de dados principal. Esse artigo descreve como ativar essa conexão de envio de dados.

Observação: Você pode ter uma conexão de envio de dados somente na conexão de dados principal com um banco de dados. Não é possível adicionar uma conexão de envio de dados ao modelo de formulário que seja uma conexão de dados secundária com um banco de dados. Se quiser usar uma conexão de envio de dados com um banco de dados como uma conexão de dados secundária, use um serviço da Web que funcione com o banco de dados e, em seguida, adicione uma conexão de envio de dados com esse serviço da Web.

Após ativar a conexão de envio de dados, você também pode personalizar as opções de envio para o seu modelo de formulário das seguintes maneiras:

  • Alterar o texto que aparece no botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Alterar o atalho de teclado do botão Enviar na barra de ferramentas Padrão e o comando Enviar no menu Arquivo.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechá-lo ou abrir outro formulário em branco após o formulário ser enviado.

Início da página

Etapa 1: Ativar a conexão de envio de dados

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de Dados clique na conexão de dados principal e, em seguida clique em Modificar.

  3. No Assistente para Conexão de Dados, clique em Avançar.

  4. Na próxima página do assistente, marque a caixa de seleção Ativar envio para esta conexão e, em seguida, clique em Concluir.

Início da página

Etapa 2: Configurar as opções de envio

Após você ativar a conexão de envio de dados, o InfoPath adicionará o botão Enviar à barra de ferramentas Padrão e o comando Enviar ao menu Arquivo. O InfoPath também configurará os formulários que baseados nesse modelo de formulário para que exibam uma mensagem aos usuários após o envio dos formulários preenchidos. Essa mensagem informa se o formulário foi enviado com êxito. Por padrão, o InfoPath também mantém os formulários abertos após os usuários os enviarem. Para alterar o texto que aparece no botão Enviar, bem como o comportamento que ocorre após os usuários enviarem seus formulários, siga este procedimento:

  1. No menu Ferramentas, clique em Opções de envio.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Dica: Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  2. Se não quiser que as pessoas para usar um comando Enviar ou no botão Enviar na barra de ferramentas padrão, quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      • Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Dica: Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      • Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação: Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×