Editar uma relação

Editar uma relação

Se o design do banco de dados do Access for alterado, talvez seja necessário alterar uma relação entre tabelas. Para fazer isso em um banco de dados da área de trabalho do Access, selecione a relação na janela Relações e edite-a. A alteração de uma relação em um aplicativo Web do Access é um processo diferente, como explicado posteriormente, na seção Editar uma relação em um aplicativo Web do Access.

Para saber mais sobre relações, confira o artigo Criar, editar ou excluir uma relação.

Neste tópico

Editar uma relação em um banco de dados da área de trabalho do Access

Editar uma relação em um aplicativo Web do Access

Editar uma relação em um banco de dados da área de trabalho do Access

  1. Para ver todas as relações entre as tabelas de um banco de dados da área de trabalho, na guia Ferramentas de Banco de Dados, clique em Relações.

    Comando Relações na guia Ferramentas de Banco de Dados

  2. Clique em Todas as Relações.

    Todas as tabelas com relações serão exibidas, mostrando as linhas de relações.

  3. Posicione cuidadosamente o cursor de forma que ele aponte para a linha da relação que você deseja editar e clique na linha para selecioná-la.

    Linha de relação entre campos em duas tabelas

    A linha da relação aparecerá mais grossa quando for selecionada.

  4. Com a linha da relação selecionada, clique duas vezes nela. A caixa de diálogo Editar Relações é exibida.

    Caixa de diálogo Editar Relações

  5. Faça suas alterações e clique em OK.

    A caixa de diálogo Editar Relações permite alterar uma relação de tabelas. Especificamente, você pode alterar as tabelas ou as consultas em qualquer lado da relação, ou os campos em qualquer um dos lados. Você também pode definir o tipo de junção ou impor a integridade referencial e escolher uma opção em cascata.

  6. Quando terminar na janela Relações, clique em Salvar para salvar todas as alterações de layout de relação.

Editar uma relação em um aplicativo Web do Access

A janela Relações não está disponível nos aplicativos Web do Access. Você usa um campo em uma tabela como a origem (campo de pesquisa) dos valores do campo relacionado em outra tabela.

  1. Abra a tabela que contém a pesquisa que você deseja alterar clicando em Editar Tabela.

    Editar Tabela

  2. Selecione o campo que recebe os seus valores de outra tabela.

  3. Na guia Design, em Ferramentas de Tabela, clique em Modificar Pesquisas.

  4. Siga os procedimentos do assistente para fazer as mudanças que quiser. É possível alterar o seguinte:

    • O campo que é a fonte de valores

    • A ordem de classificação dos valores

    • A largura do campo, e se quiser ocultar a coluna chave

    • O rótulo para o campo de pesquisa

    • Se a integridade dos dados está habilitada

    • Se a integridade dos dados está habilitado, se as exclusões estão em cascata ou restritas

Deseja somente obter noções básicas sobre a criação ou a exclusão de relações? Consulte os seguintes artigos:

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×