ESCOLHER (Função ESCOLHER)

Este artigo descreve a sintaxe da fórmula e o uso da função ESCOLHER no Microsoft Excel.

Descrição

Use núm_índice para retornar um valor da lista de argumentos de valor. Use ESCOLHER para selecionar um valor entre 254 valores que se baseie no número de índice. Por exemplo, se do valor1 até o valor7 forem os números da semana, ESCOLHER retorna um dos dias quando um número entre 1 e 7 for usado como núm_índice.

Sintaxe

ESCOLHER(núm_índice, valor1, [valor2],...)

A sintaxe da função ESCOLHER tem os seguintes argumentos:

  • núm_índice    Obrigatório. Especifica o argumento de valor selecionado. Núm_índice deve ser um número entre 1 e 254, ou uma fórmula ou referência a uma célula que contenha um número entre 1 e 254.

    • Se núm_índice for 1, ESCOLHER retornará valor1; se for 2, ESCOLHER retornará valor2; e assim por diante.

    • Se núm_índice for menor do que 1 ou maior do que o número do último valor na lista, ESCOLHER retornará o valor de erro #VALOR!.

    • Se núm_índice for uma fração, ela será truncada para o menor inteiro antes de ser usada.

  • valor1, valor2,...     Valor1 é obrigatório, valores subsequentes são opcionais. De 1 a 254 argumentos de valor a partir dos quais ESCOLHER seleciona um valor ou uma ação a ser realizada com base no núm_índice. Os argumentos podem ser números, referências de célula, nomes definidos, fórmulas, funções ou texto.

Comentários

  • Se núm_índice for uma matriz, cada valor será avaliado quando ESCOLHER for avaliada.

  • Os argumentos de valor para ESCOLHER podem ser referências de intervalo bem como valores únicos.

    Por exemplo, a fórmula:

=SOMA (ESCOLHER(2, A1:A10, B1:B10, C1:C10))

avalia para:

=SOMA(B1:B10)

que depois retorna um valor baseado nos valores do intervalo B1:B10.

A função ESCOLHER é a primeira a ser avaliada, retornando a referência B1:B10. A função SOMA é avaliada posteriormente usando B1:B10, o resultado da função ESCOLHER, como seu argumento.

Exemplos

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Dados

 

Pregos

Parafusos

Porcas

Concluído

Parafusos

Fórmula

Descrição

Resultado

=ESCOLHER(2;A2;A3;A4;A5)

Valor do segundo argumento de lista (valor da célula A3)

=ESCOLHER(4;B2;B3;B4;B5)

Valor do quarto argumento de lista (valor da célula B5)

Parafusos

=ESCOLHER(3,"Largura",115,"mundo",8)

Valor do terceiro argumento de lista

mundo

Exemplo 2

Dados

23

45

12

10

Fórmula

Descrição (Resultado)

Resultado

=SOMA(A2:ESCOLHER(2;A3;A4;5))

Soma o intervalo A2:A4. A função ESCOLHER retorna A4 como a segunda parte do intervalo para a função SOMA.

80

Compartilhar Facebook Facebook Twitter Twitter Email Email

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×