Dividir um banco de dados do Access

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Considere a possibilidade de dividir qualquer banco de dados compartilhado por diversas pessoas através de uma rede. A divisão de um banco de dados compartilhado pode ajudar a melhorar seu desempenho e reduzir a chance de corrupção do arquivo de banco de dados.

Após dividir o banco de dados, você pode decidir mover o banco de dados back-end ou usar um banco de dados back-end diferente. Você pode usar o Gerenciador de Tabelas Vinculadas para alterar o banco de dados back-end que utiliza.

Observação :  Este artigo não se aplica aos aplicativos do Access – o novo tipo de banco de dados que você cria com o Access e publica online. Consulte Criar um aplicativo do Access para saber mais.

Observações : 

  • Dividir um banco de dados não é a mesma coisa que arquivar um banco de dados. Este tópico não discute como arquivar dados. Você arquiva dados movendo arquivos mais antigos periodicamente para um banco de dados diferente, seja porque o arquivo de banco de dados está crescendo rápido demais até o limite de tamanho do arquivo, seja porque você quer manter o arquivo de banco de dados pequeno e seus dados organizados por período. Em algumas circunstâncias, você pode arquivar dados dividindo um banco de dados. Para obter mais informações, consulte o artigo online Arquivar dados do Access data.

  • Se você dividir um banco de dados da Web, as tabelas da Web que houver nesse banco de dados não serão movidas para o banco de dados back-end e não serão acessíveis do banco de dados front-end resultante.

Neste artigo

Visão geral

Antes de começar

Dividir o banco de dados

Distribuir o banco de dados front-end

Alterar qual banco de dados back-end você usa

Visão geral

Ao dividir um banco de dados, você o reorganiza em dois arquivos: um banco de dados back-end que contém as tabelas de dados e um banco de dados front-end que contém todos os outros objetos de banco de dados, como consultas, formulários e relatórios. Cada usuário interage com os dados usando uma cópia local do banco de dados front-end.

Para dividir um banco de dados, use o Assistente do Divisor de Banco de Dados. Após dividir o banco de dados, distribua o banco de dados front-end para os usuários.

Cuidado :  Para proteger os dados se o banco de dados tem vários usuários finais, é recomendável não compartilhar cópias de um banco de dados que contenha links para listas do SharePoint, inclusive links para listas dentro de um banco de dados da Web publicado. Se você vincular a uma tabela que seja uma lista do SharePoint, isso criará uma possibilidade de qualquer usuário mal-intencionado alterar o destino do link e potencialmente modificar as permissões no site do SharePoint, pois as informações de conexão para tabelas vinculadas não são criptografadas.

Benefícios de um banco de dados dividido

Estes são os benefícios de um banco de dados dividido:

  • Melhor desempenho    Em geral, o desempenho do banco de dados melhora significativamente, porque somente os dados são enviados pela rede. Em um banco de dados compartilhado que não é dividido, os objetos de banco de dados em si — tabelas, consultas, formulários, relatórios, macros e módulos — são enviados pela rede, não apenas os dados.

  • Maior disponibilidade    Como somente os dados são enviados pela rede, as transações de banco de dados, como edições de registro, são concluídas mais rapidamente, deixando os dados mais disponíveis para edição.

  • Segurança aprimorada    Se você armazena o banco de dados back-end em um computador que usa o sistema de arquivos NTFS, pode usar os recursos de segurança NTFS para ajudar a proteger os dados. Como os usuários acessam o banco de dados back-end utilizando tabelas vinculadas, é menos provável que intrusos consigam obter acesso não autorizado aos dados roubando o banco de dados front-end ou se fazendo passar por um usuário autorizado. Por padrão, o Windows XP, o Windows Vista e o Windows Server 2003 usam o sistema de arquivos NTFS. Se você não tem certeza sobre qual sistema seu servidor de arquivos usa, pergunte ao administrador do sistema. Se você tem privilégios de administrador no servidor de arquivos, pode executar o comando msinfo32 para identificar o sistema de arquivos você mesmo.

    Como eu uso msinfo32 para verificar o sistema de arquivos?

    1. Clique no botão Iniciar e em Executar.

    2. Na caixa Executar, digite msinfo32 e clique em OK.

    3. Em Resumo do Sistema, clique no sinal de adição ao lado de Componentes.

    4. Em Componentes, clique no sinal de adição ao lado de Armazenamento e clique em Unidades. A caixa de diálogo exibe informações sobre as unidades disponíveis no painel à direita.

  • Maior confiabilidade    Se um usuário encontra um problema e o banco de dados é fechado inesperadamente, qualquer corrupção eventual do arquivo de banco de dados geralmente se limita à cópia do banco de dados front-end que o usuário tinha aberta. Como o usuário só acessa dados no banco de dados back-end usando tabelas vinculadas, a probabilidade de o arquivo de banco de dados ser corrompido é bem menor.

  • Ambiente de desenvolvimento flexível    Como cada usuário trabalha em uma cópia local do banco de dados front-end, ele pode desenvolver consultas, formulários, relatórios e outros objetos de banco de dados independentemente, sem afetar outros usuários. Da mesma forma, você pode desenvolver e distribuir uma nova versão do banco de dados front-end sem atrapalhar o acesso aos dados armazenados no banco de dados back-end.

Início da página

Antes de começar

Antes de dividir um banco de dados, considere o seguinte:

  • Faça sempre backup de um banco de dados antes de dividi-lo. Se você dividir um banco de dados e depois decidir que não queria fazer isso, poderá restaurar o original a partir da cópia de backup.

  • A divisão de um banco de dados pode demorar muito. Notifique os usuários para que não usem o banco de dados enquanto você o divide. Se um usuário alterar dados enquanto você estiver dividindo o banco de dados, as alterações não serão refletidas no banco de dados back-end.

    Dica : Se um usuário alterar dados enquanto o banco de dados estiver sendo dividido, você poderá importar os novos dados para o banco de dados back-end após concluir.

  • Embora a divisão do banco de dados seja uma maneira de compartilhar dados, todos que usam o banco de dados devem ter uma versão do Microsoft Office Access que seja compatível com o formato de arquivo do banco de dados back-end. Por exemplo, se o arquivo de banco de dados back-end usa o formato de arquivo .accdb, os usuários não podem acessar seus dados usando o Access 2003.

  • Convém usar um formato de arquivo anterior do Access para o banco de dados back-end se você usa recursos que não têm mais suporte. Por exemplo, se você usa páginas de acesso a dados (DAPs), poderá continuar a usá-las se o banco de dados back-end estiver em um formato de arquivo anterior com suporte para DAPs. Você poderá então usar o novo formato de arquivo com o banco de dados front-end, para que os usuários tenham acesso aos benefícios do novo formato. Observe que não é possível alterar dados em uma Página de Acesso a Dados usando o Access 2013.

Início da página

Dividir o banco de dados

  1. No seu computador, faça uma cópia do banco de dados que você deseja dividir. Comece pelo arquivo de banco de dados no disco rígido local, não no compartilhamento de rede. Se o arquivo de banco de dados estiver sendo compartilhado atualmente da sua unidade de disco rígido local, você poderá deixá-lo onde está.

  2. Abra a cópia do banco de dados que está na sua unidade de disco rígido local.

  3. Na guia Ferramentas de banco de dados, no grupo Mover dados, clique em Banco de dados do Access. Inicia o Assistente do divisor de banco de dados.

  4. Clique em Dividir Banco de Dados.

  5. Na caixa de diálogo Criar Banco de Dados Back-end, especifique um nome, um tipo de arquivo e um local para o arquivo de banco de dados back-end.

    Observações : 

    • Considere o uso do nome sugerido pelo Access. Ele preserva o nome de arquivo original e indica que o banco de dados é um banco de dados back-end, inserindo _be no nome, antes da extensão de nome de arquivo.

    • Não altere o tipo de arquivo, a menos que alguns usuários utilizem uma versão anterior do Access para acessar os dados.

    • Você pode inserir o caminho para o local de rede na caixa Nome do Arquivo, na frente do nome do arquivo. Por exemplo, se o local de rede do banco de dados back-end for \\server1\share1\ e o nome do arquivo do banco de dados back-end for MeuBD_be.accdb, você poderá inserir \\server1\share1\MeuBD_be.accdb na caixa Nome do Arquivo.

    • O local que você escolher deverá estar disponível para todos que usarão o banco de dados. Como os mapeamentos de unidade podem variar, você deve especificar o caminho UNC do local em vez de usar uma letra de unidade mapeada.

  6. Quando o assistente for concluído, ele exibirá uma mensagem de confirmação.

Seu banco de dados agora está dividido. O banco de dados front-end é o arquivo pelo qual você começou (a cópia do banco de dados compartilhado original), e o banco de dados back-end está no local de rede que você especificou na etapa 5 deste procedimento.

Restringir alterações no design do banco de dados front-end

Para restringir alterações no banco de dados front-end que você distribui, considere a possibilidade de salvá-lo como um arquivo binário compilado (um arquivo .accde). Um arquivo binário compilado é um arquivo de aplicativo de banco de dados que foi salvo com todo o código VBA (Visual Basic Access) compilado. Nenhum código-fonte VBA permanece em um arquivo binário compilado do Access. Os usuários não podem alterar o design de objetos em um arquivo .accde.

  1. Abra o arquivo de banco de dados front-end (.accdb) que você deseja salvar como um arquivo binário compilado (.accde).

  2. Clique em Arquivo > Salvar como > Criar ACCDE > Salvar como.

  3. Na caixa de diálogo Salvar como, navegue até a pasta onde você deseja salvar o arquivo, digite um nome para o arquivo na caixa Nome do Arquivo e clique em Salvar.

Início da página

Distribuir o banco de dados front-end

Após dividir o banco de dados, distribua o banco de dados front-end para os usuários, a fim de que possam começar a usá-lo.

Cuidado : Para proteger os dados se o banco de dados tem vários usuários finais, é recomendável não compartilhar cópias de um banco de dados que contenha links para listas do SharePoint, inclusive links para listas dentro de um banco de dados da Web publicado. Se você vincular a uma tabela que seja uma lista do SharePoint, isso criará uma possibilidade de qualquer usuário mal-intencionado alterar o destino do link e potencialmente modificar as permissões no site do SharePoint, pois as informações de conexão para tabelas vinculadas não são criptografadas.

Siga um destes procedimentos:

  • Envie uma mensagem de email para os usuários do banco de dados e anexe o arquivo de banco de dados front-end à mensagem. Inclua instruções que tornem mais fácil para os usuários começarem a usar o banco de dados front-end imediatamente.

  • Salve o arquivo de banco de dados front-end em um local de rede que todos os usuários do banco de dados possam acessar e, em seguida, envie aos usuários uma mensagem de email especificando o local de rede, junto com qualquer outra instrução de que eles possam precisar para acessar o banco de dados.

  • Distribua o arquivo de banco de dados front-end usando mídia removível, como um CD-ROM ou um pen drive USB. Se instalar o arquivo você mesmo, poderá testá-lo para verificar se funciona. Se os usuários forem instalar o arquivo, você deverá incluir um documento que explique o que eles devem fazer para instalar o arquivo e quem contatar em caso de dificuldade.

Início da página

Alterar qual banco de dados back-end você usa

Você pode mover seu banco de dados back-end ou usar um banco de dados back-end diferente, com o Gerenciador de Tabelas Vinculadas.

Se você deseja mover seu banco de dados back-end, faça primeiro uma cópia dele no novo local e depois siga este procedimento.

  1. Na guia Dados Externos, no grupo Importar e Vincular, clique em Gerenciador de Tabelas Vinculadas.

  2. No Gerenciador de Tabelas Vinculadas, selecione as tabelas que estão no banco de dados back-end atual.

    Dica : Se você não vinculou a nenhum outro banco de dados, clique em Selecionar Tudo.

  3. Marque a caixa de seleção Sempre verificar se há um novo local e clique em OK.

  4. Navegue até o novo banco de dados back-end e selecione-o.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×