Criar uma solução de controlador de ativos usando o InfoPath e o Excel

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Microsoft Office InfoPath permite criar modelos de formulário para entrada de dados e conjunto. Microsoft Office Excel 2007 permite aos usuários calcular, gráfico e analisar dados. Usando tanto desses programas e XML, você pode criar facilmente um simples mas solução de negócios eficaz sem código para controlar ativos em uma empresa.

Visão geral da solução para controlar ativos

Neste artigo

Introdução à criação de uma solução de controlador de ativos

Etapa 1: Personalizar o modelo de formulário do controlador de ativos

Etapa 2: Mapear o arquivo de esquema e personalizar o layout de tabela no Excel

Etapa 3: Criar um relatório de resumo de tabela dinâmica e gráfico dinâmico

Etapa 4: Coletar informações sobre os ativos dos usuários

Etapa 5: Importar formulários para o Excel

Conclusões: considere o uso de uma lista do SharePoint ou o banco de dados do Access

Introdução à criação de uma solução de controlador de ativos

Você pode trocar dados XML entre o InfoPath e o Excel. Embora o comando Infopath Exportar é um simples, direto enviar dados de formulário para o Excel, há outra abordagem que você pode realizar que lhe dá muito mais flexibilidade. Explicitamente mapeando o arquivo de esquema (. xsd) do InfoPath XML no Excel e, em seguida, importar arquivos de formulário do InfoPath (. xml) para o Excel, você pode personalizar o layout dos seus dados e aproveitar melhor os recursos do Excel para ajudá-lo a gerenciar e analisar seus dados com mais eficiência.

Neste artigo, usaremos o modelo de formulário de exemplo do controlador de ativos do InfoPath para ilustrar como você pode fazer o InfoPath, XML e Excel trabalham juntos. Imagine que cada ano, sua organização faz o inventário ativos no office de cada funcionário. Em seguida, um relatório do Excel é executado para ajudar a decidir como alocar o orçamento de equipamentos para o próximo ano. O diagrama a seguir é uma visão geral de como você pode coletar, controlar e relatar dados de ativos no seu departamento.

a

1. no modelo de formulário do controlador de ativos é criado.

2. o arquivo de esquema é mapeado para uma tabela do Excel e o layout da tabela é personalizado.

3. um relatório de resumo de tabela dinâmica e gráfico dinâmico em branco é criado.

4. o formulário de controlador de ativos é usado para coletar dados de usuários.

5. todos os dados de formulário é exportado na tabela do Excel e os relatórios de tabela dinâmica e gráfico dinâmico são atualizados.

Essa solução envolve as seguintes funções de usuário e os produtos:

Ícone Suporte completo = necessários Ícone de ausência de suporte = não necessária

Requisitos de software

Funções

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Designer de solução

Ícone Suporte completo

Ícone Suporte completo

Ícone Suporte completo

Profissionais responsáveis pelas decisões

Ícone Suporte completo

Ícone Suporte completo

Ícone Suporte completo

Funcionários

Ícone Suporte completo

Ícone Suporte completo

Ícone de ausência de suporte

Início da página

Etapa 1: Personalizar o modelo de formulário do controlador de ativos

O modelo de formulário do controlador de ativos, que está incluído no InfoPath, permite que você colete informações sobre cada ativo no escritório de um funcionário, o departamento que o funcionário pertence, categorias de ativos e detalhes sobre cada ativo. Nesta solução, um designer de formulário envia o modelo de formulário a conta de email a tomadores usando Office Outlook 2007.

o modelo do controlador de ativos

Tarefa 1: Abrir e personalizar o modelo de formulário do controlador de ativos

Porque você não pode publicar um modelo de formulário a uma lista de destinatários de email se ele tiver um controle de caixa de rich text com imagens vinculadas, você precisa fazer uma pequena alteração ao formulário de modelo de exemplo do controlador de ativos.

  1. No menu Arquivo, clique em Criar um Modelo de Formulário.

  2. Na caixa de diálogo de Design de um modelo de formulário, em Abra um modelo de formulário, clique em Personalizar uma amostra.

  3. Na caixa de diálogo Guia de Introdução, clique em Sample - controlador de ativos e, em Tarefas de formulário, clique em criar este formulário.

  4. Clique com botão direito no controle de assetNotes, aponte para propriedades de Caixa de Rich Text, clique na guia exibição e em Formatação disponível, desmarque a caixa de seleção de Imagens vinculadas.

Tarefa 2: Definir as opções de envio

A próxima tarefa é definir as opções de envio para que os funcionários possam enviar um arquivo de formulário exclusivamente nomeado (. xml) à conta de email a tomadores como um arquivo anexado.

  1. No menu Ferramentas, clique em Opções de envio.

  2. Na caixa de diálogo Opções de envio, marque a caixa de seleção Permitir que os usuários enviarem este formulário.

  3. Clique em Enviar dados de formulário para um único destino e, em seguida, na lista, clique em Email.

  4. Clique em Adicionar.

    O Assistente de Conexão de dados aparece.

  5. Na caixa para, digite o alias do tomador de decisões que receberão todos os formulários enviados.

  6. Para especificar uma linha de assunto exclusivos, na caixa assunto:

    • Clique em Inserir Fórmula imagem do botão .

    • Digite a seguinte fórmula:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Clique em Verificar fórmula e, em seguida, clique duas vezes em Okey.

  • Na caixa Introdução, digite uma mensagem apropriada ou adicione instruções importantes para esta solução.

  • Clique em Avançar.

  • Na próxima página do assistente, clique em enviar os dados do formulário como um anexo e, em seguida, marque a caixa de seleção de anexar o modelo de formulário para garantir que os usuários podem abrir o formulário.

    Isso ajuda a garantir que os funcionários tenham acesso ao arquivo de modelo de formulário (. xsn) caso eles não é possível acessá-lo em seu local de rede.

  • Para especificar uma um nome de arquivo exclusivo para cada arquivo de formulário (. xml) na caixa Nome do anexo:

    1. Clique em Inserir Fórmula imagem do botão .

    2. Digite a mesma fórmula como aquele na linha assunto:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Clique em Verificar fórmula e, em seguida, clique duas vezes em Okey.

  • Clique em Avançar.

  • Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para este enviar conexão de dados.

  • Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

  • Salve o formulário para uma pasta de rede pública acessível para os profissionais responsáveis pelas decisões e para todos os funcionários.

Início da página

Etapa 2: Mapear o arquivo de esquema e personalizar o layout de tabela no Excel

Configurar a conexão entre o InfoPath e o Excel requer três tarefas: extrair o arquivo de esquema para o modelo de formulário do controlador de ativos, mapeando este arquivo de esquema no Excel e personalizar o layout padrão de tabela do Excel que conterá o XML importado arquivos de dados do formulário.

Tarefa 1: Extrair o arquivo de esquema do InfoPath

  1. No InfoPath, abra o arquivo de modelo de formulário do controlador de ativos.

  2. No menu Ferramentas, clique em criar este formulário.

  3. No menu Arquivo, clique em Salvar como Arquivos de Origem.

  4. Na caixa de diálogo Procurar pasta, selecione uma pasta ou crie uma nova pasta onde você deseja armazenar o arquivo de esquema.

Observe o local da pasta onde todos os arquivos de origem são salvos e o nome do arquivo do esquema, nesse caso, myschema.xsd, que contém a definição de esquema do formulário de dados XML.

Tarefa 2: Mapear o arquivo de esquema do InfoPath no Excel

  1. Criar um novo arquivo do Excel e salve-a em um local acessível para os profissionais responsáveis pelas decisões.

  2. No Excel, se a guia desenvolvedor não estiver visível, faça o seguinte:

    1. Clique no Botão do Microsoft Office imagem do botão office e clique em Opções do Excel.

    2. Na categoria Popular, em Opções principais para o trabalho com o Excel, marque a caixa de seleção Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

      Observação : A Faixa de Opções é um componente da Interface de usuário do Microsoft Office Fluent.

  3. Na guia Desenvolvedor, no grupo XML, clique em Origem.

    grupo xml na faixa de opções

    O painel de tarefas Código-fonte XML é exibido.

  4. Clique em Mapas XML e, em seguida, na caixa de diálogo Mapas XML, clique em Adicionar.

  5. Em um computador que esteja executando o Windows Vista    

    1. Na barra de endereços, clique na unidade ou pasta que contém o arquivo de myschema.xsd que você criou na etapa 2 da seção, tarefa 1: extrair o arquivo de esquema do InfoPath.

      Em um computador que esteja executando o Microsoft Windows XP    

    2. Na lista Examinar, clique na unidade ou pasta que contém o arquivo de myschema.xsd que você criou na etapa 2 da seção, tarefa 1: extrair o arquivo de esquema do InfoPath.

  6. Clique no arquivo e clique em Abrir.

  7. Quando a caixa de diálogo de Várias raízes aparece, clique no nó de raiz de assetTracking que é definido no arquivo myschema.xsd e clique em Okey.

    O mapa XML é exibido no painel de tarefas Código-fonte XML.

  8. Arraste o elemento de nó ns1:asset, que é um elemento XML repetido, para o local da planilha onde deseja que a tabela do Excel apareça.

    Mapeando o arquivo de esquema inopath para o excel

Tarefa 3: Personalizar o layout da tabela do Excel

Por padrão, o Excel usará os nomes dos elementos XML como títulos de coluna da tabela. No entanto, você pode alterar os títulos de coluna editando as células de cabeçalho de coluna.

  1. Para modificar os cabeçalhos de coluna padrão, manter a tabela do Excel selecionada, localize o seguinte prefixo de cadeia de caracteres, ns1:asset e removê-lo. Por exemplo, você poderia alterar ns1:assetIDID.

    personalizando os cabeçalhos de tabela do excel

  2. Para ajustar a largura da coluna, clique no botão Selecionar tudo e, em seguida, clique duas vezes em qualquer limite de título de coluna.

Início da página

Etapa 3: Criar um relatório de resumo de tabela dinâmica e gráfico dinâmico

Responsáveis pelas decisões usam tabela dinâmica e relatórios de gráfico dinâmico para analisar, explorar e visualizar dados de resumo. Configurando os relatórios de tabela dinâmica e gráfico dinâmico que você deseja usar neste cenário antecedência, será uma operação de simple para uma profissionais responsáveis pelas decisões executar o relatório com os dados concluídos mais tarde.

  1. Selecione uma célula na tabela do Excel.

  2. Na guia Inserir, no grupo Tabelas, clique em Tabela Dinâmica e, em seguida, clique em Tabela Dinâmica novamente.

    Imagem da Faixa de Opções do Excel

    O Excel exibe a caixa de diálogo Criar Tabela Dinâmica.

  3. Para colocar o relatório de tabela dinâmica em uma nova planilha, começando na célula A1, clique em Nova planilha e clique em Okey.

    Excel adiciona um relatório de tabela dinâmica vazio ao local especificado e exibe a Lista de campos da tabela dinâmica para que você possa adicionar campos, criar um layout e personalizar o relatório de tabela dinâmica.

  4. Para criar um relatório tabular de fluxogramas de dados, arraste o campo ID à área valores, o campo de departamento para a área de rótulos de coluna, o campo de categoria para a área de rótulos de linha e o campo AssignedTo para a área de filtro de relatório.

  5. Clique no relatório de tabela dinâmica.

  6. Na guia Inserir, no grupo gráficos, clique no tipo de gráfico de barras.

    imagem da faixa de opções do excel

  7. Na Barra 2D, escolha Barras Agrupadas.

  8. Ajuste o tamanho e a localização do relatório de gráfico dinâmico com sua preferência.

os relatórios de tabela dinâmica e gráfico dinâmico em branco

Início da página

Etapa 4: Coletar informações sobre os ativos dos usuários

Agora, se o modelo de formulário está pronto para ser preenchido por todos os funcionários, você precisa publicar o formulário e enviá-lo para cada funcionário. Quando cada funcionário submete o formulário concluído, ela é enviada como um arquivo de dados XML (. xml) anexado em uma mensagem de email à conta de email a tomadores. Os profissionais responsáveis pelas decisões pode mover todas as mensagens para uma pasta dedicada do InfoPath no Outlook. Neste cenário, é recomendável que você atribui um período de tempo específico para todos os usuários concluir os formulários para que os profissionais responsáveis pelas decisões pode executar o relatório com todos os formulários concluídos quando você atingiu o limite de coleta de dados.

inserindo dados nos formulários de controlador de ativos

  1. No InfoPath, abra o modelo de formulário (. xsn) que você salvou na etapa 1: criar o modelo de formulário de amostra do controlador de ativos

  2. No menu Ferramentas, clique em criar este formulário.

  3. No menu Arquivo, clique em Publicar.

  4. No Assistente para Publicação, clique em Para uma lista de destinatários de email e clique em Avançar.

  5. Na próxima página do assistente, na caixa Nome do modelo de formulário, digite um nome para o modelo de formulário e clique em Avançar. O nome será exibido no assunto da mensagem enviada aos destinatários de email.

  6. Opcionalmente, na próxima página do assistente, você pode criar colunas que serão exibidas em suas pastas do Outlook para ajudar a organizar suas mensagens de email.

  7. Clique em Avançar.

  8. Clique em Publicar.

  9. Após o Assistente de publicação concluir publicar o modelo de formulário, será aberta uma mensagem de email com o formulário.

  10. Preencha a mensagem, digite os nomes dos funcionários ou usar uma lista de distribuição e envie a mensagem.

No Outlook, os profissionais responsáveis pelas decisões pode organizar todos os formulários XML enviados em uma das duas maneiras:

  • Se a caixa de mensagem de pastas de formulário do InfoPath aparece na primeira vez em que a mensagem é aberta, clique em Criar pasta de formulário.

  • Crie uma regra no Outlook para mover todos os formulários do InfoPath relacionados à pasta do InfoPath.

    Para obter mais informações, consulte Gerenciar mensagens usando regras.

Início da página

Etapa 5: Importar formulários para o Excel

Como você já criou as etapas de pasta de trabalho do Excel 2 e 3, ele é uma questão simple para as decisões de exportar e analisar os dados do formulário. O criador de decisão simplesmente precisa exportar os arquivos xml (. xml) do Outlook, importar todos os arquivos de formulário (. xml) para a pasta de trabalho do Excel e, em seguida, atualizar os dados.

Tarefa 1: Exportar os formulários do Outlook para uma pasta do Windows

  1. No Outlook, selecione a pasta que contém todos os formulários que você tenha recebido de funcionários e, em seguida, pressione CTRL + A para selecionar todas as mensagens de email de formulário.

  2. Clique com botão direito na seleção, aponte para Ações do InfoPath e, em seguida, clique em Exportar formulários.

  3. Na caixa de diálogo Exportar formulários, selecione uma pasta e pressione Okey.

Tarefa 2: Importar os formulários para o Excel

  1. Na pasta de trabalho do Excel que você criou no etapa 2: mapear o arquivo de esquema e personalizar o layout da tabela no Excel, selecione uma das células mapeadas na tabela do Excel.

  2. Na guia desenvolvedor, no grupo XML, clique em Importar.

    grupo xml na faixa de opções

    A caixa de diálogo Importar XML é exibida.

  3. Em um computador que esteja executando o Windows Vista    

  4. Siga um destes procedimentos:

    • Se os arquivos forem contíguos, pressione SHIFT e clique o primeiro e o último arquivo na lista.

    • Se os arquivos não contíguos, pressione CTRL e clique em cada arquivo que você deseja importar na lista.

  5. Clique em Importar.

    tabela de dados importados do Excel

Por padrão, o Excel substitui quaisquer dados existentes nas células mapeadas, que é o resultado final desejado para esta solução de negócios. No entanto, um profissionais responsáveis pelas decisões poderia, por exemplo, importar os dados várias vezes para medir o progresso antes do prazo agendado.

Observação : No Excel, você também pode acrescentar os dados usando a opção Acrescente novos dados às tabelas XML existentes (na guia desenvolvedor, no grupo XML, clique em Propriedades do mapa ), que pode ser apropriado para outras soluções.

Para obter mais informações, consulte os tópicos da Ajuda do Excel, dados XML de importação e Acrescentar ou substituir dados XML mapeado.

Tarefa 3: Atualizar os relatórios de tabela dinâmica e gráfico dinâmico

  • Clique em uma célula no relatório de tabela dinâmica.

  • Na guia Opções, no grupo dados, clique na seta ao lado de Atualizar tudo e, em seguida, clique em Atualizar.

    .

relatório de tabela dinâmica e gráfico dinâmico final

A pasta de trabalho do Excel agora contém todos os dados e relatórios de resumo que você precisa ajudá-lo a alocar o orçamento de equipamentos para o próximo ano. Claro, você pode fazer mais análise em sua pasta de trabalho do Excel se for necessário, como classificação, filtragem ou formatação condicional os dados.

Início da página

Conclusões: considere o uso de uma lista do SharePoint ou o banco de dados do Access

Como alternativa, considere o uso de uma lista do SharePoint ou o banco de dados do Access, em vez de XML, para transferir dados entre o InfoPath e o Excel.

Usar uma lista do SharePoint

No InfoPath, você pode facilmente usar uma lista do SharePoint como uma fonte de dados somente leitura. Você pode fazer uma das duas coisas:

  • Lista do SharePoint, exporte os dados para o Excel, que cria automaticamente uma conexão de dados no Excel.

  • No Excel, crie explicitamente uma conexão de dados na lista do SharePoint.

Depois que uma conexão de dados é criado, você pode atualizar os dados do Excel para recuperar dados atualizados.

Você pode usar uma lista do SharePoint para adicionar e atualizar os dados, use um formulário do InfoPath para exibir um item da lista (por exemplo, um longo ou complexo item melhor exibida verticalmente) e, em seguida, usar o Excel para analisar melhor os dados.

combinação de infopath, lista do sharepoint e excel

1. exiba um único item para revisão fácil no InfoPath.

2. adicionar e atualizar dados em uma lista do SharePoint.

3. Atualize e relatar atualizado com o Excel.

Para obter mais informações, consulte Adicionar uma conexão de dados para uma lista ou biblioteca de documentos do SharePoint e Importar dados de uma lista do SharePoint.

Usar um banco de dados do Access

No InfoPath, você pode criar uma conexão de leitura/gravação para um banco de dados do Access. No Excel, você pode criar explicitamente uma conexão de dados no banco de dados do Access que você pode atualizar para recuperar dados atualizados. Você pode até mesmo definir a conexão para atualizar automaticamente quando a pasta for aberta ou periodicamente atualizar, tais como a cada 5 minutos.

Você pode usar um banco de dados como um intermediário entre o InfoPath e o Excel. Quando você envia um formulário do InfoPath para o Access, você pode atualizar o banco de dados do Access. Quando você atualiza a conexão de dados no Excel, você recuperar dados atualizados do Access. Na verdade, você está enviando dados indiretamente do InfoPath para uma pasta de trabalho do Excel.

combinação de infopath, acessar e excel

1. exibir e enviar um formulário para um banco de dados do Access.

2. armazenar dados em um banco de dados do Access.

3. Atualize e relatar atualizado com o Excel.

Para obter mais informações, consulte o Design de um modelo de formulário baseado em um banco de dados do Microsoft Access.

Dica : Você sabia que você pode criar um formulário do InfoPath diretamente do Access 2007? Se seus usuários tiverem o Outlook 2007 e o InfoPath 2007 instalado em seus computadores, você pode coletar dados de usuários diversos diretamente no Access 2007 usando o Assistente de coletar dados de mensagens de email. Para obter mais informações, consulte o tópico de ajuda acesso 2007, coletar dados usando mensagens de email.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×