Criar uma referência externa (link) para um intervalo de células em outra pasta de trabalho

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode fazer referência ao conteúdo de células em outra pasta de trabalho criando uma referência externa. Uma referência externa (também chamada de link) é uma referência a uma célula ou um intervalo em uma planilha em outra pasta de trabalho do Excel ou uma referência a um nome definido em outra pasta de trabalho. Você pode fazer referência ao intervalo de células específico, a um nome definido do intervalo de células ou definir um nome para a referência externa.

O que você deseja fazer?

Saiba mais sobre as referências externas

Criar uma referência externa entre células em diferentes pastas de trabalho

Criar uma referência externa para um nome definido em outra pasta de trabalho

Definir um nome que contém uma referência externa para células em outra pasta de trabalho

Saber mais sobre as referências externas

Embora as referências externas sejam semelhantes às referências de células, existem diferenças importantes. Você usa referências externas ao trabalhar com grandes quantidades de dados ou fórmulas complexas distribuídas em várias pastas de trabalho. Você as cria de modo diferente e elas são exibidas diferentemente em uma célula ou na barra de fórmulas.

Onde as referências externas podem ser usadas eficientemente

As referências externas são particularmente úteis quando não é prático manter grandes modelos de planilhas juntos na mesma pasta de trabalho.

  • Mesclar dados de várias pastas de trabalho    Você pode vincular pastas de trabalho de vários usuários ou departamentos e depois integrar os dados pertinentes em uma pasta de trabalho de resumo. Dessa maneira, quando as pastas de trabalho de origem forem alteradas, você não precisa alterar manualmente a pasta de trabalho de resumo.

  • Criar exibições diferentes de seus dados    Você pode inserir todos os seus dados em uma ou mais pastas de trabalhos de origem e criar uma pasta de trabalho de relatório que contenha referências externas apenas para os dados pertinentes.

  • Simplificar modelos complexos e grandes    Ao dividir um modelo complicado em uma sequência de pastas de trabalho interdependentes, você poderá trabalhar no modelo sem abrir todas as planilhas relacionadas. As pastas de trabalho menores são mais fáceis de se alterar, não necessitam de muita memória e abrem, salvam e calculam com mais rapidez.

Meios para criar referências externas

Se você usar uma referência de célula para criar uma referência externa, poderá também aplicar fórmulas às informações. Ao alternar entre os vários tipos de referência de célula, você também pode controlar quais células de referência estão vinculadas se você mover a referência externa. Por exemplo, se você usar uma referência relativa, quando mover a referência externa, a célula ou as células às quais ela está vinculada serão alteradas para refletir sua nova posição na planilha.

Quando você criar uma referência externa de uma pasta de trabalho para outra, deverá usar um nome para fazer referência às células às quais está vinculando. Você pode criar uma referência externa usando um nome que já esteja definido ou pode definir o nome quando criar a referência externa. Ao usar um nome, é mais fácil lembrar do conteúdo das células às quais você está vinculando. As referência externa que usam nomes definidos não são alterados quando são movidos porque um nome faz referência a uma célula ou intervalo de células específico. Se você desejar que uma referência externa que use um nome definido seja alterado ao ser movido, pode alterar o nome usado na referência externa ou pode alterar as células às quais o nome faz referência.

Qual é a aparência de uma referência externa para outra pasta de trabalho

Fórmulas com referências externas a outras pastas de trabalho são exibidas de duas maneiras, dependendo de a pasta de trabalho de origem ( aquela que fornece dados para uma fórmula ) estar aberta ou fechada.

Quando uma origem estiver aberta, a referência externa incluirá o nome da pasta de trabalho entre colchetes ([ ]), seguido do nome da planilha, um ponto de exclamação (!) e as células das quais a fórmula depende. Por exemplo, a fórmula a seguir adiciona as células C10:C25 a partir da pasta de trabalho com o nome Orçamento.xls.

Referência externa

=SOMA([Orçamento.xlsx]Anual!C10:C25)

Quando a origem não estiver aberta, a referência externa incluirá o caminho inteiro.

Referência externa

=SOMA('C:\Relatórios\[Orçamento.xlsx]Anual'!C10:C25)

Observação : Se o nome da outra planilha ou pasta de trabalho contiver caracteres não alfabéticos, você deverá colocar o nome (ou o caminho) entre aspas simples.

As fórmulas que se vinculam a um nome definido em outra pasta de trabalho usam o nome da pasta de trabalho seguido por um ponto de exclamação (!) e pelo nome. Por exemplo, a fórmula a seguir adiciona as células do intervalo denominado Vendas da pasta de trabalho Orçamento.xlsx.

Referência externa

=SOMA(Orçamento.xlsx!Vendas)

Início da página

Criar uma referência externa entre células em pastas de trabalho diferentes

  1. Abra a pasta de trabalho que conterá a referência externa (a pasta de trabalho de destino) e a pasta de trabalho com os dados aos quais você deseja vincular (a pasta de trabalho de origem).

  2. A pasta de trabalho de origem, clique em Salvar Imagem do botão na barra de Ferramentas de acesso rápido.

  3. Selecione a célula ou as células nas quais você deseja criar uma referência externa.

  4. Digite = (sinal de igual). Se você quiser executar cálculos ou funções no valor de referência externa, digite o operador ou função que você deseja que preceda a referência externa.

  5. Alterne para a pasta de trabalho de origem e, em seguida, clique na planilha que contém as células às quais você deseja vincular.

  6. Selecione a célula ou as células às quais você deseja vincular.

  7. Retorne para a pasta de trabalho de destino e observe que o Excel adiciona a referência à pasta de trabalho de origem e às células que você selecionou na etapa anterior.

  8. Opcionalmente, na planilha de destino, edite ou altere a fórmula.

  9. Pressione CTRL+SHIFT+ENTER.

Início da página

Criar uma referência externa para um nome definido em outra pasta de trabalho

  1. Abra a pasta de trabalho que conterá a referência externa (a pasta de trabalho de destino) e a pasta de trabalho com os dados aos quais você deseja vincular (a pasta de trabalho de origem).

  2. A pasta de trabalho de origem, clique em Salvar Imagem do botão na barra de Ferramentas de acesso rápido.

  3. Selecione a célula ou as células nas quais você deseja criar uma referência externa.

  4. Digite = (sinal de igual). Se você quiser executar cálculos ou funções em valor de referência externa, digite o operador ou a função que você deseja que preceda a referência externa.

  5. Na guia Exibir, no grupo Janela, clique em Alternar Janelas, clique na pasta de trabalho de origem e, em seguida, clique na planilha que contém as células às quais você deseja vincular.

    Grupo Janela na guia Exibir

  6. Pressione F3 e, em seguida, selecione o nome ao qual deseja vincular.

Início da página

Definir um nome que contenha uma referência externa para células em outra pasta de trabalho

  1. Abra a pasta de trabalho de destino e a pasta de trabalho de origem.

  2. Na pasta de trabalho de destino, na guia Fórmulas, no grupo Nomes Definidos, clique em Definir Nome.

    Imagem da Faixa de Opções do Excel

  3. Na caixa de diálogo Novo Nome, na caixa Nome, digite um nome para o intervalo.

  4. Na caixa Refere-se a, exclua o conteúdo e mantenha o cursor na caixa.

    Se o nome contiver uma fórmula, insira a fórmula e, em seguida, posicione o cursor no local onde você deseja colocar a referência externa. Por exemplo, digite =SOMA() e posicione o cursor entre os parênteses.

  5. Na guia Exibir, no grupo Janela, clique em Alternar Janelas, clique na pasta de trabalho de origem e, em seguida, clique na planilha que contém as células às quais você deseja vincular.

    Grupo Janela na guia Exibir

  6. Selecione a célula ou o intervalo de células ao qual deseja vincular.

  7. Na caixa de diálogo Novo Nome, clique em OK.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×