Criar um relatório agrupado ou de resumo

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Informações muitas vezes é mais fácil de compreender quando ele é dividido em grupos. Por exemplo, um relatório que agrupe as vendas por região pode realçar tendências que não seriam notadas. Além disso, colocar os totais no final de cada grupo no relatório pode substituir muita interação manual com uma calculadora.

Microsoft Office Access 2007 facilita a trabalhar com relatórios agrupados. Você pode criar um relatório agrupado básico usando o Assistente de relatório, você pode adicionar agrupamento e classificação a um relatório existente ou você pode revisar agrupamento e classificação opções que já foram definidas.

Neste artigo

Noções básicas sobre agrupamento, seções de relatório e controles

Compilar um novo relatório agrupado usando o Assistente de Relatório

Ajustar seu relatório

Adicionar campos ou outros controles a um relatório existente

Adicionar ou modificar agrupamento e classificação em um relatório existente

Salvar, imprimir ou enviar seu relatório

Comentários

Noções básicas sobre agrupamento, seções de relatório e controles

Se você estiver começando a usar relatórios agrupados, é útil para ter algumas informações gerais sobre agrupamento e classificação, bem como as seções de relatório diferente e tipos de controles. Se você se sentir confortável com esses conceitos já, você pode pular esta seção e vá para a seção criar um novo relatório agrupado usando o Assistente de relatório.

Sobre o agrupamento e classificação

Quando você imprime um relatório, você geralmente deseja organizar os registros em uma ordem específica. Por exemplo, se você estiver imprimindo uma lista de fornecedores, talvez você queira classificar os registros em ordem alfabética pelo nome da empresa.

Em vários relatórios, os registros de classificação não é suficiente. Você também pode querer dividi-los em grupos. Um grupo é um conjunto de registros, juntamente com as informações de apresentação e de resumo exibidas com os registros, como um cabeçalho. Um grupo consiste em um cabeçalho de grupo aninhado grupos (se houver), registros de detalhe e um rodapé de grupo.

Agrupamento permite que você separe grupos de registros visualmente e exibir dados de apresentação e de resumo para cada grupo. Por exemplo, o relatório a seguir agrupa as vendas por data de envio e calcula a quantidade total de vendas para cada dia.

Relatório agrupado com totais

1. a data apresenta o grupo.

2. o total resume o grupo.

Você pode ver como o agrupamento funciona comparando a lista de produtos por relatório de categoria (mostrado na ilustração a seguir) para a folha de dados para sua consulta subjacente, lista de produtos. O relatório e os produtos de classificação de consulta por categoria, mas o relatório também imprime o nome de cada categoria em uma linha separada no início de cada grupo (no cabeçalho de grupo) e o número de produtos para cada categoria em uma linha separada no final de cada grupo (no rodapé de grupo).

Produtos por relatório de Categoria

1. o nome da categoria aparece em cada linha na folha de dados.

2. o nome da categoria aparece uma vez para cada grupo no relatório, no cabeçalho do grupo.

3. o total para a categoria aparece no final de cada grupo, no rodapé do grupo.

4. os registros são exibidos como um grande grupo na folha de dados.

5. os registros de cada categoria aparecem como uma seção separada no relatório, precedidos por um cabeçalho de grupo e seguido por um rodapé de grupo.

Você pode agrupar quaisquer campos e expressões que você classificar (até 10). Você pode agrupar o mesmo campo ou expressão mais de uma vez. Quando você agrupa em mais de um campo ou expressão, Office Access 2007 aninha os grupos de acordo com seu nível de grupo. O primeiro campo que você agrupa é o nível de grupo de primeiro e mais significativo; o segundo campo agrupado é o próximo nível de grupo; e assim por diante. A ilustração a seguir mostra como Office Access 2007 aninha os grupos.

Hierarquia cabeçalho rodapé

1. cada cabeçalho de grupo possui um rodapé de grupo.

Você normalmente usa um cabeçalho de grupo para exibir dados que identificam o grupo em uma seção separada no início do grupo. Use um rodapé de grupo para resumir os dados no grupo em uma seção separada no final do grupo.

Início da página

Sobre as seções de relatório

No Access, o design de um relatório é dividido em seções. Para criar relatórios úteis, você precisa compreender como funciona a cada seção. Por exemplo, a seção na qual você optar por inserir um controle calculado determina como o Access calcula os resultados. A lista a seguir mostra um resumo dos tipos de seção e seus usos.

  • Cabeçalho do relatório    Impresso uma vez no início do relatório. Use o cabeçalho do relatório para informações que normalmente apareceriam em uma página de rosto, como um logotipo, ou um título e uma data. Cabeçalho do relatório imprime antes do cabeçalho de página. Quando você coloca um controle calculado no cabeçalho do relatório, o valor é calculado para o relatório inteiro. Por exemplo, colocando um controle que usa a função agregada soma no cabeçalho do relatório calcula a soma de todo o relatório.

  • Cabeçalho da página    Impressa na parte superior de cada página. Use um cabeçalho de página, por exemplo, para repetir o título do relatório em cada página.

  • Cabeçalho de grupo    Impresso no início de cada novo grupo de registros. Use o cabeçalho do grupo para imprimir o nome do grupo. Por exemplo, em um relatório agrupado por produto, use o cabeçalho do grupo para imprimir o nome do produto. Quando você coloca um controle calculado que usa a função agregada soma no cabeçalho do grupo, a soma é para o grupo atual.

  • Detalhes    Impresso uma vez para cada linha na fonte de registro. A seção detalhe é onde você coloca os controles que compõem o corpo principal do relatório.

  • Rodapé de grupo    Impressa no final de cada grupo de registros. Use um rodapé de grupo para imprimir informações de resumo para um grupo.

  • Rodapé da página    Impressa no final de cada página. Use um rodapé de página para os números de página para impressão ou informações por página.

  • Rodapé do relatório    Impresso uma vez no final do relatório. Use o rodapé do relatório para imprimir totais do relatório ou outras informações de resumo para o relatório inteiro.

    Observação : No modo Design, o rodapé do relatório aparece abaixo do rodapé da página. No entanto, quando o relatório é impresso ou visualizado, o rodapé do relatório aparece acima de rodapé da página, logo após a última grupo rodapé ou detalhe linha na página final.

Início da página

Sobre controles

Controles são objetos que exibem dados, executam ações e permitem visualizar e trabalhar com informações que aprimoram a interface do usuário, como rótulos e imagens. Access oferece suporte a três tipos de controles: acoplado, não acoplado e calculado. A lista a seguir mostra um resumo desses controles e seus usos.

  • Controle acoplado    Um controle cuja fonte de dados é um campo em uma tabela ou consulta. Use controles acoplados para exibir valores de campos no banco de dados. Os valores podem ser texto, datas, números, valores Sim/Não, imagens ou gráficos. Uma caixa de texto é o tipo mais comum de controle acoplado. Por exemplo, uma caixa de texto em um formulário que exibe o sobrenome do funcionário pode receber essas informações do campo Sobrenome na tabela Funcionários.

  • Controle de desvinculado    Um controle que não tem uma fonte de dados. Você pode usar controles não acoplados para exibir informações, linhas, retângulos e imagens. Por exemplo, um rótulo que exibe o título de um relatório é um controle não acoplado.

  • Controle calculado    Um controle cuja fonte de dados é uma expressão em vez de um campo. Você pode especificar o valor que você deseja no controle definindo uma expressão como fonte de dados para o controle. Uma expressão é uma combinação de operadores (como = e + ), nomes, nomes de campo, funções que retornam um único valor e valores constantes de controle. Por exemplo, a expressão a seguir calcula o preço de um item com um desconto de 25% multiplicando o valor no campo preço unitário por um valor constante (. 75).

= [Unit Price] * .75

Uma expressão pode usar dados a partir de um campo na tabela ou consulta base do relatório ou um controle no relatório.

Quando você cria um relatório, ele é provavelmente mais eficiente para adicionar e organizar todos os controles acoplados primeiro, especialmente se elas compõem a maioria dos controles no relatório. Em seguida, você pode adicionar os controles não acoplados e calculados que concluir o design usando as ferramentas no grupo controles da guia Design.

imagem da faixa de opções do access

Vincular um controle a um campo identificando o campo do qual o controle obtém seus dados. Você pode criar um controle que esteja vinculado ao campo selecionado arrastando o campo do painel Lista de campos para o relatório. (O painel Lista de campos exibe os campos da tabela ou consulta base do relatório. Para exibir o painel Lista de campos, siga um destes procedimentos:

  • Na guia Design, no grupo Ferramentas, clique em Adicionar campo existente. Texto explicativo 4

  • Pressione ALT+F8.

Quando você clique duas vezes em um campo ou arraste-o do painel Lista de campos para o relatório, você pode criar um controle acoplado.

Como alternativa, você pode vincular a um campo a um controle digitando o nome do campo no próprio controle ou na caixa para o valor de OrigemDoControle na folha de propriedades do controle. Folha de propriedades define as características do controle, como seu nome, a fonte de dados e seu formato. Para exibir a folha de propriedades, pressione F4.

Usando o painel Lista de campos é a melhor maneira de criar um controle acoplado por duas razões:

  • Um controle acoplado tem um rótulo anexado, e o rótulo recebe o nome do campo (ou a legenda definida para esse campo na tabela ou consulta subjacente) sua legenda por padrão, para que você não precise digitar a legenda.

  • Um controle acoplado herda muitos das mesmas configurações do campo na tabela ou consulta (como as propriedades Formatar, CasasDecimaise MáscaraDeEntrada ) subjacente. Portanto, você pode ter certeza de que essas propriedades do campo permanecem os mesmos sempre que você criar um controle que está vinculado a esse campo.

Se você já tiver um controle não acoplado e deseja vinculá-lo a um campo, defina a propriedade OrigemDoControle do controle como o nome do campo.

Início da página

Compilar um novo relatório agrupado usando o Assistente de Relatório

O Assistente de Relatório apresenta uma série de perguntas e depois gera um relatório com base nas suas respostas. Entre essas perguntas, há uma que pede os campos a serem usados para agrupar seu relatório. Depois que o relatórtio é criado, você pode usá-lo como está ou modificá-lo de acordo com as suas necessidades. Antes de iniciar o Assistente de Relatório, é necessário decidir a fonte de dados.

Escolha uma fonte de registro

Um relatório consiste em informações extraídas de uma tabela ou consulta e informações armazenadas com o design de relatório, como rótulos, títulos e elementos gráficos. A tabela ou consulta que fornece os dados subjacentes também é conhecido como fonte de registro do relatório. Antes de começar a criar seu relatório, você deve primeiro pensar sobre as informações que você deseja incluir. Entre os campos que você escolher deve ser aqueles que você deseja agrupar ou resumir. Se os campos que você deseja incluir todos existirem em uma única tabela, use essa tabela como fonte de registro. Se os campos são extraídos de mais de uma tabela, convém usar uma consulta como fonte de registro. Essa consulta pode já existir no banco de dados ou talvez você precise criar uma consulta especificamente para atender às necessidades do seu relatório.

Para saber mais sobre consultas, siga os links na seção Consulte também deste artigo.

Iniciar o Assistente de Relatório

  1. Na guia criar, no grupo relatórios, clique em Assistente de relatório. Texto explicativo 4

    O Access inicia o Assistente de Relatório.

    Seleção de campos no Assistente de Relatório

  2. Clique na lista suspensa Tabelas/Consultas e escolha a tabela ou consulta contendo os campos que você quer incluir em seu relatório.

  3. Clique duas vezes nos campos da lista Campos Disponíveis para escolhê-los.

    O Access os move para a lista Campos Selecionados. Alternativamente, você pode clicar nos botões localizados entre a caixa Campos Disponíveis e a caixa Campos Selecionados para adicionar ou remover o campo selecionado, ou para adicionar ou remover todos os campos.

  4. Se houver campos em outra tabela ou consulta que você também queira colocar em seu relatório, clique na lista suspensa Tabelas/Consultas novamente, escolha a outra tabela ou consulta e continue a adicionar campos.

  5. Após terminar de adicionar campos, clique em Avançar.

Agrupar registros no Assistente de Relatório

O agrupamento permite organizar registros por grupo, como por Região ou Vendedor. Os grupos podem ser aninhados, para que você possa identificar facilmente as relações entre os grupos e encontrar as informações desejadas facilmente. Você também pode usar o agrupamento para calcular informações de resumo, como totais e porcentagens.

Quando você inclui mais de uma tabela em um relatório, o assistente examina as relações entre as tabelas e determina como você talvez queira exibir as informações.

  1. Na página do Assistente de Relatório que pergunta Deseja adicionar algum nível de agrupamento?, clique em um dos nomes de campo na lista e clique em Avançar.

  2. Para adicionar níveis de agrupamento, clique duas vezes em qualquer um dos nomes de campos da lista para adicioná-los ao relatório.

    Você também pode remover um nível de agrupamento clicando duas vezes na exibição da página no lado direito da caixa de diálogo. Use os botões de direção para adicionar e remover níveis de agrupamento, e ajustar a prioridade de um nível de agrupamento selecionando-o e clicando nos botões para elevar ou baixar a prioridade. O Access adiciona cada nível de agrupamento e o mostra aninhado dentro de seu nível de agrupamento pai.

    adicionando níveis de agrupamento no assistente de relatório

  3. Clique em Opções de Agrupamento para exibir a caixa de diálogo Intervalos de Agrupamento.

    Intervalos de Agrupamento no Assistente de Relatório

  4. Opcionalmente, para cada campo no nível do grupo, escolha um intervalo de agrupamento.

    O intervalo de agrupamento permite que você personalize como os registros são agrupados. Na ilustração anterior, os registros são agrupados no campo DataDeEnvio, que é a data/hora tipo. O Assistente de relatório oferece opções apropriadas para o tipo de campo na lista de intervalos de agrupamento. Portanto, como DataDeEnvio é um tipo de data/hora, você pode escolher agrupar pelo valor real (Normal), ano, trimestre, mês, semana, dia, horas e minutos. Se o campo fosse um tipo de dados de texto, você pode escolher agrupar por todo o campo (Normal) ou talvez pelos primeiros cinco caracteres. Para um tipo de dados numéricos, você pode escolher agrupar por valor (Normal), ou intervalo em incrementos selecionados.

    Após selecionar um intervalo de agrupamento, clique em OK.

  5. Clique em Avançar para navegar para a próxima página do assistente.

Classificar e resumir registros

Você pode classificar os registros por até quatro campos, em ordem crescente ou decrescente.

  1. Clique na primeira lista suspensa e escolha um campo para classificar.

    Você pode clicar no botão à direita da lista para alternar entre ordem crescente e decrescente (Crescente é o padrão). Opcionalmente, clique na segunda, terceira e quarta lista suspensa para escolher campos de classificação adicionais.

    Ordens de classificação no Assistente de Relatório

  2. Clique em Opções de Resumo se desejar resumir qualquer um dos campos numéricos.

    Observe que o botão Opções de Resumo só estará visível se você tiver um ou mais campos numéricos na seção Detalhe do seu relatório. O assistente exibe os campos numéricos disponíveis.

    Opções de Resumo no Assistente de Relatório

  3. Marque a caixa de seleção na sua opção de Soma, Média, Mín ou Máx para incluir esses cálculos no rodapé do grupo.

    Você também pode optar por mostrar os detalhes e o resumo ou só o resumo. No último caso, os totais de cada valor de DataDeEnvio são mostrados (se você marcou a caixa de seleção para Soma, por exemplo), mas o detalhe do pedido é omitido. Você também pode optar por mostrar a porcentagem dos cálculos totais para as somas.

  4. Clique em OK.

  5. Siga as instruções das páginas restantes do Assistente de Relatório. Na última página, você pode editar o título do relatório. Esse título será exibido na primeira página do relatório, e o Access também salvará o relatório, usando o título como nome do documento. Você pode editar o título e o nome do documento mais tarde.

  6. Clique em Concluir. O Access salva automaticamente o relatório e o exibe na Visualização de Impressão, que mostra como será a aparência do relatório quando impresso.

Você pode usar os botões de navegação na parte inferior do painel de visualização para exibir as páginas do relatório sequencialmente ou pular para qualquer página do relatório. Clique em um dos botões de navegação ou digite o número da página que você quer ver na caixa de número da página. Em seguida, pressione ENTER.

Na Visualização de Impressão, você pode ampliar para ver detalhes ou reduzir para ver como os dados estão posicionados na página. Com o ponteiro do mouse posicionado sobre o relatório, clique uma vez. Para reverter o efeito do zoom, clique novamente. Você também pode usar o controle de zoom da barra de status.

Início da página

Ajustar seu relatório

É provável que o Assistente de relatório não produzirá os resultados exatos que você está procurando em seu relatório. Por exemplo, talvez você queira adicionar texto, ajuste as larguras de coluna, adicionar um logotipo, etc. O Access fornece dois modos de exibição no qual você pode fazer modificações ao seu relatório: exibição de Layout e Design. Estes são discutidos resumidamente nesta seção.

Sobre o modo de exibição de Layout

Modo de exibição de layout é o modo de exibição mais fáceis de usar para fazer alterações de relatório e fornece a maioria das ferramentas que necessárias para ajustar seu relatório. Você pode ajustar as larguras de coluna, reorganizar as colunas e adicionar ou modificar níveis de agrupamento e totais. Você pode colocar novos campos no design do relatório e defina as propriedades do relatório e seus controles. A vantagem de modo de exibição de Layout é que você pode ver seus dados ao fazer alterações no formato de relatório, para que você possa ver imediatamente como as alterações afetam a exibição de dados.

Para abrir um relatório no modo de exibição de Layout, clique com botão direito no relatório no painel de navegação e clique em modo Layout Texto explicativo 4 .

Você pode usar a folha de propriedades para modificar as propriedades de relatório e seus controles e seções. Para exibir a folha de propriedades, pressione F4.

Você pode usar o painel Lista de campos para adicionar campos de tabela ou consulta base para o design do relatório. Para mostrar o painel Lista de campo:

  1. Na guia Formatar, no grupo controles, clique em Adicionar campos existentes Texto explicativo 4 .

    Dica : Access 2010 inclui novos recursos de formatação condicionais que podem melhorar a legibilidade de um relatório.

Sobre o modo de exibição de Design

Se não for possível fazer uma alteração específica em seu relatório no modo de exibição de Layout, tente o modo Design. Modo de exibição de design mostra a estrutura subjacente do relatório e fornece que alguns desenvolvam mais ferramentas e recursos que o modo de exibição de Layout. Por exemplo, você pode colocar uma maior variedade de controles no relatório, você pode ajustar o alinhamento dos controles com mais precisão e você tem a capacidade de definir propriedades mais do que você pode fazer no modo de exibição de Layout.

Para abrir um relatório no modo Design, clique com botão direito no relatório no painel de navegação, clique em Modo Design Texto explicativo 4 .

Início da página

Adicionar campos ou outros controles a um relatório existente

Cada campo, rótulo, linha ou imagem que você vê em seu relatório é criada usando algum tipo de controle. O controle usado com mais frequência em um relatório é a caixa de texto. Este é o que normalmente é usado para exibir dados da fonte de registro subjacente do relatório. Você pode criar caixas de texto que já estão vinculadas aos campos na fonte de registro adicionando campos do painel Lista de campo, ou você pode adicioná-los ao relatório enquanto estiver trabalhando no modo de exibição de Design (mas, em seguida, você deve "vincular"-las aos campos na fonte de registro por conta própria). A vantagem de modo de exibição é que você pode adicionar vários outros tipos de controles além de Design vinculado caixas de texto, como retângulos, quebras de página e gráficos. Esta seção descreve os dois métodos para adicionar controles a um relatório.

Adicionar campos a um relatório existente

Modo de exibição de layout é o recomendado para adicionar campos a um relatório, mas ele também pode ser feito no modo Design. Para adicionar um campo, primeiro certifique-se de que o painel Lista de campos é exibido. O painel Lista de campos contém uma lista de todos os campos que estão disponíveis para ser colocado no relatório. Para exibir o painel Lista de campo, pressione ALT + F8.

Adicionar campos do painel lista de campo

  • Para adicionar um único campo, arraste o campo do painel Lista de campos para a seção no relatório onde deseja que ele exibido.

  • Para adicionar vários campos ao mesmo tempo, clique no primeiro campo desejado e, em seguida, mantenha pressionada a tecla CTRL e clique em cada campo adicional desejado. Em seguida, arraste os campos selecionados para o relatório.

Quando você solta os campos, o Access cria um controle de caixa de texto acoplado para cada campo e automaticamente posiciona um controle de rótulo ao lado de cada campo.

Observação : 

  • Se você adicionar um campo de uma tabela relacionada, o Access adicionará o nível de agrupamento apropriado para você.

  • Se você adicionar um campo de outra tabela (não relacionadas), o Access exibirá uma caixa de diálogo onde você pode especificar como relacionar a tabela à fonte de dados existente para o relatório.

Para ver quais relações de tabela já foram especificadas para seu banco de dados, ou para adicionar novos:

  1. Na guia Ferramentas de banco de dados, no grupo Mostrar/ocultar, clique em relações. Texto explicativo 4

Para obter mais informações, consulte o artigo criar, editar ou excluir uma relação.

Adicionar outros controles a um relatório existente

Quando você adicionar um campo do painel Lista de campos ao relatório, um controle de caixa de texto acoplado para ele será criado automaticamente. Outros controles como rótulos, linhas e imagens podem ser adicionados alternando para o modo Design e usando as ferramentas no grupo controles na guia Design.

imagem da faixa de opções do access

Determinar o nome de uma ferramenta

  • Coloque o ponteiro do mouse sobre a ferramenta.

    Access exibe o nome da ferramenta.

Criar um controle usando as ferramentas no grupo controles

  • Clique na ferramenta do tipo de controle que você deseja adicionar. Por exemplo, para criar uma caixa de seleção, clique na ferramenta de caixa de seleção Texto explicativo 4 .

  • Clique no design de relatório onde você deseja posicionar o canto superior esquerdo do controle. Clique uma vez para criar um controle com tamanho padrão, ou clique e arraste no relatório para criar um controle do tamanho desejado.

  • Se você não posicionar o controle perfeitamente na primeira tentativa, você pode movê-la usando o procedimento a seguir:

    • Clique no controle para selecioná-lo.

    • Posicione o ponteiro sobre o controle até que ele se transformar em uma seta de quatro pontas ponteiro mover e, em seguida, arraste o controle para o local desejado.

Esse processo cria um controle "não acoplado". Se o controle é o tipo que pode exibir dados (uma caixa de texto ou caixa de seleção, por exemplo), você precisará inserir um nome de campo ou expressão na propriedade Fonte do controle do controle antes que ele exibirá todos os dados.

Exibir a folha de propriedades

  • Pressione F4.

Observação : Quando seu novo relatório estiver concluído, certifique-se de salvar seu trabalho.

Início da página

Adicionar ou modificar agrupamento e classificação em um relatório existente

Se você tem um relatório existente e quer adicionar classificação ou agrupamento a ele, ou se quer modificar a classificação ou agrupamento existente do relatório, esta seção o ajuda a começar.

Adicionar agrupamento, classificação e totais no modo de exibição de Layout

Você pode executar simples de classificação, agrupamento e totalizando operações clicando campos no modo de exibição de Layout e, em seguida, escolhendo a operação desejada no menu de atalho. Para alternar para modo de exibição de Layout, clique com botão direito no relatório no painel de navegação e clique em modo Layout Texto explicativo 4 .

Observação : Embora as instruções desta seção não usem o painel Agrupar, Classificar e Total diretamente, é uma boa ideia abrir o painel e observar como ele muda conforme você trabalha. Você terá uma ideia melhor do que o Access está fazendo e, conforme for se sentindo mais à vontade ao trabalhar com o painel Agrupar, Classificar e Total, poderá usá-lo para fazer ajustes adicionais em seu relatório. Para exibir o painel Agrupar, Classificar e Total:

  1. Na guia Formatar, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

Classificar em um único campo

  • Clique com botão direito qualquer valor no campo que você deseja classificar.

  • No menu de atalho, clique na opção de classificação desejada. Por exemplo, para classificar um campo de texto em ordem crescente, clique em Classificar de a Z Texto explicativo 4 . Para classificar um campo numérico em ordem decrescente, clique em Classificar do maior para o menor Texto explicativo 4 .

O Access classifica o relatório conforme você especificou. Se o painel Agrupar, Classificar e Total estiver aberto, você poderá ver que uma nova linha Classificar por para o campo foi adicionada.

Classificar em vários campos

Observação : Quando você aplicar classificação clicando em um campo no modo de exibição de Layout, você só pode classificar um campo por vez. Aplicação de classificação para outro campo remove a classificação no primeiro campo. Isso difere do comportamento de classificação em formulários, onde várias ordens de classificação podem ser feitas clicando cada campo alternadamente e a escolher a ordem de classificação desejada. Para criar vários níveis de classificação, consulte a seção Adicionar agrupamento, classificação e totais usando o painel Agrupar, classificar e Total.

Agrupar em um campo

  • Clique com o botão direito do mouse em qualquer valor no campo em que você queira agrupar.

  • No menu de atalho, clique em Agrupar Texto explicativo 4 .

O Access adiciona o nível de agrupamento e cria um cabeçalho de grupo para ele. Se o painel Agrupar, Classificar e Total estiver aberto, você poderá ver que uma nova linha Agrupar para o campo foi adicionada.

Adicionar um total a um campo

Esta opção permite calcular uma soma, média, contagem ou outra agregação para um campo. Um total geral é adicionado ao fim do relatório, e totais de grupo são adicionados aos grupos existentes no relatório.

  • Clique com o botão direito do mouse em qualquer valor do campo que você queira totalizar.

  • Clique em Total.

  • Clique na operação que você deseja realizar: Soma, Média, Contar Registros (para contar todos os registros), Contar Valores (para contar apenas os registros com um valor neste campo), Máx, Mín, Desvio Padrão ou Variação.

O Access adiciona um controle de caixa de texto calculado ao rodapé do relatório, que cria um total geral. Além disso, se seu relatório tiver níveis de agrupamento, o Access adicionará rodapés de grupo (se já não estiverem presentes) e colocará o total em cada rodapé.

Você pode também adicionar totais clicando no campo que você deseja totalizado e, na guia Formatar, no grupo agrupamento e totais, clique em totais Texto explicativo 4 .

Adicionar agrupamento, classificação e totais usando o painel Agrupar, Classificar e Total

Ao trabalhar no painel Agrupar, Classificar e Total, você contará com máxima flexibilidade quando quiser adicionar ou modificar grupos, ordens de classificação ou opções de totais em um relatório. Novamente, o modo Layout é o modo de exibição preferido no qual trabalhar, pois é muito mais fácil ver como suas alterações afetam a exibição dos dados.

Exibir o painel Agrupar, Classificar e Total

  • No modo de exibição de Layout:

    Na guia Formatar, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

  • No modo de Design:

    Na guia Design, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

Access exibe o painel Agrupar, classificar e Total.

painel agrupar, classificar e total

Para adicionar um novo nível de agrupamento ou classificação, clique em Adicionar um grupo ou Adicionar uma classificação.

Uma nova linha é adicionada ao painel Agrupar, Classificar e Total, e uma lista de campos disponíveis é exibida.

Lista de campos no painel Agrupar, Classificar e Total

Você pode clicar em um desses nomes de campo ou você pode clicar em expressão abaixo da lista de campos para inserir uma expressão. Depois que você escolha um campo ou insere uma expressão, o Access adiciona o nível de agrupamento ao relatório. Se você estiver no modo de exibição de Layout, a tela é alterada imediatamente para mostrar o agrupamento ou ordem de classificação.

Observações : 

  • Se já há diversos níveis de classificação ou agrupamento definidos, pode ser necessário rolar para baixo no painel Agrupar, Classificar e Total para ver os botões Adicionar um grupo e Adicionar uma classificação.

  • É possível definir até 10 níveis de agrupamento e classificação em um relatório.

Alterar as opções de agrupamento

Cada nível de classificação ou agrupamento tem um número de opções que podem ser definidas para obter os resultados desejados.

Opções de agrupamento

  • Para exibir todas as opções de um nível de agrupamento ou classificação, clique em Mais no nível que você deseja alterar.

    Opções de agrupamento (expandidas)

  • Para ocultar as opções, clique em Menos.

Ordem de classificação    Você pode alterar a ordem de classificação clicando na lista suspensa de ordem de classificação e depois clicando na opção desejada.

Intervalo do grupo    Esta configuração determina como os registros são agrupados juntos. Por exemplo, você pode agrupar com base no primeiro caractere de de um campo de texto, de forma que todos que comecem com "A" sejam agrupados juntos, todos que comecem com "B" e assim por diante. Para um campo de data, é possível agrupar por dia, semana, mês, trimestre, ou você pode inserir um intervalo personalizado.

Totais    Para adicionar totais, clique nesta opção. Você pode adicionar totais em vários campos e pode fazer vários tipos de totais no mesmo campo.

Janela pop-up Totais

  • Clique na seta suspensa Total em e selecione o campo a ser resumido.

  • Clique na seta suspensa Tipo e selecione o tipo de cálculo a ser realizado.

  • Selecione Mostrar Total Geral para adicionar um total geral ao fim do relatório (no rodapé).

  • Selecione Mostrar totais de grupo como % do total geral para adicionar um controle ao rodapé do grupo que calcule a porcentagem do total geral para cada grupo.

  • Selecione Mostrar cabeçalho de grupo ou Mostrar rodapé de grupo para exibir o total no local desejado.

Após todas as opções terem sido escolhidas para um campo, você poderá repetir o processo e resumir outro campo, selecionando-o na lista suspensa Total em. Caso contrário, clique fora da janela pop-up Totais para fechá-la.

Título    Permite alterar o título do campo que está sendo resumido. É usado para o título da coluna e para rotular os campos de resumo nos cabeçalhos e rodapés.

Para adicionar ou modificar o título:

  • Clique no texto azul após com título.

    A caixa de diálogo Zoom é exibida.

  • Digite o novo título na caixa de diálogo e clique em OK.

Com/sem uma seção de cabeçalho    Use esta configuração para adicionar ou remover a seção de cabeçalho que precede cada grupo. Quando uma seção de cabeçalho é adicionada, o Access move o campo de agrupamento para o cabeçalho. Quando você remove uma seção de cabeçalho que contém outros controles além do campo de agrupamento, o Access pede confirmação para excluir os controles.

Com/sem uma seção de rodapé    Use esta configuração para adicionar ou remover a seção de rodapé após cada grupo. Quando você remove uma seção de rodapé que contém controles, o Access pede confirmação para excluir os controles.

Manter o grupo    Esta configuração determina como os grupos são dispostos na página quando o relatório é impresso. Convém manter os grupos juntos tanto quanto possível para o usuário não ter de ficar virando páginas para ver o grupo inteiro. Entretanto, isso geralmente aumenta a quantidade de papel necessária para imprimir o relatório, pois a maioria das páginas terá algum espaço em branco na parte inferior.

  • Não manter o grupo em uma mesma página    Use esta opção se você não estiver preocupado com os grupos serem quebrados por quebras de página. Por exemplo, um grupo de 30 itens pode ter 10 itens na parte inferior de uma página e os 20 itens restantes na parte superior da página seguinte.

  • Manter todo o grupo em uma única página    Esta opção ajuda a minimizar o número de quebras de página em um grupo. Se um grupo não couber no espaço restante de uma página, o Access deixará esse espaço em branco e começará o grupo na página seguinte. Grupos grandes ainda poderão abranger várias páginas, mas esta opção minimiza o número de quebras de página dentro do grupo tanto quanto possível.

  • Manter o cabeçalho e o primeiro registro em uma mesma página    Para grupos com cabeçalhos de grupo, isto assegura que o cabeçalho de grupo não seja impresso sozinho na parte inferior de uma página. Se o Access determinar que não há espaço suficiente para que pelo menos uma linha de dados seja impressa após o cabeçalho, o grupo começará na página seguinte.

Alterar a prioridade dos níveis de agrupamento e classificação

Para alterar a prioridade de um nível de agrupamento ou classificação, clique na linha no painel Agrupar, Classificar e Total e depois clique na seta para cima ou para baixo no lado direito da linha.

Excluir níveis de agrupamento e classificação

Para excluir um nível de agrupamento ou classificação, clique na linha a ser excluída no painel Agrupar, Classificar e Total e pressione a tecla DELETE ou clique no botão Excluir no lado direito da linha. Quando você exclui um nível de agrupamento, se o campo de agrupamento estava no cabeçalho ou rodapé de grupo, o Access o move para a seção Detalhe do relatório. Todos os outros controles que estavam no cabeçalho ou rodapé de grupo são excluídos.

Início da página

Criar um relatório de resumo (sem detalhes do registro)

Se você quiser mostrar apenas totais (ou seja, apenas as informações nas linhas de cabeçalho e rodapé), na guia Formatar (ou na guia Design, no modo Design), no grupo agrupamento e totais, clique em Ocultar detalhes. Isso oculta os registros no próximo nível inferior de agrupamento, resultando em uma apresentação muito mais compacta dos dados de resumo. Embora os registros estiverem ocultas, os controles na seção oculto não são excluídos. Clique em Ocultar detalhes novamente para restaurar as linhas de detalhes para o relatório.

Criar um efeito de agrupamento sem usar cabeçalhos

Você pode obter um efeito de agrupamento em seu relatório sem o uso de cabeçalhos. Removendo cabeçalhos cria um relatório mais compacto porque menos espaço vertical é usado pelas linhas de cabeçalho.

O procedimento geral envolve remover cabeçalho para cada grupo, que move cada campo de agrupamento para a seção de detalhes do relatório. Para restaurar o efeito de agrupamento visual, você pode definir a propriedade Ocultar duplicatas de cada campo de agrupamento para Sim.

Exemplo

Considere este relatório agrupado típico que usa cabeçalhos de grupo:

Relatório agrupado com cabeçalhos de grupo

Como você pode ver, cada nome de empresa ocupa uma linha inteira, como faz cada pedido.

Neste exemplo, você irá editar o relatório para que ele se parece com a ilustração a seguir:

relatório agrupado com cabeçalhos de grupo removidos

  1. Abra o relatório no modo Layout clicando-la no painel de navegação e clicando em Modo Layout Texto explicativo 4 .

  2. Na guia Formatar, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

    Observação : É recomendável iniciar com o grupo de nível mais baixo e gradativamente para cima; Caso contrário, a exibição do relatório pode se tornar confusa enquanto você está trabalhando.

  3. Clique no nível de agrupamento mais baixo na lista e, em seguida, clique em mais.

  4. Na lista suspensa de seção de cabeçalho, selecione sem uma seção de cabeçalho.

    Quando você remove um cabeçalho, o Access preserva a caixa de texto para o campo de agrupamento movendo-o para a seção de detalhes. No entanto, quaisquer outros controles no cabeçalho de grupo podem ser excluídos. Access avisa se quaisquer controles vai ser excluída como resultado esta ação. Se houver controles no cabeçalho de grupo que você deseja preservar, certifique-se de movê-las para outra seção de relatório antes de executar esta etapa. Você precisa alternar para modo de Design para mover os controles para outras seções.

    O relatório resultante é mostrado na ilustração a seguir. Observe que a primeira CódigoDoPedido na mesma linha que o primeiro registro de detalhe, em vez de em sua própria linha.

    relatório agrupado com cabeçalho do códigodopedido removido

    Infelizmente, o OrderID repete em cada linha de detalhe, e isso dificulta ver exatamente quantos pedidos existem. Neste ponto, a configuração de propriedade de Ocultar duplicatas do controle de caixa de texto é útil. Siga estas etapas para definir essa propriedade:

    • Selecione um dos valores de repetição.

    • Se a folha de propriedades não estiver sendo exibida, pressione F4 para exibi-la.

    • Na guia formato da folha de propriedades, clique na lista suspensa para Ocultar duplicatas e, em seguida, clique em Sim.

      As IDs de pedido duplicados estão ocultas. Observe que você pode ver quantos pedidos lá estão e quantos produtos lá estão por ordem.

      Relatório agrupado com códigos de pedidos repetidos ocultos

  5. Neste exemplo, podemos Repita a etapa 4 para o nível de agrupamento do nome da empresa. O relatório final parece com a ilustração a seguir:

    relatório agrupado com cabeçalhos de grupo removidos

    O valor de nome de empresa agora está na mesma linha que o primeiro registro de detalhe, e a propriedade Ocultar duplicatas impede que o valor de nome da empresa em cada linha de repetição. Para um relatório de tempo que usa vários níveis de agrupamento, isso pode resultar em uma economia de papel significativo.

Início da página

Salvar, imprimir ou enviar seu relatório

Depois de salvar o design do relatório, você pode usar várias vezes. O design do relatório permanece o mesmo, mas você verá dados atuais sempre que você imprimir o relatório. Se alterar suas necessidades de relatório, você pode modificar o design de relatório ou criar um novo relatório semelhante com base no original.

Salvar seu relatório

  1. Clique em imagem do botão office o Botão Microsoft Office e, em seguida, clique em Salvar ou pressione CTRL + S Texto explicativo 4 .

    Como alternativa, você pode clicar em Salvar Texto explicativo 4 na barra de Ferramentas de acesso rápido.

  2. Se o relatório estiver sem título, digite um nome na caixa Nome do relatório e clique em OK.

Salve seu design de relatório em um novo nome

  1. Clique o Botão Microsoft Office imagem do botão office e clique em Salvar como Imagem do botão .

  2. Na caixa de diálogo Salvar como, digite um nome na caixa Salvar relatório em, clique em relatório na caixa como e clique em OK.

Imprimir o relatório

Você pode imprimir um relatório de visualização de impressão, modo de exibição de Layout, o modo Design, o modo de exibição de relatório, ou no painel de navegação. Antes de imprimir, você deve verificar configurações de página, como margens e orientação da página. Access salva as configurações de página com o relatório, então você precisa defini-las apenas uma vez. Você pode salvar as configurações mais tarde, se for necessário alterar.

Alterar as configurações de página

  1. Abra o relatório em qualquer modo de exibição.

  2. Na guia Layout da página, no grupo página, clique em uma opção:

    • Tamanho Imagem do botão permite que você selecione um número de tamanhos de papel, ou insira um tamanho de papel personalizado.

    • Retrato Imagem do botão orienta a página verticalmente.

    • Orientação paisagem Imagem do botão orienta a página horizontalmente.

    • Margens Imagem do botão permite a seleção de várias larguras de margem predefinida, ou você pode clicar em Avançado para inserir as larguras de margem personalizada usando a caixa de diálogo Configurar página.

    • Mostrar Margens alterna a exibição das margens e desativar (modo de exibição de Layout).

    • Colunas exibe a caixa de diálogo Configurar página. Insira o número de colunas desejadas, defina o tamanho da coluna desejada e, em seguida, clique em OK.

    • Imprimir somente dados elimina a impressão de todos os rótulos que você colocou em seu relatório. Somente os controles que estão vinculados aos dados da tabela ou consulta subjacente serão impressas. Esse recurso pode ser útil nos relatórios que você ocasionalmente imprimir em formulários pré-impressos. Você pode suprimir a impressão de etiquetas nessas situações e em seguida, habilitar a impressão de etiquetas quando você imprimir o relatório em papel em branco.

Observação : Para usar as configurações de página mais detalhadas, clique no botão de Configuração de página no canto inferior direito do grupo Layout de página para exibir a caixa de diálogo Configurar página. Você pode usar a caixa de diálogo Configurar página para ajustar todas as configurações que estão disponíveis na guia Layout de página e também para selecionar uma impressora específica para o relatório.

Enviar seu relatório a uma impressora

  1. Abra o relatório em qualquer modo de exibição ou selecione apenas o relatório no painel de navegação.

  2. Clique o Botão Microsoft Office imagem do botão office e clique em Imprimir. Ferramentas de Tabela Dinâmica

  3. Na caixa de diálogo Imprimir, insira as opções para as opções como impressora, intervalo de impressão e número de cópias.

  4. Clique em OK.

Início da Página

Enviar o relatório como uma mensagem de email

Você pode enviar o relatório aos usuários como uma mensagem de email em vez de imprimir uma cópia em papel.

  1. No painel de navegação, clique no relatório para selecioná-lo, clique o Botão Microsoft Office imagem do botão office e clique em email Texto explicativo 4 .

  2. Na caixa de diálogo Enviar objeto como, clique no formato de arquivo que você deseja usar.

    Caixa de diálogo Enviar Objeto Como

  3. Preencha as caixas de diálogo restantes.

  4. Quando o programa de email for exibida, digite os detalhes da mensagem e envie a mensagem.

Início da Página

Comentários

Um problema pode ocorrer se você tiver um relatório em um arquivo. accdb que classifica ou grupos em um campo de pesquisa, e você quiser importar esse relatório em um arquivo. mdb e abra-o com uma versão anterior do Access.

O método interno pelos quais campos de pesquisa são classificados e agrupados em arquivos. accdb é incompatível com arquivos. mdb. Se você criar um relatório em um arquivo. accdb que usa o agrupamento ou classificação em uma pesquisa de campo e, em seguida, exportá-los para um arquivo. mdb (ou use o comando Salvar como para salvar o banco de dados como um arquivo. mdb) e tente abrir o relatório com uma versão anterior do Access, o relatório falhará carregar.

Para revisar o relatório para que você possa importá-lo para um arquivo. mdb e abri-lo em uma versão anterior do Access, faça o seguinte:

  1. No arquivo. accdb, crie uma cópia do relatório.

  2. Abra a cópia do relatório no modo de exibição de Layout.

  3. Se o painel Agrupar, classificar e Total não for exibido:

    1. Na guia Formatar, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

  4. Exclua todas as linhas no painel Agrupar, classificar e Total clicando no botão Excluir à direita de cada linha.

  5. Clique em imagem do botão office o Botão Microsoft Office e, em seguida, clique em Salvar ou pressione CTRL + S Texto explicativo 4 .

  6. Clique o Botão Microsoft Office imagem do botão office e clique em Fechar banco de dados. Imagem do botão

  7. Clique o Botão Microsoft Office imagem do botão office e clique em Abrir. Texto explicativo 4

  8. Navegue até o arquivo. mdb em que você deseja importar o relatório e clique em Abrir.

  9. Importe a cópia do relatório para o arquivo. mdb.

    Como?

    1. Na guia Dados externos, no grupo Importar, clique em acesso. Texto explicativo 4

    2. Clique em Procurar.

    3. Navegue até o arquivo. accdb que contém o relatório e clique em Abrir.

    4. Você não está importando todas as tabelas no momento, portanto, não importa se você optar por importar ou vincular a dados de origem. Clique em OK para continuar.

    5. Na caixa de diálogo Importar objetos, clique na guia relatórios.

    6. Clique no relatório que você deseja importar e clique em OK.

    7. Se a operação de importação for bem-sucedida, o Access perguntará se você deseja salvar as etapas de importação para uso posterior. Se você quiser salvar as etapas, marque a caixa de seleção Salvar etapas de importação, insira as informações solicitadas e clique em Salvar importação. Se não quiser salvar as etapas, clique em Fechar.

      O Access importa o relatório e exibe no painel de navegação.

  10. Abra o relatório no modo de exibição de Layout.

  11. Se o painel Lista de campos não for exibido:

    1. Na guia Formatar, no grupo controles, clique em Adicionar campos existentes Texto explicativo 4 .

  12. No painel campos disponíveis em tabelas relacionadas, encontre a tabela que contém o campo que você deseja exibir no relatório. Este campo conterá os mesmos valores que você vê atualmente exibido no campo de pesquisa no relatório.

  13. Arraste o campo para o relatório.

    Agora, você tem duas colunas exibindo as mesmas informações.

  14. O campo de exibição que você acabou de adicionar de atalho e clique na opção de classificação que você deseja usar.

  15. Exclua o campo de exibição que recém-adicionado e classificadas.

  16. Se o painel Agrupar, classificar e Total não for exibido:

    1. Na guia Formatar, no grupo agrupamento e totais, clique em Agrupar e classificar. Texto explicativo 4

  17. Clique em Adicionar um grupo.

  18. Na janela pop-up de Campo/expressão, clique no nome do campo de pesquisa no relatório.

O relatório agora está classificado e agrupado como ela estava no arquivo. accdb. Salve e feche o relatório.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×