Criar um modelo de formulário usando configurações na biblioteca de conexões de dados

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Este artigo mostra como criar um modelo de formulário, com base nas configurações armazenadas em uma biblioteca de conexões de dados em um site do Microsoft Office SharePoint Server 2007, que pode consultar ou enviar dados.

Neste artigo

Visão Geral

Antes de começar

Criar um modelo de formulário com uma conexão de dados de consulta

Criar um modelo de formulário com uma conexão de dados de envio

Visão Geral

Uma conexão de dados secundária é qualquer conexão de dados a uma fonte de dados externos que você adiciona a um modelo de formulário. Esta conexão de dados é diferente da conexão de dados principal que é criada quando você cria um modelo de formulário com base em um banco de dados, serviço da Web ou configurações em uma biblioteca de conexão. Você adiciona uma conexão de dados secundária somente se você não pode consultar ou enviar dados através da conexão de dados principal.

Um formulário pode ter uma conexão de dados primária, chamada de conexão de dados principal, e pode ter, opcionalmente, uma ou mais conexões de dados secundárias. Dependendo dos seus objetivos para o formulário, uma conexão de dados pode consultar ou enviar dados do formulário para uma fonte de dados externa, como um banco de dados do Microsoft SQL Server ou um serviço da Web.

Se você estiver criando vários modelos de formulário que usam conexões de dados semelhantes, considere usar um arquivo de conexão de dados em vez de criar uma conexão de dados a uma fonte de dados externa para cada modelo de formulário. Dessa forma, que você precisa atualizar somente um arquivo de conexão de dados quando as informações de conexão de dados é alterado para um conjunto de modelos de formulário relacionado. Por exemplo, quando você move seus modelos de formulário de uma rede de teste para uma rede de produção, você precisa atualizar as configurações de conexão de dados apenas uma vez na biblioteca de conexão em vez de atualizar a conexão de dados em cada modelo de formulário. Quando um formulário baseado em um modelo de formulário que usa um arquivo de conexão de dados usa a conexão de dados, a conexão de dados é atualizada automaticamente com as novas configurações.

Um arquivo de conexão de dados é um arquivo XML com uma extensão de arquivo. XML ou. udcx que contém informações de conexão para uma fonte de dados externa única. Esse arquivo é armazenado em uma biblioteca de conexões de dados em um servidor executando Microsoft Office SharePoint Server 2007. Um arquivo de conexão de dados é criado por um desenvolvedor ou convertendo uma conexão de dados em um modelo de formulário existente em um arquivo de conexão de dados clicando no botão Converter na caixa de diálogo Conexões de dados (menuFerramentas ).

Vantagens de usar os arquivos de conexão de dados incluem:

  • Vários formulários podem usar o mesmo arquivo de conexão de dados, para que não é necessário para criar a mesma conexão de dados do zero para cada modelo de formulário.

  • Se as configurações de local ou de conexão de uma fonte de dados externa mudar, será necessário atualizar apenas o arquivo de conexão de dados e não cada modelo de formulário.

  • O arquivo de conexão de dados pode conter informações de autenticação alternativo que podem ser usadas pelo servidor quando um usuário preenche um formulário usando um navegador da Web.

  • Formulários baseados em um modelo de formulário compatível com o navegador que são preenchidos em um navegador podem se conectar aos servidores em outro domínio somente com conexões de dados que usam arquivos de conexão de dados.

Microsoft Office InfoPath usa arquivos de conexão de dados que acompanha o formato de arquivo 2.0 de versão de conexão de dados Universal. Esta versão é um subconjunto o versão 1.0 do formato de arquivo usado pelo Microsoft Office FrontPage e Microsoft Office Excel. O InfoPath não pode usar arquivos de conexão de dados no formato de arquivo 1.0 versão.

Quando você cria um modelo de formulário que é baseado nas configurações em um arquivo de conexão de dados, o Microsoft Office InfoPath cria uma conexão de dados com base nas configurações da biblioteca de conexões de dados. Se o arquivo de conexão de dados contém configurações de uma conexão de dados da consulta, o InfoPath cria principal data source do formulário com campos de consulta, campos de dados e grupos que correspondem da maneira que os dados são armazenados na fonte de dados externos que é referenciada pelas configurações no arquivo de conexão de dados. Campos de consulta contêm os dados que usa a fonte de dados externa para determinar o que enviar ao formulário. Os resultados da consulta são colocados em campos de dados. Para permitir que usuários para consultar a fonte de dados externos, o InfoPath adiciona um botão de Executar consulta ao modelo de formulário.

Como a estrutura de dados da consulta e os campos de dados devem coincidir com a maneira que os dados são armazenados na fonte de dados externa, não é possível modificar os campos ou grupos existentes na fonte de dados principal. É possível adicionar campos ou grupos ao grupo raiz apenas na fonte de dados principal.

Se você estiver usando as configurações de uma conexão de dados de envio, o InfoPath habilita o botão Enviar na barra de ferramentas Padrão o comando Enviar no menu Arquivo dos formulários com base nesse modelo de formulário. Isso permite que os usuários enviem os dados sem seus formulários para a fonte de dados externa.

Início da página

Antes de começar

Para criar um modelo de formulário com base nas configurações em uma biblioteca de conexões de dados, você precisa das seguintes informações do administrador da biblioteca de conexões de dados ou do desenvolvedor que criou o arquivo de conexão de dados:

  • O local do site Office SharePoint Server 2007 com a biblioteca de conexões.

  • O nome do arquivo de conexão de dados na biblioteca de conexões de dados que deseja usar.

Início da página

Criar um modelo de formulário com uma conexão de dados de consulta

Para criar um modelo de formulário com base em um arquivo de conexão de dados com configurações para uma conexão de dados de consulta, é necessário fazer o seguinte:

  1. Criar o modelo de formulário com base no arquivo de conexão de dados     Essa etapa cria a fonte de dados principal para o modelo de formulário com os campos e grupos apropriados que têm base nas configurações do arquivo de conexão de dados.

  2. Adicionar um controle ao modelo de formulário que exibirá os resultados da consulta     Para exibir para os seus usuários os dados armazenados nos campos e grupos da fonte de dados principal, é necessário adicionar um controle ao seu modelo de formulário e, em seguida, vincular esse controle a um campo de consulta ou campo de dados na fonte de dados principal.

Etapa 1: Criar o modelo de formulário com base no arquivo de conexão de dados

  1. No menu Arquivo, clique em Criar um Modelo de Formulário.

  2. Em Criar um novo, na caixa de diálogo Criar um Formulário, clique em Modelo de Formulário.

  3. Na lista Coma base em, clique em Biblioteca de Conexões.

  4. Se você estiver criando um modelo de formulário compatível com o navegador, marque a caixa de seleção Habilitar recursos compatíveis com navegador apenas.

  5. Clique em OK.

  6. Na lista Site, no Assistente para Conexão de Dados, clique no nome do site no servidor executando o Office SharePoint Server 2007 que inclui a biblioteca de conexões de dados.

    Adicionar seu site à lista

    1. Clique em Gerenciar Sites.

    2. Na caixa de diálogo Gerenciar Sites, clique em Adicionar.

    3. Na caixa URL, digite o local da biblioteca de conexões de dados.

    4. Na caixa nome para exibição, digite um nome para a biblioteca de conexões de dados. Esse nome aparecerá na lista de sites no Assistente de conexão de dados.

    5. Clique em OK.

    6. Clique em Fechar.

  7. Clique no nome da biblioteca de conexões de dados para ver uma lista de arquivos de conexão de dados, clique no nome do arquivo de conexão de dados que deseja usar para essa conexão de dados e, em seguida, clique em Avançar.

  8. Se você selecionou um arquivo de conexão de dados com as configurações de conexão com um serviço da Web, a próxima página do assistente poderá solicitar a especificação dos valores de exemplo para cada parâmetro para determinar quais campos ou grupos adicionar à fonte de dados secundária.

    Como?

    1. Selecione um parâmetro na tabela parâmetros e clique em Definir valor de exemplo.

    2. Na caixa valor de amostra, digite um valor que o usuário pode usar para esse campo e clique em OK.

    3. Repita essas etapas para cada parâmetro na tabela parâmetros e clique em Avançar.

    Detalhes técnicos

    Quando você configura uma conexão de dados a um serviço Web no Assistente de conexão de dados, o Microsoft Office InfoPath se conecta ao serviço da Web e solicita o arquivo de idioma de descrição de serviço da Web (WSDL). O arquivo WSDL contém o esquema usado pelo serviço da Web. O serviço Web responde à solicitação enviando esse arquivo ao InfoPath. Para adicionar os campos apropriados e grupos à fonte de dados secundária no modelo de formulário, o InfoPath usa as informações neste arquivo. Se o InfoPath encontrar um tipo de elemento desconhecido no arquivo WSDL, o InfoPath usa dados de exemplo para determinar a definição do tipo de elemento desconhecido e depois adiciona os campos apropriados e grupos com a fonte de dados secundária.

  9. Se a fonte de dados externa citada nas configurações retornar um DataSet ADO.NET da Microsoft , a próxima página do assistente perguntará se você deseja incluir as informações sobre alterações quando os usuários enviarem seus dados do formulário. Na maioria dos casos, deixe a caixa de seleção Incluir informações sobre alterações ao enviar dados marcada e, em seguida, clique em Avançar. Se não quiser incluir as informações sobre alterações, desmarque a caixa de seleção Incluir informações sobre alterações ao enviar dados e, em seguida, clique em Avançar.

    Detalhes técnicos

    Essa página do assistente aparece apenas se as configurações forem para um serviço da Web e o arquivo WSDL (Web Service Description Language) indicar que o serviço da Web retorna um DataSet ADO.NET.

  10. Na próxima página do assistente, digite um nome para a conexão de dados e clique em Concluir.

Etapa 2: Adicionar um controle para exibir os dados no campo

  1. Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.

  2. Arraste um controle para o seu modelo de formulário.

  3. Na caixa de diálogo Vinculação de Controle, selecione o campo ao qual deseja vincular o controle.

Início da página

Criar um modelo de formulário com uma conexão de dados de envio

Se o arquivo de conexão de dados contiver configurações para uma conexão de dados de envio, você poderá configurar seu modelo de formulário para permitir que os usuários enviem seus dados de formulário por meio da conexão de dados. Ao fazer isso, o InfoPath adiciona um botão de Envio à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo. É possível configurar as opções de envio para o formulário na caixa de diálogo Opções de Envio (menu Ferramentas). As opções de envio são configuradas da mesma forma como se você estivesse criando um modelo de formulário com base em um banco de dados ou em um serviço da Web. Encontre links para informações adicionais sobre como criar um modelo de formulário com base em um banco de dados ou em um serviço da Web na seção Consulta Também.

  1. No menu Arquivo, clique em Criar um Modelo de Formulário.

  2. Em Criar um(a) novo(a) na caixa de diálogo Criar um Modelo de Formulário, clique em Modelo de Formulário.

  3. Na lista Com base em, clique em Biblioteca de Conexões.

  4. Se você estiver criando um modelo de formulário compatível com o navegador, selecione Habilitar recursos compatíveis com navegador apenas.

  5. Clique em OK.

  6. Na lista Site, no Assistente para Conexão de Dados, clique no nome do site no servidor executando o Office SharePoint Server 2007 que inclui a biblioteca de conexões.

    Adicionar seu site à lista

    1. Clique em Gerenciar Sites.

    2. Na caixa de diálogo Gerenciar Sites, clique em Adicionar.

    3. Na caixa URL, digite o local da biblioteca de conexões de dados.

    4. Na caixa nome para exibição, digite um nome para a biblioteca de conexões de dados. Esse nome aparecerá na lista de sites no Assistente de conexão de dados.

    5. Clique em OK.

    6. Clique em Fechar.

  7. Clique no nome da biblioteca de conexões de dados para ver uma lista dos arquivos de conexão de dados, clique no nome do arquivo de conexão de dados que deseja usar para essa conexão de dados e, em seguida, clique em Avançar.

  8. Se você selecionou um arquivo de conexão de dados com configurações de conexão com um serviço da Web, a próxima página do assistente poderá solicitar a especificação dos valores de exemplo para cada parâmetro para determinar o melhor campo ou grupo para adicionar à fonte de dados secundária.

    Como?

    1. Selecione um parâmetro na tabela parâmetros e clique em Definir valor de exemplo.

    2. Na caixa valor de amostra, digite um valor que o usuário pode usar para esse campo e clique em OK.

    3. Repita essas etapas para cada parâmetro na tabela parâmetros e clique em Avançar.

    Detalhes técnicos

    Quando você configura uma conexão de dados a um serviço Web no Assistente de conexão de dados, o Microsoft Office InfoPath se conecta ao serviço da Web e solicita o arquivo de idioma de descrição de serviço da Web (WSDL). O arquivo WSDL contém o esquema usado pelo serviço da Web. O serviço Web responde à solicitação enviando esse arquivo ao InfoPath. Para adicionar os campos apropriados e grupos à fonte de dados secundária no modelo de formulário, o InfoPath usa as informações neste arquivo. Se o InfoPath encontrar um tipo de elemento desconhecido no arquivo WSDL, o InfoPath usa dados de exemplo para determinar a definição do tipo de elemento desconhecido e depois adiciona os campos apropriados e grupos com a fonte de dados secundária.

  9. Na próxima página do assistente, digite um nome descritivo pra a conexão de dados e, em seguida, clique em Concluir.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×