Criar um modelo de dados no Excel

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Um modelo de dados é uma nova abordagem para integrar dados de várias tabelas, efetivamente construindo uma fonte de dados relacionais dentro de uma pasta de trabalho do Excel. No Excel, modelos de dados são usados transparente, fornecendo dados tabulares usados em relatórios de tabelas dinâmicas, gráficos dinâmicos e Power View. Antes de mergulhar detalhes, você talvez queira voltar um pouco e assistir a um vídeo ou levar nosso guia de aprendizado em Get e transformação e Power Pivot.

Observação : Este artigo descreve os modelos de dados no Excel 2013. No entanto, os recursos de Power Pivot introduzidos no Excel 2013 e modelagem de dados mesmos também se aplicam ao Excel 2016. Não há efetivamente pouca diferença entre nessas versões do Excel.

Na maioria das vezes, você sequer saberá que o modelo está lá. No Excel, um modelo de dados é visualizado como um conjunto de tabelas em uma Lista de campos. Para trabalhar com o modelo diretamente, é preciso usar o suplemento Power Pivot no Microsoft Excel 2013 do Microsoft Office.

Ao importar dados relacionais, a criação de um modelo ocorrerá automaticamente ao selecionar várias tabelas:

  1. No Excel, use Dados > Obter Dados Externos para importar dados do Access ou de outro banco de dados relacional que contém várias tabelas relacionadas.

  2. O Excel solicitará que você selecione uma tabela. Marque Habilitar seleção de várias tabelas.

    caixa de diálogo Selecionar Tabela

  3. Selecione duas ou mais tabelas, clique em Avançar e Concluir.

  4. Em Importar Dados, escolha a opção de visualização de dados que você deseja, como uma Tabela Dinâmica em uma nova planilha, e crie seu relatório.

Você agora tem um Modelo de Dados que contém todas as tabelas que você importou. Como você selecionou a opção de relatório de Tabela Dinâmica, o modelo é representado na Lista de Campos que você usará para criar o relatório de Tabela Dinâmica.

Lista de Campos da Tabela Dinâmica

O que você pode fazer com esse modelo? Você pode usá-lo para criar Tabelas dinâmicas, Gráficos dinâmicos ou relatórios do Power View na mesma pasta de trabalho. Você pode modificá-lo adicionando ou removendo tabelas e, se você usar o suplemento Power Pivot, poderá estender o modelo adicionando colunas calculadas, campos calculados, hierarquias e KPIs.

Ao criar o Modelo de Dados, a opção de visualização será importante. Você quer escolher Relatório de Tabela Dinâmica, Gráfico Dinâmico ou Relatório do Power View para visualização de dados. Essas opções permitem que você trabalhe com todas as tabelas coletivamente. Se você tivesse escolhido Tabela, cada tabela importada teria sido colocada em uma planilha separada. Nesta organização, as tabelas podem ser usadas individualmente, mas usar todas as tabelas juntas exige uma Tabela Dinâmica, um Gráfico Dinâmico, ou um relatório do Power View.

Observações : 

  • Os modelos são criados de modo implícito quando você importa duas ou mais tabelas simultaneamente no Excel.

  • Os modelos são criados de modo explícito quando você usa o suplemento Power Pivot para importar dados. No suplemento, o modelo é representado em um layout tabulado, onde cada guia contém dados tabulares. Veja Obter dados usando o suplemento Power Pivot paraaprender as noções básicas de importação de dados usando um banco de dados do SQL Server.

  • Um modelo pode conter uma única tabela. Para criar um modelo com base em apenas uma tabela, selecione a tabela e clique em Adicionar ao Modelo de Dados no Power Pivot. Você pode fazer isso se quiser usar os recursos do Power Pivot, como conjunto de dados filtrados, colunas calculadas, campos calculados, KPIs e hierarquias.

  • As relações de tabelas poderão ser criadas automaticamente se você importar tabelas relacionadas que tenham relações de chave primária e chave estrangeira. Geralmente o Excel pode usar as informações de relações importadas como base para relações de tabelas no Modelo de Dados.

  • Para obter dicas sobre como reduzir o tamanho de um modelo de dados, consulte Criar um modelo de dados com uso eficiente de memória usando o Excel 2013 e o suplemento Power Pivot.

  • Para obter uma maior exploração, consulte Tutorial: análise de dados de Tabela Dinâmica usando um Modelo de Dados no Excel 2013.

Dica :  Sua pasta de trabalho possui dados, mas você sabe se ela contém um modelo de dados? Você pode determinar rapidamente o status do modelo abrindo a janela do Power Pivot. Se os dados aparecerem em guias, isso significa que existe um modelo. Saiba mais em Descobrir que fontes de dados são usadas no modelo de dados de uma pasta de trabalho.

Use um Modelo de Dados em outra Tabela Dinâmica, Gráfico Dinâmico ou relatório do Power View

Uma pasta de trabalho do Excel pode conter apenas um Modelo de Dados, mas esse modelo pode ser usado repetidamente em toda a pasta de trabalho.

  1. No Excel, clique em Inserir > Tabela Dinâmica.

  2. Em Criar Tabela Dinâmica, clique em Usar uma fonte de dados externa e clique em Escolher Conexão.

  3. Em Conexões Existentes, clique em Tabelas.

  4. Em Este Modelo de Dados de Pasta de Trabalho, Tabelas no Modelo de Dados de Pasta de Trabalho é selecionado por padrão. Clique em Abrir e em OK. Uma lista de Campos da Tabela Dinâmica aparece, exibindo todas as tabelas no modelo.

Adicionar dados existentes e não relacionados a um Modelo de Dados

Suponha que você importou ou copiou muitos dados que você deseja usar em um modelo, mas não marcou a caixa Adicionar estes dados ao Modelo de Dados durante a importação. Enviar os novos dados para um modelo é mais fácil do que você imagina.

  1. Inicie com os dados que você quer adicionar ao modelo. Pode ser qualquer intervalo de dados, mas usar um intervalo nomeado funciona melhor.

  2. Realce as células que você quer adicionar ou, se os dados estiverem em uma tabela ou intervalo nomeado, coloque o cursor em uma célula.

  3. Use uma destas abordagens para adicionar seus dados:

  4. Clique em Power Pivot > Adicionar ao Modelo de Dados.

  5. Clique em Inserir > Tabela dinâmica e marque a opção Adicionar estes dados ao Modelo de Dados na caixa de diálogo Criar Tabela Dinâmica.

O intervalo ou tabela é agora adicionado ao modelo como uma tabela vinculada. Para saber mais sobre como trabalhar com tabelas vinculadas em um modelo, consulte Adicionar dados usando tabelas vinculadas do Excel no Power Pivot.

Refine e estenda o modelo de dados no suplemento Power Pivot

No Excel, os Modelos de Dados existem para amplificar e enriquecer a experiência de relatório, especialmente quando essa experiência inclui Tabelas Dinâmicas ou outros formatos de relatório que são destinados à exploração de dados e análise. Embora seja importante, os Modelos de Dados são mantidos de propósito no plano de fundo para que você possa se concentrar no que quer fazer com eles.

Mas suponha que trabalhar diretamente no modelo seja exatamente o que você quer fazer. Sabendo que a Lista de Campos esteja baseada em um modelo, talvez você queira remover tabelas ou campos porque eles não sejam úteis na lista. Talvez você queira exibir todos os dados subjacentes que o modelo fornece, ou adicionar KPIs, hierarquias e lógica de negócios. Por todas estas razões e muito mais, você desejará modificar o Modelo de Dados diretamente.

Para modificar ou gerenciar o modelo de dados, use o suplemento Power Pivot. O suplemento é parte da edição Office Professional Plus do Excel 2013, mas não habilitado por padrão. Mais informações sobre como Iniciar o Power Pivot no suplemento do Microsoft Excel.

Diferenças entre uma tabela no Power Pivot e uma tabela em uma planilha

No Power Pivot, não é possível adicionar uma linha a uma tabela digitando diretamente uma nova linha como  em uma planilha do Excel. Mas é possível adicionar linhas usando comandos de Colar e atualizando os dados.

Os dados de uma planilha do Excel são frequentemente variáveis e irregulares: ou seja, uma linha pode conter dados numéricos e a linha seguinte pode conter um gráfico ou cadeia de texto. Em contrapartida, uma tabela no Power Pivot é similar a de um banco de dados relacional, no qual cada linha tem o mesmo número de colunas e a maioria das colunas contém dados.

Use o modelo de dados no Power View

Um modelo de dados é usado como base de um relatório do Power View. Usando o suplemento Power Pivot é possível aplicar aprimoramentos ao modelo que melhorem o relatório do Power View. O aprimoramentos incluem: especificação de uma lista de campos padrão, escolha de campos representativos ou imagens para identificar linhas específicas exclusivamente, ou para especificar como linhas com valores repetidos (como funcionários ou clientes com o mesmo nome) serão tratadas em um aplicativo de relatório.

  1. Criar um modelo de dados importando várias tabelas relacionadas.

  2. Clique em Power Pivot > Gerenciar para abrir a janela do Power Pivot.

  3. Selecione uma tabela e aplique as otimizações:

    1. Clique em Avançado > Conjunto de Campos Padrão. Escolha os campos que deverão aparecer automaticamente em um relatório do Power View quando você clicar na tabela pai. Consulte Configurar conjunto de campo padrão para relatórios de Power View para obter detalhes.

    2. Clique em Avançado > Comportamento da Tabela. Otimize para layouts de relatório que agrupam dados. O agrupamento está sujeito a comportamentos padrão que às vezes produzem resultados não intencionais, como consolidar linhas que deveriam ser listadas separadamente. Consulte Configurar propriedades de comportamento de tabela para relatórios de Power View para obter detalhes.

    3. Clique em Avançado > Categoria de Dados. Algumas visualizações de relatório são específicas para tipos de dados. Por exemplo, se você tiver uma tabela baseada em hora ou data, poderá atribuir uma categoria Data que ajuda o Power View com visualizações baseadas em hora.

  4. Repita para outras tabelas.

  5. No Excel, clique em Inserir > Power View para iniciar um novo relatório. Consulte Power View: explore, visualize e apresente seus dados para obter mais informações.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×