Criar um diagrama do Visualizador de Dados

Deseja criar automaticamente um fluxograma detalhado e bem acabado do Visio a partir de uma pasta de trabalho do Excel? Você pode fazer isso usando os modelos do Visualizador de Dados. Cada modelo tem uma pasta de trabalho do Excel associada, usada para converter dados de processos em um fluxograma no Visio. Você também pode obter seu próprio modelo personalizado do Excel, especificar mapeamentos no assistente do modelo e criar o diagrama automaticamente. Depois de criar o fluxograma, você pode adicionar, editar ou excluir linhas no Excel e, em seguida, atualizar o diagrama no Visio. Você pode até mesmo adicionar mais colunas de dados no Excel, que são convertidas em dados de forma do Visio Pro para Office 365.

Visão geral do Visualizador de Dados

A capacidade de usar os modelos do Visualizador de Dados está disponível somente com o Visio Pro para Office 365 no Canal de lançamento atual. Se não tem certeza de qual versão do Visio está usando, selecione Arquivo > Conta > Sobre o Visio. Confira Visio Pro para Office 365 para saber mais sobre a versão de assinatura do Visio.

Caso você não encontre os modelos do Visualizador de Dados ou tenha outras dúvidas sobre como começar, acesse a página Perguntas frequentes do Visualizador de Dados.

Observação : Para usá-lo, você deve ter uma assinatura do Office 365. Se você é um assinante do Office 365, certifique-se de ter a versão mais recente do Office. Se você é um profissional de TI que gerencia o processo de atualização do Office 365, confira a página de lançamentos para canais, para saber quais atualizações são fornecidas em cada canal.

Neste artigo

Criar um diagrama do Visualizador de Dados

Antes de começar

Reúna suas ideias e elabore-as em formato de rascunho usando uma folha de papel ou a escrita à tinta. Esse rascunho inicial pode ajudá-lo a colocar seu trabalho em movimento e a facilitar as etapas seguintes.

Para criar um diagrama do Visualizador de Dados, você pode trabalhar simultaneamente no Excel e no Visio. Talvez você ache mais fácil trabalhar em duas janelas no seu dispositivo Windows ou em um ambiente com vários monitores. A comparação visual do seu trabalho entre o Excel e o Visio ajuda a confirmar que você está realmente fazendo o que pretende fazer.

Estágio 1: Escolher um modelo do Visualizador de Dados

  1. Abra o Visio ou escolha Arquivo > Novo se você estiver editando um diagrama.

  2. Selecione MODELOS.

    O comando MODELOS
  3. Escolha Fluxograma.

    O comando Fluxograma
  4. Escolha Fluxograma Básico - Visualizador de Dados ou Fluxograma Multifuncional - Visualizador de Dados.

    Os modelos do Visualizador de Dados

    Um modelo do Visualizador de dados tem um ícone do Excel no canto superior esquerdo.

Para obter mais informações sobre fluxogramas e suas formas, confira Criar um fluxograma básico e Criar um fluxograma multifuncional.

Estágio 2: Criar uma pasta de trabalho do Excel

  1. Na visualização do modelo, selecione Modelo de dados do Excel.

    Como escolher o link do Modelo de Dados do Excel

    Observação, se você quiser usar os mesmos modelos de amostra do Excel usados para referência neste artigo, baixe-os nos links a seguir:

  2. Escolha Arquivo > Salvar, especifique um computador, um servidor de rede ou uma biblioteca de documentos do SharePoint, insira um nome de arquivo e escolha Salvar.

  3. Para adicionar uma nova planilha, na parte inferior da pasta de trabalho, selecione Nova planilha Botão Nova Planilha .

  4. Crie uma tabela do Excel. Para obter mais informações sobre como usar tabelas do Excel, confira Visão geral de tabelas do Excel, Criar ou excluir uma tabela do Excel e Redimensionar uma tabela adicionando ou removendo linhas e colunas.

  5. Adicione colunas e linhas à tabela, que são usadas para criar o diagrama do Visio. Existem requisitos específicos para os cabeçalhos e valores de colunas da tabela do Excel. Use a seção, Como colunas do Excel interagem com componentes de fluxograma do Visio como guia visual.

Estágio 3: Adicionar mais dados de forma à tabela do Excel (opcional)

  1. Examine a guia Mapa de Processos no modelo do Excel. As colunas na tabela do Excel são verdes e azuis. A cor fornece uma pista visual sobre a diferença entre as colunas.

    As colunas azuis são usadas para criar o fluxograma no diagrama do Visio. Todas as colunas também são adicionadas como dados de forma.

  2. Para adicionar mais dados de forma, adicione uma ou mais colunas à sua tabela do Excel.

    As colunas verdes indicam outros dados de forma que você pode adicionar a cada forma. É possível acrescentar qualquer número de colunas adicionais. Por padrão, esses dados não ficam visíveis no diagrama, a menos que você adicione elementos gráficos de dados. Para ver os dados de forma no diagrama do Visio, selecione Dados > Janela Dados da Forma. Para obter mais informações sobre dados de forma e gráficos de dados, confira Adicionar dados a formas e Visão geral: gráficos de dados.

Estágio 4: Criar um diagrama do Visio com o assistente

  1. Retorne ao Visio. Na visualização do modelo, selecione sua unidade de medida e clique em Criar.

  2. Na primeira página do assistente Criar Diagrama a partir de Dados, faça o seguinte:

    1. Em Que diagrama você deseja criar dos dados?, selecione um modelo: Fluxograma Básico, Fluxograma Multifuncional (horizontal) ou Fluxograma Multifuncional (vertical).

    2. Em Selecionar a pasta de trabalho do Excel, selecione uma pasta de trabalho na lista das pastas de trabalho usadas mais recentemente ou selecione Procurar para localizar a pasta de trabalho que você criou no Estágio 2.

    3. Em Selecione uma tabela ou um intervalo personalizado na pasta de trabalho, selecione a tabela que contém seus dados de processos do Excel.

    4. Selecione Concluir. Essa ação aceita todos os valores padrão preenchidos pelo Visio para as outras páginas do assistente.

Como resultado, o diagrama é criado automaticamente dentro de um contêiner. Páginas adicionais do Visio são adicionadas dependendo do tamanho do fluxograma.

Estágio 5: Salve o diagrama do Visio

  • Selecione Arquivo > Salvar, encontre uma localização, insira um nome de arquivo e selecione Salvar.

É uma boa ideia manter os arquivos do Excel e do Visio no mesmo local, porque eles trabalham lado a lado.

Estágio 6: Atualize o diagrama

Depois de criar um diagrama com o Visualizador de Dados, você pode querer fazer alterações nele. Como o Visualizador de Dados tem dois componentes, uma pasta de trabalho do Excel e um diagrama do Visio, atualize este último para mantê-lo sincronizado com as alterações de dados feitas na tabela do Excel. É importante compreender que o processo de sincronização é uma operação unidirecional. Primeiro, você atualiza os dados no Excel e, em seguida, atualiza o diagrama no Visio. Se houver diferenças entre os dados no Excel e no Visio na hora de atualizar, os dados no Excel terão precedência.

  1. Faça alterações nos dados da tabela do Excel. Você pode adicionar, atualizar ou excluir linhas.

  2. Salve a pasta de trabalho do Excel.

  3. No Visio, selecione o contêiner do diagrama e depois escolha Dados > Atualizar.

Como resultado, as alterações feitas na pasta de trabalho do Excel serão exibidas no diagrama do Visio. A ação de atualizar apenas fará alterações nas formas e conexões dentro do contêiner. Mantenha todas as formas e linhas conectoras do diagrama dentro do contêiner. Se você adicionar uma forma manualmente ao contêiner e, em seguida, atualizar o diagrama, essa forma será removida. Nenhum outro objeto na página, mas fora do contêiner, será afetado. Todas as alterações de formatação feitas nas formas ou nos conectores dentro do contêiner serão preservadas. Para saber mais sobre contêineres, confira Esclarecer a estrutura de diagramas usando contêineres e listas.

Estágio 7: Personalize a interação entre a tabela do Excel e o diagrama do Visio (opcional)

Há momentos em que você pode querer personalizar a criação dos seus diagramas do Visualizador de Dados. Por exemplo, talvez você queira usar formas diferentes para manter a conformidade com os padrões da sua organização ou mapear para nomes de colunas diferentes na tabela do Excel.

  1. Quando você selecionar Criar para entrar no assistente Criar Diagrama a partir de Dados e depois de inserir valores na primeira página (consulte o Estagio 4), selecione Avançar ou Voltar para exibir cada página do assistente.

  2. Selecione Ajuda (?) para obter mais informações sobre como personalizar cada opção na página. Para obter mais informações, confira Usar o assistente Criar Diagrama a partir de Dados.

Início da página

Como colunas do Excel interagem com componentes de fluxograma do Visio

Use o seguinte passo a passo com imagens para entender como cada coluna do Excel é usada para criar o fluxograma do Visio.

ID da Etapa do Processo    Um número que identifica cada forma do fluxograma. Essa coluna é necessária, e cada valor na tabela do Excel deve ser exclusivo e não estar em branco. Esse valor não aparece no fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID da Etapa do Processo

Descrição da Etapa do Processo   Texto adicionado a cada forma do fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Descrição da Etapa do Processo

ID da Próxima Etapa   A ID da Etapa do Processo da próxima forma da sequência. Uma forma de ramificação tem duas próximas etapas e é representada por números separados por vírgulas, como 4,5. Você pode ter mais de duas próximas etapas.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID da Próxima Etapa

Rótulo do Conector   Para formas de ramificação, rótulos de conector são representados como texto separado por vírgula, como Sim, Não. No exemplo, Sim corresponde a 4 e Não, a 5.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Rótulo do Conector

Tipo de Forma   O tipo da forma que você deseja representar no diagrama do Visio, como Processo ou Decisão. A Microsoft recomenda usar as listas suspensas para ajudar a validar suas escolhas.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Tipo de Forma

Função e Fase    A função (ou raia) e a fase (a linha do tempo) as quais cada forma pertence. Essa coluna somente é aplicável a um diagrama de Fluxograma Multifuncional, sendo ignorada por um diagrama de Fluxograma Básico.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Função e Fase

Início da página

Usar outros estênceis para criar um diagrama de Visualizador de Dados

Além de utilizar os modelos de fluxograma básico e multifuncionais, você pode usar estênceis de outros modelos ao criar um diagrama de Visualizador de Dados. Por exemplo, há outros estênceis orientados a processos como Diagrama de auditoria, BPMN Basic ou Fluxograma Seis Sigma. Mas você pode adicionar formas de qualquer estêncil, como Minhas Formas.

  1. Abra um diagrama de Visualizador de Dados que você já criou.

  2. Adicione um ou mais estênceis ao painel Formas.

    Por exemplo, escolha Mais Formas e, em seguida, escolha Negócio > Processo Empresarial > Formas do Diagrama de Auditoria.

    Modelos adicionais no painel Formas
  3. Na guia Dados, escolha Criar para iniciar o assistente Criar Diagrama a partir de Dados.

  4. Escolha Avançar até que a página Escolha uma forma apropriada para cada valor listado em "Tipo de Forma" seja exibida.

  5. No lado direito da página, escolha o estêncil desejado na lista, como Formas do Diagrama de Auditoria.

    Outros modelos adicionados à página do assistente

Aplicar Gráficos de Dados ao seu diagrama

Office Insider

Para usar o recurso Aplicar Gráficos de Dados no Visio Pro para o Office 365, você deve ser um Office Insider   

Participantes do programa Office Insider são assinantes do Office 365 que têm acesso antecipado a novos recursos todos os meses e ajudam a equipe do Office a avaliá-los. Seja um Office Insider.

Você pode melhorar ainda mais o seu diagrama adicionando gráficos de dados, que ajudam a visualizar dados de forma no diagrama. Na verdade, você pode transformar seu diagrama em um painel de processos em que os gráficos de dados mostram informações sobre KPIs (indicadores chave de desempenho) usando o ícone de gráficos de dados com base nos seus dados de forma.

  1. Abra o diagrama do Visualizador de Dados.

    Selecione o contêiner ao qual você deseja aplicar os Gráficos de Dados.

  2. Selecione Dados > Campos de Gráficos de Dados.

  3. Selecione os campos de gráficos de dados que você deseja para o seu diagrama.

    Os gráficos de dados são aplicados ao diagrama inteiro. Para ocultar gráficos de dados para certas formas, mantenha os valores da coluna de dados em branco na pasta de trabalho do Excel para essas linhas.

  4. Se desejar, você pode definir opções adicionais na guia Dados.

Aplicar Gráficos de Dados para o Diagrama do Visualizador de Dados do Visio

Início da página

Próximas etapas

Veja a seguir algumas tarefas que você pode querer fazer depois de criar um diagrama do Visualizador de Dados.

  • Temas    Um tema no Visio é um conjunto de cores e efeitos que você pode aplicar a um desenho com um único clique. Temas são uma maneira rápida de dar uma aparência profissional aos seus desenhos. Para obter mais informações, confira Aplicar uma aparência profissional aos seus desenhos com temas.

  • Layout    O Visio tem guias manuais e ferramentas automáticas para ajudar a garantir o bom alinhamento e espaçamento das formas no seu diagrama. Isso ajuda a dar a maior clareza possível para o seu desenho, além de deixá-lo com uma aparência bem organizada. Para obter mais informações, consulte Alinhar e posicionar formas em um diagrama.

  • Exportar    Exporte um diagrama de Visualizador de Dados e uma pasta de trabalho do Excel associada para um pacote de modelos do Visio (.vtpx). Um pacote de modelos do Visio salva as configurações do diagrama, estênceis e dados para que outras pessoas as utilizem como um ponto de partida rápido para criar seu próprio diagrama de Visualizador de Dados. Outros usuários podem instalar e personalizar o pacote de modelos em seus computadores. Confira mais informações em Exportar e instalar um pacote de modelos de Visualizador de Dados.

Início da página

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×