Criar um Modelo de Banco de Dados (também conhecido como diagrama de Relação de Entidade)

Criar um Modelo de Banco de Dados (também conhecido como diagrama de Relação de Entidade)

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Com o modelo Diagrama de Modelo de Banco de Dados, você pode criar um novo modelo, ou fazer engenharia reversa de um modelo existente de banco de dados para um modelo, usando tanto conceitos relacionais quanto conceitos de modelagem relacional do objeto. Use o estêncil Relação de Entidade para modelar bancos de dados baseados no padrões SQL92 e anteriores. Use o estêncil Relacional do Objeto, que tem formas adicionais para trabalhar com tipos, para modelar bancos de dados baseados nos padrões SQL99 e posteriores.

Exemplo de modelo de banco de dados

Com o modelo Diagrama de Modelo de Banco de Dados, você pode criar um novo modelo, ou fazer engenharia reversa de um modelo existente de banco de dados para um modelo, usando tanto conceitos relacionais quanto conceitos de modelagem relacional do objeto. Use o estêncil Relação de Entidade para modelar bancos de dados baseados no padrões SQL92 e anteriores. Use o estêncil Relacional do Objeto, que tem formas adicionais para trabalhar com tipos, para modelar bancos de dados baseados nos padrões SQL99 e posteriores.

Este artigo descreve como você pode criar um modelo de banco de dados e o que poderá fazer com o modelo depois de criá-lo.

Não consegue encontrar o banco de dados recursos de modelo?

Nem todas as edições do Microsoft Visio têm o recurso de modelo de banco de dados. Se você não conseguir localizar os recursos descritos nos procedimentos deste artigo, provavelmente possui uma edição do Visio que não as inclui.

  • O Microsoft Visio Standard não contém o modelo Diagrama de Modelo de Banco de Dados.

  • As edições Microsoft Office Visio Professional e Premium dão suporte aos recursos de engenharia reversa do modelo Diagrama de Modelo de Banco de Dados (isto é, usar um banco de dados existente para criar um modelo no Visio), mas não dão suporte à engenharia prospectiva (isto é, usar um modelo de banco de dados do Visio para gerar código SQL).

  1. Para iniciar o diagrama de modelo de banco de dados, escolha uma das ações a seguir:

    Criar um novo diagrama de modelo do zero

    Caso você não tenha um banco de dados que queira usar como ponto de partida, pode começar com um Modelo de Banco de Dados em branco e adicionar suas próprias tabelas e relações.

    1. Clique na guia Arquivo.

    2. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    3. Na guia Banco de Dados, no grupo Gerenciar, clique em Exibir Opções.

    4. Na caixa de diálogo Opções de Documento de Banco de Dados, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e de relação e clique em OK.

    Usar um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que deseja modelar a fim de entendê-lo melhor ou usá-lo como ponto de partida para um novo modelo, poderá usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Antes de iniciar o assistente:

    1. Se estiver fazendo engenharia reversa de uma pasta de trabalho do Microsoft Excel, antes de iniciar o assistente, você precisará abrir a pasta de trabalho e nomear o grupo (ou intervalo) de células que contém os títulos das colunas. Se quiser usar mais de uma planilha, basta nomear o grupo de células de coluna em cada planilha. Esses intervalos são tratados pelo assistente como tabelas. Para obter mais informações sobre como nomear um intervalo de células, consulte o tópico da Ajuda do Excel denominado Definir referências de células ou intervalos nomeados.

    2. Para obter melhores resultados, defina o driver padrão para o banco de dados de destino em que você deseja fazer engenharia reversa antes de executar o Assistente de Engenharia Reversa. Essa etapa assegura que o assistente mapeará os tipos de dados nativos corretamente e que todo o código extraído por ele será exibido apropriadamente na janela Código.

    3. Clique na guia Arquivo.

    4. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    5. Na guia Banco de Dados, no grupo Modelo, clique em Engenharia Reversa.

    6. Na primeira tela do Assistente de Engenharia Reversa, proceda da seguinte forma:

      1. Selecione o driver do banco de dados para o sistema de gerenciamento de banco de dados (DBMS). Se você ainda não tiver associado o driver de banco de dados do Visio a uma fonte de dados ODBC específica, clique em Configurar.

        Observação : Se estiver fazendo engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que está atualizando. Se você ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazê-lo agora.

        Quando uma nova fonte é criada, seu nome é adicionado à lista Fontes de Dados.

      3. Quando estiver satisfeito com as configurações, clique em Avançar.

    7. Siga as instruções de todas as caixas de diálogo específicas do driver.

      Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite o nome de usuário e a senha e clique em OK.

      Observação : Se você usar o Driver Genérico ODBC, talvez receba uma mensagem de erro indicando que as informações da engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema — apenas clique em OK e prossiga com o assistente.

    8. Marque as caixas de seleção do tipo de informação que deseja extrair e clique em Avançar.

      Observação : Alguns itens podem não estar disponíveis (aparecem esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados têm suporte a todos os tipos de elementos que o assistente é capaz de extrair.

    9. Marque as caixas de seleção das tabelas (e exibições, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todas, e clique em Avançar.

      Observação : Se estiver fazendo engenharia reversa em uma planilha do Excel e não aparecer nada nessa lista, é provável que você precise nomear o intervalo de células que contém os títulos de colunas da planilha.

    10. Se você marcou a caixa de seleção Procedimentos Armazenados, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e clique em Avançar.

    11. Selecione se quiser que os itens de engenharia reversa sejam adicionados automaticamente à página atual.

      Observação : Você pode escolher que o assistente crie automaticamente o desenho, além de listar os itens que tiverem sofrido engenharia reversa na janela Tabelas e Exibições. Se decidir que o desenho não deve ser criado automaticamente, poderá arrastar os itens da janela Tabelas e Exibições para a página de desenho, a fim de montar manualmente o modelo de banco de dados.

    12. Reveja suas seleções para verificar se está extraindo as informações desejadas e clique em Concluir.

      O assistente extrai as informações selecionadas e exibe observações sobre o processo de extração na janela Saída.

    Importar e refinar um modelo existente

    Caso você tenha um modelo existente do VisioModeler ou do PLATINUM ERwin, talvez seja capaz de importá-lo para criar um diagrama de modelo de banco de dados do Visio. Essa capacidade é limitada a arquivos de modelo de dicionário (.imd) do VisioModeler 2.0, ou posterior, e a arquivos .erx do PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. Clique na guia Arquivo.

    2. Clique em Novo, em Software e Banco de Dados e clique duas vezes em Diagrama de Modelo de Banco de Dados.

    3. Na guia Banco de Dados, no grupo Modelo, clique em Importar e clique no tipo de modelo.

    4. Digite o caminho e o nome do arquivo de modelo a ser importado ou clique no botão Procurar para localizar o arquivo de modelo e clique em Abrir.

    5. Na caixa de diálogo Importar, clique em OK.

      O Visio importa o arquivo e exibe o andamento da importação na janela Saída. As tabelas importadas são exibidas na janela Tabelas e Exibições.

    6. Na janela Tabelas e Exibições, selecione as tabelas que deseja modelar e arraste-as para a página de desenho.

  2. Depois que é criado o diagrama de um modelo de banco de dados, começa o trabalho de refinar o diagrama. Você pode adicionar e personalizar tabelas e exibições, criar relações e personalizar tipos de dados e colunas

    Tabelas

    Use a forma Entidade para criar uma tabela no diagrama.

    1. A partir do estêncil Relação de Entidade ou Relacional do Objeto, arraste uma forma Entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades do Banco de Dados.

    3. Em Categorias, clique em Definição e digite um nome para a tabela.

    4. Em Categorias, clique em Colunas, digite um nome e escolha um tipo de dados.

    5. Marque a caixa de seleção Necessário das colunas que não podem ter valores nulos.

    6. Marque a caixa de seleção CP (chave primária) das colunas que identificam exclusivamente cada linha da tabela do banco de dados.

    7. Em Categorias, clique em Índices, Disparadores, Verificar ouEstendidos para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades do Banco de Dados para adicionar ou alterar propriedades de colunas, incluindo tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela do diagrama.

    2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula Nome Físico vazia e digite um nome.

    4. Para alterar o tipo de dados de uma coluna, clique no campo Tipo de Dados da coluna e selecione um tipo de dados na lista ou digite-o na lista. Você pode, por exemplo, digitar decimal(8,2) ou char(30).

    5. Para impedir valores nulos, marque a caixa de seleção Necessário.

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção CP.

    7. Para ver mais propriedades de colunas além das que aparecem quando você clica na categoria Colunas, selecione a coluna e clique em Editar.

    Relações

    As relações usam chaves primárias e estrangeiras para permitir que bancos de dados correspondam uma linha de uma tabela com uma linha de uma tabela relacionada. Você pode mostrar essas relações em seu diagrama. Além disso, pode definir a cardinalidade (por exemplo, um-para-muitos) e usar a notação Pés de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. No modelo Diagrama de Modelo de Banco de Dados, não é possível mostrar relações muitos-para-muitos com nenhuma dessas notações.

    1. Crie uma relação entre tabelas:

      1. Verifique se ambas as tabelas estão visíveis no diagrama. Se você fez engenharia reversa no modelo a partir de um banco de dados existente, talvez seja necessário arrastar uma ou ambas da janela Tabelas e Exibições para a página de desenho

      2. Clique duas vezes na tabela que deve ser o lado da chave primária da relação.

      3. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

      4. Na grade, clique na coluna que você quer usar para identificar exclusivamente cada linha da tabela e marque a caixa de seleção CP para defini-la como chave primária.

      5. A partir do estêncil Relacional do Objeto ou Relação de Entidade, arraste uma forma Relação e solte-a em um espaço em branco da página.

      6. Conecte a extremidade superior à tabela que tem a tabela pai.

      7. Conecte a outra extremidade à tabela filho.

        Se a segunda tabela ainda não contiver uma coluna com o mesmo nome da chave primária, o modelador a adicionará à segunda tabela como chave estrangeira.

        Observação : Se as linhas do relacionamento desaparecerem, na guia Banco de Dados, no grupo Opções, clique em Exibir Opções. Na guia Relacionamento, em Mostrar, marque a caixa de seleção Relacionamentos.

    2. Defina a cardinalidade da relação:

      1. Clique duas vezes na relação.

      2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Miscelânea.

      3. Em Cardinalidade, escolha a cardinalidade que se ajuste melhor ao relacionamento. Em relacionamentos um-para-muitos, a melhor escolha é Zero ou mais ou Um ou mais. Em relacionamentos um-para-um, a melhor escolha é Zero ou um ou Exatamente um.

  3. Para fazer outros refinamentos no diagrama (como criar índices, cláusulas de verificação e disparadores), você pode fazer o seguinte:

    Criar índices

    Os índices melhoram o desempenho, ou aumentam a velocidade, do banco de dados quando se executa uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela à qual deseja adicionar um índice e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, digite um nome para o índice e clique em OK.

    5. Na lista Tipo de Índice, selecione uma opção para criar um índice exclusivo ou não-exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que deseja incluir nesse índice e clique em Adicionar >.

    7. Na lista Colunas Indexadas, marque a caixa de seleção Crescente para criar um índice com ordem de classificação crescente ou desmarque-a para criar um índice que tenha ordem de classificação decrescente.

      O diagrama de modelo de banco de dados é atualizado.

    Criar modos de exibição

    Considere uma exibição como uma consulta salva. As exibições são particularmente úteis quando se precisa acessar várias vezes a mesma informação a partir de várias tabelas ou quando se quer expor os dados aos usuários sem permitir que eles alterem as tabelas reais.

    A partir do estêncil Relação de Entidade ou Relacional do Objeto, arraste uma forma Exibição para a página de desenho.

    Definir as propriedades estendidas para tabelas e exibições

    Dependendo de seu sistema de gerenciamento de banco de dados (DBMS), você talvez possa definir propriedades estendidas de tabelas ou exibições para determinar onde elas estão armazenadas.

    Clique duas vezes na tabela ou no modo de exibição cujas propriedades estendidas você deseja definir e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Estendidas.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estejam dentro de determinado intervalo de valores. Você pode, por exemplo, criar uma cláusula de verificação que exija que os dados de uma coluna chamada "Idade" sejam acima de 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Colunas e, em seguida, clique na coluna à qual deseja adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da Coluna, insira as restrições desejadas.

      A cláusula de verificação será adicionada à janela Código em Código local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use procedimentos armazenados e funções definidas pelo usuário para criar pacotes de código que você possa reutilizar a fim de executar várias vezes as mesmas ações. A principal diferença entre eles é que a função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa o código sem retornar um valor.

    1. Na guia Banco de Dados, no grupo Mostrar/Ocultar, marque a caixa de seleção Código para abrir a janela Código.

    2. Clique em Código Global e clique em Novo.

    3. Na guia Propriedades do Editor de Códigos, clique no tipo de código que deseja criar e digite um nome para o código.

    4. Na guia Corpo, digite o código e clique em OK.

    Criar disparadores

    Os disparadores fazem com que o código SQL especificado no disparador seja executado quando ocorrer determinado evento no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Disparadores e clique emAdicionar.

    3. Na guia Propriedades, digite um nome para o disparador.

    4. Na guia Corpo, digite o código e clique em OK.

      O disparador será adicionado à janela Código, em Código local.

Este artigo descreve como você pode criar um modelo de banco de dados e o que pode fazer com o modelo depois de criá-lo. Para começar rapidamente, no menu Arquivo, aponte para Novo, para Software e Banco de Dados e clique em Diagrama de Modelo de Banco de Dados.

Não consegue encontrar o banco de dados recursos de modelo?

Muito provavelmente, sua edição do Microsoft Office Visio não contém os recursos que você está procurando. Para descobrir qual a sua edição do Visio, clique em Sobre o Microsoft Office Visio, no menu Ajuda. O nome da edição está na linha superior do texto da caixa de diálogo.

  • O Microsoft Office Visio Standard não contém o modelo Diagrama de Modelo de Banco de Dados.

  • O Microsoft Office Visio Professional oferece suporte aos recursos de engenharia reversa do modelo Diagrama de Modelo de Banco de Dados (isto é, usar um banco de dados existente para criar um modelo no Visio), mas não oferece suporte à engenharia prospectiva (isto é, usar um modelo de banco de dados do Visio para gerar código SQL).

  • Você pode encontrar o conjunto completo de recursos de modelagem de banco de dados, incluindo tanto a engenharia reversa quanto a prospectiva, no Visio for Enterprise Architects. O Visio for Enterprise Architects está incluído na assinatura do MSDN Premium, que está disponível nas edições do Visual Studio Professional e do Visual Studio Team System, baseadas em função.

  1. Para iniciar o diagrama de modelo de banco de dados, escolha uma das ações a seguir:

    Criar um novo diagrama de modelo do zero

    Caso você não tenha um banco de dados que queira usar como ponto de partida, pode começar com um Modelo de Banco de Dados em branco e adicionar suas próprias tabelas e relações.

    1. No menu Arquivo, aponte para Novo, para Software e Banco de Dados e clique em Diagrama de Modelo de Banco de Dados.

    2. No menu Banco de Dados, aponte para Opções e clique em Documento.

    3. Na caixa de diálogo Opções de Documento de Banco de Dados, selecione o conjunto de símbolos que deseja usar e outras opções de tabela e de relação e clique em OK.

    Usar um banco de dados existente como ponto de partida

    Se você tiver um banco de dados que deseja modelar a fim de entendê-lo melhor ou usá-lo como ponto de partida para um novo modelo, poderá usar o Assistente de Engenharia Reversa para extrair o esquema, ou estrutura, do banco de dados e criar um novo modelo.

    Observação : Antes de iniciar o assistente:

    1. Se estiver fazendo engenharia reversa de uma pasta de trabalho do Microsoft Office Excel, antes de iniciar o assistente você precisará abrir a pasta de trabalho e nomear o grupo (ou intervalo) de células que contém os títulos das colunas. Se quiser usar mais de uma planilha, basta nomear o grupo de células de coluna em cada planilha. Esses intervalos são tratados pelo assistente como tabelas. Para obter mais informações sobre como nomear um intervalo de células, consulte o tópico da Ajuda do Microsoft Office Excel chamado Definir referências de células ou intervalos nomeados.

    2. Para obter melhores resultados, defina o driver padrão para o banco de dados de destino em que você deseja fazer engenharia reversa antes de executar o Assistente de Engenharia Reversa. Essa etapa assegura que o assistente mapeará os tipos de dados nativos corretamente e que todo o código extraído por ele será exibido apropriadamente na janela Código.

    3. No menu Arquivo, aponte para Novo, para Software e Banco de Dados e clique em Diagrama de Modelo de Banco de Dados.

    4. No menu Banco de Dados, clique em Engenharia Reversa.

    5. Na primeira tela do Assistente de Engenharia Reversa, proceda da seguinte forma:

      1. Selecione o driver do banco de dados do Microsoft Office Visio para o sistema de gerenciamento de banco de dados (DBMS). Se você ainda não tiver associado o driver de banco de dados do Visio a uma fonte de dados ODBC específica, clique em Configurar.

        Observação : Se estiver fazendo engenharia reversa de uma planilha do Excel, escolha o Driver Genérico ODBC.

      2. Selecione a fonte de dados do banco de dados que está atualizando. Se você ainda não tiver criado uma fonte de dados para o banco de dados existente, clique em Novo para fazê-lo agora.

        Quando uma nova fonte é criada, seu nome é adicionado à lista Fontes de Dados.

      3. Quando estiver satisfeito com as configurações, clique em Avançar.

    6. Siga as instruções de todas as caixas de diálogo específicas do driver.

      Por exemplo, na caixa de diálogo Conectar Fonte de Dados, digite um nome de usuário e uma senha e clique em OK. Se o banco de dados não for protegido por senha, basta clicar em OK.

      Observação : Se você usar o Driver Genérico ODBC, talvez receba uma mensagem de erro indicando que as informações da engenharia reversa podem estar incompletas. Na maioria dos casos, isso não é um problema — apenas clique em OK e prossiga com o assistente.

    7. Marque as caixas de seleção do tipo de informação que deseja extrair e clique em Avançar.

      Observação : Alguns itens podem não estar disponíveis (aparecem esmaecidos) porque nem todos os sistemas de gerenciamento de banco de dados têm suporte a todos os tipos de elementos que o assistente é capaz de extrair.

    8. Marque as caixas de seleção das tabelas (e exibições, se houver) que deseja extrair ou clique em Selecionar Tudo para extrair todas, e clique em Avançar.

      Observação : Se estiver fazendo engenharia reversa em uma planilha do Excel e não aparecer nada nessa lista, é provável que você precise nomear o intervalo de células que contém os títulos de colunas da planilha.

    9. Se você marcou a caixa de seleção Procedimentos Armazenados na etapa 5, selecione os procedimentos que deseja extrair ou clique em Selecionar Tudo para extrair todos e clique em Avançar.

    10. Selecione se quiser que os itens de engenharia reversa sejam adicionados automaticamente à página atual.

      Observação : Você pode escolher que o assistente crie automaticamente o desenho, além de listar os itens que tiverem sofrido engenharia reversa na janela Tabelas e Exibições. Se decidir que o desenho não deve ser criado automaticamente, poderá arrastar os itens da janela Tabelas e Exibições para a página de desenho, a fim de montar manualmente o modelo de banco de dados.

    11. Reveja suas seleções para verificar se está extraindo as informações desejadas e clique em Concluir.

      O assistente extrai as informações selecionadas e exibe observações sobre o processo de extração na janela Saída.

    Importar e refinar um modelo existente

    Caso você tenha um modelo existente do VisioModeler ou do PLATINUM ERwin, talvez seja capaz de importá-lo para criar um diagrama de modelo de banco de dados do Visio. Essa capacidade é limitada a arquivos de modelo de dicionário (.imd) do VisioModeler 2.0, ou posterior, e a arquivos .erx do PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. No menu Arquivo, aponte para Novo, para Software e Banco de Dados e clique em Diagrama de Modelo de Banco de Dados.

    2. No menu Banco de Dados aponte para Importar e clique em Importar <tipo de modelo>.

    3. Digite o caminho e o nome do arquivo de modelo a ser importado ou clique no botão Procurar para localizar o arquivo de modelo e clique em Abrir.

    4. Na caixa de diálogo Importar, clique em OK.

      O Visio importa o arquivo e exibe o andamento da importação na janela Saída. As tabelas importadas são exibidas na janela Tabelas e Exibições.

    5. Na janela Tabelas e Exibições, selecione as tabelas que deseja modelar e arraste-as para a página de desenho.

  2. Depois que é criado o diagrama de um modelo de banco de dados, começa o trabalho de refinar o diagrama. Você pode adicionar e personalizar tabelas e exibições, criar relações e personalizar tipos de dados e colunas

    Tabelas

    Use a forma Entidade para criar uma tabela no diagrama.

    1. A partir do estêncil Relação de Entidade ou Relacional do Objeto, arraste uma forma Entidade para o desenho.

    2. Clique duas vezes na forma para abrir a janela Propriedades do Banco de Dados.

    3. Em Categorias, clique em Definição e digite um nome para a tabela.

    4. Em Categorias, clique em Colunas, digite um nome e escolha um tipo de dados.

    5. Marque a caixa de seleção Necessário das colunas que não podem ter valores nulos.

    6. Marque a caixa de seleção CP (chave primária) das colunas que identificam exclusivamente cada linha da tabela do banco de dados.

    7. Em Categorias, clique em Índices, Disparadores, Verificar ouEstendidos para criar esses elementos opcionais.

    Colunas

    Use a janela Propriedades do Banco de Dados para adicionar ou alterar propriedades de colunas, inclusive tipos de dados e chaves primárias.

    1. Clique duas vezes na tabela do diagrama.

    2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula Nome físico vazia e digite um nome.

    4. Para alterar o tipo de dados de uma coluna, clique no campo Tipo de Dados da coluna e selecione um tipo de dados na lista ou digite-o na lista. Você pode, por exemplo, digitar decimal(8,2) ou char(30).

    5. Para impedir valores nulos, marque a caixa de seleção Necessário.

    6. Para especificar que a coluna é uma chave primária, marque a caixa de seleção CP.

    7. Para ver mais propriedades de colunas além das que aparecem quando você clica na categoria Colunas, selecione a coluna e clique em Editar.

    Relações

    As relações usam chaves primárias e estrangeiras para permitir que bancos de dados correspondam uma linha de uma tabela com uma linha de uma tabela relacionada. Você pode mostrar essas relações em seu diagrama. Além disso, pode definir a cardinalidade (por exemplo, um-para-muitos) e usar a notação Pés de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. No modelo Diagrama de Modelo de Banco de Dados, não é possível mostrar relações muitos-para-muitos com nenhuma dessas notações.

    1. Crie uma relação entre tabelas:

      1. Verifique se ambas as tabelas estão visíveis no diagrama. Se você fez engenharia reversa no modelo a partir de um banco de dados existente, talvez seja necessário arrastar uma ou ambas da janela Tabelas e Exibições para a página de desenho

      2. Clique duas vezes na tabela que deve ser o lado da chave primária da relação.

      3. Na janela Propriedades do Banco de Dados, em Categorias, clique em Colunas.

      4. Na grade, clique na coluna que você quer usar para identificar exclusivamente cada linha da tabela e marque a caixa de seleção CP para defini-la como chave primária.

      5. A partir do estêncil Relacional do Objeto ou Relação de Entidade, arraste uma forma Relação e solte-a em um espaço em branco da página.

      6. Conecte a extremidade superior à tabela que tem a tabela pai.

      7. Conecte a outra extremidade à tabela filho.

        Se a segunda tabela ainda não contiver uma coluna com o mesmo nome da chave primária, o modelador a adicionará à segunda tabela como chave estrangeira.

        Observação : Se as linhas de relação desaparecerem, no menu Banco de Dados, aponte para Opções e clique em Documento. Na guia Relações, em Mostrar, marque a caixa de seleção Relações.

    2. Defina a cardinalidade da relação:

      1. Clique duas vezes na relação.

      2. Na janela Propriedades do Banco de Dados, em Categorias, clique em Miscelânea.

      3. Em Cardinalidade, escolha a cardinalidade que se ajuste melhor à relação. Em relações um-para-muitos, a melhor escolha é Zero ou mais ou Um ou mais. Em relações um-para-um, a melhor escolha é Zero ou um ou Exatamente um.

  3. Para fazer outros refinamentos no diagrama (como criar índices, cláusulas de verificação e disparadores), você pode fazer o seguinte:

    Criar índices

    Os índices melhoram o desempenho, ou aumentam a velocidade, do banco de dados quando se executa uma consulta.

    1. Abra o diagrama de modelo de banco de dados.

    2. Clique duas vezes na tabela à qual deseja adicionar um índice e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, digite um nome para o índice e clique em OK.

    5. Na lista Tipo de Índice, selecione uma opção para criar um índice exclusivo ou não-exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que deseja incluir nesse índice e clique em Adicionar >.

    7. Na lista Colunas Indexadas, marque a caixa de seleção Crescente para criar um índice com ordem de classificação crescente ou desmarque-a para criar um índice que tenha ordem de classificação decrescente.

      O diagrama de modelo de banco de dados é atualizado.

    Criar modos de exibição

    Considere uma exibição como uma consulta salva. As exibições são particularmente úteis quando se precisa acessar várias vezes a mesma informação a partir de várias tabelas ou quando se quer expor os dados aos usuários sem permitir que eles alterem as tabelas reais.

    A partir do estêncil Relação de Entidade ou Relacional do Objeto, arraste uma forma Exibição para a página de desenho.

    Definir as propriedades estendidas para tabelas e exibições

    Dependendo de seu sistema de gerenciamento de banco de dados (DBMS), você talvez possa definir propriedades estendidas de tabelas ou exibições para determinar onde elas estão armazenadas.

    Clique duas vezes na tabela ou na exibição cujas propriedades estendidas quer definir e, na janela Propriedades do Banco de Dados, na lista Categorias, clique em Estendidas.

    Criar cláusulas de verificação

    Use cláusulas de verificação para garantir que os dados inseridos em uma coluna estejam dentro de determinado intervalo de valores. Você pode, por exemplo, criar uma cláusula de verificação que exija que os dados de uma coluna chamada "Idade" sejam acima de 65.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Colunas e, em seguida, clique na coluna à qual deseja adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. Na guia Verificar da caixa de diálogo Propriedades da coluna, insira as restrições que desejar. Para saber mais sobre as opções, consulte caixa de diálogo coluna e propriedades de campo (guia verificar).

      A cláusula de verificação será adicionada à janela Código, em Código local.

    Criar procedimentos armazenados e funções definidas pelo usuário

    Use procedimentos armazenados e funções definidas pelo usuário para criar pacotes de código que você possa reutilizar a fim de executar várias vezes as mesmas ações. A principal diferença entre eles é que a função definida pelo usuário retorna um valor, enquanto o procedimento armazenado executa o código sem retornar um valor.

    1. No menu Banco de Dados, aponte para Exibir e clique em Código para abrir a janela Código.

    2. Clique em Código Global e clique em Novo.

    3. Na guia Propriedades do Editor de Códigos, clique no tipo de código que deseja criar e digite um nome para o código.

    4. Na guia Corpo, digite o código e clique em OK.

    Criar disparadores

    Os disparadores fazem com que o código SQL especificado no disparador seja executado quando ocorrer determinado evento no banco de dados.

    1. Clique duas vezes na tabela para abrir a janela Propriedades do Banco de Dados.

    2. Em Categorias, clique em Disparadores e clique emAdicionar.

    3. Na guia Propriedades, digite um nome para o disparador.

    4. Na guia Corpo, digite o código e clique em OK.

      O disparador será adicionado à janela Código, em Código local.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×