Criar ou executar uma macro

No Word, você pode automatizar tarefas usadas com frequência criando e executando macros. Uma macro é uma série de comandos e instruções que você agrupa juntos como um único comando para realizar uma tarefa automaticamente.

Para poupar tempo em tarefas que você costuma realizar com frequência, compacte as etapas em uma macro. Em primeiro lugar, grave a macro. Em seguida, você poderá executá-la clicando em um botão da Barra de Ferramentas de Acesso Rápido ou pressionando uma combinação de teclas. Isso dependerá de como você a configurar.

  1. Clique em Exibir > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Digite um nome para a macro.

    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).

    Caixa para escolher onde armazenar uma macro

  4. Para executar uma macro quando você clicar em um botão, clique em Botão.

    Clique para atribuir a macro a um botão

  5. Clique na nova macro (cujo nome é algo do tipo Normal.NovasMacros.<nome da sua macro>) e clique em Adicionar.

    A macro e o botão Adicionar

  6. Clique em Modificar.

    Botão Modificar na caixa Personalizar a Barra de Ferramentas de Acesso Rápido

  7. Escolha uma imagem de botão, digite o nome desejado e clique em OK duas vezes.

    Opções de botão na caixa Modificar Botão

  8. Agora, chegou a hora de gravar as etapas. Clique nos comandos ou pressione as teclas para cada etapa na tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação: Use o teclado para selecionar texto enquanto você grava a macro. Macros não gravam seleções feitas com o mouse.

  9. Para parar de gravar, clique em Exibir > Macros > Parar Gravação.

    Comando Parar Gravação

O botão da sua macro aparece na Barra de Ferramentas de Acesso Rápido.

Botão da macro na Barra de Ferramentas de Acesso Rápido

Para executar a macro, clique no botão.

  1. Clique em Exibir > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Digite um nome para a macro.

    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).

    Caixa para escolher onde armazenar uma macro

  4. Para executar sua macro quando você pressionar um atalho do teclado, clique em Teclado.

    Clique para atribuir a macro a um atalho de teclado

  5. Digite uma combinação de teclas na caixa Pressione a nova tecla de atalho.

  6. Verifique se essa combinação já não está atribuída a outro item. Se estiver, tente uma combinação diferente.

  7. Para usar esse atalho de teclado em qualquer novo documento criado, verifique se a caixa Salvar alterações em indica Normal.dotm.

  8. Clique em Atribuir.

  9. Agora, chegou a hora de gravar as etapas. Clique nos comandos ou pressione as teclas para cada etapa na tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação: Use o teclado para selecionar texto enquanto você grava a macro. Macros não gravam seleções feitas com o mouse.

  10. Para parar de gravar, clique em Exibir > Macros > Parar Gravação.

    Comando Parar Gravação

Para executar a macro, pressione as teclas de atalho do teclado.

Para executar uma macro, clique no botão na Barra de Ferramentas de Acesso Rápido, pressione o atalho de teclado ou executar a macro a partir da lista de Macros.

  1. Clique em Exibir > Macros > Exibir Macros.

    Comando Exibir Macros

  2. Na lista em Nome da macro, clique na macro a ser executada.

  3. Clique em Executar.

Para disponibilizar uma macro de um documento em todos os novos documentos, adicione-a ao modelo Normal.dotm.

  1. Abra o documento que contém a macro.

  2. Clique em Exibir > Macros > Exibir Macros.

    Comando Exibir Macros

  3. Clique em Organizador.

    Botão Organizador na caixa Exibir Macros

  4. Clique na macro que você quer adicionar ao modelo Normal.dotm e clique em Copiar.

  1. Clique em Arquivo > Opções > Personalizar Faixa de Opções.

  2. Em Escolher comandos de, clique em Macros.

  3. Clique na macro desejada.

  4. Em Personalizar a faixa de opções, clique na guia e no grupo personalizado onde você quer adicionar a macro.

Se você não tiver um grupo personalizado, clique em novo grupo. Em seguida , clique em renomear e digite um nome para o seu grupo personalizado.

  1. Clique em Adicionar.

  2. Clique em Renomear para escolher uma imagem para a macro e digitar o nome desejado.

  3. Clique em OK duas vezes.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der à nova macro o mesmo nome de uma macro embutida no Word, as ações da nova macro substituirão a macro interna. Para exibir uma lista de macros internas, clique em comandos do Word na lista macros em .

  3. Na lista macros em , clique no modelo ou documento no qual você deseja armazenar a macro.

    Para disponibilizar sua macro em todos os documentos, certifique-se de clicar em normal. dotm.

  4. Clique em criar para abrir o editor do Visual Basic.

Depois de abrir o editor do Visual Basic, talvez você queira mais informações sobre como trabalhar com o Visual Basic for Applications. Para obter mais informações, clique em ajuda do Microsoft Visual Basic no menu ajuda ou pressione F1.

Você pode gravar uma sequência de ações ou pode escrever uma macro do zero inserindo o código do Visual Basic for Applications na Editor do Visual Basic.

Observação: Para trabalhar com macros no Office Word 2007, é preciso mostrar a guia desenvolvedor .

  1. Clique no Botão do Microsoft Office Imagem do botão Office e em Opções do Word.

  2. Clique em Popular.

  3. Em opções principais para trabalhar com o Word, marque a caixa de seleção Mostrar guia Desenvolvedor na faixa de opções.

    Observação: A Faixa de Opções é um componente de Interface de usuário do Microsoft Office Fluent.

  1. Na guia Desenvolvedor, no grupo Código, clique em Gravar Macro.

    Grupo código na guia Desenvolvedor
  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der à nova macro o mesmo nome de uma macro interna no Office Word 2007, as ações da nova macro substituirão a macro interna. Para exibir uma lista de macros internas, na guia desenvolvedor , no grupo código , clique em macros . Na lista macros em , clique em comandos do Word.

  3. Na caixa armazenar macro em , clique na modelo ou no documento em que você deseja armazenar a macro.

    Importante: Para disponibilizar sua macro em todos os documentos, certifique-se de clicar em normal. dotm.

  4. Na caixa Descrição, digite uma descrição da macro.

  5. Siga um destes procedimentos:

    • Começar a gravar    Para começar a gravar a macro sem atribuí-la a um botão na barra de ferramentas de acesso rápido ou a uma tecla de atalho, clique em OK.

    • Criar um botão    Para atribuir a macro a um botão na barra de ferramentas de acesso rápido, siga este procedimento:

      1. Clique no botão.

      2. Em Personalizar barra de ferramentas de acesso rápido, selecione o documento (ou todos os documentos) ao qual você deseja adicionar a macro à barra de ferramentas de acesso rápido.

        Importante: Para disponibilizar sua macro em todos os documentos, certifique-se de clicar em normal. dotm.

      3. Em escolha os comandos na caixa de diálogo, clique na macro que você está gravando e, em seguida, clique em Adicionar.

      4. Para personalizar o botão, clique em Modificar.

      5. Em símbolo, clique no símbolo que você deseja usar para o botão.

      6. Na caixa nome para exibição , digite o nome da macro que você deseja exibir.

      7. Clique em OK duas vezes para começar a gravar a macro.

        O símbolo que você escolher será exibido na barra de ferramentas de acesso rápido. O nome que você digita é exibido quando você aponta para o símbolo.

    • Atribua um atalho de teclado    Para atribuir a macro a um atalho de teclado, faça o seguinte:

      1. Clique em Teclado.

      2. Na caixa comandos , clique na macro que você está gravando.

      3. Na caixa pressione a nova tecla de atalho , digite a sequência de teclas desejada e, em seguida, clique em atribuir.

      4. Clique em fechar para começar a gravar a macro.

  6. Execute as ações que você deseja incluir na macro.

    Observação: Ao gravar uma macro, você pode usar o mouse para clicar em comandos e opções, mas não para selecionar texto. Você deve usar o teclado para selecionar texto. Para obter mais informações sobre como selecionar texto usando o teclado, consulte selecionar texto.

  7. Para parar de gravar suas ações, clique em parar gravação no grupo código .

Alterar o atalho de teclado para uma macro

  1. Clique no Botão do Microsoft Office Imagem do botão Office e em Opções do Word.

  2. Clique em Personalizar.

  3. Ao lado de atalhos de teclado, clique em Personalizar.

  4. Na lista categorias , clique em macros.

  5. Na lista macros , clique na macro que você deseja alterar.

  6. Na caixa pressione a nova tecla de atalho , digite a combinação de teclas que você deseja escolher.

  7. Marque a caixa teclas atuais para certificar-se de que você não esteja atribuindo uma combinação de teclas que você já use para executar uma tarefa diferente.

  8. Na lista salvar alterações em , clique na opção que corresponde ao local em que você deseja executar a macro.

    Importante: Para disponibilizar sua macro em todos os documentos, certifique-se de clicar em normal. dotm.

  9. Clique em Fechar.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    Grupo código na guia Desenvolvedor

  2. Na lista em nome da macro, clique na macro que você deseja executar.

  3. Clique em Executar.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    Grupo código na guia Desenvolvedor

  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der à nova macro o mesmo nome de uma macro interna no Office Word 2007, as ações da nova macro substituirão a macro interna. Para exibir uma lista de macros internas, clique em comandos do Word na lista macros em .

  3. Na lista macros em , clique no modelo ou no documento em que você deseja armazenar a macro.

    Para disponibilizar sua macro em todos os documentos, certifique-se de clicar em normal. dotm.

  4. Clique em criar para abrir o editor do Visual Basic.

Depois de abrir o editor do Visual Basic, talvez você queira mais informações sobre como trabalhar com o Visual Basic for Applications. Para obter mais informações, clique em ajuda do Microsoft Visual Basic no menu ajuda ou pressione F1.

Para fazer um trabalho rápido das tarefas que você faz com frequência, na versão da área de trabalho do Word, você pode reunir as etapas em macros executadas com um único clique. Em Word para a Web, é preciso percorrer essas tarefas manualmente.

Se você tiver o Word, clique primeiro em abrir no Word para abrir o documento no Word.

Imagem do comando Abrir no Word do Word Web App

Em seguida, siga as instruções para a versão da área de trabalho do Word.

Ao executar a macro no Word e salvar o documento, você verá os resultados da macro quando reabrir o documento no Word para a Web.

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×