Criar ou excluir uma macro

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Para automatizar uma tarefa repetitiva, você pode gravar rapidamente um macro no Microsoft Excel. Você também pode criar uma macro usando o Editor do Visual Basic no Microsoft Visual Basic for Applications (VBA) para escrever seu próprio código de macro, ou para copiar toda ou parte de uma macro para uma nova macro. Depois de criar uma macro, você pode atribui-la a um objeto (como um botão de barra de ferramentas, gráfico ou controle) para que você possa executá-lo clicando no objeto. Se você já não usar uma macro, você poderá excluí-la.

A seguir estão as etapas para criar ou excluir macros no Excel 2013 e no Excel 2016.

Gravar uma macro

Quando você grava uma macro, o gravador de macros grava todas as etapas necessárias para concluir as ações que você quer que a macro execute. Essas etapas podem incluir digitar texto ou números, clicar em células ou comandos na faixa de opções ou nos menus, formatar, selecionar células, linhas ou colunas e arrastar o mouse para selecionar células na sua planilha. Os comandos para gravar, criar e excluir macros estão disponíveis na guia Desenvolvedor da Faixa de Opções.

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo.

    2. Clique em Opções e em Personalizar Faixa de Opções.

    3. Na categoria Personalizar Faixa de Opções, na lista Guias Principais, marque a caixa de seleção Desenvolvedor e depois clique em OK.

  2. Pode ser necessário primeiro definir o nível de segurança para habilitar todas as macros. Para fazê-lo:

    1. Na guia desenvolvedor, no grupo código, clique em Segurança de Macro.

      O grupo Código na guia Desenvolvedor no Excel

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Cuidado : Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a uma das configurações que desabilita todas as macros após trabalhar com elas.

  3. Na guia Desenvolvedor, no grupo Código, clique em Gravar Macro.

  4. Na caixa Nome da macro, insira um nome para a macro.

    Observação : O primeiro caractere do nome da macro deve ser uma letra. Os caracteres subsequentes podem ser letras, números ou caracteres sublinhados. Não são permitidos espaços em um nome de macro; um caractere sublinhado funciona da mesma forma que um separador de palavras. Se usar um nome de macro que também é uma referência de célula, você poderá receber uma mensagem de erro informando que o nome da macro é inválido.

  5. Para atribuir uma tecla de atalho de combinação com Ctrl para executar a macro, na caixa Tecla de atalho, digite qualquer letra maiúscula ou minúscula que você queira usar.

    A tecla de atalho substituirá qualquer tecla de atalho padrão equivalente do Excel enquanto a pasta de trabalho que contém a macro estiver aberta.

  6. Na lista Armazenar macro em, selecione a pasta de trabalho na qual deseja armazenar a macro.

    Para que uma macro esteja disponível sempre que você usar o Excel, selecione Pasta de trabalho pessoal de macros. Quando você seleciona Pasta de trabalho pessoal de macros, o Excel cria uma pasta de trabalho pessoal de macros oculta (Pessoal.xlsb), se já não tiver uma, e salva a macro nessa pasta de trabalho. No Windows 7 e Windows Vista, essa pasta de trabalho é salva na pasta C:\Usuários\nome do usuário\AppData\Local\Microsoft\Excel\XLStart. No Microsoft Windows XP, essa pasta de trabalho é salva na pasta C:\Documents and Settings\nome do usuário\Dados de Aplicativos\Microsoft\Excel\XLStart. As pastas de trabalho da pasta XLStart são abertas automaticamente sempre que o Excel é iniciado. Se desejar que uma macro da pasta de trabalho pessoal de macros seja executada automaticamente em outra pasta de trabalho, você também deverá salvá-la na pasta XLStart, para que ambas sejam abertas quando o Excel for iniciado.

  7. Na caixa Descrição, digite a descrição da macro.

  8. Clique em OK para iniciar a gravação.

  9. Execute as ações que deseja gravar.

  10. Na guia Desenvolvedor, no grupo Código, clique em Interromper Gravação Imagem do botão .

Início da Página

Criar uma macro com o VBA

  1. Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

  2. Se necessário, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

    Observação : Os módulos são criados automaticamente para todas as planilhas da pasta de trabalho.

  3. Na janela de código do módulo, digite ou copie o código de macro que deseja usar.

  4. Para executar a macro da janela de módulo, pressione F5.

  5. No menu Arquivo do Editor do Visual Basic, clique em Fechar e Retornar ao Microsoft Excel quando terminar de gravar a macro.

Início da página

Copiar parte de uma macro para criar outra macro

  1. Abra a pasta de trabalho que contém a macro que você deseja copiar.

  2. Na guia Desenvolvedor, no grupo Código, clique em Macros.

  3. Na caixa Nome da macro, clique no nome da macro que deseja copiar.

  4. Clique em Editar.

  5. Na janela de código do Editor do Visual Basic, selecione as linhas da macro que deseja copiar.

    Dica : Para copiar a macro inteira, inclua as linhas Sub e End Sub na seleção.

  6. No menu Editar, clique em Copiar.

  7. Na caixa Procedimento da janela de código, clique no módulo em que deseja inserir o código.

  8. No menu Editar, clique em Colar.

Talvez você não consiga editar seu arquivo de pasta de trabalho pessoal de macros (Pessoal.xlsb), pois trata-se de uma pasta de trabalho oculta que está sempre aberta. É preciso reexibi-la com o comando Reexibir. Você também pode abri-la no Editor do Visual Basic pressionando Alt+F11.

Início da Página

Atribuir uma macro a um objeto, a um elemento gráfico ou a um controle

  1. Em uma planilha, clique com o botão direito do mouse no objeto, no elemento gráfico ou no controle ao qual deseja atribuir uma macro existente e, em seguida, clique em Atribuir Macro.

  2. Na caixa Nome da macro, clique na macro que deseja atribuir.

Início da página

Excluir uma macro

  1. Siga um destes procedimentos:

    • Abra a pasta de trabalho que contém a macro que você deseja excluir.

    • Se a macro que você deseja excluir estiver armazenada na pasta de trabalho pessoal de macros (Pessoal.xlsb), e essa pasta de trabalho estiver oculta, siga este procedimento para torná-la visível:

      1. Na guia Exibir, no grupo Janela, clique em Reexibir.

      2. Em Reexibir pastas de trabalho, clique em pessoal e clique em OK.

  2. Na lista Macros em, selecione a pasta de trabalho que contém a macro a ser excluída. Por exemplo, clique em Esta Pasta de Trabalho.

  3. Na caixa Nome da macro, clique no nome da macro que deseja excluir.

  4. Clique em Excluir.

Início da página

A seguir estão as etapas para criar ou excluir macros no Excel 2010.

Gravar uma macro

Quando você grava uma macro, todas as etapas do processo são gravadas para que seja possível concluir as ações que a macro deverá desempenhar. A navegação na Faixa de Opções não está incluída nas etapas gravadas.

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo.

    2. Clique em Opções e em Personalizar Faixa de Opções.

    3. Na categoria Personalizar Faixa de Opções, na lista Guias Principais, marque a caixa de seleção Desenvolvedor e depois clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Nota    Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a qualquer uma das configurações que desabilita todas as macros após trabalhar com macros.

      Para obter mais informações sobre como alterar as configurações, consulte o artigo sobre como alterar as configurações de segurança de macro no Excel.

  3. Na guia Desenvolvedor, no grupo Código, clique em Gravar Macro.

  4. Na caixa Nome da macro, insira um nome para a macro.

    Observação    O primeiro caractere do nome da macro deve ser uma letra. Os caracteres seguintes podem ser letras, números ou caracteres sublinhados. Espaços não podem ser usados em um nome de macro; um caractere sublinhado funciona bem como um separador de palavras. Se você usar um nome de macro que também é uma referência de célula, você pode receber uma mensagem de erro que o nome da macro não é válido.

  5. Para atribuir uma tecla de atalho de combinação com CTRL para executar a macro, na caixa Tecla de atalho, digite as letras maiúsculas ou minúsculas a serem usadas.

    Nota    A tecla de atalho substituirá qualquer tecla de atalho padrão equivalente do Excel enquanto a pasta de trabalho que contém a macro estiver aberta.

    Para obter uma lista de teclas de atalho de combinação com CTRL que já estão atribuídas no Excel, consulte o artigo sobre teclas de atalho e de função do Excel.

  6. Na lista Armazenar macro em, selecione a pasta de trabalho na qual deseja armazenar a macro.

    Dica    Se desejar que uma macro fique disponível sempre que você usar o Excel, selecione a Pasta de trabalho pessoal de macros. Quando você selecionar a Pasta de trabalho pessoal de macros, o Excel cria uma pasta de trabalho pessoal de macros ocultas (xlsb), se ele ainda não existir e salva a macro nesta pasta de trabalho. No Windows Vista, esta pasta de trabalho é salvo na pasta de name\AppData\Local\Microsoft\Excel\XLStart C:\Users\user. No Microsoft Windows XP, esta pasta de trabalho é salvo na pasta C:\Documents and Settings name\Application Data\Microsoft\Excel\XLStart. Pastas de trabalho na pasta XLStart são abertas automaticamente sempre que o Excel é iniciado. Se você quiser uma macro na pasta de trabalho pessoal de macros para ser executado automaticamente em outra pasta de trabalho, você também deve salvar essa pasta de trabalho na pasta XLStart para que as duas pastas de trabalho são abertas ao iniciar o Excel.

  7. Na caixa Descrição, digite a descrição da macro.

  8. Clique em OK para iniciar a gravação.

  9. Execute as ações que deseja gravar.

  10. Na guia Desenvolvedor, no grupo Código, clique em Interromper Gravação Imagem do botão .

    Dica    Também é possível clicar em Parar gravação Imagem do botão no lado esquerdo da barra de status.

Início da Página

Criar uma macro com o VBA

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo.

    2. Clique em Opções e em Personalizar Faixa de Opções.

    3. Na categoria Personalizar Faixa de Opções, na lista Guias Principais, marque a caixa de seleção Desenvolvedor e depois clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Nota    Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a qualquer uma das configurações que desabilita todas as macros após trabalhar com macros.

      Para obter mais informações sobre como alterar as configurações, consulte o artigo sobre como alterar as configurações de segurança de macro no Excel.

  3. Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

  4. Se necessário, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

    Observação    Módulos são criados automaticamente para todas as planilhas na pasta de trabalho.

  5. Na janela de código do módulo, digite ou copie o código de macro que deseja usar.

  6. Para executar a macro da janela de módulo, pressione F5.

  7. No menu Arquivo do Editor do Visual Basic, clique em Fechar e Retornar ao Microsoft Excel quando terminar de gravar a macro.

Início da página

Copiar parte de uma macro para criar outra macro

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo.

    2. Clique em Opções e em Personalizar Faixa de Opções.

    3. Na categoria Personalizar Faixa de Opções, na lista Guias Principais, marque a caixa de seleção Desenvolvedor e depois clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Nota    Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a qualquer uma das configurações que desabilita todas as macros após trabalhar com macros.

      Para obter mais informações sobre como alterar as configurações, consulte o artigo sobre como alterar as configurações de segurança de macro no Excel.

  3. Abra a pasta de trabalho que contém a macro que você deseja copiar.

  4. Na guia Desenvolvedor, no grupo Código, clique em Macros.

  5. Na caixa Nome da macro, clique no nome da macro que deseja copiar.

  6. Clique em Editar.

  7. Na janela de código do Editor do Visual Basic, selecione as linhas da macro que deseja copiar.

    Dica    Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  8. No menu Editar, clique em Copiar.

    Dica    Você pode também com o botão direito e, em seguida, clique em Copiar, ou você pode pressionar CTRL + C.

  9. Na caixa Procedimento da janela de código, clique no módulo em que deseja inserir o código.

  10. No menu Editar, clique em Colar.

    Dica    Você pode também com o botão direito e, em seguida, clique em Colar, ou você pode pressionar CTRL + V.

Dica    Você não pode editar o arquivo de pasta de trabalho pessoal de macros (pessoal. xlsb) porque é uma pasta de trabalho oculta que está sempre aberta. Você deve primeiro reexibi-la usando o comando Reexibir. Você pode também abri-lo no Editor do Visual Basic pressionando ALT + F11.

Início da Página

Atribuir uma macro a um objeto, a um elemento gráfico ou a um controle

  1. Em uma planilha, clique com o botão direito do mouse no objeto, no elemento gráfico ou no controle ao qual deseja atribuir uma macro existente e, em seguida, clique em Atribuir Macro.

  2. Na caixa Nome da macro, clique na macro que deseja atribuir.

Início da página

Excluir uma macro

  1. Siga um destes procedimentos:

    • Abra a pasta de trabalho que contém a macro que você deseja excluir.

    • Se a macro que você deseja excluir estiver armazenada na pasta de trabalho pessoal de macros (Pessoal.xlsb), e essa pasta de trabalho estiver oculta, siga este procedimento para torná-la visível:

      1. Na guia Exibir, no grupo Janela, clique em Reexibir.

      2. Em Re-exibir pasta de trabalho, clique em PESSOAL e em OK.

  2. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo.

    2. Clique em Opções e em Personalizar Faixa de Opções.

    3. Na categoria Personalizar Faixa de Opções, na lista Guias Principais, marque a caixa de seleção Desenvolvedor e clique em OK.

  3. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    O grupo Código na guia Desenvolvedor

  4. Na lista Macros em, selecione a pasta de trabalho que contém a macro a ser excluída. Por exemplo, clique em Esta Pasta de Trabalho.

  5. Na caixa Nome da macro, clique no nome da macro que deseja excluir.

  6. Clique em Excluir.

Início da página

A seguir estão as etapas para criar ou excluir macros no Excel 2007.

Gravar uma macro

Quando você grava uma macro, todas as etapas do processo são gravadas para que seja possível concluir as ações que a macro deverá desempenhar. A navegação na Faixa de Opções não está incluída nas etapas gravadas.

Observação : A Faixa de Opções é um componente da Interface de usuário do Microsoft Office Fluent.

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique no Botão do Microsoft Office imagem do botão office e clique em Opções do Excel.

    2. Na categoria Popular, em Opções principais para o trabalho com o Excel, marque a caixa de seleção Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Observação : Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a qualquer uma das configurações que desabilita todas as macros após trabalhar com elas. Para obter mais informações sobre como alterar as configurações, confira Alterar as configurações de segurança de macro no Excel.

  3. Na guia Desenvolvedor, no grupo Código, clique em Gravar Macro.

  4. Na caixa Nome da macro, insira um nome para a macro.

Observação : O primeiro caractere do nome da macro deve ser uma letra. Os caracteres subsequentes podem ser letras, números ou caracteres sublinhados. Não são permitidos espaços em um nome de macro; um caractere sublinhado funciona da mesma forma que um separador de palavras. Se usar um nome de macro que também é uma referência de célula, você poderá receber uma mensagem de erro informando que o nome da macro é inválido.

  1. Para atribuir uma tecla de atalho de combinação com CTRL para executar a macro, na caixa Tecla de atalho, digite as letras maiúsculas ou minúsculas a serem usadas.

    Observação : A tecla de atalho substituirá todas as teclas de atalho padrão equivalentes do Excel enquanto a pasta de trabalho que contém a macro estiver aberta. Para obter uma lista de teclas de atalho de combinação com CTRL já atribuídas no Excel, consulte Teclas de atalho e de função do Excel.

  2. Na lista Armazenar macro em, selecione a pasta de trabalho na qual deseja armazenar a macro.

    Dica : Para que uma macro esteja disponível sempre que você usar o Excel, selecione Pasta de Trabalho Pessoal de Macros. Quando você seleciona Pasta de Trabalho Pessoal de Macros, o Excel cria uma pasta de trabalho pessoal de macros oculta (Pessoal.xlsb) caso ela ainda não exista, ele salvará a macro nessa pasta de trabalho. No Windows Vista, essa pasta de trabalho é salva na pasta C:\Users\nome do usuário\AppData\Local\Microsoft\Excel\XLStart. No Microsoft Windows XP, essa pasta de trabalho é salva na pasta C:\Documents and Settings\nome do usuário\Application Data\Microsoft\Excel\XLStart. As pastas de trabalho da pasta XLStart são abertas automaticamente sempre que o Excel é iniciado. Se desejar que uma macro da pasta de trabalho pessoal de macros seja executada automaticamente em outra pasta de trabalho, você também deverá salvá-la na pasta XLStart para que ambas sejam abertas quando o Excel for iniciado.

  3. Na caixa Descrição, digite a descrição da macro.

  4. Clique em OK para iniciar a gravação.

  5. Execute as ações que deseja gravar.

  6. Na guia Desenvolvedor, no grupo Código, clique em Interromper Gravação Imagem do botão .

    Também é possível clicar em Interromper Gravação Imagem do botão no lado esquerdo da barra de status.

Início da página

Criar uma macro usando o Microsoft Visual Basic for Applications

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique no Botão do Microsoft Office imagem do botão office e clique em Opções do Excel.

    2. Na categoria Popular, em Opções principais para o trabalho com o Excel, marque a caixa de seleção Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Observação : Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a uma das configurações que desabilita todas as macros após trabalhar com elas.

  3. Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

  4. Se necessário, no Editor do Visual Basic, no menu Inserir, clique em Módulo.

    Observação : Os módulos são criados automaticamente para todas as planilhas da pasta de trabalho.

  5. Na janela de código do módulo, digite ou copie o código de macro que deseja usar.

  6. Para executar a macro da janela de módulo, pressione F5.

  7. No menu Arquivo do Editor do Visual Basic, clique em Fechar e Retornar ao Microsoft Excel quando terminar de gravar a macro.

Início da página

Copiar parte de uma macro para criar outra macro

  1. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique no Botão do Microsoft Office imagem do botão office e clique em Opções do Excel.

    2. Na categoria Popular, em Opções principais para o trabalho com o Excel, marque a caixa de seleção Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

  2. Para definir temporariamente o nível de segurança e habilitar todas as macros, faça o seguinte:

    1. Na guia Desenvolvedor, no grupo Código, clique em Segurança da Macro.

      O grupo Código na guia Desenvolvedor

    2. Em Configurações da Macro, clique em Habilitar todas as macros (não recomendável; códigos possivelmente perigosos podem ser executados) e, em seguida, clique em OK.

      Observação : Para ajudar a impedir a execução de códigos possivelmente perigosos, é recomendável que você retorne a uma das configurações que desabilita todas as macros após trabalhar com elas.

  3. Abra a pasta de trabalho que contém a macro que você deseja copiar.

  4. Na guia Desenvolvedor, no grupo Código, clique em Macros.

  5. Na caixa Nome da macro, clique no nome da macro que deseja copiar.

  6. Clique em Editar.

  7. Na janela de código do Editor do Visual Basic, selecione as linhas da macro que deseja copiar.

Dica : Para copiar a macro inteira, inclua as linhas Sub e End Sub na seleção.

  1. No menu Editar, clique em Copiar.

    Você também pode clicar com o botão direito do mouse e clicar em Copiar ou pressionar CTRL+C.

  2. Na caixa Procedimento da janela de código, clique no módulo em que deseja inserir o código.

  3. No menu Editar, clique em Colar.

    Você também pode clicar com o botão direito do mouse e clicar em Copiar ou pressionar CTRL+V.

Dica : Você não pode editar seu arquivo de pasta de trabalho pessoal de macros (Personal.xlsb) por ela ser uma pasta de trabalho oculta que está sempre aberta. Você deve primeiro reexibi-la com o comando Reexibir. Você também pode abri-la no Editor do Visual Basic, pressionando ALT+F11.

Início da página

Atribuir uma macro a um objeto, a um elemento gráfico ou a um controle

  1. Em uma planilha, clique com o botão direito do mouse no objeto, no elemento gráfico ou no controle ao qual deseja atribuir uma macro existente e, em seguida, clique em Atribuir Macro.

  2. Na caixa Nome da macro, clique na macro que deseja atribuir.

Excluir uma macro

  1. Siga um destes procedimentos:

    • Abra a pasta de trabalho que contém a macro que você deseja excluir.

    • Se a macro que você deseja excluir estiver armazenada na pasta de trabalho pessoal de macros (Pessoal.xlsb), e essa pasta de trabalho estiver oculta, siga este procedimento para torná-la visível:

      1. Na guia Exibir, no grupo Janela, clique em Reexibir.

      2. Em Re-exibir pasta de trabalho, clique em PESSOAL e em OK.

  2. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique no Botão do Microsoft Office imagem do botão office e clique em Opções do Excel.

    2. Na categoria Popular, em Opções principais para o trabalho com o Excel, marque a caixa de seleção Mostrar guia Desenvolvedor na Faixa de Opções e clique em OK.

  3. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    O grupo Código na guia Desenvolvedor

  4. Na lista Macros em, selecione a pasta de trabalho que contém a macro a ser excluída. Por exemplo, clique em Esta Pasta de Trabalho.

  5. Na caixa Nome da macro, clique no nome da macro que deseja excluir.

  6. Clique em Excluir.

Início da página

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Consulte Também

Início rápido: criar uma macro

Editar uma macro

Executar uma macro

Copiar um módulo de macro para outra pasta de trabalho

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Localizar e corrigir erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Funções do Excel (ordem alfabéticos)

Funções do Excel (por categoria)

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×