Criar formulários e relatórios do Access com base em uma lista do SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode criar formulários e relatórios de uma lista do SharePoint e usá-los como modos de exibição. Usuários do site do SharePoint com o Access 2007 instalado podem abrir esses formulários e relatórios usando o menu de exibição da lista do SharePoint. Você pode fazer com que um acesso exibir o modo de exibição padrão para uma lista.

Os modos de exibição que você cria usando Access 2007 são armazenados em um arquivo de banco de dados no servidor Windows SharePoint Services. Quando você abre um modo de exibição de acesso de uma lista do SharePoint, começa do Access, e ele exibe o formulário ou relatório. Como o banco de dados é armazenado no site do SharePoint, o modo de exibição pode ser aberto por outros usuários do site. Um usuário não precisa saber o local, no site do SharePoint, do arquivo de banco de dados que contém o modo de exibição do Access para poder usar o modo de exibição. Além disso, o usuário não nem precisa saber como iniciar o Access — isso é tratado automaticamente pelo site do SharePoint.

Observação : O usuário precisa ter o Access 2007 instalado em seu computador para criar, usar ou modificar um modo de exibição do Access em um site do SharePoint.

O que você deseja fazer?

Criar um modo de exibição do Access de uma lista do SharePoint

Tornar um acesso a visualização do modo de exibição padrão para lista do SharePoint

Usar um modo de exibição do Access de uma lista do SharePoint

Modificar um modo de exibição do Access de uma lista do SharePoint

Criar um modo de exibição do Access de uma lista do SharePoint

Quando você cria um modo de exibição do Access de uma lista do SharePoint, o Access é iniciado automaticamente. No Access, é possível basear o modo de exibição em vários modelos de formulário e relatório e, em seguida, personalizar o modo. Publicando o modo de exibição no site do SharePoint, você poderá facilmente disponibilizá-lo para outros usuários.

Observação : Para criar um modo de exibição de uma lista do SharePoint, você precisa da permissão Gerenciar Listas do Windows SharePoint Services, que, por padrão, está incluída no nível de permissão Design.

Use o seguinte procedimento para criar um modo de exibição do Access de uma lista do SharePoint que você esteja visualizando no navegador.

  1. No site do SharePoint, no menu Exibir Menu suspenso , clique em Criar Modo de Exibição.

  2. Na página Criar Modo de Exibição, clique em Modo de Exibição do Access.

    O Access é iniciado e solicita que você salve uma cópia local do banco de dados que conterá o novo modo de exibição.

  3. Na caixa de diálogo Salvar Cópia Local, vá até o local do computador em que você deseja salvar a cópia, digite um nome para a cópia local na caixa Nome do Arquivo e clique em Salvar.

    O Access salvará e abrirá a cópia local e, depois, a caixa de diálogo Criar Modo de Exibição do Access será exibida.

  4. Na caixa de diálogo Criar Modo de Exibição do Access, clique duas vezes no tipo de modo de exibição que deseja criar.

    O Access criará o novo modo de exibição e o abrirá no modo Layout.

  5. Você pode personalizar o novo modo de exibição no modo Layout ou alternar para o modo Design.

    No modo Layout, você pode redimensionar e reorganizar controles (como rótulos e campos), mas não pode adicionar outros controles. O modo Layout permite a visualização dos dados, facilitando a exibição da aparência final do modo de exibição.

    No modo Design, você pode redimensionar e reorganizar controles, além de adicionar outros controles. No entanto, ele não permite a visualização dos dados.

    É possível alternar entre os modos Design e Layout sempre que desejar. Se você usar o modo Design para adicionar controles ao modo de exibição, poderá alternar para o modo Layout e organizar esses controles enquanto visualiza os dados.

  6. Depois que você fizer as personalizações, na Barra de Mensagens, clique em Publicar no Site do SharePoint.

    barra de ferramentas

    A caixa de diálogo Publicar no Servidor Web é exibida.

    Se a Barra de Mensagens não aparecer, exiba-a da seguinte maneira:

    • Na guia Ferramentas de Banco de Dados, no grupo Mostrar/Ocultar, clique em Barra de Mensagens.

  7. Por padrão, o Access salva o modo de exibição em um arquivo de banco de dados localizado na biblioteca de Documentos Compartilhados no site do SharePoint . Esse site contém a lista em que você criou o modo de exibição. Na maioria dos casos, esse provavelmente será o procedimento desejado, mas você pode alterar a biblioteca de documentos na qual armazenará o banco de dados escolhendo outra biblioteca na caixa Salvar em, na caixa de diálogo Publicar no Servidor Web. Você pode fazer isso para controlar mais especificamente que terá acesso ao modo de exibição e se os usuários poderão abrir o modo de exibição como somente leitura ou apenas para edição. Talvez, o site do SharePoint tenha também bibliotecas específicas configuradas para publicar os modos de exibição do Access. Nesse caso, você provavelmente precisará alterar o local Salvar em para selecionar a biblioteca correta.

    O administrador do site do SharePoint pode ajudar você a selecionar a biblioteca correta.

  8. O Access fornece um nome para o banco de dados na caixa Nome do arquivo, na caixa de diálogo Publicar no Servidor Web. Esse nome coincidirá com o nome do banco de dados que você salvou como cópia local. Você pode alterar o nome se desejar, mas na maioria dos casos, deve aceitar o nome sugerido . Isso facilitará a memorização do banco de dados local correspondente ao banco de dados publicado no site do SharePoint.

  9. Clique em Publicar para salvar o banco de dados no site do SharePoint.

Início da página

Tornar um acesso a visualização do modo de exibição padrão para lista do SharePoint

Quando você faz um acesso exibir a exibição padrão para uma lista do SharePoint, o modo de exibição do Access abre automaticamente quando os usuários abrirem a lista, se os usuários tem acesso instalado em seus computadores.

Importante : Se você cometer um modo de exibição do Access a exibição padrão, os visitantes de lista que não têm o Access 2007 instalado não poderão usar a lista.

  1. Com a lista do SharePoint aberta, no menu configurações, clique em Configurações da lista.

  2. Na página Configurações da lista, em modos de exibição, clique no nome do modo de acesso que você deseja tornar a visualização padrão.

  3. Na página Editar modo de exibição, selecione tornar este modo de exibição padrão e clique em OK.

Início da página

Usar um modo de exibição do Access de uma lista do SharePoint

Para usar um modo de exibição do Access de uma lista do SharePoint, você escolhe o modo no menu Exibir da lista.

  • No menu Exibir Menu suspenso , clique no nome do modo de exibição do Access. O Access é iniciado e mostra o modo de exibição como somente leitura.

    No modo somente leitura, você pode alterar os dados no modo de exibição e imprimi-lo, mas não pode alterar o design do modo. Para alterar o design do modo de exibição, consulte a próxima seção deste artigo, Modificar um modo de exibição do Access de uma lista do SharePoint.

Início da página

Modificar um modo de exibição do Access de uma lista do SharePoint

Para modificar o design de um modo de exibição do Access, salve uma cópia local do banco de dados que contém o modo e faça as alterações. Em seguida, use a cópia local do modo de exibição ou, caso tenha as permissões apropriadas no site do SharePoint, publique o novo modo de exibição.

Observação : Você pode modificar a cópia local de um modo de exibição do Access, independentemente do seu nível de permissão no Windows SharePoint Services. Entretanto, para publicar o modo de exibição modificado no site do SharePoint, você precisará da permissão Gerenciar Listas do Windows SharePoint Services, que, por padrão, está incluída no nível de permissão Design. Se você tiver criado o modo de exibição do Access, já deverá ter a permissão Gerenciar Listas. Caso não tenha certeza, contate o administrador do site do SharePoint para saber se você tem as permissões necessárias.

  1. Com o modo de exibição do Access aberto, na Barra de Mensagens, clique em Salvar como.

    Botão Salvar como na Barra de Mensagens

    Observação : Se a Barra de Mensagens não aparecer, exiba-a da seguinte maneira:

    • Na guia Ferramentas de Banco de Dados, no grupo Mostrar/ocultar, clique em Barra de Mensagens.

  2. Clique em Sim quando o Access solicitar que você feche o modo de exibição e todos os outros objetos abertos.

    A caixa de diálogo Salvar como é exibida.

  3. Na caixa Salvar em, especifique o local em que a cópia local será salva, digite um nome para a cópia na caixa Nome do arquivo e clique em Salvar.

    O Access salvará a cópia local do banco dedados e a abrirá.

  4. Siga um destes procedimentos:

    • Para alterar o layout do modo de exibição sem adicionar novos controles, no Painel de Navegação, clique com o botão direito do mouse no modo de exibição e, em seguida, clique em Modo Layout no menu de atalho.

      No modo Layout, você pode redimensionar e reorganizar controles (como rótulos e campos), mas não pode adicionar outros controles. O modo Layout permite a visualização dos dados, facilitando a exibição da aparência final do modo de exibição.

    • Para adicionar ou remover controles do modo de exibição (como rótulos ou campos), no Painel de Navegação, clique com o botão direito do mouse no modo de exibição e, em seguida, clique em Modo Design no menu de atalho.

      No modo Design, você pode redimensionar e reorganizar controles, além de adicionar outros controles. No entanto, ele não permite a visualização dos dados.

      Observação : Se você optar por editar o modo de exibição no modo Design e pretende publicar o modo de exibição revisado no site do SharePoint, não adicione nenhum campo ao modo de exibição que não faça parte da lista do SharePoint.

  5. É possível alternar entre os modos Design e Layout sempre que desejar. Se você usar o modo Design para adicionar controles ao modo de exibição, poderá alternar para o modo Layout e organizar esses controles enquanto visualiza os dados.

Publicar o modo de exibição do Access modificado no site do SharePoint

Depois que você modificar o modo de exibição, se tiver a permissão Gerenciar Listas no site do SharePoint, poderá publicar o modo de exibição modificado executando o procedimento a seguir.

Para obter a permissão Gerenciar Listas, contate o administrador do site do SharePoint.

  1. Salve o modo de exibição na cópia local do banco de dados.

  2. Na Barra de Mensagens, clique em Publicar no Site do SharePoint.

    barra de ferramentas

    Observação : Se você não tiver a permissão Gerenciar Listas, a Barra de Mensagens não exibirá o botão Publicar no Site do SharePoint. Se a Barra de Mensagens não aparecer, exiba-a da seguinte maneira:

    • Na guia Ferramentas de Banco de Dados, no grupo Mostrar/ocultar, clique em Barra de Mensagens.

  3. Na caixa de diálogo Publicar no Servidor Web , clique em Publicar.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Compartilhar Facebook Facebook Twitter Twitter Email Email

Essas informações foram úteis?

Ótimo! Outros comentários?

Como podemos melhorá-lo?

Obrigado por seus comentários!

×