Criar fórmulas condicionais

Testar se condições são verdadeiras ou falsas e fazer comparações lógicas entre expressões são ações comuns a várias tarefas. Use as funções E, OU, NÃO e SE para criar fórmulas condicionais.

Por exemplo, a função SE usa os argumentos a seguir.

fórmula com a se função

Fórmula que usa a função SE

Imagem do botão  teste_lógico: a condição a ser verificada.

Imagem de botão  valor_se_verdadeiro: o valor a ser retornado se a condição for verdadeira.

Imagem do botão  valor_se_falso: o valor a ser retornado se a condição for falsa.

Para obter mais informações sobre como criar fórmulas, confira Criar ou excluir uma fórmula.

O que você deseja fazer?

Criar uma fórmula condicional que resulte em um valor lógico (VERDADEIRO ou FALSO)

Criar uma fórmula condicional que resulte em outro cálculo ou em valores diferentes de VERDADEIRO ou FALSO

Criar uma fórmula condicional que resulte em um valor lógico (VERDADEIRO ou FALSO)

Para executar esta tarefa, use as funções E, OU e NÃO e operadores como mostrado no exemplo a seguir.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo.

    Importante : Não selecione os cabeçalhos de linha ou de coluna.

    selecionando um exemplo na Ajuda do Excel 2013 para Windows

    Selecionando um exemplo na Ajuda

  2. Pressione CTRL+C.

  3. Crie uma planilha ou pasta de trabalho em branco no Excel.

  4. Na planilha, selecione a célula A1 e pressione CTRL+V.

Importante : Para que o exemplo funcione corretamente, basta colá-lo na célula A1 da planilha.

  1. Para alternar entre ver os resultados e ver as fórmulas que retornam os resultados, pressione CTRL+` (acento grave), ou na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.

1

2

3

4

5

6%

7



8



9


10


11



12

A

B

Dados

15

9

8

Rodas dentadas

Widgets

Fórmula

Descrição (Resultado)

=E(A2>A3; A2<A4)

Determina se o valor da célula A2 é maior do que o valor em A3 e também se o valor de A2 é menor do que o valor de A4. (FALSO)

=OU(A2>A3; A2<A4)

Determina se o valor da célula A2 é maior do que o valor em A3 ou se o valor de A2 é menor do que o valor de A4. (VERDADEIRO)

=NÃO(A2+A3=24)

Determina se a soma dos valores das células A2 e A3 não é igual a 24. (FALSO)

=NÃO(A5="Rodas dentadas")

Determina se o valor da célula A5 não é igual a "Rodas dentadas." (FALSO)

=OU(A5<>"Rodas dentadas";A6 = "Widgets")

Determina se o valor da célula A5 não é igual a "Rodas dentadas" ou se o valor em A6 é igual a "Acessórios." (VERDADEIRO)

Para obter mais informações sobre como usar essas funções, consulte Função E, Função OU e Função NÃO.

Início da página

Criar uma fórmula condicional que resulte em outro cálculo ou em valores diferentes de VERDADEIRO ou FALSO

Para executar esta tarefa, use as funções SE, E e OU e operadores como mostrado no exemplo a seguir.

Exemplo

Talvez seja mais fácil de compreender o exemplo se você copiá-lo para uma planilha em branco.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo.

Importante : Não selecione os cabeçalhos de linha ou de coluna.

selecionando um exemplo na Ajuda do Excel 2013 para Windows

Selecionando um exemplo na Ajuda

  1. Pressione CTRL+C.

  2. Crie uma planilha ou pasta de trabalho em branco no Excel.

  3. Na planilha, selecione a célula A1 e pressione CTRL+V.

Importante : Para que o exemplo funcione corretamente, basta colá-lo na célula A1 da planilha.

  1. Para alternar entre ver os resultados e ver as fórmulas que retornam os resultados, pressione CTRL+` (acento grave), ou na guia Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo em uma planilha em branco, você poderá adaptá-lo às suas necessidades.

1

2

3

4

5

6%

7


8



9



10



11




12



13



14




15



16

A

B

Dados

15

9

8

Rodas dentadas

Widgets

Fórmula

Descrição (Resultado)

=SE(A2=15; "OK"; "Não OK")

Se o valor na célula A2 for igual a 15, retornar "OK". Caso contrário, retornar "Não OK". (OK)

=SeA2<>15;"OK";"Não OK")

Se o valor na célula A2 não for igual a 15, retornar "OK". Caso contrário, retornar "Não OK". (Não OK)

=SE(NÃO(A2<=15); "OK"; "Não OK")

Se o valor na célula A2 não for menor ou igual a 15, retornar "OK". Caso contrário, retornar "Não OK". (Não OK)

=SE(A5<>"RODAS DENTADAS"; "OK"; "Não OK")

Se o valor na célula A5 não for igual a "RODAS DENTADAS", retornar "OK". Caso contrário, retornar "Não OK". (Não OK)

=SE(E(A2>A3; A2<A4); "OK"; "Não OK")

Se o valor da célula A2 for maior do que o valor de A3 e se o valor de A2 também for menor do que o valor de A4, retornar "OK". Caso contrário, retornar "Não OK". (Não OK)

=SE(E(A2<>A3; A2<>A4); "OK"; "Não OK")

Se o valor da célula A2 não for igual a A3 e se o valor de A2 também não for igual ao valor de A4, retornar "OK". Caso contrário, retornar "Não OK". (OK)

=SE(OU(A2>A3; A2<A4); "OK"; "Não OK")

Se o valor da célula A2 for maior do que o valor de A3 ou se o valor de A2 for menor do que o valor de A4, retornar "OK". Caso contrário, retornar "Não OK". (OK)

=SE(OU(A5<>"Rodas dentadas"; A6<>"Widgets"); "OK"; "Não OK")

Se o valor na célula A5 não for igual a "Rodas dentadas" ou o valor na célula A6 não for igual a "Widgets", retornar "OK". Caso contrário, retornar "Não OK". (Não OK)

=SE(OU(A2<>A3; A2<>A4); "OK"; "Não OK")

Se o valor da célula A2 não for igual ao valor de A3 ou se o valor de A2 não for igual ao valor de A4, retornar "OK". Caso contrário, retornar "Não OK". (OK)

Para obter mais informações sobre como usar essas funções, consulte Função SE, Função E e Função OU.

Início da página

Essas informações foram úteis?

Como podemos melhorá-lo?

Como podemos melhorá-lo?

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!