Criar e executar uma consulta exclusão

Criar e executar uma consulta exclusão

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando você deseja excluir muitos dados ou excluir um conjunto de dados regularmente em um banco de dados da área de trabalho do Access rapidamente, uma exclusão ou uma consulta atualização pode ser útil porque as consultas possibilitam especificar critérios para localizar e excluir os dados rapidamente. Usando uma consulta também pode ser uma economia de tempo porque você pode reutilizar uma consulta salva.

Observação : Antes de excluir qualquer dado ou executar uma consulta exclusão, certifique-se de que você tenha um backup do seu banco de dados da área de trabalho do Access.

Se desejar apenas excluir alguns registros, você não precisa de uma consulta. Basta abrir a tabela no modo Folha de Dados, selecionar os campos (colunas) ou registros (linhas) que você deseja excluir e pressionar DELETE.

Importante : As informações neste artigo destina-se ao uso apenas com bancos de dados da área de trabalho. Você não pode usar delete ou atualizar consultas em aplicativos web do Access.

Neste artigo

Escolhendo um tipo de consulta

Usando uma consulta exclusão

Usando uma consulta atualização

Informações adicionais

Dicas para solução de problemas

Escolhendo um tipo de consulta

Você pode usar uma consulta atualização ou uma consulta exclusão para excluir dados do seu banco de dados. Selecione uma consulta com base nos detalhes da seguinte tabela:

Tipo de consulta

Quando utilizar

Resultados

Use uma consulta exclusão

Para remover registros inteiros (linhas) de uma tabela ou de duas tabelas relacionadas simultaneamente.

Observação : Se os registros residirem no lado "um" de uma relação um-para-muitos, pode ser necessário alterar a relação antes de executar a consulta exclusão. Consulte a seção sobre exclusão de dados de tabelas relacionadas.

As consultas exclusão removem todos os dados de cada campo, incluindo o valor de chave que torna um registro exclusivo

Use uma consulta atualização

Para excluir valores de campos individuais de uma tabela.

Facilita a exclusão de valores atualizando os valores existentes para um valor nulo (ou seja, sem dados) ou uma cadeia de comprimento zero (um par de aspas duplas sem espaço entre elas).

Início da página

O que verificar antes de usar uma consulta para excluir qualquer dado

  • Verifique se o arquivo não é somente leitura:

    1. Clique com o botão direito do mouse em Início e clique em Abrir o File Explorer.

    2. Clique com o botão direito do mouse no arquivo de banco de dados e clique em Propriedades.

    3. Veja se o atributo Somente Leitura está selecionado.

  • Confirme se você tem as permissões necessárias para excluir registros do banco de dados. Se não tiver certeza, contate o administrador do sistema ou o designer do banco de dados.

  • Verifique se você tem conteúdo habilitado no banco de dados. Por padrão, o Access bloqueia todas as consultas de ação (exclusão, atualização e criar tabela), a menos que você primeiro confie no banco de dados. Para obter informações sobre como confiar em um banco de dados, consulte a seção Impedir que o Modo Desabilitado bloqueie uma consulta.

  • Peça aos demais usuários do banco de dados para fechar todas as tabelas, formulários, consultas e relatórios que usam os dados que você deseja excluir. Isso ajuda a evitar violações de bloqueio.

  • Antes de editar ou excluir registros, fazer uma cópia de backup do banco de dados é uma boa ideia, caso você deseje reverter as alterações.

Dica : Se um grande número de usuários se conectar ao banco de dados, talvez seja necessário fechar o banco de dados e reabri-lo no modo exclusivo.

Para abrir um banco de dados em modo Exclusivo

  1. Clique na guia Arquivo > Abrir.

  2. Navegue até o banco de dados e aponte para selecioná-lo, clique na seta ao lado do botão Abrir e clique em Abrir exclusivo.

    Abrindo o arquivo no modo Exclusivo

Faça backup do banco de dados

  1. Clique na guia Arquivo e aponte para Salvar como.

  2. Clique em Salvar Banco de Dados como e em Fazer Backup do Banco de Dados. O Access fecha o arquivo original, cria um backup e abre novamente o arquivo original.

  3. Clique em Salvar como, especifique um nome e local para a cópia de backup e clique em Salvar.

Observação :  Se estiver usando um banco de dados somente leitura ou criado na versão anterior do Access, você poderá receber uma mensagem de que não é possível criar um backup do banco de dados.

Para reverter para um backup, feche e renomeie o arquivo original para que a cópia de backup possa usar o nome da versão original. Atribua o nome da versão original à cópia de backup e abra a cópia de backup renomeada no Access.

Usando uma consulta exclusão

Para criar uma consulta exclusão, clique o guia, além de criar o grupo de consultas, clique em Design da consulta. No caixa de diálogo Mostrar tabela caixa, clique duas vezes em cada tabela da qual você deseja excluir registros e, em seguida, clique em Fechar.

A tabela aparece como uma janela na seção superior da grade de design da consulta. Na lista de campos, clique duas vezes no asterisco (*) para adicionar todos os campos da tabela à grade de design.

Usando um critério específico em uma consulta exclusão

Importante : Use critérios para retornar apenas os registros que você deseja excluir. Caso contrário, a consulta exclusão removerá todos os registros da tabela.

Duas vezes no campo que você deseja especificar como os critérios de exclusão, insira um ao critério na linha critérios da consulta designer e, em seguida, limpar o caixa de seleção Mostrar para cada campo de critérios.

Um exemplo de quando convém usar essa opção: suponha que você queira remover todos os pedidos pendentes de um cliente. Para localizar apenas esses registros, você adiciona os campos ID do Cliente e Data do Pedido à grade de design da consulta e então insere o número de identificação do cliente e a data na qual os pedidos desse cliente tornaram-se inválidos.

  1. Na guia Design, clique em Exibir > Modo folha de dados.

  2. Confirme se a consulta retorna os registros que você deseja excluir e pressione CTRL+S para salvar a consulta.

  3. Para executar a consulta, clique duas vezes na consulta no Painel de Navegação.

Início da página

Usando uma consulta atualização

Observação : Você não pode usar a opção de consulta de atualização em um Access web app.

Esta seção explica como usar uma consulta atualização para excluir arquivos individuais de tabelas. Lembre-se de que a execução de uma consulta atualização para excluir dados alterará os valores existentes para NULL ou uma cadeia de comprimento zero (um par de aspas duplas sem espaço entre elas), dependendo dos critérios que você especificar.

  1. Clique na guia Criar e, no grupo Consultas, clique em Design da Consulta.

  2. Selecione a tabela com os dados que você deseja excluir (se a tabela for relacionada, selecione-a no lado "um" da relação), clique em Adicionar e em Fechar.

    A tabela aparece como uma janela na seção superior da grade de design da consulta. A janela lista todos os campos da tabela selecionada.

  3. Clique duas vezes no asterisco (*) para adicionar todos os campos da tabela à grade de design. A adição de todos os campos de tabela habilita a consulta exclusão a remover registros inteiros (linhas) da tabela.

    Opcionalmente, você pode inserir critérios para um ou mais campos na linha Critérios do designer e então desmarcar a caixa de seleção Mostrar para cada campo de critério. Para obter mais informações sobre o uso de critérios, consulte a tabela Exemplos de critérios para consultas selecionadas.

    Observação : Use critérios para retornar apenas os registros que deseja alterar. Caso contrário, a consulta atualização definirá como NULL todos os registros em cada um dos campos da sua consulta.

  4. Na guia Design, no grupo Resultados, clique em Modo de Exibição e clique em Modo de Exibição de Folha de Dados.

  5. Confirme se a consulta retorna os registros que você deseja definir como NULL ou uma cadeia de caracteres de comprimento zero (um par de aspas duplas sem espaço entre elas ("").

  6. Conforme necessário, repita as etapas 3 a 5 e altere os campos ou critérios até que a consulta retorna somente os dados que você deseja excluir e, em seguida, pressione CTRL + S para salvar a consulta.

  7. Para executar a consulta, clique duas vezes na consulta no Painel de Navegação.

Início da página

Informações adicionais

Excluindo dados de tabelas relacionadas

Se você deseja excluir dados de diversas tabelas relacionadas, deve habilitar as opções Integridade Referencial e Propagar exclusão dos registros relacionados para cada relação. Isso permite à sua consulta excluir dados das tabelas nos lados "um" e "muitos" da relação. A preparação para excluir dados relacionados requer a verificação do seguinte:

  • Determinar quais registros residem no lado "um" da relação e quais residem no lado "muitos".

  • Se você precisa excluir registros no lado "um" da relação e os registros relacionados no lado "muitos", habilite um conjunto de regras chamado Integridade Referencial e exclusões em cascata. As etapas desta seção explicam a Integridade Referencial e como executar ambas as tarefas.

  • Se você precisa excluir registros apenas no lado "um" da relação, exclua primeiro essa relação e depois os dados.

Se você precisa remover dados apenas no lado "muitos" da relação, pode criar e executar sua consulta exclusão sem ter de alterar a relação.

Para saber quais registros residem nos lados "um" e "muitos" de uma relação, na guia Ferramentas de Banco de Dados, no grupo Relações, clique em Relações. A guia Relações exibe as tabelas do seu banco de dados e as relações. Cada relação é representada como uma linha que conecta tabelas entre campos.

A figura a seguir mostra uma relação típica. A maioria das relações em um banco de dados, se não todas, tem um lado "um" e um lado "muitos". O diagrama da relação denota o lado "um" com o numeral um (1) e o lado "muitos" com o símbolo de infinito ().

Uma relação entre duas tabelas

Quando você exclui registros no lado "um" da relação, também exclui todos os registros relacionados no lado "muitos". Entretanto, quando exclui registros no lado "muitos" de uma relação, você geralmente não exclui registros no lado "um".

Além disso, o Access automaticamente impõe um conjunto de regras chamado de integridade referencial. Essas regras asseguram que as chaves estrangeiras em um banco de dados contenham os valores corretos. Uma chave estrangeira é uma coluna cujos valores correspondem aos valores da coluna da chave principal de outra tabela.

Editar a relação

Siga estas etapas apenas quando precisar excluir dados nos lados "um" e "muitos" de uma relação.

  1. Na guia Ferramentas de Banco de Dados, no grupo Relações, clique em Relações.

  2. Clique com o botão direito do mouse na relação (a linha) que conecta as tabelas envolvidas na operação de exclusão e clique em Editar Relação no menu de atalho.

  3. Na caixa de diálogo Editar Relações, verifique se a caixa de seleção Impor integridade referencial está marcada.

  4. Marque a caixa de seleção Propagar exclusão dos registros relacionados.

    Observação : Até você desabilitar essa propriedade novamente, a exclusão de um registro no lado "um" da relação excluirá todos os registros relacionados no lado "muitos" da relação.

  5. Clique em OK, feche o painel Relações e prossiga para o próximo conjunto de etapas.

Excluir uma relação

  1. Se você ainda não o fez, abra o painel Relações.

  2. Na guia Ferramentas de Banco de Dados, no grupo Relações, clique em Relações.

    Tome nota dos campos envolvidos na relação, para que você possa restaurá-la após excluir seus dados.

  3. Clique com botão direito na relação (a linha) que conecta as tabelas envolvidas na operação de exclusão e clique em Excluir no menu de atalho.

Observação : Para restaurar a relação, siga as etapas anteriores para abrir o painel Relações, arraste o campo de chave primária da tabela "um" e solte-o no campo de chave estrangeira da tabela "muitos". A caixa de diálogo Editar Relações é exibida. Se a relação antiga impunha integridade referencial, selecione Impor integridade referencial e clique em Criar. Caso contrário, basta clicar em Criar.

Início da página

Exemplos de critérios para consultas selecionadas

A tabela a seguir lista alguns exemplos de critérios que você pode usar em consultas selecionadas quando deseja se certificar de que irá excluir apenas os dados que quer que sejam excluídos. Alguns desses exemplos usam caracteres curinga.

Critérios

Efeito

> 234

Retorna todos os números maiores que 234. Para localizar todos os números menores que 234, use < 234.

>= "Cajhen"

Retorna todos os registros de Cajhen até o fim do alfabeto.

Entre #02/02/10# e #01/12/10#

Retorna datas de 2-fev-2010 até 1-dez-2010 (ANSI-89). Se o banco de dados utilizar os caracteres curinga ANSI-92, use aspas simples (') em vez do sinal de cerquilha (#). Exemplo: Between '2/2/2010' And '12/1/2010'.

Não "Alemanha"

Localiza todos os registros em que os conteúdos exatos do campo não são exatamente iguais a "Alemanha". O critério retornará registros que contêm caracteres além de "Alemanha," tais como "Alemanha (euro)" ou "Europa (Alemanha)".

Não "T*"

Localiza todos os registros, exceto aqueles que começam com T. Se o banco de dados utilizar o conjunto de caracteres curinga ANSI-92, use o símbolo de porcentagem (%) em vez do asterisco (*).

Não "*t"

Localiza todos os registros que não terminam com t. Se o banco de dados utilizar o conjunto de caracteres curinga ANSI-92, use o símbolo de porcentagem (%) em vez do asterisco (*).

In(Canadá,RU)

Em uma lista, localiza todos os registros que contêm Canadá ou Reino Unido.

Como "[A-D]*"

Em um campo Texto, localiza todos os registros que começam com as letras A até D. Se o banco de dados utilizar o conjunto de caracteres curinga ANSI-92, use o sinal de porcentagem (%) no lugar do asterisco (*).

Como "*ar*"

Localiza todos os registros que incluem a sequência de letras "ar". Se o banco de dados utilizar o conjunto de caracteres curinga ANSI-92, utilize o sinal de porcentagem (%) no lugar do asterisco (*).

Como "Maison Dewe?"

Localiza todos os registros que começam por "Maison" e contêm uma outra cadeia de 5 letras, na qual as primeiras 4 letras são "Dewe" e a última letra é desconhecida. Se o banco de dados utilizar o conjunto de caracteres curingas ANSI-92, use o sublinhado (_) no lugar do ponto de interrogação (?).

#02/02/10#

Localiza todos os registros de 2 de fevereiro de 2010. Se o banco de dados utilizar o conjunto de caracteres curinga ANSI-92, coloque a data entre aspas simples em vez de usar sinais de cerquilha ('2/2/2010').

< Data() - 30

Usa a função Date para retornar todas as datas com mais de 30 dias.

Data().

Usa a função Date para retornar todos os registros que contêm a data de hoje.

Entre Date() e DateAdd("M", 3, Date())

Usa as funções Date e DateAdd para retornar todos os registros entre a data de hoje e três meses a partir da data de hoje.

É Nulo

Retorna todos os registros que contêm um valor nulo (vazio ou indefinido).

É Negado Nulo

Retorna todos os registros que contêm qualquer valor (que não são nulos).

""

Retorna todos os registros que contêm uma cadeia de comprimento zero. As cadeias de comprimento zero são usadas quando você precisa adicionar um valor a um campo obrigatório, mas ainda não sabe qual é o valor. Por exemplo, um campo pode exigir um número de fax, mas alguns de seus clientes talvez não possuam aparelho de fax. Nesse caso, você deve digitar um par de aspas duplas sem espaço entre elas em vez de um número ("").

Início da página

Dicas para solução de problemas

Por que estou vendo esta mensagem de erro e como eu corrijo esse erro?

Quando você cria uma consulta exclusão usando várias tabelas e a propriedade Registros Exclusivos da consulta está definida como Não, o Access exibe a mensagem de erro Não foi possível excluir itens das tabelas especificadas quando você executa a consulta.

Para corrigir esse problema, defina a propriedade Registros exclusivos da consulta como Sim.

  1. Abra a consulta exclusão no modo Design.

  2. Se a folha de propriedades da consulta não estiver aberta, pressione F4 para abri-la.

  3. Clique no designer de consulta para mostrar as propriedades da consulta (em vez das propriedades do campo).

  4. Na folha de propriedades da consulta, localize a propriedade Registros Exclusivos e defina-a como Sim.

Impedir que o Modo Desabilitado bloqueie uma consulta

Por padrão, se você abrir um banco de dados da área de trabalho que você não escolheu confiar ou que não reside em um local confiável, o Access bloqueia todas as consultas de ação.

Se você tentar executar uma consulta de ação e perceber que nada acontece, verifique se a seguinte mensagem aparece na barra de status do Access:

Esta ação ou este evento foi bloqueado pelo Modo Desabilitado.

Quando você vir essa mensagem, siga este procedimento para habilitar o conteúdo bloqueado:

  • Na barra de mensagem de Aviso de segurança, clique em Habilitar conteúdo, e execute a consulta novamente.

Para obter mais informações sobre o Modo Desabilitado e a segurança do Access, consulte o artigo Como os objetos de banco de dados se comportam quando são confiáveis ou não confiáveis.

 início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×