Converter um banco de dados no formato de arquivo .accdb

Importante:  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Access 2016, o Access 2013, o Access 2010 e o Access 2007 criam bancos de dados no formato de arquivo. accdb. Esse formato oferece suporte a recursos como campos de múltiplos valores, macros de dados e publicação nos serviços do Access.

Você pode converter bancos de dados criados no Microsoft Office Access 2003, no Access 2002, no Access 2000 ou no Access 97 para o formato de arquivo .accdb. Contudo, lembre-se de que não é possível abrir ou vincular um banco de dados no formato de arquivo .accdb usando versões do Access anteriores ao Access 2007.

Além disso, o formato .accdb não dá suporte a replicação ou segurança em nível de usuário. Caso precise compartilhar seu banco de dados com usuários do Access 2003 ou anteriores, ou caso precise usar a replicação ou a segurança em nível de usuário, você deverá usar o formato de arquivo .mdb.

Observação: Mesmo que compartilham o mesmo formato de arquivo, alguns recursos do Access 2016, o Access 2013 e o Access 2010 não podem ser usados no Access 2007. Para obter mais informações, consulte a seção usar o Access 2007 para abrir um banco de dados que foi criado ou modificado no Access 2010, o Access 2013 ou o Access 2016.

Neste artigo

Converter um banco de dados do Access 2000 ou Access 2002 - 2003 para o formato .accdb

Converter um banco de dados do Access 97 para o formato .accdb

Usar o Access 2007 para abrir um banco de dados que foi criado ou modificado no Access 2010, no Access 2013 ou 2016 de acesso

Converter um banco de dados do Access 2000 ou Access 2002 - 2003 para o formato .accdb

Para converter um Access 2000 ou Access 2002-2003 banco de dados (. mdb) para o formato de arquivo. accdb, você deve primeiro abrir o banco de dados usando o Access 2007, o Access 2010, o Access 2013 ou o Access 2016 e salve-o no formato de arquivo. accdb.

  1. Clique em Arquivo e em Abrir.

  2. Clique no banco de dados do Access 2000 ou do Access 2002 - 2003 (.mdb) que deseja converter.

    Observação: Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, significa que o banco de dados está usando um formato de arquivo anterior ao do Access 2000. Para continuar, consulte a seção Converter um banco de dados do Access 97 no formato .accdb.

  3. Clique em Arquivo, Salvar como e em Salvar Banco de Dados como.

  4. Escolha o tipo de arquivo Access e clique em Salvar como.

    Se houver objetos do banco de dados abertos quando você clicar em Salvar como, o Access solicitará que eles sejam fechados antes da criação da cópia. Clique em Sim para fazer com que o Access feche os objetos ou clique em Não para cancelar todo o processo. Se necessário, o Access também solicitará que você salve as alterações feitas.

  5. Na caixa de diálogo Salvar como, digite um nome de arquivo na caixa Nome do arquivo e clique em Salvar.

    O Access cria e, em seguida, abre a cópia do banco de dados. Ele automaticamente fecha o banco de dados original.

Início da página

Converter um banco de dados do Access 97 para o formato .accdb

A partir do Access 2013, não é mais possível converter diretamente um banco de dados do Access 97 (.mdb) no formato de arquivo .accdb. Entretanto, você pode abrir um banco de dados do Access 97 em uma versão anterior do Access e depois salvar o banco de dados em um formato que o Access 2013 possa abrir. Por exemplo, veja como usar o Access 2003 para abrir um banco de dados do Access 97 e depois convertê-lo em um formato que possa ser aberto pelo Access 2013:

  1. Abra o banco de dados do Access 97 no Access 2003.

  2. Clique em Ferramentas > Utilitários de banco de dados > Converter Banco de Dados > Em Formato de Arquivo do Access 2002 - 2003.

  3. Insira um nome para o banco de dados e clique em Salvar.

  4. Feche o Access 2003 e abra o Access 2013.

  5. Abra o banco de dados e clique em Arquivo > Salvar como > Banco de Dados do Access (.accdb) > Salvar como > Salvar.

Você também pode usar o Access 2007 ou o Access 2010 para converter um banco de dados do Access 97 no formato .accdb. Quando você abre um banco de dados do Access 97 em qualquer um desses dois produtos, o Assistente para Aprimoramento do Banco de Dados é exibido para ajudar a converter o banco de dados em um formato .accdb.

Início da página

Usar o Access 2007 para abrir um banco de dados que foi criado ou modificado no Access 2010, no Access 2013 ou 2016 de acesso

Porque o Access 2016, Access 2013, Access 2010 e Access 2007 usam o mesmo formato de arquivo, você pode usar o Access 2007 para abrir um banco de dados que foi criado no Access 2010, Access 2013 ou Access 2016 sem primeiro usar o comando Salvar como . No entanto, o Access 2016, Access 2013 e Access 2010 incluem alguns recursos que exigem acesso 2016, Access 2013 e Access 2010 para executar. Dependendo do recurso, uma das seguintes pode ocorrer quando você tenta usar o banco de dados no Access 2007:

  • Você não poderá modificar o objeto que usa o recurso.

  • Você não poderá abrir o objeto que usa o recurso.

  • Você não poderá abrir o banco de dados no Access 2007 de forma alguma.

Início da página

Observação: Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×