Controlar seu site com o Visio

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Se você gerencia as operações diárias de um site, sabe que é fundamental ter uma clara visão do fluxo e da estrutura geral do site, controlar alterações de desenvolvimento, bem como monitorar e reparar hiperlinks desfeitos. Todas essas tarefas e muito mais podem ser executadas com as ferramentas Mapa de Sites da Web, do Microsoft Office Visio Professional.

O que você deseja fazer?

Mapear o conteúdo do seu site

Verificar automaticamente se há erros no site

Manter controle das alterações ao seu site

Mapear o conteúdo do site

O gerenciamento do site começa com uma análise de seu estado atual. Ao mapear o site, você cria uma representação gráfica atualizada de sua estrutura e de seu conteúdo.

Um mapa de sites mostrando a estrutura hierárquica real dos links no site

Cada forma no mapa de sites representa um link em seu site, e cada forma inclui informações sobre o tipo e o local do link. Clique com o botão direito do mouse em uma forma, para que você possa ir diretamente da forma para o seu respectivo local na Web.

  1. No Visio, no menu Arquivo , aponte para Novo, para Software e Banco de Dados e clique em Mapa de Sites da Web.

  2. Na caixa de diálogo Gerar Mapa de Sites, digite um endereço de site para um destes itens:

    • Para um servidor HTTP, na caixa Endereço, digite o endereço do site que você deseja mapear.

    • Para um servidor de rede ou um disco rígido local, clique em Procurar, navegue até o arquivo desejado na raiz do mapa de sites e clique em Abrir.

  3. Na caixa de diálogo Gerar Mapa de Sites, clique em Configurações para revisar as configurações, verificando o número máximo de níveis e o número de links que serão descobertos.

  4. Para alterar as configurações, siga um destes procedimentos:

    • Na guia Layout, altere o estilo de layout do mapa de sites, como o número de níveis que você deseja descobrir ou se o desenho mostrará uma opção Compactar árvore ou Fluxograma.

    • Na guia Extensões, selecione o tipo de arquivo (por exemplo, .doc, .jpg ou .exe) que deseja mapear.

    • Na guia Protocolos, selecione os protocolos (por exemplo, mailto, ftp ou NNTP) que você deseja mapear.

    • Na guia Atributos, selecione os atributos HTML (por exemplo, HREF, SRC ou CODE) nos quais você deseja procurar links.

    • Na guia Avançadas, selecione as opções que especificam ainda mais os critérios de pesquisa.

    • Clique em OK.

  5. Na caixa de diálogo Gerar Mapa de Sites, clique em OK.

  6. Para salvar o mapa de sites, no menu Arquivo, clique em Salvar.

Início da página

Verificar automaticamente se há erros no site

Manter os links do site ativos e sem erros é a tarefa de gerenciamento de site mais importante.

Ao mapear o site, o Visio segue cada link dentro dos parâmetros especificados e controla qualquer erro encontrado. Os links com erros aparecem no mapa de sites e nas janelas Filtro e Lista como formas contendo um X vermelho. Se você não conseguir exibir essas janelas, no menu Mapa de Sites da Web, aponte para Janelas e clique em Janela Lista ou Janela Filtro. Você pode gerar rapidamente uma lista dos links desfeitos junto com os erros associados, o que o ajudará a manter o controle de seu trabalho e fazer os reparos necessários.

Um mapa de sites mostrando a estrutura do site; qualquer forma com um X vermelho indica um link desfeito

Criar um relatório de links com erros do site

  1. Abra o mapa de sites para o qual você deseja criar um relatório de erro.

  2. No menu Mapa de Sites da Web, aponte para Relatórios, clique em Links com Erros do Mapa de Sites da Web e, em seguida, clique em Executar.

  3. Selecione o tipo de arquivo (por exemplo, Excel ou XML) a ser usado para salvar as informações e clique em OK.

    O Visio criará um relatório listando todos os links com erros de hiperlink.

  4. Se seu relatório for aberto em um programa fora do Visio, como o Microsoft Office Excel, nomeie e salve o relatório.

Corrigir links desfeitos

Alguns links desfeitos são causados por erros de tempo limite. Para solucionar esses erros, clique com o botão direito do mouse no link e, em seguida, clique em Atualizar ou Refresh Parent.

Outros links desfeitos são causados pelo erro Site Não Encontrado, Acesso Negado ou Senha Obrigatória ou por nomes de arquivo incorretos, locais de arquivo incorretos e arquivos não encontrados, que podem disparar a mensagem de erro 404 ou Arquivo Não Encontrado. Qualquer um desses erros deverá ser corrigido no site.

Seu site e o mapa de sites não estarão dinamicamente vinculados, pois a alteração feita em um deles não afeta automaticamente o outro. Após corrigir um link desfeito no site, você poderá atualizar o mapa de sites clicando com o botão direito do mouse na forma que representa o link desfeito e, em seguida, clicando em Renovar Hiperlink. O X vermelho desaparecerá.

Início da página

Manter controle das alterações feitas no site

Se vários desenvolvedores estiverem trabalhando em seu site, controlar seu trabalho poderá se tornar rapidamente uma tarefa de tempo integral. Use o relatório de comparação do Mapa de Sites da Web para comparar duas versões do site a fim de quantificar as alterações feitas durante um determinado período de tempo. O relatório compara as duas versões e gera uma lista de diferenças. Ele não só identifica os links que aparecem em apenas um dos mapas, mas também lista as seguintes alterações nos links dos dois mapas:

  • Status de erro

  • Título do arquivo

  • Tamanho do arquivo

  • Data de modificação do arquivo

Por exemplo, suponha que você deseje quantificar semanalmente o trabalho feito em um site. Basta você mapear o site no início da semana e, novamente, no final dela. Em seguida, compare os dois mapas para gerar um relatório das alterações. Você também pode comparar o relatório com uma agenda do trabalho planejado para a semana e verificar se seu projeto de site está sendo executado corretamente.

Comparar mapas de sites

  1. Abra o mapa mais recente de seu site.

  2. No menu Mapa de Sites da Web, clique em Comparar ao documento anterior.

  3. Vá para o mapa de sites a ser comparado, selecione o arquivo e clique em Abrir.

    O Visio compara os dois mapas e gera um relatório HTML listando as diferenças.

  4. Nomeie e salve o relatório.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×