Contar valores únicos dentre duplicatas

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Digamos que você deseja descobrir quantas exclusivos de texto ou existem em um intervalo de valores numéricos. Por exemplo, se uma coluna tiver texto valores Moreno, Neves, Neves, Neves, há dois valores únicos — Moreno e Neves. Se o intervalo tem números 5, 6, 7, 6, os valores exclusivos são 5, 6 e 7.

Para contar apenas os valores únicos, use uma combinação das funções a seguir conforme a planilha de exemplo abaixo:

  • Use a função se para atribuir um valor de 1 a cada condição verdadeira.

  • Use a função soma para adicionar todos os valores únicos.

  • Use a função frequência para contar o número de valores exclusivos. Esta função ignora valores zero e texto. Para a primeira ocorrência de um determinado valor, ela retorna um número igual ao número de ocorrências desse valor. Para cada ocorrência desse mesmo valor após o primeiro, essa função retorna um valor de 0.

  • Use a função CORRESP para retornar a posição de um valor de texto em um intervalo. A função frequência usa o valor resultante para avaliar os valores de texto correspondentes.

  • Use a função LEN para localizar células em branco. Células em branco tem um comprimento (contagem de caracteres) de 0.

Exemplo

Copie a tabela para a célula A1 em uma planilha em branco no Excel para trabalhar com esses exemplos de fórmulas que usam funções.

Dados

Dados

986

Moreno

Neves

563

67

789

235

Moreno

Neves

689

789

Neves

143

56

237

67

235

Fórmula

Descrição (Resultado)

=SOMA(SE(FREQUÊNCIA(A2:A10,A2:A10)>0,1))

Conta o número de valores numéricos únicos nas células A2:A10, mas não conta células vazias ou valores de texto (4)

=SOMA(SE(FREQUÊNCIA(CORRESP(B2:B10,B2:B10,0),CORRESP(B2:B10,B2:B10,0))>0,1))

Conta o número de valores de textos e valores numéricos únicos nas células B2:B10 (que não devem conter células vazias) (7)

=SOMA(SE(FREQUÊNCIA(SE(NÚM.CARACT(A2:A10)>0,CORRESP(A2:A10,A2:A10,0),""), SE(NÚM.CARACT(A2:A10)>0,CORRESP(A2:A10,A2:A10,0),""))>0,1))

Conta o número de valores de texto e valores numéricos únicos nas células A2:A10, mas não conta células vazias ou valores de texto (6)

Observações: 

  • As fórmulas contidas neste exemplo devem ser inseridas como fórmulas de matriz. Selecione cada célula que contém uma fórmula, pressione F2 e, em seguida, pressione Ctrl + Shift + Enter.

  • Para ver uma função avaliada passo a passo, selecione a célula que contém a fórmula e, em seguida, na guia Fórmulas, no grupo Auditoria de Fórmulas clique em Avaliar Fórmula.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×