Contar valores únicos dentre duplicatas

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Digamos que você deseja descobrir quantas exclusivos de texto ou existem em um intervalo de valores numéricos. Por exemplo, se uma coluna tiver texto valores Bradley, Neves, Neves, Neves, há dois valores únicos — Bradley e Neves. Se o intervalo tem números 5, 6, 7, 6, os valores exclusivos são 5, 6 e 7.

Para contar apenas os valores únicos, use uma combinação das funções a seguir conforme a planilha de exemplo abaixo:

  • Use a função SE para atribuir o valor 1 para cada condição VERDADEIRA.

  • Use a função SOMA para adicionar todos os valores únicos.

  • Use a função FREQUÊNCIA para contar o número de valores únicos. Essa função ignora valores de texto e iguais a zero. Para a primeira ocorrência de um valor específico, ela retorna um número equivalente à quantidade de ocorrências desse valor. Para cada ocorrência desse mesmo valor depois da primeira, a função retorna o valor 0.

  • Use a função CORRESP para retornar a posição de um valor de texto em um intervalo. A função FREQUÊNCIA usa o valor resultante para avaliar os valores de texto correspondentes.

  • Use a função NÚM.CARACT para encontrar as células em branco. As células em branco têm comprimento (contagem de caracteres) 0.

Exemplo

Copie a tabela para a célula A1 em uma planilha em branco no Excel para trabalhar com esses exemplos de fórmulas que usam funções.

Dados

Dados

986

Moreno

Neves

563

67

789

235

Moreno

Neves

689

789

Neves

143

56

237

67

235

Fórmula

Descrição (Resultado)

=SOMA(SE(FREQUÊNCIA(A2:A10,A2:A10)>0,1))

Conta o número de valores numéricos únicos nas células A2:A10, mas não conta células vazias ou valores de texto (4)

=SOMA(SE(FREQUÊNCIA(CORRESP(B2:B10,B2:B10,0),CORRESP(B2:B10,B2:B10,0))>0,1))

Conta o número de valores de textos e valores numéricos únicos nas células B2:B10 (que não devem conter células vazias) (7)

=SOMA(SE(FREQUÊNCIA(SE(NÚM.CARACT(A2:A10)>0,CORRESP(A2:A10,A2:A10,0),""), SE(NÚM.CARACT(A2:A10)>0,CORRESP(A2:A10,A2:A10,0),""))>0,1))

Conta o número de valores de texto e valores numéricos únicos nas células A2:A10, mas não conta células vazias ou valores de texto (6)

Observações : 

  • As fórmulas contidas neste exemplo devem ser inseridas como fórmulas de matriz. Selecione cada célula que contém uma fórmula, pressione F2 e, em seguida, pressione Ctrl + Shift + Enter.

  • Para ver uma função avaliada passo a passo, selecione a célula que contém a fórmula e, em seguida, na guia Fórmulas, no grupo Auditoria de Fórmulas clique em Avaliar Fórmula.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×