Contar números ou datas com base em uma condição

Para contar números ou datas que correspondem a uma condição simples (como igual a, maior que, menor que, maior que ou igual a ou menor que ou igual a), use a função CONT.SE. Para contar números ou datas que se enquadram em um intervalo (como maior que 9000 e ao mesmo tempo menor que 22500), você pode usar a função CONT.SES. Como alternativa, você pode usar SOMARPRODUTO também.

Exemplo

1

2

3

4

5

6%

7

8

9

10

11

12

13

14

15

16

17

A

B

Vendedor

Fatura

Cardoso

15.000

Cardoso

9.000

Ruivo

8.000

Ruivo

20.000

Cardoso

5.000

Couto

22.500

Fórmula

Descrição (resultado)

=CONT.SE(B2:B7;">9000")

A função CONT.SE conta o número de células no intervalo B2:B7 que contêm números maiores que 9000 (4)

=CONT.SE(B2:B7;"<=9000")

A função CONT.SE conta o número de células no intervalo B2:B7 que contêm números menores que 9000 (4)

=CONT.SES(B2:B7,">=9000",B2:B7,"<=22500")

A função CONT.SES (disponível no Excel 2007 e versões superiores) conta o número de células no intervalo B2:B7 maiores que ou iguais a 9000 e menores que ou iguais a 22500 (4)

=SOMARPRODUTO((B2:B7>=9000)*(B2:B7<=22500))

A função SOMARPRODUTO conta o número de células no intervalo B2:B7 que contêm números maiores que ou iguais a 9000 e menores que ou iguais a 22500 (4). Você pode usar essa função no Excel 2003 e versões anteriores, nas quais a função CONT.SES não está disponível.

Data

11.03.11

01.01.10

31.12.10

30.06.10

Fórmula

Descrição (resultado)

=CONT.SE(B14:B17,">3/1/2010")

Conta o número de células no intervalo B14:B17 cuja data é posterior a 3/1/2010 (3)

=CONT.SE(B14:B17,"12/31/2010")

Conta o número de células no intervalo B14:B17 iguais a 12/31/2010 (1). O sinal de igual não é necessário nos critérios e, portanto, não é incluído aqui (a fórmula funcionará com um sinal de igual se você o incluir ("=12/31/2010").

=CONT.SES(B14:B17,">=1/1/2010",B14:B17,"<=12/31/2010")

Conta o número de células no intervalo B14:B17 que estão entre (inclusive) 1/1/2010 e 12/31/2010 (3).

=SOMARPRODUTO((B14:B17>=DATA.VALOR("1/1/2010"))*(B14:B17<=DATA.VALOR("12/31/2010")))

Conta o número de células no intervalo B14:B17 que estão entre (inclusive) 1/1/2010 e 12/31/2010 (3). Esse exemplo serve como substituto para a função CONT.SES, que foi introduzida no Excel 2007. A função DATA.VALOR converte as datas em um valor numérico com o qual a função SOMARPRODUTO pode trabalhar.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×