Contar com que frequência um valor ocorre

Algumas funções de planilha podem ajudá-lo a contar quantas vezes um determinado texto ou valor numérico ocorre em um intervalo de células. Por exemplo, você pode usar a função CONT.SEpara contar quantas vezes um único valor ocorre, conforme mostrado no exemplo a seguir.

Exemplo

Vendedor

Fatura

Bonfim

15.000

Bonfim

9.000

Ruivo

8.000

Ruivo

20.000

Bonfim

5.000

Couto

22.500

Fórmula

Descrição

Resultado

=CONT.SE(A2:A7,"Bonfim")

Número de entradas para Bonfim (3)

3

=CONT.SE(A2:A7,A4)

Número de entradas para Ruivo (2)

2

=CONT.SE(B2:B7,"< 20000")

Número de valores de fatura menores que 20.000 (4)

4

=CONT.SE(B2:B7,">="&B5)

Número de valores de fatura maiores ou iguais a 20.000 (2)

2

Usar CONT.SE para contar valores com base em vários critérios

A função CONT.SES é semelhante à função CONT.SE com uma importante exceção: a função CONT.SES permite aplicar critérios às células em vários intervalos e conta o número de vezes que todos os critérios são atendidos. É possível usar até 127 pares de intervalo/critérios com a função CONT.SES. A sintaxe para a função é semelhante a esta:

CONT.SES(intervalo_critérios1, critérios1, [intervalo_critérios2, critérios2],…)

Exemplo

ID do Funcionário

Número de Região

Departamento

20552

2

Vendas

21268

2

Finanças

23949

1

Administrador

24522

4

Administrador

28010

3

TI

29546

4

Vendas

31634

3

TI

32131

1

TI

35106

4

Finanças

40499

1

HR

42051

1

Vendas

43068

2

HR

45382

2

Finanças

47971

1

TI

Fórmula

Descrição

Resultado

=CONT.SE(B2:B15,"2",C2:C15,"Finanças")

Número de funcionários na região 2 e no departamento financeiro

2

O primeiro intervalo de critérios se refere aos números de região e o segundo se refere aos nomes de departamentos. O critério aplicado ao primeiro intervalo é "2" e o critério aplicado ao segundo é "financeiro". A função CONT.SES verifica se ambos são atendidos.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×