Contar caracteres em células

Para contar os caracteres contidos nas células, use a função NÚM.CARACT. Essa função conta letras, números, caracteres e todos os espaços. Por exemplo, o comprimento de "Hoje chegamos a 37 graus, então vou nadar" (excluindo as aspas) é de 41 caracteres. Isso inclui 31 letras, 2 números, 7 espaços e uma vírgula.

  • Para usar a função, insira =NÚM.CARACT(célula) na barra de fórmulas e pressione Enter. Nesses exemplos, célula é a célula que você deseja contar, como B1.

  • Para contar os caracteres em mais de uma célula, insira a fórmula e arraste a alça de preenchimento pelo intervalo de células que você quer usar.

Inserindo várias funções NÚM.CARACT em uma planilha

  • Para contar o número total de caracteres em várias células, use as funções SOMA junto com NÚM.CARACT. Por exemplo, =SOMA((NÚM.CARACT(célula1),NÚM.CARACT(célula2),(NÚM.CARACT(célula3)))). Nesse exemplo, a função NÚM.CARACT conta os caracteres em cada célula e a função SOMA adiciona as contagens.

Experimente

Use os exemplos na pasta abaixo para ver como usar a função NÚM.

Copie a tabela a seguir e cole-a na célula A1 de uma planilha do Excel. Arraste a fórmula de B2 para B3:B4 para ver o comprimento do texto nas células da coluna A.

Cadeia de Caracteres de Texto

Fórmulas

A raposa marrom rápida

=NÚM.CARACT(A2)

A raposa marrom rápida saltou

A raposa marrom rápida saltou sobre o cachorro preguiçoso.

Contar caracteres em uma célula

  1. Na Planilha1 desta pasta de trabalho de exemplo, clique na célula B2.

  2. Na célula, insira =NÚM.CARACT(A2) e pressione Enter.

A fórmula conta os caracteres na célula A1, 45, incluindo todos os espaços. Se você tem espaços depois do ponto final, eles também são contados.

Contar caracteres em várias células

  1. Na pasta de trabalho de exemplo, clique na célula B2.

  2. Na célula, insira =NÚM.CARACT(A2).

  3. Pressione Ctrl+C para copiar a B2 e pressione Ctrl+V para colar sua fórmula nas células B3:B4.

Isso copia a fórmula para as células B3 e B4, e a função conta os caracteres em cada célula (19, 26 e 45).

Contar o número total de caracteres

  1. Na pasta de trabalho de exemplo, clique na célula B6.

  2. Na célula, insira =SOMA(NÚM.CARACT(A2),NÚM.CARACT(A3),NÚM.CARACT(A4)) e pressione Enter.

Isso conta os caracteres em cada uma das três células e os totaliza (90).

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×