Como evitar fórmulas quebradas

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando fórmulas apresentam resultados não intencionais ou erros, pode ser muito frustrante, especialmente se você não souber o que fazer em seguida.

Várias coisas podem estar erradas. Por exemplo, pode haver parênteses incompatíveis, erros de digitação ou referências a dados em intervalos que não existem. As práticas recomendadas a seguir podem ajudá-lo a evitar ou resolver erros comuns quando você cria ou precisa corrigir suas fórmulas.

Siga esta prática recomendada:

Para evitar este erro comum:

Inicie cada função com o sinal de igual (=)

Se a sua entrada não começar com um sinal de igual, não será uma fórmula e não será calculada — um erro comum, fácil de cometer.

Por exemplo, quando você digita algo como SOMA(A1:A10), o Excel Online mostra a cadeia de caracteres de texto SOMA(A1:A10) em vez de um resultado de fórmula. Se você digitar 2/11, verá uma data, como 2-Nov ou 2/11/2009, em vez da divisão 2 por 11.

Para evitar estes resultados inesperados, sempre comece com o sinal de igual. Por exemplo, digite: =SOMA(A1:A10) e = 2/11

Combine todos os parênteses de abertura e de fechamento

Certifique-se de que todos os parênteses possuem um par correspondente. Em uma fórmula que usa uma função, cada parêntese de abertura precisa de um parêntese de fechamento para que a função funcione corretamente.

Por exemplo, a fórmula =SE(B5<0),"Não válido",B5*1,05) não funcionará porque existem dois parênteses de fechamento e apenas um de abertura.

A fórmula correta teria o seguinte formato: =SE(B5<0,"Não válido",B5*1,05).

Insira todos os argumentos obrigatórios

A maioria das funções têm argumentos obrigatórios — valores que você precisa fornecer para que a função funcione. Somente algumas funções (tais como PI ou HOJE) não precisam de argumentos. Verifique a sintaxe de fórmula que aparece quando você começa a digitar um sinal de igual, seguido de uma função, para certificar-se de ter inserido todos os argumentos obrigatórios — nem mais nem menos.

Por exemplo, a função MAIÚSCULA aceita somente uma cadeia de texto ou referência de célula como seu argumento: =MAIÚSCULA("olá") ou =MAIÚSCULA(C2)

Além disso, algumas funções, tais como SOMA, exigem argumentos numéricos apenas, enquanto outras funções, tais como SUBSTITUIR, exigem um valor de texto para pelo menos um de seus argumentos. Se você usar o tipo de dados errado, algumas funções podem retornar resultados inesperados ou mostrar um erro #VALOR!.

Use números não formatados em fórmulas

Não digite números formatados com cifrões ($) ou separadores decimais (,) em fórmulas, pois cifrões indicam referências absolutas e vírgulas são separadoras de argumentos. Números formatados não são usados no cálculo de fórmula. Em vez de digitar $1.000, digite 1000 na fórmula.

Se você usar números formatados em argumentos, obterá resultados de cálculo inesperados, mas você também pode ver o erro #NUM!. Por exemplo, se você digitar a fórmula =ABS(-2,134) para encontrar o valor absoluto de -2134, Excel Online será mostrado o erro #NUM!, pois a função ABS aceita apenas um argumento.

Você pode formatar o resultado da fórmula com separadores decimais e símbolos de moeda depois que você inserir a fórmula usando números não formatados, aplicando um formato de número.

Use o tipo de dados da célula correto

Sua fórmula pode não retornar os resultados esperados se o tipo de dados da célula não puder ser usado nos cálculos.

Por exemplo, se você inserir uma fórmula simples =2+3 em uma célula que está formatada como texto, Excel Online não será possível calcular os dados inseridos. Tudo o que você verá na célula é =2+3.

Para corrigir esse problema, altere o tipo de dados da célula de Texto para Geral como este:

  1. Selecione a célula.

  2. Clique em Página Inicial > seta Formato de Número e escolha Geral.

  3. Pressione F2 para colocar a célula no modo de Edição e pressione Enter para aceitar a fórmula.

Uma data que você digitar em uma célula que tem o tipo de dados Número pode ser mostrada como um valor de data numérico, em vez de uma data. Para mostrar este número como uma data, escolha um formato de Data na galeria Formato de Número.

Use o símbolo * para multiplicar números

Talvez você queira usar x como o operador de multiplicação em uma fórmula, mas precisa usar o asterisco (*) em vez dele.

Quando você usa um x em sua fórmula, Excel Online não é possível calcular o resultado e é mostrada a fórmula na célula em vez disso, colocando-se uma borda pontilhada de vermelho em torno da célula para que você saiba que há um erro de fórmula.

Use aspas ao redor do texto em fórmulas

Se você criar uma fórmula que inclui texto, coloque esse texto entre aspas.

Por exemplo, a fórmula = "Hoje é " & TEXTO(HOJE(),"dddd, mmmm dd") combina o texto "Hoje é " com os resultados das funções TEXTO e HOJE e retorna Hoje é Segunda-Feira, 30 de maio na célula.

Na fórmula, "Hoje é " tem um espaço antes da aspa final para fornecer o espaço em branco entre as palavras Hoje é e Segunda-Feira, 30 de maio. Sem aspas ao redor do texto, a fórmula pode mostrar o erro #NOME?.

Não aninhe mais de 64 funções em uma fórmula

É possível combinar (ou aninhar) até 64 níveis de funções em uma fórmula.

Por exemplo, a fórmula =SE(RAIZ(PI())<2,"Menor que dois!","Maior que dois!") tem 3 níveis de funções: a função PI está aninhada dentro da função RAIZ, que por sua vez está aninhada dentro da função SE.

Evite dividir valores numéricos por zero

Dividir uma cela por outra célula que tem zero (0) ou nenhum valor, resulta em um erro #DIV/0!.

Para evitar esse erro, aninhe a sua operação de divisão dentro da função SEERRO. Por exemplo, insira as duas fórmulas a seguir nas célula de uma planilha:

=SEERRO(3/0,0)

=SEERRO(3/7,0)

A primeira fórmula retorna 0 porque a função SEERRO reconhece que a divisão por zero resulta em um erro. A segunda fórmula retorna o valor de 3/7 — não há nenhum erro porque você não está dividindo por zero.

Para facilitar a criação de fórmulas, convém saber mais sobre essas dicas e truques sobre fórmulas.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×