Como corrigir um erro #VALOR! nas funções ÍNDICE/CORRESP

Este tópico explica os cenários comuns onde você encontra o erro #VALOR! ao usar as funções ÍNDICE e CORRESP juntas em uma fórmula. Um dos motivos mais comuns para usar a combinação de ÍNDICE e CORRESP é quando você quer pesquisar um valor em um cenário em que PROCV não funciona para você, como quando o valor de pesquisa é maior que 255 caracteres.

Problema: A fórmula não foi inserida como uma matriz

Se você estiver usando o ÍNDICE como uma fórmula de matriz junto com o CORRESP para poder recuperar um valor, você precisará converter sua fórmula em uma fórmula de matriz, caso contrário, você verá um erro #VALOR!.

Solução: ÍNDICE e CORRESP devem ser usados como uma fórmula de matriz, o que significa que você precise pressionar CTRL+SHIFT+ENTER. Isso quebrará automaticamente a fórmula em chaves {}. Se você tentar inseri-las por conta própria, o Excel exibirá a fórmula como texto.

Se você estiver usando as funções ÍNDICE/CORRESP quando tiver um valor de pesquisa maior que 255 caracteres, elas precisam ser inseridas como uma fórmula de matriz.  A fórmula na célula F3 é =ÍNDICE(B2:B4,CORRESP(VERDADEIRO,A2:A4=F2,0),0) e é inserida pressionando Ctrl+Shift+Enter
ÍNDICE e CORRESP devem ser usados como uma fórmula de matriz

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR!

Função ÍNDICE

Função CORRESP

Pesquisar valores com PROCV, ÍNDICE ou CORRESP

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×