Como corrigir um erro #VALOR! na função CONT.SE/CONT.SES

Este tópico lista as causas mais comuns do erro #VALOR! nas funções CONT.SE e CONT.SES.

Problema: A fórmula faz referência a células em uma pasta de trabalho fechada

As funções CONT.SE/CONT.SES que fazem referência a uma célula ou a um intervalo em uma pasta de trabalho fechada resultará em um erro #VALOR!.

Observação: Esse é um problema conhecido com várias outras funções do Excel, como SOMASE, SOMASES, CONTAR.VAZIO, para citar algumas. Veja Funções SOMASE, CONT.SE e CONTAR.VAZIO retornam um erro #VALOR! para saber mais.

Solução: Abrir a pasta de trabalho vinculada indicada na fórmula e pressione F9 para atualizar a fórmula.

Você também pode contornar esse problema usando as funções SOMA e SE juntas em uma fórmula de matriz. Veja Funções SOMASE, CONT.SE e CONTAR.VAZIO retornam um erro #VALOR! para saber mais.

Problema: A cadeia de caracteres é maior que 255 caracteres

Solução: Reduza a cadeia de caracteres, se possível. Se você não puder reduzi-la, use a função CONCATENAR ou o operador E comercial (&) para dividir o valor em várias cadeias de caracteres. Por exemplo,

  • =CONT.SE(B2:B12,"texto longo"&"outra cadeia longa")

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR!

Função CONT.SE

Função CONT.SES

Função SE – fórmulas aninhadas e evitando armadilhas

Veja um vídeo sobre as funções SE avançadas

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×