Como corrigir um erro #VALOR! na função CONCATENAR

Importante: Em Excel 2016, Excel Mobile e Excel Online, CONCATENAr foi substituída pela função CONCAT. Embora CONCATENAR ainda esteja disponível para compatibilidade com versões anteriores, recomenda-se usar CONCAT por ela ser uma função mais robusta.

Um dos cenários mais comuns onde você encontra o erro #VALOR! com CONCATENAR é quando você tenta criar uma cadeia de caracteres que inclui uma referência de célula que contém um erro, como #VALOR!.

No exemplo a seguir, queremos concatenar D2, E2 e F2, em que E2 tem um #VALUE! #REF!.

Erro #VALOR! em CONCATENAR

O erro em E2 faz com que a função exiba o #VALUE! #REF!. Para que ele funcione com êxito, será preciso substituir o erro por um valor diferente do erro. Você pode criar uma fórmula que verifique se há um erro na referência da célula e, em caso afirmativo, exibir a cadeia de caracteres de texto em que um 0 é exibido em vez do erro (ou você pode substituir seu próprio texto por 0, mas precisará quebrar o texto entre aspas – "seu texto").

Uma fórmula como esta funciona:

=SE(ÉERROS(E2);CONCATENAR(D2;" ",0," ",F2))

As funções se e IsError são usadas como uma solução alternativa para concatenar uma cadeia de caracteres com o #VALUE! erro

Como isso funciona? A função SE usa a função SEERRO para determinar se há um erro em E2, e se houver, a função CONCATENAR combina os valores em D2, E2 e F2 (a função substitui o erro por um 0) e exibe a cadeia de texto resultante. Observe que a fórmula também usa espaços (" ") para ajudar a separar os valores.

Corrigir o erro #VALOR! com CONCATENAR no Excel 2003 e em versões mais antigas

Se você estiver recebendo o erro #VALOR! no Office Excel 2003 ou em versões mais antigas, você precisará desmarcar a opção de Avaliação de Fórmula de Transição (TFE) no Excel. Siga as etapas descritas em #VALUE! erro ao concatenar células para resolver o problema.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Confira Também

Corrigir um erro #VALOR! erro

Função CONCATENAR

Função CONCAT

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×