Como corrigir um erro #REF!

Como corrigir um erro #REF!

O erro #REF! é mostrado quando uma fórmula se refere a uma célula que não é válida. Isso geralmente ocorre quando células que foram referenciadas por fórmulas são excluídas ou algo é colado sobre elas.

Exemplo - erro #REF! causado pela exclusão de uma coluna

O exemplo a seguir usa a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula que usa referências de células explícitas como =SOMA(B2;C2;D2) poderá causar um erro #REF! se uma coluna for excluída.

Se você excluir a coluna B, C ou D, isso causará um erro #REF!. Nesse caso, excluiremos a coluna C (Vendas de 2007), e a fórmula passará a ser =SOMA(B2;#REF!,C2). Quando você usa referências explícitas a células assim (em que faz referência a cada célula individualmente, separada por uma vírgula) e exclui uma referência de linha ou coluna, o Excel não pode resolvê-la, então, retorna o erro #REF!. Esse é o principal motivo pelo qual o uso de referências explícitas a células em funções não é recomendado.

Exemplo do erro #REF! causado pela exclusão de uma coluna.

Solução

  • Se excluiu linhas ou colunas por engano, você pode clicar imediatamente no botão Desfazer na Barra de Ferramentas de Acesso Rápido (ou pressionar CTRL+Z) para restaurá-las.

  • Ajuste a fórmula para que ela use uma referência de intervalo em vez de células individuais, como =SOMA(B2:D2). Agora você pode excluir qualquer coluna dentro do intervalo de soma, e o Excel ajustará automaticamente a fórmula. Você também pode usar =SOMA(B2:B5) para uma soma de linhas.

Exemplo - PROCV com referências de intervalo incorretas

No exemplo a seguir, =PROCV(A8;A2:D5;5;FALSO) retornará um erro #REF! porque está procurando um valor de retorno da coluna 5, mas o intervalo de referência é A:D, que só tem quatro colunas.

Exemplo de uma fórmula PROCV com um intervalo incorreto.  A fórmula é =PROCV(A8;A2:D5;5;FALSO).  Não há uma quinta coluna no intervalo PROCV, assim, 5 causa um erro #REF!.

Solução

Ajuste o intervalo para ser maior ou reduza o valor de pesquisa de coluna para corresponder ao intervalo de referência. =PROCV(A8;A2:E5;5;FALSO) seria um intervalo de referência válida, assim como =PROCV(A8;A2:D5;4;FALSO).

Exemplo - ÍNDICE com uma referência incorreta de linha ou coluna

Nesse exemplo, a fórmula =ÍNDICE(B2:E5;5;5) retorna um erro #REF! porque o intervalo de índice é de quatro linhas por quatro colunas, mas a fórmula está pedindo para retornar o que está na quinta coluna e na quinta linha.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo é de apenas quatro linhas por quatro colunas.

Solução

Ajuste as referências de linha ou coluna para que estejam dentro do intervalo de pesquisa de ÍNDICE. =ÍNDICE(B2:E5;4;4) retornaria um resultado válido.

Exemplo – referência a uma pasta de trabalho fechada com INDIRETO

No exemplo a seguir, uma função INDIRETO está tentando fazer referência a uma pasta de trabalho fechada, causando um erro #REF!.

Exemplo de um erro #REF! causado porque INDIRETO faz referência a uma pasta de trabalho fechada.

Solução

Abra a pasta de trabalho referenciada

Problemas com OLE/DDE

Se você usou um link OLE (Vinculação e Incorporação de Objeto) que está retornando um erro #REF!, inicie o programa que o link está chamando.

Observação: OLE é uma tecnologia que você pode usar para compartilhar informações entre programas.

Se você usou um tópico DDE (Troca Dinâmica de Dados) que está retornando um erro #REF!, verifique se está referenciando o tópico correto.

Observação: DDE é um protocolo estabelecido para troca de dados entre programas baseados no Microsoft Windows.

Problemas de Macro

Se uma macro inserir uma função na planilha que faz referência a uma célula acima da função, e a célula que contém a função estiver na linha 1, a função retornará #REF! , pois não há células acima da linha 1. Verifique a função para determinar se um argumento faz referência a uma célula ou a intervalo de células que não é válido. Isso pode exigir a edição da macro no VBE (Editor do Visual Basic) para levar essa situação em conta.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Consulte Também

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×