Como corrigir um erro #N/D

Como corrigir um erro #N/D

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Normalmente, o erro #N/D indica que a fórmula não consegue encontrar o item solicitado.

Principal solução

A causa mais comum para o erro #N/D se deve às funções PROCV, PROCH, PROC ou CORRESP, quando uma fórmula não consegue encontrar um valor de referência. Por exemplo, seu valor de pesquisa não existe nos dados de origem.

O valor de pesquisa não existe. A fórmula na célula E2 é =PROCV(D2;$D$6:$E$8;2;FALSO). Como o programa não encontra o valor Banana, a fórmula retorna um erro #N/D.
O item não foi encontrado nos dados de origem

Nesse caso, não há nenhum item "Banana" listado na tabela de pesquisa; portanto, a função PROCV retorna um erro #N/D.

Solução: verifique se o valor de pesquisa existe nos dados de origem ou use um manipulador do erro como SEERRO na fórmula. Por exemplo, =SEERRO(FÓRMULA();0), que diz:

  • =SE(a fórmula é avaliada como um erro e exibe 0; caso contrário, exibe o resultado da fórmula)

Você pode usar "" para não exibir nada ou substituir seu próprio texto: =SEERRO(FÓRMULA();"Mensagem de erro aqui")

Caso não saiba ao certo o que fazer ou o tipo de ajuda de que precisa nessa ocasião, você pode postar uma pergunta ou pesquisar perguntas semelhantes no Fórum da Comunidade do Excel.

Link para o Fórum da comunidade do Excel

Se desejar continuar, a Lista de verificação a seguir fornece etapas de solução de problemas para ajudá-lo a compreender o que deu errado nas fórmulas.

O valor de pesquisa e os dados de origem são tipos de dados diferentes. Por exemplo, você tenta fazer com que PROCV faça referência a um número, mas os dados de origem estão armazenados como texto.

Tipos de valores incorretos.  O exemplo mostra uma fórmula PROCV retornando um erro #N/D. Isso ocorre porque o item da pesquisa está formatado como número, ao passo que a tabela de pesquisa está formatada como texto.
Erro #N/D causado por tipos de dados diferentes

Solução: Verifique se os tipos de dados são os mesmos. Você pode verificar os formatos das células selecionando uma célula ou um intervalo de células, clicando com o botão direito do mouse e selecionando Formatar Células > Número (ou pressionando Ctrl+1) e alterando o formato do número, se necessário.

Caixa de diálogo Formatar Células exibindo a guia Número e a opção Texto selecionada

Dica : Se precisar forçar uma alteração de formato em uma coluna inteira, primeiro aplique o formato que você deseja; em seguida, é possível usar Dados > Textos para Colunas > Concluir.

Você pode usar a função ARRUMAR para remover espaços à direita ou à esquerda. O exemplo a seguir usa a função ARRUMAR, aninhada em uma função PROCV, para remover espaços à esquerda dos nomes no intervalo A2:A7 e retornar o nome do departamento.

Usando a função PROCV com ARRUMAR em uma fórmula de matriz para remover espaços à esquerda ou à direita.  A fórmula na célula E3 é {=PROCV(D2;ARRUMAR(A2:B7);2;FALSO)}. Para inseri-la, use o comando Ctrl+Shift+Enter.

{=PROCV(D2;ARRUMAR(A2:B7);2;FALSO)}

Observação : Esta é uma fórmula de matriz e você deve inseri-la com o comando Ctrl+Shift+Enter. O Excel quebrará automaticamente a fórmula em chaves {} para você. Se você tentar inseri-las por conta própria, o Excel exibirá a fórmula como texto.

Por padrão, as funções que procuram informações em tabelas devem ser classificadas em ordem crescente. No entanto, as funções PROCV e PROCH da planilha incluem um argumento procurar_intervalo que instrui a função a localizar uma correspondência exata, mesmo que a tabela não esteja classificada. Para localizar uma correspondência exata, defina o argumento procurar_intervalo como FALSO. Observe que o uso do argumento VERDADEIRO, que determina a procura de uma correspondência aproximada pela função, pode retornar um erro #N/D, além de resultados incorretos, conforme mostra o exemplo a seguir.

Exemplo de uso da função PROCV com o argumento procurar_intervalo VERDADEIRO, que pode causar resultados incorretos.
A função PROCV falha devido ao uso do argumento de correspondência aproximada em uma tabela não classificada

Neste exemplo, "Banana" retorna um erro #N/D e "Pera" retorna o preço errado. Isso ocorre devido ao uso do argumento VERDADEIRO, que determina a procura de uma correspondência aproximada pela função PROCV, em vez de uma correspondência exata. Não há correspondências aproximadas para "Banana"; além disso, "Pera" vem antes de "Pêssego" na ordem alfabética. Nesse caso, o uso de PROCV com o argumento FALSO deve retornar o preço correto de "Pera"; no entanto, "Banana" continua gerando um erro #N/D, uma vez que não há nenhuma correspondência para "Banana" na lista de pesquisa.

Se estiver usando a função CORRESP, experimente mudar o valor do argumento coincidir_tipo para especificar a ordem de classificação da tabela. Para encontrar uma correspondência exata, defina o argumento coincidir_tipo como 0 (zero).

Para corrigir o problema, verifique se o intervalo referenciado pela fórmula de matriz tem o mesmo número de linhas e colunas que o intervalo de células no qual a fórmula de matriz foi inserida ou digite a fórmula de matriz em menos ou mais células para coincidir com a referência de intervalo na fórmula.

Neste exemplo, a célula E2 fez referência a intervalos não compatíveis:

Exemplo de uma fórmula de matriz com referências de intervalo incompatíveis que causam um erro #N/D. A fórmula na célula E2 é {=SOMA(SE(A2:A11=D2;B2:B5))} e você deve inseri-la usando o comando Ctrl+Shift+Enter.

{=SOMA(SE(A2:A11=D2;B2:B5))}

Para que a fórmula calcule corretamente, você deve alterá-la de modo que os dois intervalos considerem as linhas de 2 a 11.

{=SOMA(SE(A2:A11=D2;B2:B11))}

Observação : Esta é uma fórmula de matriz e você deve inseri-la com o comando Ctrl+Shift+Enter. O Excel quebrará automaticamente a fórmula em chaves {} para você. Se você tentar inseri-las por conta própria, o Excel exibirá a fórmula como texto.

Exemplo de um erro #N/D inserido nas células, evitando o cálculo adequado da função SOMA.

Nesse caso, maio-dezembro tem valores #N/D, portanto, o programa não pode calcular o total e retorna um erro #N/D.

Para corrigir o problema, verifique a sintaxe da fórmula da função que você está usando e insira todos os argumentos necessários na fórmula que retorna o erro. Pode ser necessário usar o VBE (Editor do Visual Basic) para verificar esta função. Você pode acessar o VBE na guia Desenvolvedor ou através do comando Alt+F11.

Para corrigir o problema, verifique se a pasta de trabalho que contém a função definida pelo usuário está aberta e a função está funcionando corretamente.

Para corrigir o problema, verifique se os argumentos na função estão corretos e são usados na posição correta.

Para corrigir isso, pressione Ctrl+Alt+F9 para calcular novamente a planilha

Você pode usar o Assistente de Função para ajudá-lo, caso não saiba ao certo sobre os argumentos adequados. Escolha a célula que contém a fórmula em questão, vá para a guia Fórmulas na Faixa de Opções e pressione Inserir Função.

Botão Inserir Função.

O Excel carregará o assistente automaticamente para você:

Exemplo da caixa de diálogo do Assistente de fórmula.

À medida que você clicar em cada argumento, o Excel fornecerá as informações apropriadas para cada um deles.

#N/D pode ser útil! É muito comum usar #N/D durante a utilização de dados, uma vez que os valores de #N/D não são plotados em gráficos, conforme mostra o exemplo de gráfico a seguir. Veja alguns exemplos da aparência de um gráfico com valores 0 e #N/D.

Exemplo de um gráfico de linhas com plotagem de 0 valor.

No exemplo anterior, você verá que os valores 0 foram plotados e são exibidos como uma linha reta na parte inferior do gráfico e, em seguida, eles disparam para exibir o Total. No exemplo a seguir, você verá os valores 0 substituídos por #N/D.

Exemplo de um gráfico de linhas sem plotagem de valores de #N/D.

Confira os tópicos a seguir para saber mais sobre os erros #N/D exibidos em uma função específica:

Início da página

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no UserVoice do Excel.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Consulte Também

Converter números armazenados como texto em números

Função PROCV

Função PROCH

Função proc

Função CORRESP

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar verificação de erros para detectar erros em fórmulas

Atalhos de teclado no Excel para Windows

Atalhos de teclado no Excel para Mac

Funções de todo o Excel (ordem alfabética)

Excel todas as funções (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×