Como corrigir o erro #VALOR! nas funções MÉDIA ou SOMA

Se MÉDIA ou SOMA se referir a células que contêm erros #VALOR!, as fórmulas resultarão em um erro #VALOR!.

Erro #VALOR! em MÉDIA

Para ignorar os valores de erro, construiremos uma fórmula que ignora os erros no intervalo de referência enquanto calcula a média com os valores restantes "normais".

Para contornar esse cenário, usamos uma combinação de MÉDIA junto com SE e ÉERROS para determinar se há um erro no intervalo especificado. Este cenário específico exige uma fórmula de matriz:

=MÉDIA(SE(ÉERROS(B2:D2),"", B2:D2))

Observação : Esta é uma fórmula de Matriz e precisa ser inserida com o comando CTRL+SHIFT+ENTER. O Excel envolverá automaticamente a fórmula com chaves {}. Se você tentar inseri-las por conta própria, o Excel exibirá a fórmula como texto.

Função matriz em MÉDIA para resolver o erro #VALOR!

Observação : A função acima não só funcionará para #VALOR!, como também para #N/D, #NULO, #DIV/0!, etc.

Também é possível utilizar a SOMA da mesma maneira:

=SOMA(SE(ÉERROS(B2:D2),"",B2:D2))

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR!

Função MÉDIA

Função SOMA

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×