Como corrigir o erro #VALOR! na função SOMASE/SOMASES

Este tópico lista as causas mais comuns do erro #VALOR! nas funções SOMASE e SOMASES e como resolvê-las.

Problema: A fórmula faz referência a células em uma pasta de trabalho fechada

As funções SOMASE/SOMASES que fazem referência a uma célula ou a um intervalo em uma pasta de trabalho fechada resultará em um erro #VALOR!.

Observação: Esse é um problema conhecido com várias outras funções do Excel, como CONT.SE, CONT.SES, CONTAR.VAZIO, para citar algumas. Veja o artigo Funções SOMASE, CONT.SE e CONTAR.VAZIO retornam um erro "#VALOR!" para saber mais.

Solução: Abra a pasta de trabalho indicada na fórmula e pressione F9 para atualizar a fórmula.

Você também pode contornar esse problema usando as funções SOMA e SE juntas em uma fórmula de matriz. Veja o artigo Funções SOMASE, CONT.SE e CONTAR.VAZIO retornam um erro #VALOR! para saber mais.

Problema: A cadeia de caracteres de critérios é maior que 255 caracteres

As funções SOMASE/SOMASES retornam resultados incorretos quando você tenta corresponder cadeias de caracteres com mais de 255 caracteres.

Solução: Reduza a cadeia de caracteres, se possível. Se você não puder reduzi-la, use a função CONCATENAR ou o operador E comercial (&) para dividir o valor em várias cadeias de caracteres. Por exemplo:

=SOMASE(B2:B12,"texto longo"&"outra cadeia longa")

Problema: Em SOMASES, o argumento criteria_range não é consistente com o argumento sum_range.

Os argumentos de intervalo sempre devem ser os mesmos em SOMASES. Isso significa que os argumentos criteria_range e sum_range devem se referir ao mesmo número de linhas e colunas.

No exemplo a seguir, a fórmula deve retornar a soma das vendas diárias de maçãs em Palmares. O argumento sum_range (C2:C10), entretanto, não corresponde ao mesmo número de linhas e colunas nos argumentos criteria_range (A2:A12 & B2:B12). Usando a sintaxe =SOMASES(C2:C10,A2:A12,A14,B2:B12,B14) resultará no erro #VALOR!.

A fórmula incorreta é =SOMASES(C2:C10,A2:A12,A14,B2:B12,B14), onde C2:C10 precisa ser C2:C12
Na função SOMASES, o criteria_range deve ser consistente com o sum_range

Solução: Seguindo este exemplo, altere o sum_range para C2:C12 e repita a fórmula.

Observação :  SOMASE pode usar intervalos de tamanhos diferentes.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR

Função SOMASE

Função SOMASES

Vídeos de função SE avançada

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×