Como corrigir o erro #VALOR! na função SOMARPRODUTO

Este tópico aborda os cenários comuns do erro #VALOR! ao se trabalhar com SOMARPRODUTO.

Problema: Os argumentos de matriz não têm a mesma dimensão

Todos os argumentos de matriz devem ser da mesma dimensão Se não forem, você receberá o erro #VALOR!. Por exemplo, se a Matriz 1 se referir a um intervalo de 3 linhas e 2 colunas, então a Matriz 2 também deve corresponder ao intervalo semelhante.

A fórmula SOMARPRODUTO que causa um erro é =SOMARPRODUTO(D2:D13,E2:E10) - E10 precisa ser alterado para E13 para corresponder ao primeiro intervalo.
  • =SOMARPRODUTO(D2:D13,E2:E10)

Falhará já que os intervalos referenciados não são do mesmo número de linhas (13 no primeiro intervalo, mas apenas 10 no segundo).

Solução: Altere a fórmula para:

  • =SOMARPRODUTO(D2:D13,E2:E13)

Para que os dois intervalos tenham os mesmos números de linhas iniciais e finais e tentem novamente a fórmula.

Resolver o erro #VALOR! nos dados para resolver o erro SOMARPRODUTO

Problema: Uma ou mais células no intervalo contêm texto

Se uma ou mais células no intervalo de referência contiver texto ou estiver formatada como um tipo de dados de Texto, você obterá o erro #VALOR!. O texto pode ser o resultado de um cálculo de outra fórmula, ou talvez a célula simplesmente não está formatada corretamente.

A fórmula na célula E15 mostra um erro #VALOR! porque existe um erro #VALOR! na coluna E.

Solução: Verifique as células que contêm texto ou estão formatadas como texto e definidas para o tipo correto de dados.

Você tem dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Consulte Também

Corrigir um erro #VALOR!

Função SOMARPRODUTO

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Usar a verificação de erros para detectar erros em fórmulas

Todas as funções do Excel (ordem alfabética)

Todas as funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×