Calcular a diferença entre duas horas

Calcular a diferença entre duas horas

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Digamos que você queira descobrir quanto tempo um funcionário leva para concluir uma operação em uma linha de montagem, ou quanto tempo um pedido em uma lanchonete demora para ser processado no horário de pico. Há várias maneiras de calcular a diferença.

Apresentar o resultado no formato de hora oficial

Há duas abordagens que você pode executar para apresentar os resultados em formato de hora padrão (horas: minutos: segundos). Você usa o operador de subtração (-) para encontrar a diferença entre horas e siga um destes procedimentos:

Aplica um código de formato personalizado para a célula, fazendo o seguinte:

  1. Selecione a célula.

  2. Na guia Página Inicial, no grupo Número, clique na seta ao lado da caixa Geral e depois clique em Mais Formatos de Número.

  3. Na caixa de diálogo Formatar Células, clique em Personalizado na lista Categoria e selecione um formato personalizado na caixa Tipo.

Use a função texto para formatar as horas: Quando você usar os códigos de formato de hora, horas nunca excedem 24, os minutos nunca excederem 60 e segundos nunca excederem 60.

Tabela de exemplo 1 — Apresentar o resultado em formato de hora padrão

Copiar a tabela a seguir para uma planilha em branco e, em seguida, modifique se necessário.

1

2

3


4


5


6

7


8


9

A

B

Hora de início

Hora de término

09.06.07 10:35:00

09.06.07 15:30:00

Fórmula

Descrição (Resultado)

=B2-A2

Horas entre dois horários (4). Você deve aplicar manualmente o formato personalizado "h" à célula.

=B2-A2

Horas e minutos entre dois horários (4:55). Você deve aplicar manualmente o formato personalizado "h:mm" à célula.

=B2-A2

Horas, minutos e segundos entre dois horários (4:55:00). Você deve aplicar manualmente o formato personalizado "h:mm:ss" à célula.

=TEXTO(B2-A2;"h")

Número de horas entre dois horários com a célula formatada como "h" ao usar a função TEXTO (4)

=TEXTO(B2-A2;"h:mm")

Número de horas e minutos entre dois horários com a célula formatada como "h:mm" ao usar a função TEXTO (4:55)

=TEXTO(B2-A2;"h:mm:ss")

Número de horas, minutos e segundos entre dois horários com a célula formatada como "h:mm:ss" ao usar a função TEXTO (4:55:00)

Observação: Se você usar um formato aplicado com a função TEXTO e aplicar um formato de número à célula, a função TEXTO terá precedência sobre a formatação da célula.

Para obter mais informações sobre como usar essas funções, confira Função TEXTO e Exibir números como datas ou horários.

Tabela de exemplo 2 — Apresentar o resultado com base em uma única unidade de tempo

Para executar essa tarefa, você usará a função INT ou as funções hora, minutoe segundo , conforme mostrado no exemplo a seguir.

Copie a seguinte tableto uma planilha em branco e, em seguida, modifique conforme necessário.

1

2

3


4


5


6

7


8


9

A

B

Hora de início

Hora de término

09.06.07 10:35:00

09.06.07 15:30:00

Fórmula

Descrição (Resultado)

=INT((B2-A2)*24)

Total de horas entre dois horários (4)

=(B2-A2)*1440

Total de minutos entre dois horários (295)

=(B2-A2)*86400

Total de segundos entre dois horários (17700)

=HORA(B2-A2)

A diferença na unidade de horas entre dois horários. Esse valor não pode exceder 24 (4).

=MINUTO(B2-A2)

A diferença na unidade de minutos entre dois horários. Esse valor não pode exceder 60 (55).

=SEGUNDO(B2-A2)

A diferença na unidade de segundos entre dois horários. Esse valor não pode exceder 60 (0).

Para obter mais informações sobre como usar essas funções, confira Função INT, Função HORA, Função MINUTO e Função SEGUNDO.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×