CONT.SES (Função CONT.SES)

CONT.SES (Função CONT.SES)

A função COUNT.SES Aplica critérios a células em vários intervalos e conta o número de vezes que todos os critérios são atendidos.

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Este vídeo faz parte de um treinamento chamado Funções SE avançadas.

Sintaxe

CONT.SES(intervalo_critérios1, critérios1, [intervalo_critérios2, critérios2]…)

A sintaxe da função CONT.SES tem os seguintes argumentos:

  • intervalo_critérios1    Obrigatório. O primeiro intervalo no qual avaliar os critérios associados.

  • critérios1    Obrigatório. Os critérios no formato de um número, uma expressão, uma referência de célula ou um texto que define quais células serão contadas. Por exemplo, os critérios podem ser expressos como 32, ">32", B4, "maçãs" ou "32".

  • intervalo_critérios2, critérios2, ...    Opcional. Intervalos adicionais e seus critérios associados. Até 127 intervalo/critérios pares são permitidos.

Importante : Cada intervalo adicional deve ter o mesmo número de linhas e colunas que o argumento intervalo_critérios1. Os intervalos não precisam ser adjacentes entre si.

Comentários

  • Os critérios de cada intervalo são aplicados a uma célula de cada vez. Se todas as primeiras células atenderem aos seus critérios associados, a contagem aumentará em 1. Se todas as segundas células atenderem aos seus critérios associados, a contagem aumentará em 1 novamente e assim por diante até que todas as células sejam avaliadas.

  • Se o argumento de critérios for uma referência a uma célula vazia, a função CONT.SES tratará essa célula vazia como um valor 0.

  • Você pode usar os caracteres curinga (o ponto de interrogação (?) e o asterisco (*)) nos critérios. Um ponto de interrogação corresponde a qualquer caractere simples, enquanto um asterisco corresponde a qualquer cadeia de caracteres. Se você quiser encontrar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Exemplo 1

Copie os dados de exemplo das tabelas a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter. Se precisar, você poderá ajustar as larguras das colunas para ver todos os dados.

Vendedor

Cota de T1 excedida

Cota de T2 excedida

Cota de T3 excedida

Andrade

Sim

Não

Não

Barros

Sim

Sim

Não

Gonçalves

Sim

Sim

Sim

Nuno

Não

Sim

Sim

Fórmula

Descrição

Resultado

=CONT.SES(B2:D2;"=Sim")

Conta quantas vezes Andrade excedeu uma cota de vendas para os períodos T1, T2 e T3 (somente em T1).

1

=CONT.SES(B2:B5;"=Sim";C2:C5;"=Sim")

Conta quantos vendedores excederam suas cotas em T1 e T2 (Barros e Gonçalves).

2

=CONT.SES(B5:D5;"=Sim";B3:D3;"=Sim")

Conta quantas vezes Nuno e Barros excederam a mesma cota para os períodos T1, T2 e T3 (somente em T2).

1

Exemplo 2

Dados

 

1

01/05/2011

2

02/05/2011

3

03/05/2011

4

04/05/2011

5

05/05/2011

6

06/05/2011

Fórmula

Descrição

Resultado

=CONT.SES(A2:A7;"<6";A2:A7;">1")

Conta quantos números entre 1 e 6 (sem incluir 1 e 6) estão contidos nas células entre A2 e A7.

4

=CONT.SES(A2:A7; "<5";B2:B7;"<03/05/2011")

Conta quantas linhas têm números menores que 5 nas células entre A2 a A7 e também têm datas anteriores a 03/05/2011 nas células entre B2 e B7.

2

=CONT.SES(A2:A7; "<" & A6;B2:B7;"<" & B4)

Mesma descrição que o exemplo anterior, mas usando referências de célula no lugar de constantes nos critérios.

2

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Consulte Também

Para contar células que não estão em branco, use a função CONT.VALORES

Para contar células usando um único critério, use a função CONT.SE

A função SOMASE soma apenas os valores que atendem a um único critério

A função SOMASES adiciona apenas os valores que atendem a vários critérios

A função SES (Office 365, Excel 2016 e posterior)

Visão geral de fórmulas do Excel

Como evitar fórmulas desfeitas

Usar a verificação de erros para detectar erros em fórmulas

Funções estatísticas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×